kBuild-vl.spec 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. Summary: A cross-platform build environment
  2. Summary(ja): クロスプラットフォームビルド環境
  3. Name: kBuild
  4. Version: 0.1.5
  5. Release: 1%{?_dist_release}
  6. Group: Development/Tools
  7. License: BSD and GPLv2+
  8. # most tools are from NetBSD, some are from FreeBSD,
  9. # and make and sed are from GNU
  10. URL: http://svn.netlabs.org/kbuild
  11. Source0: ftp://ftp.netlabs.org/pub/kbuild/%{name}-%{version}-src.tar.gz
  12. Patch0: kBuild-0.1.3-escape.patch
  13. Patch1: kBuild-0.1.5-dprintf.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: byacc libacl-devel flex
  16. BuildRequires: autoconf automake gettext-devel cvs
  17. %description
  18. This is a GNU make fork with a set of scripts to simplify
  19. complex tasks and portable versions of various UNIX tools to
  20. ensure cross-platform portability.
  21. It is used mainly to build VirtualBox OSE packages for RPM Fusion
  22. repository.
  23. %prep
  24. %setup -q
  25. %patch0 -p1 -b .escape
  26. %patch1 -p1 -b .dprintf
  27. # Remove prebuilt stuff
  28. rm -rf kBuild/bin/*
  29. %build
  30. %define bootstrap_mflags %{_smp_mflags} \\\
  31. CFLAGS="%{optflags}" \\\
  32. KBUILD_VERBOSE=2
  33. %define mflags %{bootstrap_mflags} \\\
  34. NIX_INSTALL_DIR=%{_prefix} \\\
  35. BUILD_TYPE=release \\\
  36. MY_INST_MODE=0644 \\\
  37. MY_INST_BIN_MODE=0755
  38. # The bootstrap would probably not be needed if we depended on ourselves,
  39. # yet it is not guarranteed that new versions are compilable with older
  40. # kmk versions, so with this we are on a safer side
  41. kBuild/env.sh --full make -f bootstrap.gmk %{bootstrap_mflags}
  42. kBuild/env.sh kmk %{mflags} rebuild
  43. %install
  44. rm -rf $RPM_BUILD_ROOT
  45. export KBUILD_VERBOSE=2
  46. kBuild/env.sh kmk %{mflags} PATH_INS=$RPM_BUILD_ROOT install
  47. # These are included later in files section
  48. rm -r $RPM_BUILD_ROOT%{_docdir}
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %files
  52. %defattr(-,root,root,-)
  53. %{_bindir}/*
  54. %{_datadir}/*
  55. %doc COPYING ChangeLog
  56. %doc kBuild/doc/COPYING-FDL-1.3 kBuild/doc/QuickReference*
  57. %changelog
  58. * Fri May 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5-1
  59. - initial build for Vine Linux
  60. * Mon Apr 13 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-4
  61. - Fix typoes (Robert P. J. Day, #495393)
  62. - Comment out the colliding dprintf
  63. * Sun Mar 1 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-3
  64. - Fix up BRs
  65. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.5-2
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  67. * Sat Jan 24 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-1
  68. - Update to new upstream release
  69. * Tue Dec 30 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-0.1.20081106svn
  70. - Update to build VirtualBox OSE 2.1.0
  71. * Fri Sep 19 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.4-1
  72. - New upstream release
  73. * Thu Aug 28 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-2
  74. - Add gettext-devel to BRs for autopoint
  75. * Sun Aug 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-1
  76. - New upstream version
  77. - Install into FHS hierarchy
  78. - Honour optflags
  79. - No need to be arch specific
  80. * Tue Oct 30 2007 Till Maas <opensource till name> - 0.1.0-0.3.20070627svn
  81. - add support for x86_64
  82. - add BR: autoconf, automake
  83. * Wed Jun 27 2007 Till Maas <opensource till name> - 0.1.0-0.2.20070627svn
  84. - Update to a new version
  85. - just copy the bin files to %%{_libexecdir}, kmk install does not work
  86. * Sun Feb 18 2007 Till Maas <opensource till name> - 0.1.0-0.1.20070218svn
  87. - Initial spec for fedora extras