kdebindings-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649
  1. %define csharp 1
  2. %define falcon 0
  3. %define php 1
  4. %define ruby 1
  5. %define smoke 1
  6. %define java 0
  7. %define pykde4_akonadi 1
  8. %define pyqt4_version 4.7
  9. # ugly hack for Qt4 version auto-detection -- inagaki
  10. %define _qt4_notfound %(eval "pkg-config --exists Qt"; echo $?)
  11. %if %{_qt4_notfound}
  12. %define qt4_version 4.6.1
  13. %else
  14. %define qt4_version %(pkg-config --modversion Qt)
  15. %endif
  16. %define mono_dir %{_prefix}/lib/mono
  17. #if 0%{?ruby}%{?smoke}
  18. #define devel 1
  19. #endif
  20. %global ruby_lib %(ruby -rrbconfig -e 'puts Config::CONFIG["rubylibdir"]')
  21. %global ruby_arch %(ruby -rrbconfig -e 'puts Config::CONFIG["archdir"]')
  22. %global ruby_sitelib %(ruby -rrbconfig -e 'puts Config::CONFIG["sitelibdir"]')
  23. %global ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
  24. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  25. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  26. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  27. Name: kdebindings
  28. Version: 4.4.1
  29. Release: 1%{?_dist_release}
  30. Summary: KDE bindings to non-C++ languages.
  31. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
  32. # http://techbase.kde.org/Policies/Licensing_Policy
  33. License: LGPLv2+
  34. Group: System Environment/Libraries
  35. URL: http://www.kde.org/
  36. # fix build with CMAKE_SKIP_RPATH - also needs sed line below
  37. # WARNING: This is a bunch of quick hacks to get this to build. Please do not
  38. # commit this upstream without further discussion.
  39. Patch1: kdebindings-4.3.75-no-rpath.patch
  40. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  41. BuildRequires: akonadi-devel >= 1.3.0
  42. BuildRequires: kdebase-workspace-devel >= %{version}
  43. # okular bindings
  44. BuildRequires: kdegraphics-devel >= %{version}
  45. BuildRequires: kdelibs4-devel >= %{version}
  46. BuildRequires: kdepimlibs-devel >= %{version}
  47. # kdebindings does not support polkit-qt-1 yet
  48. #BuildRequires: polkit-qt-devel
  49. BuildRequires: python-devel
  50. BuildRequires: PyQt4-devel >= %{pyqt4_version}
  51. BuildRequires: qimageblitz-devel
  52. BuildRequires: qscintilla-devel >= 2.4
  53. BuildRequires: soprano-devel
  54. %if %{csharp}
  55. BuildRequires: mono-core
  56. BuildRequires: mono-devel
  57. %endif
  58. %if %{falcon}
  59. BuildRequires: Falcon-devel >= 0.8.12
  60. %endif
  61. %if %{php}
  62. BuildRequires: php5-devel
  63. %endif
  64. %if %{ruby}
  65. BuildRequires: ruby-devel
  66. BuildRequires: ruby
  67. %endif
  68. %if %{java}
  69. # TODO: kross-java is a mess, not sure what it needs to build
  70. # CMakeLists.txt is also not portable (only gcj and i486 hardcoded)
  71. # -- mathstuf
  72. BuildRequires: java-1.6.0-openjdk-devel
  73. %endif
  74. Requires: kdelibs4 >= %{version}
  75. %description
  76. KDE bindings to non-C++ languages
  77. %package devel
  78. Summary: Development files for kdebindings.
  79. Group: Development/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: kdelibs4-devel
  82. %description devel
  83. Development files for the KDE bindings.
  84. Install kdebindings-devel if you want to develop non-KDE applications
  85. that talk to KDE.
  86. %package -n PyKDE4
  87. Summary: Python bindings for KDE4
  88. Summary(ja): KDE4 の Python バインディング
  89. Group: Development/Languages
  90. Requires: kdelibs4 >= %{version}
  91. Requires: PyQt4 >= %{pyqt4_version}
  92. %description -n PyKDE4
  93. %{summary}.
  94. %package -n PyKDE4-akonadi
  95. Summary: Akonadi runtime support for PyKDE4
  96. Group: Development/Languages
  97. Requires: PyKDE4 = %{version}-%{release}
  98. Requires: kdepimlibs-akonadi >= %{version}
  99. %description -n PyKDE4-akonadi
  100. %{summary}.
  101. %package -n PyKDE4-devel
  102. Group: Development/Libraries
  103. Summary: Files needed to build PyKDE4-based applications
  104. Requires: PyQt4-devel
  105. Requires: PyKDE4 = %{version}-%{release}
  106. Requires: PyKDE4-akonadi = %{version}-%{release}
  107. %description -n PyKDE4-devel
  108. %{summary}.
  109. # C# bindings
  110. %if %{csharp}
  111. %package -n kimono
  112. Group: Development/Languages
  113. Summary: C# bindings for KDE4
  114. Summary(ja): KDE4 の C# バインディング
  115. Requires: kdelibs4 >= %{version}
  116. Requires: qyoto = %{version}-%{release}
  117. Provides: kimono4 = %{version}-%{release}
  118. %description -n kimono
  119. %{summary}.
  120. %package -n qyoto
  121. Group: Development/Languages
  122. Summary: C# bindings for Qt4
  123. Summary(ja): Qt4 の C# バインディング
  124. Requires: qt4 >= %{qt4_version}
  125. Provides: qyoto4 = %{version}-%{release}
  126. %description -n qyoto
  127. %{summary}.
  128. %package -n qyoto-devel
  129. Group: Development/Libraries
  130. Summary: Development files for qyoto
  131. Requires: qyoto = %{version}-%{release}
  132. Requires: mono-devel
  133. Provides: qyoto4-devel = %{version}-%{release}
  134. %description -n qyoto-devel
  135. %{summary}.
  136. %endif
  137. # Ruby
  138. %if %{ruby}
  139. %package -n korundum
  140. Group: Development/Languages
  141. Summary: Ruby bindings for KDE4
  142. Summary(ja): KDE4 の Ruby バインディング
  143. Requires: kdelibs4 >= %{version}
  144. Requires: QtRuby = %{version}-%{release}
  145. Provides: korundum4 = %{version}-%{release}
  146. %description -n korundum
  147. %{summary}.
  148. %package -n korundum-devel
  149. Group: Development/Libraries
  150. Summary: Development files for korundum
  151. Requires: QtRuby-devel
  152. Requires: korundum = %{version}-%{release}
  153. Provides: korundum4-devel = %{version}-%{release}
  154. %description -n korundum-devel
  155. %{summary}.
  156. %package -n QtRuby
  157. Group: Development/Languages
  158. Summary: Ruby bindings for Qt4
  159. Summary(ja): Qt4 の Ruby バインディング
  160. Requires: qt4 >= %{qt4_version}
  161. Provides: QtRuby4 = %{version}-%{release}
  162. %description -n QtRuby
  163. %{summary}.
  164. %package -n QtRuby-devel
  165. Group: Development/Libraries
  166. Summary: Development files for QtRuby
  167. Requires: QtRuby = %{version}-%{release}
  168. Provides: QtRuby4-devel = %{version}-%{release}
  169. %description -n QtRuby-devel
  170. %{summary}.
  171. %endif
  172. %if %{php}
  173. %package -n php-qt
  174. Group: Development/Languages
  175. Summary: PHP bindings for Qt4
  176. Summary(ja): Qt4 の PHP バインディング
  177. Requires: qt4 >= %{qt4_version}
  178. Provides: php-qt4 = %{version}-%{release}
  179. %description -n php-qt
  180. %{summary}.
  181. %package -n php-qt-devel
  182. Group: Development/Libraries
  183. Summary: Development files for php-qt
  184. Requires: php-qt = %{version}-%{release}
  185. Provides: php-qt4-devel = %{version}-%{release}
  186. %description -n php-qt-devel
  187. %{summary}.
  188. %endif
  189. %package -n kross-python
  190. Group: Development/Languages
  191. Summary: Kross plugin for python
  192. Requires: kdelibs4 >= %{version}
  193. Provides: kross(python) = %{version}-%{release}
  194. %description -n kross-python
  195. Python plugin for the Kross archtecture in KDE4.
  196. %if %{ruby}
  197. %package -n kross-ruby
  198. Group: Development/Languages
  199. Summary: Kross plugin for ruby
  200. Requires: ruby
  201. Requires: kdelibs4 >= %{version}
  202. Provides: kross(ruby) = %{version}-%{release}
  203. %description -n kross-ruby
  204. Ruby plugin for the Kross archtecture in KDE4.
  205. %endif
  206. %if %{falcon}
  207. %package -n kross-falcon
  208. Group: Development/Languages
  209. Summary: Kross plugin for falcon
  210. Requires: Falcon >= 0.8.12
  211. Requires: kdelibs4 >= %{version}
  212. Provides: kross(falcon) = %{version}-%{release}
  213. %description -n kross-falcon
  214. Falcon plugin for the Kross archtecture in KDE4.
  215. %endif
  216. %prep
  217. %setup -q
  218. # do the no-rpath hack last, after the upstream backports (if any)
  219. #patch1 -p1 -b .no-rpath
  220. #sed -i -e 's!COMMAND generator!COMMAND ${PROJECT_BINARY_DIR}/generator/bin/generator${CMAKE_EXECUTABLE_SUFFIX}.shell!g' -e 's/WORKING_DIRECTORY/DEPENDS generator WORKING_DIRECTORY/g' smoke/*/CMakeLists.txt
  221. %build
  222. mkdir -p %{_target_platform}
  223. pushd %{_target_platform}
  224. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  225. %cmake \
  226. -DCMAKE_BUILD_TYPE=release \
  227. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  228. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  229. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  230. -DPYTHON_LIBRARY=%{_libdir}/libpython%{python_ver}.so.1.0 \
  231. -DPYTHON_LIBRARIES=%{_libdir}/libpython%{python_ver}.so.1.0 \
  232. -DPYTHON_INCLUDE_PATH=%{_includedir}/python%{python_ver} \
  233. %if %{csharp}
  234. -DENABLE_QYOTO=ON \
  235. %else
  236. -DBUILD_csharp=OFF \
  237. %endif
  238. %if %{falcon}
  239. -DENABLE_KROSSFALCON=ON \
  240. %else
  241. -DBUILD_falcon=OFF \
  242. %endif
  243. %if %{php}
  244. -DENABLE_PHP-QT=ON \
  245. %else
  246. -DBUILD_php=OFF \
  247. %endif
  248. %if %{ruby}
  249. -DRUBY_SITE_LIB_DIR:PATH=%{ruby_sitelib} \
  250. -DRUBY_SITE_ARCH_DIR:PATH=%{ruby_sitearch} \
  251. -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_lib} \
  252. -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_arch} \
  253. %else
  254. -DBUILD_ruby=OFF \
  255. %endif
  256. %if %{smoke}
  257. -DENABLE_SMOKE=ON \
  258. %else
  259. -DBUILD_smoke=OFF \
  260. %endif
  261. %if %{java}
  262. -DENABLE_KROSSJAVA=ON \
  263. %else
  264. -DBUILD_java=OFF \
  265. %endif
  266. -DCMAKE_SKIP_RPATH:BOOL=OFF \
  267. ..
  268. popd
  269. # -DRUBY_INCLUDE_PATH:PATH=%{ruby_arch} \
  270. # smp build not recommended (upstream)
  271. make -C %{_target_platform}
  272. %install
  273. rm -rf $RPM_BUILD_ROOT
  274. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  275. # HACK: fix multilb conflict, similar to PyQt4's http://bugzilla.redhat.com/509415
  276. rm -fv $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  277. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py \
  278. $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  279. ln -s %{_bindir}/pykdeuic4 \
  280. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py
  281. # install pykde4 examples under correct dir
  282. #mkdir -p %{buildroot}%{_docdir}
  283. #rm -f %{buildroot}%{_datadir}/kde4/apps/pykde4/examples/*.py?
  284. #mv %{buildroot}%{_datadir}/kde4/apps/pykde4 %{buildroot}%{_docdir}/
  285. # bz#551534 - qyoto doesn't pull mono in
  286. %if %{csharp}
  287. find %{buildroot} -name \*.dll -not -type l | xargs chmod ugo+x
  288. %endif
  289. %clean
  290. rm -rf $RPM_BUILD_ROOT
  291. %post -p /sbin/ldconfig
  292. %postun -p /sbin/ldconfig
  293. %pre -n PyKDE4-devel
  294. if [ -d %{_bindir}/pykdeuic4 ]; then
  295. rm -rf %{_bindir}/pykdeuic4/
  296. fi
  297. %files
  298. %defattr(-,root,root)
  299. %doc AUTHORS ChangeLog COPYING NEWS README
  300. %if %{smoke}
  301. %{_libdir}/libsmoke*.so.*
  302. %endif
  303. %files devel
  304. %defattr(-,root,root)
  305. %if %{smoke}
  306. %{_bindir}/smoke*
  307. %{_includedir}/smoke.h
  308. %{_includedir}/smoke
  309. %{_libdir}/libcppparser.so
  310. %{_libdir}/libsmoke*.so
  311. %dir %{_libdir}/smokegen
  312. %{_libdir}/smokegen/*.so
  313. %{_datadir}/smokegen
  314. %endif
  315. %files -n PyKDE4
  316. %defattr(-,root,root,-)
  317. %doc COPYING
  318. %{python_sitearch}/PyKDE4
  319. %{python_sitearch}/PyQt4/uic/widget-plugins/kde4.py*
  320. %dir %{_datadir}/kde4/apps/pykde4
  321. %{_libdir}/kde4/kpythonpluginfactory.so
  322. %exclude %{python_sitearch}/PyKDE4/akonadi.so
  323. %files -n PyKDE4-akonadi
  324. %defattr(-,root,root,-)
  325. %{python_sitearch}/PyKDE4/akonadi.so
  326. %files -n PyKDE4-devel
  327. %defattr(-,root,root,-)
  328. %{_bindir}/pykdeuic4
  329. %{python_sitearch}/PyQt4/uic/pykdeuic4.py*
  330. %{_datadir}/kde4/apps/pykde4/examples/
  331. %{_datadir}/sip/PyKDE4
  332. %if %{csharp}
  333. %files -n kimono
  334. %defattr(-,root,root,-)
  335. %{_libdir}/kde4/kimonopluginfactory.so
  336. %{_libdir}/libakonadi-sharp.so
  337. %{_libdir}/libkhtml-sharp.so
  338. %{_libdir}/libkimono.so
  339. %{_libdir}/libktexteditor-sharp.so
  340. %{_libdir}/libnepomuk-sharp.so
  341. %{_libdir}/libplasma-sharp.so
  342. %{_libdir}/libsoprano-sharp.so
  343. %{_libdir}/libqimageblitz-sharp.so
  344. %{mono_dir}/qyoto/qimageblitz.dll
  345. %{mono_dir}/qyoto/akonadi.dll
  346. %{mono_dir}/qyoto/kde-dotnet.dll
  347. %{mono_dir}/qyoto/khtml-dll.dll
  348. %{mono_dir}/qyoto/ktexteditor-dotnet.dll
  349. %{mono_dir}/qyoto/nepomuk-dll.dll
  350. %{mono_dir}/qyoto/plasma-dll.dll
  351. %{mono_dir}/qyoto/soprano.dll
  352. %{mono_dir}/gac/akonadi
  353. %{mono_dir}/gac/kde-dotnet
  354. %{mono_dir}/gac/khtml-dll
  355. %{mono_dir}/gac/ktexteditor-dotnet
  356. %{mono_dir}/gac/nepomuk-dll
  357. %{mono_dir}/gac/plasma-dll
  358. %{mono_dir}/gac/soprano
  359. %{mono_dir}/gac/qimageblitz
  360. %{_datadir}/kde4/apps/plasma_scriptengine_kimono
  361. %{_datadir}/kde4/services/plasma-scriptengine-kimono-applet.desktop
  362. %{_datadir}/kde4/services/plasma-scriptengine-kimono-dataengine.desktop
  363. %files -n qyoto
  364. %defattr(-,root,root,-)
  365. %{_libdir}/libqtscript-sharp.so
  366. %{_libdir}/libqttest-sharp.so
  367. %{_libdir}/libqtuitools-sharp.so
  368. %{_libdir}/libqtwebkit-sharp.so
  369. %{_libdir}/libqyoto.so
  370. %{_libdir}/libqyotoshared.so.1
  371. %{_libdir}/libqyotoshared.so.1.0.0
  372. %{mono_dir}/qyoto/qt-dotnet.dll
  373. %{mono_dir}/qyoto/qtscript.dll
  374. %{mono_dir}/qyoto/qttest.dll
  375. %{mono_dir}/qyoto/qtuitools.dll
  376. %{mono_dir}/qyoto/qtwebkit.dll
  377. %{mono_dir}/gac/qt-dotnet
  378. %{mono_dir}/gac/qtscript
  379. %{mono_dir}/gac/qttest
  380. %{mono_dir}/gac/qtuitools
  381. %{mono_dir}/gac/qtwebkit
  382. %files -n qyoto-devel
  383. %defattr(-,root,root,-)
  384. %{_bindir}/csrcc
  385. %{_bindir}/uics
  386. %{_includedir}/qyoto
  387. %{_libdir}/libqyotoshared.so
  388. %{_libdir}/pkgconfig/*
  389. %endif
  390. %if %{ruby}
  391. %files -n korundum
  392. %defattr(-,root,root,-)
  393. %{_bindir}/krubyapplication
  394. %{ruby_lib}/KDE/
  395. %{ruby_lib}/akonadi/
  396. %{ruby_lib}/khtml/
  397. %{ruby_lib}/ktexteditor/
  398. %{ruby_lib}/okular/
  399. %{ruby_lib}/solid/
  400. %{ruby_lib}/soprano/
  401. %{ruby_lib}/nepomuk/
  402. %{ruby_arch}/akonadi.so
  403. %{ruby_arch}/khtml.so
  404. %{ruby_arch}/korundum4.so
  405. %{ruby_arch}/ktexteditor.so
  406. %{ruby_arch}/okular.so
  407. %{ruby_arch}/plasma_applet.so
  408. %{ruby_arch}/solid.so
  409. %{ruby_arch}/soprano.so
  410. %{ruby_arch}/nepomuk.so
  411. %{_libdir}/kde4/krubypluginfactory.so
  412. %{_datadir}/applications/kde4/dbpedia_references.desktop
  413. %{_datadir}/kde4/apps/dbpedia_references
  414. %files -n korundum-devel
  415. %defattr(-,root,root,-)
  416. %{_bindir}/rbkconfig_compiler4
  417. %{_includedir}/qtruby/
  418. %exclude %{_libdir}/libqtruby4shared.so
  419. %files -n QtRuby
  420. %defattr(-,root,root,-)
  421. %{ruby_lib}/Qt/
  422. %{ruby_lib}/Qt*.rb
  423. %{ruby_lib}/qtscript/
  424. %{ruby_lib}/qttest/
  425. %{ruby_lib}/qtuitools/
  426. %{ruby_lib}/qtwebkit/
  427. %{ruby_arch}/qt*.so
  428. %{_libdir}/libqtruby4shared.so.2
  429. %{_libdir}/libqtruby4shared.so.2.0.0
  430. %files -n QtRuby-devel
  431. %defattr(-,root,root,-)
  432. %{_bindir}/rbqtapi
  433. %{_bindir}/rbrcc
  434. %{_bindir}/rbuic4
  435. %{_libdir}/libqtruby4shared.so
  436. %endif
  437. %if %{php}
  438. %files -n php-qt
  439. %defattr(-,root,root,-)
  440. %{_libdir}/php5/php_qt.so
  441. %files -n php-qt-devel
  442. %defattr(-,root,root,-)
  443. %{_bindir}/phpuic
  444. %endif
  445. %files -n kross-python
  446. %defattr(-,root,root,-)
  447. # unversioned library
  448. %{_libdir}/kde4/krosspython.so
  449. %if %{ruby}
  450. %files -n kross-ruby
  451. %defattr(-,root,root,-)
  452. %{_libdir}/kde4/krossruby.so
  453. %endif
  454. %if %{falcon}
  455. %files -n kross-falcon
  456. %defattr(-,root,root,-)
  457. %{_libdir}/kde4/krossfalcon.so
  458. %endif
  459. %changelog
  460. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  461. - new upstream release
  462. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  463. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  464. - built with new toolchain
  465. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  466. - new upstream release
  467. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  468. - merged 4.3.1-2 %changelog
  469. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  470. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  471. - use %%{_prefix}/lib for mono-dll (for x86_64)
  472. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  473. - new upstream release
  474. - built with PyQt4-4.6
  475. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  476. - define %%{mono_dir} to specify mono library install path
  477. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  478. - new upstream release
  479. - fixed ruby modules installation path
  480. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  481. - new upstream release
  482. - spilt sub package based on Fedora
  483. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  484. - applied new versioning policy
  485. - added Patch1
  486. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  487. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  488. - added --with-qt-libraries option
  489. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  490. - rebuild for VineSeed
  491. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  492. - new upstream release
  493. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  494. - rebuild for VineSeed
  495. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  496. - new upstream release
  497. - update Patch0
  498. - drop Patch1
  499. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  500. - new upstream release
  501. - add Patch1
  502. - add --enable-libsuffix option
  503. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  504. - rebuild for VineSeed
  505. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  506. - new upstream release
  507. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  508. - rebuild for VineSeed
  509. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  510. - new upstream release
  511. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  512. - rebuild for VineSeed
  513. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  514. - new upstream release
  515. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  516. - rebuild for VineSeed
  517. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  518. - new upstream release
  519. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  520. - rebuild for VineSeed
  521. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  522. - new upstream release
  523. - renew BuildPrereq and build section
  524. - renew %%files
  525. - enable python
  526. - change spec to make main and devel package
  527. - add BuildPrereq: ruby ruby-devel
  528. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  529. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  530. - build for VineSeed
  531. - disable python and mozilla
  532. - objprelink (i386 only)
  533. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  534. - 2.2.2
  535. - build kmozilla binding only on x86/alpha
  536. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  537. - Make sure %%{name}-kmozilla isn't built on ia64
  538. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  539. - Move python bindings to separate package
  540. - Add perl bindings
  541. - Shut up rpmlint
  542. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  543. - 2.1
  544. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  545. - initial RPM