libbonobo-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316
  1. %define libxml2_version 2.6.23
  2. %define orbit2_version 2.14.17
  3. %define po_package libbonobo-2.0
  4. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  5. Summary: Bonobo component system
  6. Summary(ja): Bonobo コンポーネントシステム
  7. Name: libbonobo
  8. Version: 2.24.2
  9. Release: 1%{?_dist_release}
  10. URL: http://ftp.gnome.org/
  11. Source0: %{name}-%{version}.tar.bz2
  12. Patch10: %{name}-2.14.0-i18n-help.patch
  13. License: LGPL
  14. Group: System Environment/Libraries
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libxml2-devel >= %{libxml2_version}
  17. BuildRequires: ORBit2-devel >= %{orbit2_version}
  18. Obsoletes: bonobo-activation
  19. Provides: bonobo-activation
  20. %description
  21. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  22. %description -l ja
  23. Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
  24. システムです。
  25. %package devel
  26. Summary: Libraries and headers for libbonobo
  27. Summary: libbonobo のライブラリおよびヘッダ
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. Requires: ORBit2-devel >= %{orbit2_version}
  31. Requires: libxml2-devel >= %{libxml2_version}
  32. Obsoletes: bonobo-activation-devel
  33. Provides: bonobo-activation-devel
  34. Conflicts: bonobo-devel < 1.0.8
  35. %description devel
  36. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  37. This package contains header files used to compile programs that
  38. use Bonobo.
  39. %description devel -l ja
  40. Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
  41. システムです。
  42. このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
  43. ヘッダファイルが収録されています。
  44. # compat32
  45. %package -n compat32-%{name}
  46. Summary: Bonobo component system
  47. Summary(ja): Bonobo コンポーネントシステム
  48. Group: System Environment/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. %description -n compat32-%{name}
  51. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  52. %description -n compat32-%{name} -l ja
  53. Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
  54. システムです。
  55. %package -n compat32-%{name}-devel
  56. Summary: Libraries and headers for libbonobo
  57. Summary: libbonobo のライブラリおよびヘッダ
  58. Group: Development/Libraries
  59. Requires: %{name}-devel = %{version}-%{release}
  60. Requires: compat32-%{name} = %{version}-%{release}
  61. Requires: compat32-ORBit2-devel >= %{orbit2_version}
  62. Requires: compat32-libxml2-devel >= %{libxml2_version}
  63. %description -n compat32-%{name}-devel
  64. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  65. This package contains header files used to compile programs that
  66. use Bonobo.
  67. %description -n compat32-%{name}-devel -l ja
  68. Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
  69. システムです。
  70. このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
  71. ヘッダファイルが収録されています。
  72. %prep
  73. %setup -q -n %{name}-%{version}
  74. #patch1 -p1 -b .env-leak
  75. %patch10 -p1 -b .i18n-help
  76. %build
  77. %configure --disable-static
  78. make
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. %makeinstall
  82. ## just kill this wherever it lives
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo-2.0/samples/bonobo-echo-2
  84. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/bonobo-2.0/samples/bonobo-echo-2
  85. ## kill other stuff
  86. rm $RPM_BUILD_ROOT%{_bindir}/echo-client-2
  87. rm $RPM_BUILD_ROOT%{_libdir}/*.la
  88. rm $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.*a
  89. rm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.*a
  90. %find_lang %{po_package}
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %post -p /sbin/ldconfig
  94. %postun -p /sbin/ldconfig
  95. %post -n compat32-%{name} -p /sbin/ldconfig
  96. %postun -n compat32-%{name} -p /sbin/ldconfig
  97. %files -f %{po_package}.lang
  98. %defattr(-,root,root)
  99. %doc AUTHORS COPYING ChangeLog NEWS README
  100. %{_libdir}/lib*.so.*
  101. %{_libdir}/bonobo
  102. %{_libdir}/orbit-2.0/*.so*
  103. %{_bindir}*
  104. %{_libexecdir}/*
  105. %{_sbindir}/*
  106. %dir %{_sysconfdir}/bonobo-activation
  107. %config %{_sysconfdir}/bonobo-activation/*
  108. %{_mandir}/man*/*
  109. %files devel
  110. %defattr(-,root,root)
  111. #{_libdir}/lib*.a
  112. %{_libdir}/lib*.so
  113. %{_libdir}/pkgconfig/*.pc
  114. %{_includedir}/*
  115. %{_datadir}/idl
  116. %{_datadir}/gtk-doc
  117. # compat32
  118. %if %{build_compat32}
  119. %files -n compat32-%{name}
  120. %defattr(-,root,root)
  121. %{_libdir}/lib*.so.*
  122. %{_libdir}/bonobo
  123. %{_libdir}/orbit-2.0/*.so*
  124. %files -n compat32-%{name}-devel
  125. %defattr(-,root,root)
  126. #{_libdir}/lib*.a
  127. %{_libdir}/lib*.so
  128. %{_libdir}/pkgconfig/*.pc
  129. %endif
  130. %changelog
  131. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
  132. - new upstream release
  133. * Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
  134. - added --disable-static configure option
  135. - added compat32 package for x86_64 arch support
  136. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  137. - new upstream release
  138. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  139. - new upstream release
  140. * Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.3-0vl1
  141. - new upstream release
  142. * Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
  143. - new upstream release
  144. * Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl2
  145. - add upstream patch1
  146. * Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
  147. - new upstream release
  148. * Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
  149. - update Patch0 to fix more help message translation.
  150. * Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  151. - add bindtextdomain_codeset in bonobo-activation initialize
  152. to fix corruption of help option message.(Patch0)
  153. * Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  154. - new upstream release
  155. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
  156. - new upstream release
  157. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  158. - new upstream release
  159. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  160. - new upstream release
  161. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  162. - new upstream release
  163. * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
  164. - new upstream release
  165. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  166. - new upstream release
  167. * Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
  168. - new upstream release
  169. * Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
  170. - new upstream release
  171. - rebuild with new toolchains
  172. * Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  173. - new upstream release
  174. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  175. - new upstream release
  176. * Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
  177. - new upstream release
  178. * Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  179. - new upstream release
  180. * Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  181. - new upstream release
  182. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  183. - new upstream release
  184. * Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.0-0vl1
  185. - build for Vine Linux
  186. * Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
  187. - Fix find_lang
  188. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  189. - rebuild in different environment
  190. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  191. - 2.0.0
  192. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  193. - automated rebuild
  194. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  195. - rebuild in different environment
  196. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  197. - 1.117.0
  198. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  199. - 1.116.0
  200. * Thu Apr 4 2002 Jeremy Katz <katzj@redhat.com>
  201. - 1.113.0
  202. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  203. - 1.111.0
  204. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  205. - Version 1.110.0
  206. - Rebuild for dependencies
  207. - Intltoolize, the included version has problems with our Perl
  208. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  209. - automake-1.4
  210. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  211. - 1.108.0.90 cvs snap
  212. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  213. - 1.107.0, glib 1.3.11
  214. * Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
  215. - rebuild for new glib, new snap
  216. * Fri Oct 5 2001 Havoc Pennington <hp@redhat.com>
  217. - rebuild for new glib
  218. * Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
  219. - move to 1.103.0 tarball
  220. - call automake after patching Makefile.am
  221. - patch for parallel install
  222. * Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
  223. - add some requires
  224. * Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
  225. - conflict with bonobo < 1.0.8 to avoid header conflicts
  226. - update group
  227. * Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
  228. - moved IDL files into subdir
  229. - remove smp_mflags, libbonobo does not like those
  230. * Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
  231. - remove IDL files as temporary hack
  232. * Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
  233. - Initial build.