python-ldap-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define openldap_version 2.1.22
  3. ### Abstract ###
  4. Name: python-ldap
  5. Version: 2.3.5
  6. Release: 2%{?_dist_release}
  7. Epoch: 0
  8. License: Python
  9. Group: System Environment/Libraries
  10. Summary: An object-oriented API for Python to access LDAP directory servers
  11. Summary(ja): Python 用 LDAP インタフェースモジュール
  12. URL: http://python-ldap.sourceforge.net/
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Source0: http://download.sourceforge.net/python-ldap/python-ldap-%{version}.tar.gz
  15. ### Patches ###
  16. Patch0: python-ldap-2.2.0-dirs.patch
  17. ### Dependencies ###
  18. Requires: openldap >= %{openldap_version}
  19. ### Build Dependencies ###
  20. # the openldap from RHL <= 9 and RHEL <= 3 is too old for python-ldap
  21. BuildRequires: openldap-devel >= %{openldap_version}
  22. BuildRequires: openssl-devel
  23. BuildRequires: python-devel >= 2.2
  24. BuildRequires: cyrus-sasl-devel
  25. %description
  26. python-ldap provides an object-oriented API for working with LDAP within
  27. Python programs. It allows access to LDAP directory servers by wrapping the
  28. OpenLDAP 2.x libraries, and contains modules for other LDAP-related tasks
  29. (including processing LDIF, LDAPURLs, LDAPv3 schema, etc.).
  30. %description -l ja
  31. python-ldap により、Python プログラムから LDAP へアクセスするための
  32. オブジェクト志向 API が提供されます。OpenLDAP 2.x のライブラリのラッパー
  33. として動作し、LDAP ディレクトリサーバへのアクセスを行うことができます。
  34. また他に LDIF、LDAPURL、LDAPv3 スキーマといった LDAP 関連用のモジュールも
  35. 収録されています。
  36. %prep
  37. %setup -q -n python-ldap-%{version}
  38. %patch0 -p1 -b .dirs
  39. # clean up cvs hidden files
  40. rm -rf Demo/Lib/ldap/.cvsignore Demo/.cvsignore Demo/Lib/ldif/.cvsignore Demo/Lib/ldap/async/.cvsignore \
  41. Demo/Lib/.cvsignore Demo/Lib/ldapurl/.cvsignore
  42. # Fix interpreter
  43. sed -i 's|#! python|#!/usr/bin/python|g' Demo/simplebrowse.py
  44. %build
  45. %{__python} setup.py build
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc LICENCE CHANGES README TODO Demo
  54. %{python_sitearch}/_ldap.so
  55. %{python_sitearch}/dsml.py*
  56. %{python_sitearch}/ldapurl.py*
  57. %{python_sitearch}/ldif.py*
  58. %{python_sitearch}/ldap/
  59. %{python_sitearch}/python_ldap-%{version}-*.egg-info/
  60. %changelog
  61. * Sat Apr 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-2
  62. - rebuilt with openldap-2.4.11
  63. * Tue Feb 3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-1
  64. - initial build for Vine Linux
  65. * Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> - 0:2.3.5-3
  66. - rebuild with new openssl
  67. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0:2.3.5-2
  68. - Rebuild for Python 2.6
  69. * Wed Sep 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.3.5-1
  70. - fix license tag
  71. - update to 2.3.5
  72. * Sun Feb 17 2008 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-3.fc9
  73. - Rebuild with GCC 4.3
  74. * Wed Dec 05 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-2.fc9
  75. - Rebuild against new openssl.
  76. * Wed Oct 10 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-1.fc8
  77. - Update to 2.3.1
  78. * Fri Jun 08 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.0-1.fc8
  79. - Update to 2.3
  80. - Spec file cleanups.
  81. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0:2.2.0-3
  82. - rebuild against python 2.5
  83. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com>
  84. - rebuild
  85. * Wed May 17 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-2
  86. - Put back the epoch line... happy beehive?
  87. * Tue May 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-1
  88. - Update to 2.2.0
  89. - Update python-ldap-2.0.6-rpath.patch and rename it to
  90. python-ldap-2.2.0-dirs.patch.
  91. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2.1
  92. - bump again for double-long bug on ppc(64)
  93. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2
  94. - rebuilt for new gcc4.1 snapshot and glibc changes
  95. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  96. - rebuilt
  97. * Tue Nov 8 2005 Tomas Mraz <tmraz@redhat.com> - 2.0.6-5
  98. - rebuilt with new openssl
  99. * Tue Mar 22 2005 Warren Togami <wtogami@redhat.com> - 2.0.6-4
  100. - add LICENCE (#150842)
  101. - simplify python reqs
  102. - remove invalid rpath
  103. * Wed Mar 16 2005 Dan Williams <dcbw@redhat.com> - 0:2.0.6-2
  104. - rebuilt to pick up new libssl.so.5
  105. * Tue Feb 8 2005 David Malcolm <dmalcolm@redhat.com> - 0:2.0.6-1
  106. - 2.0.6
  107. * Tue Nov 16 2004 Nalin Dahyabhai <nalin@redhat.com> - 0:2.0.1-3
  108. - rebuild (#139161)
  109. * Mon Aug 30 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-2
  110. - Rewrote description; added requirement for openldap
  111. * Tue Aug 17 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-1
  112. - imported into Red Hat's packaging system from Fedora.us; set release to 1
  113. * Wed Jun 30 2004 Panu Matilainen <pmatilai@welho.com> 0:2.0.1-0.fdr.1
  114. - update to 2.0.1
  115. * Sun Dec 07 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.4.pre16
  116. - fix spec permissions + release tag order (bug 1099)
  117. * Sat Dec 6 2003 Ville Skyttä <ville.skytta at iki.fi> 0:2.0.0-0.fdr.0.pre16.3
  118. - Stricter python version requirements.
  119. - BuildRequire openssl-devel.
  120. - Explicitly build *.pyo, install them as %%ghost.
  121. - Own more installed dirs.
  122. - Remove $RPM_BUILD_ROOT at start of %%install.
  123. * Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.2
  124. - duh, build requires python-devel, not just python...
  125. * Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.1
  126. - Initial Fedora packaging.