scim-bridge-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278
  1. %define name scim-bridge
  2. %define version 0.4.16
  3. %define release 7%{?_dist_release}
  4. # build qt3 immodule ("--without qt3" to disable qt3)
  5. %bcond_without qt3
  6. %define qt3ver %(rpm -q --queryformat '%%{version}' qt)
  7. %define qt3rel %(rpm -q --queryformat '%%{release}' qt)
  8. %define qt3dir %{_libdir}/qt-%{qt3ver}
  9. # build qt4 immodule ("--without qt4" to disable qt4)
  10. %bcond_without qt4
  11. %define qt4ver %(rpm -q --queryformat '%%{version}' qt4)
  12. %define qt4rel %(rpm -q --queryformat '%%{release}' qt4)
  13. %define _qt4_prefix %(pkg-config --variable prefix Qt)
  14. %define _qt4_plugindir %(pkg-config --variable plugindir Qt)
  15. Summary: yet another IM client of SCIM
  16. Summary(ja): もう一つ別の SCIM IM クライアント
  17. Name: %{name}
  18. Version: %{version}
  19. Release: %{release}
  20. Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
  21. # Patch from Fedora 10
  22. Patch0: scim-bridge-0.4.15-fix-gdm.patch
  23. Patch1: scim-bridge-0.4.15-bz461373.patch
  24. # Patch from Mandriva 2009
  25. Patch2: bug-351920-should-return-retval.patch
  26. Patch3: scim-bridge-0.4.15.2-linkage.patch
  27. # Patch from Fedora development
  28. Patch4: scim-bridge-0.4.15-EOF.patch
  29. Patch5: scim-bridge-0.4.15-hotkey-help.patch
  30. Url: http://www.scim-im.org/projects/scim_bridge
  31. License: GPL/LGPL
  32. Group: System Environment/Libraries
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
  34. Prefix: %{_prefix}
  35. Requires: scim >= 1.4
  36. BuildRequires: scim-devel >= 1.4 pkgconfig >= 0.9.0, gtk2-devel >= 2.14.0
  37. %description
  38. Scim-bridge is yet another IM client of SCIM.
  39. The im-module of scim-bridge communicates with scim via socket.
  40. %description -l ja
  41. scim-bridge は、もう一つ別の SCIM IM クライアントです。
  42. scim-bridge の im-module はソケット経由で SCIM と通信します。
  43. %package gtk
  44. Summary: SCIM Bridge GTK IM Module
  45. Summary(ja): SCIM Bridge GTK IM モジュール
  46. Group: System Environment/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: gtk2 >= 2.14.0
  49. PreReq: gtk2 >= 2.14.0
  50. Obsoletes: %{name} <= 0.1.7
  51. %description gtk
  52. This package provides the SCIM Bridge GTK IM module.
  53. %description -l ja gtk
  54. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  55. %if !%{without qt3}
  56. %package qt
  57. Summary: SCIM Bridge Qt IM Module
  58. Summary(ja): SCIM Bridge Qt IM モジュール
  59. Group: System Environment/Libraries
  60. Requires: %{name} = %{version}-%{release}
  61. #Requires: qt = %{qt3ver}-%{qt3rel}
  62. Requires: qt = %{qt3ver}
  63. BuildRequires: qt-devel >= %{qt3ver}-%{qt3rel}
  64. %description qt
  65. This package provides the SCIM Bridge Qt IM module.
  66. %description -l ja qt
  67. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  68. %endif
  69. %if !%{without qt4}
  70. %package qt4
  71. Summary: SCIM Bridge Qt4 IM Module
  72. Summary(ja): SCIM Bridge Qt4 IM モジュール
  73. Group: System Environment/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. #Requires: qt4 = %{qt4ver}-%{qt4rel}
  76. Requires: qt4 = %{qt4ver}
  77. BuildRequires: qt4-devel >= %{qt4ver}-%{qt4rel}
  78. %description qt4
  79. This package provides the SCIM Bridge Qt4 IM module.
  80. %description -l ja qt4
  81. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  82. %endif
  83. %prep
  84. %setup -q
  85. %patch0 -p1 -b .0-fix-gdm
  86. %patch1 -p1
  87. %patch2 -p1
  88. %patch3
  89. %patch4 -p1
  90. %patch5 -p1
  91. %build
  92. %if !%{without qt3}
  93. export QT3_PREFIX=%{qt3dir}
  94. %endif
  95. %if !%{without qt4}
  96. export QT4_PREFIX=%{_qt4_prefix}
  97. %endif
  98. %configure \
  99. %if %{without qt3}
  100. --disable-qt3-immodule \
  101. %else
  102. --enable-qt3-immodule \
  103. %endif
  104. %if %{without qt4}
  105. --disable-qt4-immodule \
  106. %else
  107. --enable-qt4-immodule \
  108. %endif
  109. --enable-gtk2-immodule
  110. %__make
  111. %install
  112. %__rm -rf %{buildroot}
  113. #%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
  114. %__make DESTDIR=%{buildroot} install
  115. # remove unneeded files
  116. %__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
  117. %__rm -f %{buildroot}%{qt3dir}/plugins/inputmethods/*.{a,la}
  118. %__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
  119. %clean
  120. %__rm -rf %{buildroot}
  121. %post gtk
  122. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  123. %postun gtk
  124. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  125. %files
  126. %defattr(-,root,root)
  127. %doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
  128. %{_bindir}/scim-bridge
  129. %files gtk
  130. %defattr(-,root,root)
  131. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  132. %if !%{without qt3}
  133. %files qt
  134. %defattr(-,root,root)
  135. %{qt3dir}/plugins/inputmethods/*.so
  136. %endif
  137. %if !%{without qt4}
  138. %files qt4
  139. %defattr(-,root,root)
  140. %{_qt4_plugindir}/inputmethods/*.so
  141. %endif
  142. %changelog
  143. * Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
  144. - rebuilt with qt4-4.6.1
  145. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
  146. - rebuilt with qt4-4.5.3
  147. * Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
  148. - cleaned up spec
  149. - renumbered patch
  150. - added Patch5 from Fedora
  151. * Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
  152. - rebuild with qt4-4.5.2
  153. * Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
  154. - dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
  155. * Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
  156. - rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
  157. * Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
  158. - new upstream release
  159. - dropt Pacth3,4,5 (these patches are merged)
  160. * Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
  161. - spec in UTF-8
  162. - fixed description in scim-bridge-qt4
  163. - added patch6,7 (import Fedora, Mandriva patches)
  164. * Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
  165. - new upstream release
  166. - added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
  167. * Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
  168. - rebuild with qt4-4.4.2
  169. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
  170. - add qt4 immodule
  171. - build gtk,qt3,qt4 immodule by default
  172. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
  173. - rebuild with gtk+-2.14
  174. * Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
  175. - new upstream release
  176. - apply new versioning policy
  177. * Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
  178. - drop unnecessary BuildRequires for qt3-immodule package
  179. - fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
  180. * Wed Jan 9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
  181. - new upstream release
  182. - drop unnecessary Qt fix patch ( Patch0 ): upstream merged
  183. - update BuildRequires
  184. - drop doxygen
  185. - add XOrg-gl-devel for building qt3-immodule
  186. - move libmng-devel for building qt3-immodule
  187. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
  188. - rebuild for Vine Linux 4.2.
  189. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
  190. - add patch0 to fix symbol lookup error with qt3.
  191. * Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
  192. - rebuild for Vine Linux 4.2.
  193. * Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
  194. - new upstrm release
  195. - detect qt version at build time.
  196. - add --disable-qt4-immodule configure option.
  197. - add BuildRequires libmng-devel.
  198. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
  199. - rebuild with libstdc++34
  200. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
  201. - new upstream release
  202. * Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
  203. - change License to GPL/LGPL
  204. - add doc/LICENSE.* as documents
  205. * Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
  206. - new upstream release
  207. - add BuildRequires: doxygen, qt-devel
  208. - add new sub-packages:
  209. - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
  210. - qt: Qt IM module
  211. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
  212. - new upstream release
  213. - add documents
  214. - running gtk-query-immodules-2.0 in post and postun scripts
  215. - add PreReq: gtk2 > 2.2
  216. * Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
  217. - new upstream release
  218. * Thu Apr 6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
  219. - initial release