vte-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533
  1. Summary: An terminal emulator.
  2. Summary(ja): ターミナルエミュレータ
  3. Name: vte
  4. Version: 0.22.5
  5. Release: 1%{?_dist_release}
  6. License: LGPL
  7. Group: System Environment/Libraries
  8. Source: %{name}-%{version}.tar.bz2
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: gtk2-devel
  11. BuildRequires: python-devel
  12. BuildRequires: pygtk2-devel
  13. BuildRequires: ncurses-devel
  14. %description
  15. VTE is an experimental terminal emulator widget for use with GTK+ 2.0.
  16. %description -l ja
  17. VTE は GTK+2.0 用のターミナルエミュレータウィジェットです。
  18. %package devel
  19. Summary: Files needed for developing applications which use vte.
  20. Summary(ja): VTE を使用したアプリケーションの開発に必要なファイル群
  21. Group: Development/Libraries
  22. Requires: %{name} = %{version}-%{release}
  23. Requires: gtk2-devel
  24. %description devel
  25. VTE is an experimental terminal emulator widget for use with GTK+ 2.0. This
  26. package contains the files needed for building applications using VTE.
  27. %prep
  28. %setup -q
  29. %build
  30. if [ -x %{_bindir}/python2.4 ]; then
  31. PYTHON=%{_bindir}/python2.4; export PYTHON
  32. fi
  33. %configure --enable-shared --enable-static --without-glX
  34. make %{?_smp_mflags}
  35. %install
  36. rm -fr $RPM_BUILD_ROOT
  37. make install DESTDIR=$RPM_BUILD_ROOT
  38. %find_lang %{name}
  39. rm -f $RPM_BUILD_ROOT/%{_bindir}/%{name}
  40. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.{a,la}
  41. rm -f $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/*.la
  42. rm -f $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/*.a
  43. %clean
  44. rm -fr $RPM_BUILD_ROOT
  45. %post -p /sbin/ldconfig
  46. %postun -p /sbin/ldconfig
  47. %files -f %{name}.lang
  48. %defattr(-,root,root)
  49. %doc ChangeLog COPYING HACKING NEWS README
  50. %doc doc/utmpwtmp.txt doc/boxes.txt src/iso2022.txt doc/openi18n/UTF-8.txt doc/openi18n/wrap.txt
  51. %{_libdir}/*.so.*
  52. %{_datadir}/%{name}
  53. %attr(2711,root,utmp) %{_libexecdir}/gnome-pty-helper
  54. %{_libdir}/python*/site-packages/gtk-2.0/*
  55. %files devel
  56. %defattr(-,root,root)
  57. %{_datadir}/gtk-doc/html/%{name}
  58. %{_includedir}/*
  59. %dir %{_libdir}/%{name}
  60. %{_libdir}/%{name}/*
  61. %{_libdir}/*.so
  62. %{_libdir}/pkgconfig/*
  63. %{_datadir}/pygtk/2.0/defs/vte.defs
  64. %changelog
  65. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.5-1
  66. - new upstream release
  67. - add BuildRequires: ncurses-devel
  68. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.22.4-3
  69. - rebuilt with gcc-4.4.3-3 on ppc
  70. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 0.22.4-2
  71. - rebuilt with python-2.6.4-3
  72. * Tue Nov 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22.4-1
  73. - new upstream release
  74. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22.2-1
  75. - new upstream release
  76. - moved %{_datadir}/pygtk/2.0/defs/vte.defs to devel package
  77. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.20.5-1
  78. - new upstream release
  79. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.20.2-1
  80. - new upstream release
  81. * Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.20.1-1
  82. - new upstream release
  83. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.20.0-1
  84. - new upstream release
  85. - remove static libs
  86. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.4-1
  87. - new upstream release
  88. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.3-1
  89. - new upstream release
  90. - drop patch1 (merged in now upstream)
  91. * Mon Aug 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.14-3
  92. - add Patch1 to fix cjk ambiguous width
  93. * Sun Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.14-2
  94. - rebuilt with python-2.5.2
  95. * Thu Jun 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.14-1
  96. - new upstream release
  97. - spec in UTF-8
  98. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.13-1vl5
  99. - new upstream release
  100. * Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.12-0vl1
  101. - new upstream release
  102. * Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.9-0vl1
  103. - new upstream release
  104. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.8-0vl1
  105. - new upstream release
  106. - changed Group to System Environment/Libraries
  107. - dropped Patch0 merged into upstream
  108. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.3-0vl2
  109. - add Patch0 to fix preedit crash
  110. http://bugzilla.gnome.org/show_bug.cgi?id=433776
  111. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.3-0vl1
  112. - new upstream release
  113. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.1-0vl1
  114. - new upstream release
  115. * Wed Aug 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.12.2-0vl2
  116. - add BuildRequires: pygtk2-devel
  117. * Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.2-0vl1
  118. - new upstream release
  119. * Thu Apr 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-0vl1
  120. - new upstream release
  121. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.0-0vl1
  122. - new upstream release
  123. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.21-0vl1
  124. - drop Patch10 which are merged in upstream
  125. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.20-0vl2
  126. - add Patch10 to update screen more frequently.
  127. (revert changes introduced in 0.11.19)
  128. * Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.20-0vl1
  129. - new upstream release
  130. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.15-0vl1
  131. - new upstream release
  132. * Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.12-0vl1
  133. - new upstream version
  134. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.11-0vl2
  135. - import some patches from fedora package.
  136. * Fri May 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.11-0vl1
  137. - new upstream release
  138. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.10-0vl3
  139. - rebuild with glib2-2.4.0
  140. * Sun Sep 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.10-0vl2
  141. - import Patch0,1 from rawhide
  142. - don't reset conversion states at end-of-line (GNOME #122156)
  143. - draw the preedit string the way GTK+ wants us to draw it (#104039)
  144. * Thu Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.10-0vl1
  145. - new upstream release
  146. * Mon Jun 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.9-0vl1
  147. - new upstream release
  148. * Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.6-0vl1
  149. - new upstream release
  150. * Sun May 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.28-0vl1
  151. - new upstream release
  152. * Fri Mar 7 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.26-0vl1
  153. - new upstream release
  154. * Wed Feb 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.25-0vl1
  155. - new upstream release
  156. * Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.22-0vl1
  157. - new upstream release
  158. * Fri Feb 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.19-0vl1
  159. - new upstream release
  160. * Sat Feb 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.16-0vl1
  161. - new upstream release
  162. * Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.15-0vl3
  163. - fixed permission
  164. * Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.15-0vl2
  165. - add missing /usr/libexec/gnome-pty-helper to %%files
  166. * Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.15-0vl1
  167. - new upstream release
  168. * Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.14-0vl1
  169. - new upstream release
  170. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.12-0vl1
  171. - new upstream release
  172. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.10-0vl1
  173. - new upstream release
  174. * Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.8-0vl1
  175. - new upstream release
  176. * Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.7-0vl1
  177. - build for Vine Linux
  178. - new upstream release (gnome-2.1.4)
  179. * Thu Sep 5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.19-1
  180. - possible fix for focusing bugs
  181. * Thu Sep 5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.18-1
  182. - fix for worst-case when stripping termcap entries from Brian Cameron
  183. - add docs
  184. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.17-1
  185. - track Xft color deallocation to prevent freeing of colors we don't own
  186. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.16-1
  187. - handle color allocation failures better
  188. * Mon Sep 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.15-1
  189. - cleanups
  190. * Fri Aug 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.14-1
  191. - get smarter about adjusting our adjustments (#73091)
  192. * Fri Aug 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.13-1
  193. - restore the IM status window by restoring our own focus-in/focus-out
  194. handlers (#72946)
  195. * Fri Aug 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-1
  196. - cleanups
  197. * Thu Aug 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.11-1
  198. - clean up autoscroll (#70481)
  199. - add Korean text examples to docs
  200. * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.10-1
  201. - autoscroll (#70481)
  202. - only perform cr-lf substitutions when pasting (#72639)
  203. - bind GDK_ISO_Left_Tab to "kB" (part of #70340)
  204. * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.9-1
  205. - handle forward scrolling again (#73409)
  206. * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.8-1
  207. - fix crashes on resize
  208. * Mon Aug 26 2002 Nalin Dahyabhai <nalin@redhat.com>
  209. - fix missing spaces on full lines
  210. * Mon Aug 26 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.7-1
  211. - fix deadlock when substitutions fail
  212. * Mon Aug 26 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.6-1
  213. - one-liner segfault bug fix
  214. * Sun Aug 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.5-1
  215. - fix reverse video mode, which broke during the rendering rewrite
  216. * Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.4-1
  217. - prevent up/UP/DO from scrolling
  218. - bind shift+insert to "paste PRIMARY", per xterm/kterm/hanterm
  219. * Thu Aug 22 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.3-1
  220. - track changes to the style's font
  221. - always open fonts right away so that the metric information is correct
  222. - make audible and visual bell independent options
  223. * Wed Aug 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.2-1
  224. - don't perform text substitution on text that is part of a control sequence
  225. * Tue Aug 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.1-1
  226. - dispose of the updated iso2022 context properly when processing incoming text
  227. * Tue Aug 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.0-1
  228. - rework font handling to use just-in-time loading
  229. - handle iso-2022 escape sequences, perhaps as much as they might make sense
  230. in a Unicode environment
  231. * Wed Aug 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.4-1
  232. - handle massive amounts of invalid data better (the /dev/urandom case)
  233. - munged up patch from Owen to fix language matching
  234. - fix initialization of new rows when deleting lines
  235. * Mon Aug 12 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.3-1
  236. - more fixes for behavior when not realized
  237. - require bitmap-fonts
  238. - escape a control sequence properly
  239. * Thu Aug 8 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.2-1
  240. - fix cursor over reversed text
  241. - fix character positioning in Xft1
  242. - add border padding
  243. - fix lack of shift-in when resetting
  244. * Tue Aug 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.1-1
  245. - rework rendering with Pango
  246. - special-case monospaced Xft1 rendering, hopefully making it faster
  247. - modify pasting to use carriage returns instead of linefeeds
  248. * Thu Aug 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.0-1
  249. - rework drawing to minimize round trips to the server
  250. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.6.0-1
  251. - rework parsing to use tables instead of tries
  252. - implement more xterm-specific behaviors
  253. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.4-1
  254. - fix default PTY size bug
  255. * Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.3-1
  256. - open PTYs with the proper size (#69606)
  257. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.2-1
  258. - fix imbalanced realize/unrealize routines causing crashes (#69605)
  259. * Thu Jul 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-1
  260. - fix a couple of scrolling artifacts
  261. * Thu Jul 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.0-1
  262. - use gunichars internally
  263. - scroll regions more effectively
  264. - implement part of set-mode/reset-mode (maybe fixes #69143)
  265. - fix corner case in dingus hiliting (#67930, really this time)
  266. * Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 0.4.9-3
  267. - free trip through the build system
  268. * Tue Jul 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.9-2
  269. - build in different environment
  270. * Tue Jul 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.9-1
  271. - check for iconv failures properly and report them more aggressively
  272. - guess at a proper default bold color (#68965)
  273. * Mon Jul 15 2002 Nalin Dahyabhai <nalin@redhat.com>
  274. - cosmetic fixes
  275. * Sat Jul 13 2002 Nalin Dahyabhai <nalin@redhat.com>
  276. - fix segfaulting during dingus highlighting when the buffer contains non-ASCII
  277. characters (#67930)
  278. * Fri Jul 12 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.8-1
  279. - implement BCE (#68414)
  280. - bind F13-F35 per termcap
  281. * Thu Jul 11 2002 Nalin Dahyabhai <nalin@redhat.com>
  282. - rework default color selection
  283. - provide a means for apps to just set the foreground/background text colors
  284. - don't scroll-on-keystroke when it's just alt, hyper, meta, or super (#68986)
  285. * Tue Jul 2 2002 Nalin Dahyabhai <nalin@redhat.com>
  286. - allow shift+click to extend the selection (re: gnome 86246)
  287. * Mon Jul 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.7-1
  288. - recover from encoding errors more gracefully
  289. * Mon Jul 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.6-1
  290. - draw unicode line-drawing characters natively
  291. * Tue Jun 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.5-1
  292. - don't append spaces to multicolumn characters when reading the screen's
  293. contents (part of #67379)
  294. - fix overexpose of neighboring cells (part of #67379)
  295. - prevent backscroll on the alternate screen for consistency with xterm
  296. - bind F10 to "k;", not "k0" (#67133)
  297. * Tue Jun 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.4-1
  298. - clear alternate buffer when switching screens (#67094)
  299. - fix setting of titles, but crept in when cleaning up GIConv usage (#67236)
  300. * Tue Jun 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.3-1
  301. - correct referencing/dereferencing of I/O channels (#66248)
  302. - correct package description to not mention the sample app which is no longer
  303. included
  304. * Tue Jun 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.2-1
  305. - fix "cursor mistakenly hidden when app exits" by making cursor visibility
  306. a widget-wide (as opposed to per-screen) setting
  307. * Tue Jun 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.1-1
  308. - fix use of alternate buffer in xterm emulation mode
  309. * Fri Jun 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
  310. - add a means for apps to add environment variables
  311. * Fri Jun 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.30-1
  312. - package up the python module
  313. * Mon Jun 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.29-1
  314. - compute padding correctly
  315. * Mon Jun 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.28-1
  316. - finish merging otaylor's Xft2 patch
  317. * Mon Jun 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.27-1
  318. - rework accessibility
  319. * Thu Jun 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.26-1
  320. - don't package up the test program
  321. - emit "child-exited" signals properly
  322. - try to allow building with either pangoxft-with-Xft1 or pangoxft-with-Xft2
  323. * Wed Jun 5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.25-1
  324. - compute font widths better
  325. * Mon Jun 3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.24-1
  326. - tweak handling of invalid sequences again
  327. * Fri May 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.23-1
  328. - switch to g_convert (again?)
  329. - fix use of core fonts
  330. * Tue May 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.22-1
  331. - plug some memory leaks
  332. * Tue May 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.21-1
  333. - fix matching, fix async background updates
  334. * Fri May 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.20-1
  335. - fixes from notting and otaylor
  336. * Tue May 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.19-1
  337. - fixes from andersca and Hidetoshi Tajima
  338. * Thu May 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.18-1
  339. - finish implementing matching
  340. * Thu May 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.17-1
  341. - tweak finding of selected text
  342. * Wed May 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.16-1
  343. - hook up Insert->kI
  344. - convert scroll events to button 4/5 if an app wants mouse events
  345. - don't send drag events when apps only want click events
  346. - fix selection crashbug
  347. * Tue May 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.15-1
  348. - fix ce, implement save/restore mode
  349. * Tue May 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.14-1
  350. - don't draw nul chars
  351. * Mon May 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.13-1
  352. - fix insert mode, implement visual bells
  353. * Thu May 9 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.12-1
  354. - iconv and remapping from otaylor
  355. - implement custom tabstopping
  356. * Wed May 8 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.11-1
  357. - add mouse drag event handling
  358. * Mon May 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.10-1
  359. - do mouse autohide and cursor switching
  360. * Mon May 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.9-1
  361. - start handling mouse events
  362. * Mon May 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.8-1
  363. - handle window manipulation sequences
  364. * Fri May 3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.7-1
  365. - discard invalid control sequences
  366. - recognize designate-??-character-set correctly
  367. * Thu May 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.6-1
  368. - add a couple of sequence handlers, fix a couple of accessibility crashbugs
  369. * Thu May 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.5-1
  370. - fix cap parsing error and "handle" long invalid multibyte sequences better
  371. * Thu May 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.4-1
  372. - try to speed up sequence recognition a bit
  373. - disable some window_scroll speedups that appear to cause flickering
  374. * Wed May 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
  375. - include a small default termcap for systems without termcap files
  376. * Tue Apr 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.1-1
  377. - disconnect from the configure_toplevel signal at finalize-time
  378. * Tue Apr 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3-1
  379. - add an accessiblity object
  380. * Mon Apr 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.2.3-1
  381. - fix color resetting
  382. - fix idle handlers not being disconnected
  383. * Mon Apr 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.2.2-1
  384. - bug fixes
  385. * Thu Apr 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.1-1
  386. - finish initial packaging, start the changelog