zsh-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443
  1. # -*- Mode: rpm-spec -*-
  2. %define name zsh
  3. %define version 4.3.10
  4. %define rversion %{version}
  5. %define dversion %{version}
  6. %define release 1%{?_dist_release}
  7. %define url ftp://ftp.zsh.org/pub/
  8. ## %define _sysconfdir /etc
  9. Summary: A shell with lots of features.
  10. Summary(ja): 多機能シェル
  11. Name: %{name}
  12. Version: %{version}
  13. Release: %{release}
  14. License: distributable (see LICENCE file)
  15. Group: System Environment/Shells
  16. Url: http://www.zsh.org
  17. Source0: %{url}/%{name}-%{rversion}.tar.bz2
  18. Source1: zcfg-vine.tar.bz2
  19. Source3: http://www.pwstephenson.fsnet.co.uk/computing/zshguide.tar.bz2
  20. # fixed that _apt fail completions rpm package name.
  21. Patch0: zsh-4.3.4-apt4rpm.patch
  22. Patch1: zsh-4.3.4-sshcomp.patch
  23. Patch2: zsh-4.2.0-completion_tar_archive.patch
  24. Patch3: zsh-4.3.10-fixpath.patch
  25. Requires(post,preun): /sbin/install-info
  26. Requires(post,postun): grep
  27. BuildRoot: %{_tmppath}/%{name}-buildroot
  28. BuildRequires: texinfo, ncurses-devel
  29. BuildRequires: findutils grep
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: iwaim
  33. Epoch: 1
  34. %description
  35. Zsh is a UNIX command interpreter (shell) usable as an
  36. interactive login shell and as a shell script command
  37. processor. Of the standard shells, zsh most closely resembles
  38. ksh but includes many enhancements. Zsh has command-line editing,
  39. built-in spelling correction, programmable command completion,
  40. shell functions (with autoloading), a history mechanism, and a
  41. lots of other features
  42. Install the zsh package if you'd like to try out a different shell.
  43. %description -l ja
  44. Zsh 対話的に使える コマンドラインインタプリタ(シェル)です。
  45. 規格上Zsh はksh ににているが多くの拡張がされている。
  46. スペルコレクション,プログラマブル補完,
  47. シェルファンクションズ(オートロード),等の多くの機能がある。
  48. %prep
  49. %setup -q -a 1 -n %{name}-%{rversion}
  50. #%patch0 -p1
  51. #%patch1 -p1
  52. #%patch2 -p1
  53. %patch3 -p1
  54. # remove temporary files
  55. find|grep '~$'|xargs rm -f
  56. %build
  57. %ifnarch sparc
  58. %configure \
  59. --enable-etcdir=%{_sysconfdir} \
  60. --enable-fndir=%{_datadir}/zsh/functions \
  61. --enable-site-fndir=%{_datadir}/zsh/site-functions \
  62. --enable-function-subdirs \
  63. --enable-scriptdir=%{_datadir}/zsh/scripts \
  64. --enable-site-scriptdir=%{_datadir}/zsh/site-scripts \
  65. --with-tcsetpgrp
  66. %else
  67. %configure \
  68. --enable-etcdir=%{_sysconfdir} \
  69. --enable-fndir=%{_datadir}/zsh/functions \
  70. --enable-site-fndir=%{_datadir}/zsh/site-functions \
  71. --enable-function-subdirs \
  72. --enable-scriptdir=%{_datadir}/zsh/scripts \
  73. --enable-site-scriptdir=%{_datadir}/zsh/site-scripts
  74. --disable-lfs
  75. %endif
  76. make
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. %makeinstall fndir=%{buildroot}%{_datadir}/zsh/functions sitefndir=%{buildroot}%{_datadir}/zsh/site-functions scriptdir=%{buildroot}%{_datadir}/zsh/scripts sitescriptdir=%{buildroot}%{_datadir}/zsh/site-scripts
  80. make install.info DESTDIR=$RPM_BUILD_ROOT
  81. mkdir -p %{buildroot}%{_sysbindir}
  82. pushd %{buildroot}%{_sysbindir} && {
  83. ln -s ..%{_bindir}/zsh ./zsh
  84. } && popd
  85. # copy Mandrake Configuration files.
  86. mkdir -p %{buildroot}%{_sysconfdir}
  87. cp -a zcfg/* %{buildroot}%{_sysconfdir}
  88. # Copy documentation.
  89. #rm -rf docroot
  90. mkdir -p docroot/{Info_html,Examples,Documentation}/
  91. cp -a README docroot/
  92. cp -a Functions/Misc/* Misc/* Util/* docroot/Examples/
  93. cp -a INSTALL ChangeLog* docroot/Documentation
  94. cp -a StartupFiles docroot/
  95. cp -a Etc/* docroot/Documentation
  96. cp -a NEWS docroot/
  97. #cp -a Doc/*html docroot/Info_html/
  98. mkdir -p docroot/Zsh_Guide
  99. bzcat %{SOURCE3}|tar xf - -C docroot/Zsh_Guide
  100. mv docroot/Zsh_Guide/zshguide/*html docroot/Zsh_Guide/
  101. rmdir docroot/Zsh_Guide/zshguide
  102. find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/zsh|#!%{_bi
  103. ndir}/zsh|'
  104. find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/perl|#!%{_b
  105. indir}/perl|'
  106. rm -f docroot/StartupFiles/.distfiles
  107. rm -f docroot/Examples/{Makefile*,*.yo}
  108. rm -f docroot/Documentation/{Makefile*,*.yo}
  109. mv docroot/Examples/compctl-examples docroot/StartupFiles
  110. #Build Helpdir
  111. mkdir -p %{buildroot}%{_datadir}/zsh/
  112. rm -rf help && mkdir help/ && pushd help && {
  113. echo "Build Documentation"
  114. make -C ../Doc/ zshbuiltins.1
  115. man ../Doc/zshbuiltins.1|colcrt -|perl ../Util/helpfiles
  116. } && popd
  117. mv help %{buildroot}%{_datadir}/zsh
  118. find docroot/ -name 'Makefile*' -o -name '.yo'|xargs rm -f
  119. %clean
  120. rm -rf %{buildroot}
  121. %post
  122. if [ ! -f %{_sysconfdir}/shells ]; then
  123. echo "/bin/zsh" > %{_sysconfdir}/shells
  124. else
  125. grep '^/bin/zsh' %{_sysconfdir}/shells > /dev/null || echo "/bin/zsh" >> /etc/shells
  126. fi
  127. /sbin/install-info %{_infodir}/zsh.info.gz %{_infodir}/dir
  128. %preun
  129. if [ "$1" = 0 ]; then
  130. /sbin/install-info --delete %{_infodir}/zsh.info.gz %{_infodir}/dir
  131. fi
  132. %postun
  133. if [ ! -x /bin/zsh ]; then
  134. grep -v '^/bin/zsh$' %{_sysconfdir}/shells | grep -v '^/bin/zsh$'> /etc/shells.rpm
  135. mv %{_sysconfdir}/shells.rpm /etc/shells
  136. fi
  137. %files
  138. %defattr(-,root,root,0755)
  139. %doc LICENCE
  140. %doc docroot/README docroot/NEWS
  141. %doc docroot/Documentation/ docroot/Examples/ docroot/Info_html/ docroot/StartupFiles/
  142. %doc docroot/Zsh_Guide
  143. %config %{_sysconfdir}/z*
  144. %{_sysbindir}/zsh
  145. %{_bindir}/zsh*
  146. %{_libdir}/zsh
  147. %{_infodir}/*.info*
  148. %exclude %{_infodir}/dir*
  149. %{_mandir}/man*/*
  150. %{_datadir}/zsh
  151. %changelog
  152. * Tue Feb 23 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-1
  153. - new upstream release
  154. - update fixpath patch (Patch3)
  155. - drop unnecessary patch: fix subversion completion patch (Patch4)
  156. - fix '--with-tcsetpgrp' option: apply besides SPARC arch
  157. - add LICENCE file in %%doc directory: fixed typo
  158. - exclude %%{_infodir}/dir* in %%files section
  159. - drop Prefix tag
  160. - replace Prereq to Requires(*)
  161. - BuildRequires: findutils grep
  162. * Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-4
  163. - fix files error (LICENSE is no longer exist)
  164. * Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-3
  165. - add --with-tcsetpgrp into configure section
  166. - add BR: texinfo, ncurses-devel
  167. * Thu Jan 7 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.4-2
  168. - add fix subversion completion patch (Patch4): <BTS:VineLinux:869>
  169. - see http://svn.haxx.se/users/archive-2008-06/0095.shtml
  170. - add Packager tag
  171. - add LICENSE file in %%doc directory
  172. - fix License tag's value
  173. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 4.3.4-1vl5
  174. - applied new versioning policy, spec in utf-8
  175. * Wed Oct 31 2007 IWAI, Masaharu <iwai@alib.jp> 4.3.4-0vl1
  176. - new upstream release
  177. - update apt4rpm patch ( Patch0 )
  178. - update sshcomp patch ( Patch1 )
  179. - add fixpath patch ( Patch3 )
  180. - update %%build and %%install section
  181. * Tue Apr 12 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.5-0vl1
  182. - new upstream release
  183. * Tue Mar 8 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.4-0vl1
  184. - new upstream release
  185. * Sat Aug 14 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.1-0vl1
  186. - new upstream release
  187. - update apt4rpm patch ( Patch0 )
  188. - drop unnecessary patch for fixed upstream: job_table_full patch ( Patch3 )
  189. - update 'Copy documentation' script: moved NEWS document in upstream archive
  190. * Sat Jul 7 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 4.2.0-0vl2
  191. - add job_table_full.patch (Patch3)
  192. see Zsh Mailing List 2004/msg00488.html
  193. * Mon Mar 29 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.0-0vl1
  194. - new upstream release
  195. - update completion tar archive patch (Patch2)
  196. - update file list: include directories in %%{_libdir} and %%{_datadir}
  197. * Sun Dec 28 2003 IWAI, Masaharu <iwai@alib.jp> 4.0.9-0vl1
  198. - upstream update
  199. - update apt4rpm.patch (Patch0)
  200. * Fri Jun 20 2003 IWAI Masaharu <iwai@alib.jp> 4.0.7-0vl1
  201. - upstream update
  202. - update apt4rpm.patch(Patch0)
  203. * Sat May 3 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl3
  204. - add completion_tar_archive.patch (Patch2)
  205. for tar's "z" option to accept bz2 tarball with zsh completion.
  206. * Mon Dec 2 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl2
  207. - add apt-cache showsrc option in apt4rpm patch (Patch0)
  208. * Thu Aug 15 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl1
  209. - upstream update
  210. * Sun Aug 11 2002 IWAI Masaharu <iwai@alib.jp> 4.0.5-0vl1
  211. - upstream update
  212. - apt-cache showsrc option changed unavailable in apt4rpm patch (Patch0)
  213. * Tue Dec 4 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.4-0vl1
  214. - loading vine specific profile scripts moved from zshrc to zprofile
  215. - fixed other bug($PATH,zmodload)
  216. * Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 4.0.2-0vl3
  217. - rebuilding current Seed
  218. - change ssh completion (Patch1)
  219. * Thu Aug 16 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.2-0vl2
  220. - fixed bug rpm package name completions in _apt
  221. * Thu Jul 19 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.2-0vl1
  222. - 4.0.2
  223. * Sun Jun 3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl1
  224. - upstream 4.0.1 release
  225. - fixed bug zshrc( add /usr/X11R6/bin $PATH)
  226. - fixed lack 'Epoch:'
  227. * Thu Apr 26 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.4.pre.3
  228. - fixed version number invalid
  229. * Fri Apr 20 2001 <sagami@vinelinux.org>
  230. - 4.0.1-0vl0.3.pre.4
  231. - install infopage/manpage and added PreReq = /sbin/install-info
  232. - fixed/added scripts in post/postun/preun for install-info
  233. * Fri Apr 13 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.3.pre.3
  234. - upstream update
  235. - fixed /etc/zshrc bugs
  236. * Tue Apr 3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.0.pre.2
  237. - upstream update
  238. - remove all patches
  239. * Tue Oct 3 2000 Kazuhisa TAKEI<takei@vinelinux.org> 3.1.9-4vl1
  240. - can read /etc/profile.d/*.sh
  241. * Wed Sep 13 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  242. - 3.1.9-4vl0
  243. - convert from Mandrake Linux to Vine Linux
  244. - add Japanise Summary and description
  245. * Sat Aug 26 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-4mdk
  246. - Set some %config file to (noreplace).
  247. - Make -A to complete spec file for _rpm.
  248. * Thu Jul 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-3mdk
  249. - Get /usr/share/man also in the completion for perl manpages.
  250. - BM.
  251. * Wed Jul 5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-2mdk
  252. - Fix buildroot hardcoded in binary.
  253. * Wed Jun 21 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-1mdk
  254. - Use makeinstall macros (not easy this one :\).
  255. - 3.1.9.
  256. * Mon Jun 5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.8-1mdk
  257. - 3.1.8.
  258. * Sun May 28 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-3mdk
  259. - Fix path (%{prefix}/ucb -> %{_bindir}/X11)
  260. - Fix keys (home-end-suppr-delete) directly in the zsh binary.
  261. * Sun Apr 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-2mdk
  262. - Remove doble .so in %{_libdir}/zsh/*.
  263. * Thu Apr 13 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-1mdk
  264. - 3.1.6dev22.
  265. * Fri Mar 31 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-3mdk
  266. - Fix completion of rpm with -qp*.
  267. * Mon Mar 27 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-2mdk
  268. - Upgrade zshguide.
  269. * Sat Mar 25 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-1mdk
  270. - 3.1.6-dev20
  271. * Wed Mar 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-3mdk
  272. - Move global configuration here.
  273. - Adjust groups.
  274. * Tue Feb 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-2mdk
  275. - Add new zshguide from pws.
  276. - Separate the doc to the doc package
  277. * Sun Feb 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-1mdk
  278. - Clean Up spec (thanks specs-helper).
  279. - Remove all our patchs (now all is commited to upstream main).
  280. - 3.1.6dev19.
  281. * Fri Feb 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-3mdk
  282. - Recompile with glibc2.1.3 (first one).
  283. * Thu Feb 17 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-2mdk
  284. - Add --freshen completion.
  285. * Tue Feb 15 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-1mdk
  286. - Fix descriptions and summary.
  287. - 3.1.6dev18.
  288. * Thu Feb 10 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev17-2mdk
  289. - Remove Makefile in %doc.
  290. - BuildRequires: autoconf tetex.
  291. - Lot of modications in the default config as suggested by Bart
  292. Schaefer <schaefer@zsh.org>.
  293. - 3.1.6dev17.
  294. * Mon Jan 24 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev16-1mdk
  295. - dev16.
  296. - Redo the tar_archive patchs.
  297. * Tue Jan 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev15-1mdk
  298. - dev15.
  299. - Fix doc generation with dev15.
  300. - remove META-FAQ.
  301. - disable lfs on sparc.
  302. * Thu Jan 6 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev14-1mdk
  303. - dev14 (note the name change).
  304. * Mon Jan 3 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6pws13-3mdk
  305. - Remove temporary files.
  306. * Fri Dec 31 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  307. - 3.1.6pws13 (mainly bug fixes).
  308. - fix %post.
  309. - fix rpm completion
  310. * Thu Dec 09 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  311. - 3.1.6pws11 (mainly bug fixes).
  312. * Tue Dec 7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  313. - Add run-help and perl-build the documentation.
  314. * Tue Nov 30 1999 Francis Galiegue <francis@mandrakesoft.com>
  315. - Completion machine patch - we use GNU make and GNU tar
  316. - Small fix to %post script
  317. * Tue Nov 30 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  318. - 3.1.6pws10
  319. - Fix zprofile.
  320. - Clean-up Franciseries.
  321. - Clean-up specs.
  322. * Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
  323. - Grrr... Rebuilt on kenobi, toy ain't a cooker
  324. * Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
  325. - Completion system now handles bzip2'ed manpages and tarballs
  326. - Some cool options
  327. * Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  328. - Add zshguide.txt to documentation.
  329. * Thu Oct 07 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  330. - Fix bug in %{_sysconfdir}/zsh use USERNAME instead of USER.
  331. - Improve %{_sysconfdir}/z* to source the /etc/profile.d/ files.
  332. * Mon Oct 04 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  333. - 3.1.6-pws6
  334. - Fix bad link.
  335. - Fix bad manpages.
  336. * Tue Aug 17 1999 Thierry Vignaud <tvignaud@mandrakesoft.com>
  337. - fix typo in examples directory name
  338. * Sun Aug 8 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  339. - Copy documentation (yes a lot).
  340. - Remove the completion machine and put them in [[ {etc,root}(skel|files) ]] package.
  341. * Sat Aug 7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  342. - By defaut we launch the completion machine.
  343. - Put zsh in %{_bindir}/
  344. - Rewrite of Spec file for this new major version.
  345. # end of file