bogofilter-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176
  1. Name: bogofilter
  2. Summary: fast anti-spam filtering by Bayesian statistical analysis
  3. Summary(ja): ベイジアン解析による高速アンチスパムフィルタリング
  4. Version: 1.2.2
  5. Release: 1%{?_dist_release}
  6. URL: http://bogofilter.sourceforge.net/
  7. Source0: http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
  8. Source999: filter-requires-bogofilter.sh
  9. #Patch10: http://www.ono.org/software/dist/%{name}-%{version}+kakasi-0.5.patch.gz
  10. Patch10: http://www.c-wind.com/bogofilter/%{name}-%{version}+kakasi-0.5.patch.gz
  11. License: GPL
  12. Group: Applications/Internet
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: kakasi
  15. BuildRequires: db4-devel >= 4.3.29, kakasi, kakasi-devel, gsl-devel, flex
  16. %define __find_requires %{SOURCE999}
  17. %description
  18. Bogofilter is a Bayesian spam filter. In its normal mode of
  19. operation, it takes an email message or other text on standard input,
  20. does a statistical check against lists of "good" and "bad" words, and
  21. returns a status code indicating whether or not the message is spam.
  22. Bogofilter is designed with fast algorithms (including Berkeley DB system),
  23. coded directly in C, and tuned for speed, so it can be used for production
  24. by sites that process a lot of mail.
  25. %prep
  26. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  27. %setup -q
  28. %patch10 -p1 -b .kakasi
  29. %build
  30. %configure --program-prefix=
  31. %__make
  32. %install
  33. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  34. %makeinstall
  35. %__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
  36. %{buildroot}%{_sysconfdir}/bogofilter.cf
  37. for n in xml html ; do
  38. %__install -d -m755 .inst/$n
  39. %__install -p -m644 doc/*.$n .inst/$n
  40. done
  41. for d in contrib ; do
  42. %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
  43. for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
  44. case $f in
  45. *.c|*.o|*.obj|*/Makefile*)
  46. continue
  47. ;;
  48. *.1)
  49. %__cp -p $f %{buildroot}%{_mandir}/man1
  50. ;;
  51. *)
  52. %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
  53. ;;
  54. esac
  55. done
  56. done
  57. for README in contrib randomtrain ; do
  58. %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
  59. done
  60. # drop executable bit from contrib/* to avoid unneeded dependencies
  61. #%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
  62. # -exec %__chmod -x '{}' \;
  63. %clean
  64. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  65. %files
  66. %defattr(-,root,root)
  67. %doc AUTHORS COPYING INSTALL NEWS
  68. %doc README* RELEASE.NOTES* TODO GETTING.STARTED
  69. %doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
  70. %doc doc/programmer
  71. %doc .inst/html .inst/xml
  72. %{_sysconfdir}/bogofilter.cf.example
  73. %config(noreplace) %{_sysconfdir}/bogofilter.cf
  74. %{_bindir}/bogofilter
  75. %{_bindir}/bogolexer
  76. %{_bindir}/bogotune
  77. %{_bindir}/bogoutil
  78. %{_bindir}/bogoupgrade
  79. %{_bindir}/bf_compact
  80. %{_bindir}/bf_copy
  81. %{_bindir}/bf_tar
  82. %{_datadir}/%{name}
  83. %{_mandir}/man1/bogofilter.1*
  84. %{_mandir}/man1/bogolexer.1*
  85. %{_mandir}/man1/bogotune.1*
  86. %{_mandir}/man1/bogoutil.1*
  87. %{_mandir}/man1/bogoupgrade.1*
  88. %{_mandir}/man1/bf_compact.1*
  89. %{_mandir}/man1/bf_copy.1*
  90. %{_mandir}/man1/bf_tar.1*
  91. %changelog
  92. * Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
  93. - new upstream release
  94. - update Patch10
  95. - add Requires: kakasi (<BTS:VineLinux:852>)
  96. - updates Source999: add filtering string
  97. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
  98. - applied new versioning policy, spec in utf-8
  99. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
  100. - rebuild with gsl-1.9
  101. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
  102. - rebuild with db4-4.3
  103. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
  104. - add filter-requires-bogofilter.sh (source999)
  105. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  106. - rebuild
  107. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  108. - new upstream release
  109. - modified kakasi patch
  110. * Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
  111. - rebuild
  112. * Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
  113. - new upstream release
  114. - update kakasi patch
  115. - remove unneeded macro %%mydocdir
  116. - fix symlink
  117. - add Japanese summary
  118. - drop executable bit from contrib/*
  119. * Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
  120. - rebuild
  121. * Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
  122. - new upstream release
  123. - update and modify kakasi patch
  124. - fix dependencies
  125. - add BuildRequires: kakasi-devel, gsl-devel, flex
  126. - add Requires: gsl
  127. - update %%files
  128. - update %%doc
  129. - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
  130. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
  131. - rebuilt with db4-4.2.52
  132. * Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
  133. - new upstream release.
  134. - update kakasi patch.
  135. * Sun May 2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
  136. - new upstream release
  137. - add kakasi patch (http://www.ono.org/software/bogofilter/)
  138. * Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
  139. - upstream release
  140. - using --program-prefix option with configure script
  141. - update %%files section
  142. * Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
  143. - first release for Vine Linux