netatalk-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326
  1. %define _sysconfdir /etc
  2. ################################################# BASIC PACKAGE INFORMATION
  3. Summary: AppleTalk and AppleShare/IP services for Linux
  4. Summary(ja): Linux 用 AppleTalk, AppleShare/IP サービス
  5. Name: netatalk
  6. Version: 2.1.3
  7. Release: 3%{_dist_release}
  8. License: GPLv2+
  9. Group: System Environment/Daemons
  10. Source0: %{name}-%{version}.tar.bz2
  11. URL: http://netatalk.sourceforge.net/
  12. Obsoletes: netatalk-1.4b2+asun
  13. # patch for default config file
  14. Patch10: netatalk-2.1.3-config-utf8.patch
  15. # other patches
  16. #Patch13: netatalk-2.0.3-db43.patch
  17. #Patch14: netatalk-2.0.3-newerdb.patch
  18. Source10: afpd.service
  19. ############################################################## REQUIREMENTS
  20. Requires(pre): chkconfig, /sbin/ldconfig, grep, textutils
  21. Requires: cracklib, openssl, tcp_wrappers, pam, perl
  22. BuildRequires: openssl-devel, pam-devel, cups-devel, db4-devel, quota
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. %description
  25. Netatalk is a freely-available Open Source AFP fileserver. It also provides a
  26. kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system
  27. running Netatalk is capable of serving many Macintosh clients simultaneously
  28. as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server,
  29. and for accessing AppleTalk printers via Printer Access Protocol (PAP).
  30. Included are a number of minor printing and debugging utilities.
  31. %description -l ja
  32. このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
  33. 扱うことができ, Macintosh と通信が可能になります.
  34. Linux 上で AppleTalk や AFP over TCP の Mac 向けファイルサーバを
  35. 稼働させることができるデーモンプログラムが収められています.
  36. %package devel
  37. Group: Development/Libraries
  38. Summary: Headers for AppleTalk development
  39. Summary(ja): AppleTalk 開発用ヘッダファイル
  40. %description devel
  41. This package contains the header files for building AppleTalk networking
  42. programs.
  43. %prep
  44. %setup -q
  45. %patch10 -p1 -b .cjk-config
  46. #%patch13 -p1 -b .db43
  47. #%patch14 -p1 -b .newerdb
  48. %build
  49. touch AUTHORS
  50. ln -s NEWS ChangeLog
  51. rm -f README.cjk4.cjk
  52. libtoolize --force
  53. aclocal -I macros
  54. automake --add-missing
  55. autoconf
  56. autoheader
  57. CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
  58. ./configure \
  59. --prefix=%{_prefix} \
  60. --libdir=%{_libdir} \
  61. --libexecdir=%{_libdir}/netatalk \
  62. --sysconfdir=%{_sysconfdir} \
  63. --mandir=%{_mandir} \
  64. --localstatedir=%{_var} \
  65. --enable-shared \
  66. --enable-afp3 \
  67. --with-cnid-dbd-backend \
  68. --with-cnid-cdb-backend \
  69. --with-cnid-default-backend=dbd \
  70. --enable-cups \
  71. --with-message-dir=%{_sysconfdir}/netatalk/msg \
  72. --with-uams-path=%{_libdir}/netatalk \
  73. --with-spooldir=%{_var}/spool/netatalk \
  74. --enable-redhat \
  75. --with-cracklib \
  76. --with-pam \
  77. --with-shadow \
  78. --with-tcp-wrappers \
  79. --with-ssl \
  80. --enable-pgp-uam
  81. make all
  82. %install
  83. ### INSTALL (USING "make install") ###
  84. rm -rf ${RPM_BUILD_ROOT}
  85. mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
  86. make DESTDIR=$RPM_BUILD_ROOT install
  87. ## netatalk/at.h is now provided by glibc
  88. rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
  89. ## for Bonjour (requires nss-mdns)
  90. install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
  91. install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
  92. %pre
  93. ### COPY OLD PREFERENCE FILES ###
  94. if [ -d /etc/atalk ] ; then
  95. mkdir -p /etc/netatalk/
  96. cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
  97. fi
  98. exit 0
  99. %post
  100. ### RUN CHKCONFIG ###
  101. /sbin/chkconfig --add netatalk
  102. /sbin/ldconfig
  103. if test -r /var/lock/atalkd ; then
  104. /etc/rc.d/init.d/netatalk restart >&2
  105. fi
  106. %preun
  107. ### RUN CHKCONFIG ###
  108. /sbin/chkconfig --del netatalk
  109. %triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
  110. /sbin/chkconfig --add netatalk
  111. %clean
  112. rm -rf ${RPM_BUILD_ROOT}
  113. %files
  114. %defattr(-,root,root)
  115. %doc CONTRIBUTORS COPYING COPYRIGHT
  116. %doc NEWS README* TODO
  117. %doc doc/[A-L,N-Z]*
  118. %config(noreplace) /etc/netatalk/Apple*
  119. %config(noreplace) /etc/netatalk/*.conf
  120. %config /etc/pam.d/netatalk
  121. %config /etc/rc.d/init.d/netatalk
  122. %dir %{_sysconfdir}/netatalk
  123. %dir %{_sysconfdir}/netatalk/msg
  124. %{_sysconfdir}/avahi/services/afpd.service
  125. %dir %{_var}/spool/netatalk
  126. %{_bindir}/*
  127. %{_sbindir}/*
  128. %{_libdir}/netatalk/*
  129. %exclude %{_libdir}/netatalk/*.a
  130. %exclude %{_libdir}/netatalk/*.la
  131. %{_mandir}/*/*
  132. %{_datadir}/netatalk/pagecount.ps
  133. %files devel
  134. %defattr(-,root,root)
  135. %{_libdir}/*.a
  136. %{_libdir}/*.la
  137. %{_libdir}/netatalk/*.a
  138. %{_libdir}/netatalk/*.la
  139. %dir %{_includedir}/atalk
  140. %{_includedir}/atalk/*.h
  141. %dir %{_includedir}/netatalk
  142. %{_includedir}/netatalk/*.h
  143. %{_datadir}/aclocal/netatalk.m4
  144. %changelog
  145. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
  146. - rebuild with openssl-1.0.0c
  147. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
  148. - fix Patch10 & update description - upon HAT-san's suggestions
  149. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
  150. - new upstream release
  151. - update Vine patch
  152. * Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
  153. - new upstream release
  154. * Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
  155. - new upstream release
  156. * Sun Mar 8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
  157. - rebuilt both for VineSeed / VinePlus-4.0
  158. * Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
  159. - updated to the cjk-6 patch
  160. - Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
  161. - Patch14 updated for db46
  162. * Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
  163. - remove openslp dependency
  164. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
  165. - add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
  166. - TODO: remember to revise this fix after VineSeed changes default locale
  167. from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
  168. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
  169. - revise description (thanks HAT-san for pointing this out)
  170. - run libtoolize/aclocal/auto{make,conf,header} before doing configure
  171. (without this, uams_* modules won't get .so suffix)
  172. * Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
  173. - Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
  174. (Patch10 now includes all the modifications and more fixes)
  175. * Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
  176. - add patch13 and patch14 for db-4.3.
  177. - move files in %%_libexecdir to %%libdir.
  178. * Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
  179. - updated to 2.0.3 release w/ cjk patches (see the above Patch section)
  180. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  181. - security fix: added Patch10 (CAN-2004-0974)
  182. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  183. - configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
  184. * Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
  185. - updated to 2.0 with cjk patch
  186. (see the above Patch section for details)
  187. * Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
  188. - merge the patch repairing bug for System 7.5.5
  189. - (patch6 netatalk-1.5.3.oldsys.patch)
  190. - made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
  191. - patch6 addupted no matter noeuc is, license GPL, URL in comment
  192. * Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
  193. - euc and kana patch originally by
  194. - Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
  195. - applied to netatalk-1.5.2 by me
  196. - README.vine
  197. - omit VERSION from doc, omit perl from require
  198. * Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
  199. - this package is removed because the release number duplicated
  200. * Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
  201. - move acleandir.rc to the doc directory, remove executable flag.
  202. * Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
  203. - updated to new upstream release
  204. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
  205. - added Japanese Summary for devel and corrected Group
  206. * Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
  207. - Oops, check /var/lock/atalkd instead of /var/run/atd.pid
  208. (say atd.pid doesn't have anything to do with netatalk!!)
  209. * Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
  210. - updated to new upstream release
  211. * Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
  212. - install man pages into %%{_mandir}
  213. - PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
  214. - let pre script exit 0
  215. * Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
  216. - spec cleanup
  217. - backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
  218. - restart atalk daemons in the %%post section
  219. * Sun Feb 3 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  220. - v1.5.1.1-0vl1
  221. * Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  222. - v1.5.0-0vl1
  223. - release 1.5.0 for sourceforge
  224. * Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  225. - v1.5pre6-1rh7
  226. - pre-release 6 for sourceforge
  227. * Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  228. - v1.5pre5-1
  229. - pre-release 5 for sourceforge
  230. * Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  231. - v1.5pre5-0
  232. - pre-release 5 for sourceforge (prebuild)
  233. * Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  234. - v1.5pre4-1
  235. - pre-release 4 for sourceforge
  236. - modified/split mandrake spec for redhat 7 build
  237. * Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  238. - v1.5pre3-1mdk
  239. - pre-release 3 for sourceforge
  240. - moved away from 1.4.99 ...
  241. * Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  242. - v1.4.99-0.20001108mdk
  243. - pre-release 2 for sourceforge
  244. * Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  245. - v1.4.99-0.20000927mdk
  246. - pre-release 1 for sourceforge