self-build-gstreamer-plugins-ffmpeg-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164
  1. %define pkgname gstreamer-plugins-ffmpeg
  2. %define name self-build-%{pkgname}
  3. %define version 0.10.11
  4. %define release 3%{?_dist_release}
  5. %define sourceurl0 http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv2+ and LGPLv2+
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.9.9
  15. # (build)requies of target package.
  16. Requires: gstreamer >= 0.10.0
  17. Requires: gstreamer-plugins-base >= 0.10.0
  18. Requires(post): gstreamer-devel >= 0.10.0
  19. Requires(post): gstreamer-plugins-base-devel >= 0.10.0
  20. Requires(post): liboil-devel
  21. Requires(post): bzip2-devel
  22. Requires(post): self-build-ffmpeg
  23. BuildArch: noarch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Packager: munepi
  26. %description
  27. GStreamer is a streaming media framework, based on graphs of filters which
  28. operate on media data. Applications using this library can do anything
  29. from real-time sound processing to playing videos, and just about anything
  30. else media-related. Its plugin-based architecture means that new data
  31. types or processing capabilities can be added simply by installing new
  32. plugins.
  33. This package provides FFmpeg-based GStreamer plug-ins.
  34. If you install this package, it automaticaly downloads source
  35. code, compile it, and create rpm packages of
  36. %{pkgname}-%{version}.
  37. And the created rpm packages are automatically installed
  38. if installation is executed by apt-get command or synaptic
  39. package manager.
  40. [Note]
  41. This package requires many other packages to compile
  42. targetsoftware. So it consume more disk space than usual.
  43. Also installation takes logner time because of compilation.
  44. (This will take a few minutes to quarter or half of an hour,
  45. depends on building environment)
  46. [About self-build package]
  47. For some kind of software, distributing of binary package
  48. may viorate the patent or law. Therefore we chose self-build
  49. packge, create binary package on your machine, for such kind
  50. of softwares instead of distributing binary package.
  51. Please obey the national law when you use the created binary
  52. packages. And if you want to use the softwares using patented
  53. thechnology, it may be required to get a permission, make an
  54. agreement or purchas a license. Please consider it with your
  55. purpose or way of use and take appropriate action.
  56. %description -l ja
  57. GStreamer はメディアデータ操作用の filter graph をベースにし
  58. たストリーミングメディアフレームワークです。 このライブラリを
  59. 使用すればアプリケーションは、サウンドのリアルタイム処理から
  60. ビデオ再生まで、メディアに関係する全ての機能が利用できます。
  61. また Gstremer はプラグイン方式を採用していることから、新しい
  62. 種類のデータや機能への対応が、プラグインを追加することで簡単
  63. に実現できます。
  64. このパッケージは ffmpeg ベースの GStreamer プラグインを提供し
  65. ます。
  66. このパッケージをインストールすると、自動的にソースコードをダ
  67. ウンロードしてコンパイルし、%{pkgname}-%{version}
  68. の rpm パッケージを作成します。
  69. また apt-get コマンドや synaptic パッケージマネージャから実行
  70. した場合は、作成された rpm パッケージのインストールも自動的に
  71. 行います。
  72. [注意]
  73. コンパイルに必要な多くの関連パッケージを要求するので通常より
  74. ディスクの領域を多く消費します。
  75. またインストール時にコンパイルを行うため、通常より時間がかか
  76. る場合があります。(環境にもよりますが数分から数十分程度)
  77. [self-build パッケージについて]
  78. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  79. 違反する可能性があるものがあります。その為、このような問題が
  80. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  81. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  82. ジという方法を採っています。
  83. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  84. アのライセンス、および利用する国の各種法令に従ってください。
  85. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  86. センスの購入などが必要となる場合がありますので、利用する目的
  87. や形態に応じて各自で判断し適切な対応を取ってください。
  88. %prep
  89. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  90. %install
  91. %{__rm} -rf ${RPM_BUILD_ROOT}
  92. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  93. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  94. %clean
  95. %{__rm} -rf ${RPM_BUILD_ROOT}
  96. %posttrans
  97. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 103000
  98. %files
  99. %defattr(-,root,root)
  100. %{_datadir}/%{name}/*
  101. %changelog
  102. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-3
  103. - dropped --with-system-ffmpeg in configure options
  104. (gstreamer-plugins-ffmpeg-vl.spec)
  105. * Sun Feb 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-2
  106. - added Requires(post): self-build-ffmpeg
  107. - already used system ffmpeg
  108. * Sat Jul 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-1
  109. - new upstream release
  110. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.10-1
  111. - new upstream release
  112. - renamed %%{Source0} to gstreamer-plugins-ffmpeg-vl.spec
  113. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.9-1
  114. - new upstream release
  115. * Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
  116. - new upstream release
  117. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-2
  118. - added BuildArch: noarch
  119. - avoided to execute self-build-rpm.sh on RPM transaction
  120. - moved %%post actions to %%posttrans
  121. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-1
  122. - new upstream release
  123. - corrected %%description
  124. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.6-1
  125. - initial build
  126. ### end of file