gstreamer-plugins-ugly-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333
  1. ## TODO: build with opencore-amr
  2. %define major 0.10
  3. %define _gst_ver 0.10.17
  4. %define _gstpb_ver 0.10.3
  5. %define pkg_release 1%{?_dist_release}
  6. Summary: GStreamer Streaming-media framework ugly plugins
  7. Summary(ja): GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
  8. Name: gstreamer-plugins-ugly
  9. Version: %{_gst_ver}
  10. Release: %{pkg_release}
  11. License: LGPLv2+
  12. Group: System Environment/Libraries
  13. URL: http://gstreamer.freedesktop.org/
  14. Source: http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. Requires: gstreamer >= %{_gst_ver}
  17. Requires: gstreamer-plugins-base >= %{_gstpb_ver}
  18. Requires: glib2
  19. Requires: libid3tag
  20. # Don't require libmad because they are provided by
  21. # self-build-libmad packages.
  22. #Requires: libmad
  23. BuildRequires: gstreamer-devel >= %{_gst_ver}
  24. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb_ver}
  25. #BuildRequires: gtk-doc >= 1.3
  26. BuildRequires: python >= 2.1, python-pyxml
  27. BuildRequires: glib2-devel >= 2.6
  28. BuildRequires: twolame-devel
  29. BuildRequires: libid3tag-devel >= 0.15
  30. BuildRequires: liboil-devel >= 0.3.0
  31. BuildRequires: libcdio-devel >= 0.82
  32. BuildRequires: libdvdread-devel
  33. BuildRequires: PyXML
  34. # *-devel packages provided by other self-build-* should only be listed
  35. # in self-build-%{name}.spec as PreReq.
  36. ##BuildRequires: x264-devel
  37. ##BuildRequires: libmpeg2-devel
  38. ##BuildRequires: a52dec-devel
  39. ##BuildRequires: lame-devel
  40. ##BuildRequires: libmad-devel >= 0.15
  41. Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
  42. %description
  43. GStreamer is a streaming-media framework, based on graphs of filters which
  44. operate on media data. Applications using this library can do anything
  45. from real-time sound processing to playing videos, and just about anything
  46. else media-related. Its plugin-based architecture means that new data
  47. types or processing capabilities can be added simply by installing new
  48. plugins.
  49. This package contains a set of plug-ins that have good quality and
  50. correct functionality, but distributing them might pose problems. The
  51. license on either the plug-ins or the supporting libraries might not
  52. be how the GStreamer authors like. The code might be widely known to
  53. present patent problems.
  54. %description -l ja
  55. GStreamer はメディアデータ操作用の filter graph をベースにしたスト
  56. リーミングメディアフレームワークです。 このライブラリを使用すれば
  57. アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
  58. メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
  59. イン方式を採用していることから、新しい種類のデータや機能への対応が、
  60. プラグインを追加することで簡単に実現できます。
  61. このパッケージは品質も機能も問題は無いものの、配布すると問題になる
  62. 可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
  63. ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
  64. 関連するコードとして良く知られています。
  65. # %package devel
  66. # Summary: Documentation files for GStreamer ugly plugins.
  67. # Summary(ja): GStreamer ugly プラグインのドキュメント
  68. # Group: Development/Libraries
  69. # Requires: %{name} = %{version}-%{release}
  70. # %description devel
  71. # GStreamer はメディアデータ操作用の filter graph をベースにしたスト
  72. # リーミングメディアフレームワークです。 このライブラリを使用すれば
  73. # アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
  74. # メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
  75. # イン方式を採用していることから、新しい種類のデータや機能への対応が、
  76. # プラグインを追加することで簡単に実現できます。
  77. # このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
  78. %prep
  79. %setup -q -n gst-plugins-ugly-%{version}
  80. %build
  81. %configure \
  82. --disable-static \
  83. --disable-amrnb \
  84. --disable-sidplay \
  85. %__make %{?_smp_mflags}
  86. %install
  87. %__rm -rf %{buildroot}
  88. %makeinstall
  89. # Clean out files that should not be part of the rpm.
  90. %__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
  91. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  92. %find_lang gst-plugins-ugly-%{major}
  93. %clean
  94. %__rm -rf %{buildroot}
  95. %files -f gst-plugins-ugly-%{major}.lang
  96. %defattr(-,root,root)
  97. %doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
  98. %{_datadir}/gstreamer-%{major}/presets
  99. # ugly plugins without external dependencies
  100. %{_libdir}/gstreamer-%{major}/*.so
  101. # ugly plugins with external dependencies, but in the main package
  102. # %{_libdir}/gstreamer-%{major}/libgstmad.so
  103. # %files devel
  104. # %defattr(-,root,root)
  105. # %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
  106. %changelog
  107. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
  108. - new upstream relase
  109. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
  110. - new upstream relase
  111. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
  112. - new upstream relase
  113. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
  114. - new upstream relase
  115. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
  116. - new upstream relase
  117. * Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
  118. - new upstream relase
  119. - enable mpeg2dec with libmpeg2-devel in %%configure
  120. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
  121. - change release to sync with self-build-gstreamer-plugins-ugly
  122. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
  123. - dropped BuildRequires: gtk-doc >= 1.3
  124. - disable-gtk-doc in configure options
  125. - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
  126. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
  127. - new upstream relase
  128. * Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
  129. - changed to PreReq: self-build-libmad >= 0.15 from libmad-devel
  130. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
  131. - new upstream relase
  132. * Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
  133. - upstream release
  134. - delete --disable-a52dec configure option
  135. - delete %%with_lame macro
  136. - added japanase summary and description
  137. * Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
  138. - upstream release
  139. - update %%_gst_ver
  140. * Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
  141. - add NoSource: 0
  142. * Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
  143. - add %%with_lame macro
  144. - enable lame support if rpmbuild with '--with lame'
  145. * Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
  146. - upstream release
  147. * Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
  148. - upstream release
  149. - add libgstdvdsub.so
  150. * Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
  151. - upstream release
  152. - update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
  153. - add libgstasf.so
  154. * Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
  155. - fix typo
  156. * Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
  157. - initial package based on gstreamer-plugins
  158. - new upstream release
  159. - change major to 0.10
  160. - update dependencies
  161. - update %%configure options
  162. * Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
  163. - remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
  164. * Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
  165. - added missing alsa plugin
  166. * Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
  167. - new upstream release
  168. - added alsa and cairo plugins
  169. * Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
  170. - new upstream release
  171. * Mon Jun 6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
  172. - new upstream release
  173. * Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
  174. - added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
  175. * Sun May 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
  176. - added libgstcdparania.so for gnome-cd (gnome-media)
  177. - BuildRequires: cdparanoia-devel
  178. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
  179. - drop BuildRequires: xmms-devel, Requires: xmms
  180. * Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
  181. - libgstvideo4linux2.so temoporally omitted for ppc
  182. (will be back later, I hope)
  183. * Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
  184. - new upstream release
  185. - s/Copyright/License/
  186. - includes plugins depend on main package libraries only
  187. * Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
  188. - new upstream release
  189. * Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
  190. - new upstream release
  191. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  192. - new upstream release
  193. * Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
  194. - new upstream release
  195. * Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
  196. - build with -fPIC on alpha
  197. * Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
  198. - modified scripts
  199. * Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
  200. - new upstream release
  201. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
  202. - disable some plugins.
  203. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
  204. - new upstream release
  205. - initial build for Vine Linux
  206. * Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
  207. - Include ia64
  208. - Add BuildRequires: autoconf automake
  209. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  210. - rebuild
  211. * Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
  212. - rebuild
  213. * Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
  214. - rebuild
  215. - disable tests
  216. * Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
  217. - rebuild
  218. * Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
  219. - fix libdir for ia64.
  220. * Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
  221. - ExcludeArch: ia64. Random assembler errors that I have no hope of fixing
  222. - Add devel package
  223. * Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
  224. - 0.5.0
  225. - apparently, festival-devel isn't needed.
  226. * Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
  227. - rebuild to fix broken dep on libgstreamer-0.4.2.so.0
  228. * Tue Dec 3 2002 Havoc Pennington <hp@redhat.com>
  229. - excludearch the arches that can't build gstreamer cothreads
  230. - well it isn't really SMP-safe
  231. - add patch for including pthread.h when required
  232. - prereq gconftool
  233. - fix typo that broke schema installation in post
  234. * Mon Dec 2 2002 Havoc Pennington <hp@redhat.com>
  235. - initial "official" import
  236. - munge tarball for legal cleanliness
  237. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  238. - 0.4.2
  239. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  240. - 0.4.1
  241. - install the gconf schema
  242. - use %%configure
  243. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  244. - update to 0.4.0
  245. - give explicit vorbis include path, don't run vorbis test
  246. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  247. - collapse into one package to preserve some sanity
  248. * Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
  249. - added more BuildRequires and Requires
  250. - rearranged some plugins
  251. - added changelog ;)