self-build-gstreamer-plugins-ugly-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172
  1. %define pkgname gstreamer-plugins-ugly
  2. %define _gst_ver 0.10.17
  3. %define _gstpb_ver 0.10.3
  4. %define release 1%{?_dist_release}
  5. %define sourceurl http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{_gst_ver}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: self-build-%{pkgname}
  9. Version: %{_gst_ver}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. Source101: gstreamer-plugins-ugly-x264.patch
  13. License: LGPL
  14. Group: Restricted Software
  15. Requires(post): self-build-setup >= 0.9.9
  16. # (build)requies of target package.
  17. Requires(post): libogg-devel, libtheora-devel, libvorbis-devel
  18. Requires(post): gstreamer-devel >= %{_gst_ver}
  19. Requires(post): gstreamer-plugins-base-devel >= %{_gstpb_ver}
  20. #Requires(post): gtk-doc >= 1.3
  21. Requires(post): python >= 2.1, python-pyxml
  22. Requires(post): glib2-devel >= 2.6
  23. Requires(post): twolame-devel
  24. Requires(post): liboil-devel >= 0.3.0
  25. Requires(post): libcdio-devel >= 0.82
  26. Requires(post): libdvdread-devel
  27. Requires(post): PyXML
  28. Requires(post): self-build-libmad >= 0.15
  29. Requires(post): libid3tag-devel >= 0.15
  30. Requires(post): self-build-ffmpeg
  31. Requires(post): self-build-x264
  32. Requires(post): self-build-libmpeg2
  33. Requires(post): self-build-a52dec
  34. Requires(post): self-build-lame
  35. Requires(post): self-build-libmad
  36. BuildArch: noarch
  37. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  38. Packager: munepi
  39. %description
  40. gstreamer-plugins-ugly is a set of ugly plugins for Gstreamer
  41. streaming-media framework.
  42. If you install this package, it automaticaly downloads source
  43. code, compile it, and create rpm packages of
  44. %{pkgname}-%{version}.
  45. And the created rpm packages are automatically installed
  46. if installation is executed by apt-get command or synaptic
  47. package manager.
  48. [Note]
  49. This package requires many other packages to compile
  50. targetsoftware. So it consume more disk space than usual.
  51. Also installation takes logner time because of compilation.
  52. (This will take a few minutes to quarter or half of an hour,
  53. depends on building environment)
  54. [About self-build package]
  55. For some kind of software, distributing of binary package
  56. may viorate the patent or law. Therefore we chose self-build
  57. packge, create binary package on your machine, for such kind
  58. of softwares instead of distributing binary package.
  59. Please obey the national law when you use the created binary
  60. packages. And if you want to use the softwares using patented
  61. thechnology, it may be required to get a permission, make an
  62. agreement or purchas a license. Please consider it with your
  63. purpose or way of use and take appropriate action.
  64. %description -l ja
  65. gstreamer-plugins-ugly は GStreamer ストリーミングメディア
  66. フレームワーク用 ugly プラグイン集です。
  67. このパッケージをインストールすると、自動的にソースコードを
  68. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  69. の rpm パッケージを作成します。
  70. また apt-get コマンドや synaptic パッケージマネージャから実行
  71. した場合は、作成された rpm パッケージのインストールも自動的に
  72. 行います。
  73. [注意]
  74. コンパイルに必要な多くの関連パッケージを要求するので通常より
  75. ディスクの領域を多く消費します。
  76. またインストール時にコンパイルを行うため、通常より時間がかか
  77. る場合があります。(環境にもよりますが数分から数十分程度)
  78. [self-build パッケージについて]
  79. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  80. 違反する可能性があるものがあります。その為、このような問題が
  81. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  82. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  83. ジという方法を採っています。
  84. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  85. アのライセンス、および利用する国の各種法令に従ってください。
  86. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  87. センスの購入などが必要となる場合がありますので、利用する目的
  88. や形態に応じて各自で判断し適切な対応を取ってください。
  89. %prep
  90. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  91. %install
  92. %{__rm} -rf ${RPM_BUILD_ROOT}
  93. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  94. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  95. %{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  96. %clean
  97. %{__rm} -rf ${RPM_BUILD_ROOT}
  98. %posttrans
  99. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 83000
  100. %files
  101. %defattr(-,root,root)
  102. %{_datadir}/%{name}
  103. %changelog
  104. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
  105. - new upstream relase
  106. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
  107. - new upstream relase
  108. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
  109. - new upstream relase
  110. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
  111. - new upstream relase
  112. - renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
  113. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
  114. - new upstream relase
  115. * Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
  116. - new upstream relase
  117. - added Requires(post): self-build-libmpeg2
  118. - enable mpeg2dec with libmpeg2-devel in %%configure
  119. - check version between original spec and self-build spec in %%prep
  120. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
  121. - avoided to execute self-build-rpm.sh on RPM transaction
  122. - moved %%post actions to %%posttrans
  123. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
  124. - added BuildArch: noarch
  125. - dropped PreReq: gtk-doc >= 1.3
  126. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
  127. - new upstream relase
  128. * Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
  129. - changed to PreReq: self-build-libmad >= 0.15 from libmad-devel
  130. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
  131. - new upstream relase
  132. * Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
  133. - initial build for Vine Linux.