pilot-link-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278
  1. %define ver 0.12.5
  2. %define srcver %{ver}
  3. %define rel 1%{?_dist_release}
  4. %define support_perl 0
  5. Name: pilot-link
  6. Summary: File transfer utilities between Linux and PalmPilots.
  7. Summary(ja): Linux と Palm handheld device を接続する為のユーティリティ
  8. Version: %{ver}
  9. Release: %{rel}
  10. Epoch: 1
  11. Group: Applications/Other
  12. License: GPL/LGPL
  13. URL: http://www.pilot-link.org/
  14. Source0: http://downloads.pilot-link.org/pilot-link-%{version}.tar.bz2
  15. Source1: connect-palm-ppp.tar.bz2
  16. Source2: 60-libpisock.rules.vine
  17. # (fc) 0.10.99 fix python/perl installation
  18. Patch1: pilot-link-0.11.0-perlmd5.patch
  19. Patch2: pilot-link-0.11.0-perlpollute.patch
  20. Patch3: pilot-link-0.11.2-malsync.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: bison >= 1.35
  23. BuildRequires: libusb-devel >= 0.1
  24. BuildRequires: readline-devel
  25. BuildRequires: bluez-libs-devel
  26. BuildRequires: popt-devel
  27. %if %{support_perl}
  28. BuildRequires: perl
  29. %endif
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. %description
  33. This suite of tools allows you to upload and download programs and
  34. data files between a Linux/UNIX machine and the PalmPilot. It has a
  35. few extra utils that will allow for things like syncing the
  36. PalmPilot's calendar app with Ical. Note that you might still need to
  37. consult the sources for pilot-link if you would like the Python, Tcl,
  38. or Perl bindings.
  39. Install pilot-link if you want to synchronize your Palm with your Vine
  40. Linux system.
  41. %description -l ja
  42. このツールを使うと、Linux/Unix マシンと Palm handheld device の間で
  43. プログラムやファイルを転送することができます。このツールには、Palm
  44. handheld device の予定表と Ical との間で同期を可能にするようないくつ
  45. かのユーティリティが付属しています。もし Python や Tcl、あるいは
  46. Perl bindingsを使用する場合は、pilot-link の source を調べる必要が
  47. あることに注意してください。
  48. Palm handheld device を Vine Linux システムで同期させたい場合は
  49. pilot-link をインストールします。
  50. %package libs
  51. Summary: Runtime libraries for %{name}
  52. Summary(ja): %{name} のランタイムライブラリ
  53. Group: System Environment/Libraries
  54. Requires: libusb >= 0.1
  55. %description libs
  56. This package provides the shared libraries for any pilot-link client
  57. program or interface.
  58. %package devel
  59. Summary: PalmPilot development header files.
  60. Summary(ja): Palm handheld プログラム開発用のヘッダ ファイル
  61. Group: Development/Libraries
  62. Requires: %{name}-libs = %{epoch}:%{version}
  63. %description devel
  64. This package contains the development headers that are used to build
  65. the pilot-link package. It also includes the static libraries
  66. necessary to build static pilot apps.
  67. If you want to develop PalmPilot synchronizing applications, you'll
  68. need to install pilot-link-devel.
  69. %description devel -l ja
  70. このパッケージには、pilot-link パッケージを構築する為に必要な開発用の
  71. ヘッダ ファイルが含まれます。また、スタティックな Palm 用アプリケーション
  72. の構築に必要なスタティック ライブラリも含まれます。
  73. Palm handheld deviceと同期するアプリケーションを開発したい場合は、
  74. pilot-link-devel パッケージをインストールする必要があります。
  75. %prep
  76. %setup -q -a 1
  77. %if %{support_perl}
  78. %patch1 -p1 -b .perlmd5
  79. %patch2 -p1 -b .perlpollute
  80. %patch3 -p1 -b .malsync
  81. %endif
  82. %build
  83. %configure\
  84. --disable-static \
  85. --enable-conduits \
  86. --enable-libusb \
  87. --with-libpng \
  88. --with-bluez \
  89. --without-python \
  90. --without-tcl \
  91. --without-java \
  92. %if %{support_perl}
  93. --with-perl
  94. %else
  95. --without-perl
  96. %endif
  97. make
  98. %install
  99. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  100. %if %{support_perl}
  101. if test -f bindings/Perl/Makefile.PL ; then
  102. cd bindings/Perl
  103. perl -pi -e 's|^\$libdir =.*|\$libdir = "%{buildroot}%{_libdir}";|g' Makefile.PL
  104. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT/usr INSTALLDIRS=vendor
  105. make
  106. cd ../..
  107. fi
  108. %endif
  109. %__make install DESTDIR=$RPM_BUILD_ROOT
  110. #%makeinstall -C doc/man
  111. %if %{support_perl}
  112. make install -C bindings/Perl
  113. rm -f %{buildroot}%{_libdir}/perl5/vendor_perl/%{perl_version}/*/auto/PDA/Pilot/Pilot.bs \
  114. %{buildroot}%{_libdir}/perl5/site_perl/*/*/*/PDA/Pilot/.packlist
  115. %endif
  116. # install modified udev rules.
  117. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
  118. install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/60-libpisock.rules
  119. # remove files we don't want to include
  120. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  121. %post libs -p /sbin/ldconfig
  122. %postun libs -p /sbin/ldconfig
  123. %clean
  124. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  125. %files
  126. %defattr(-,root,root)
  127. %doc COPYING ChangeLog README NEWS AUTHORS doc/README.*
  128. %{_bindir}/*
  129. %{_mandir}/man1/*
  130. %files libs
  131. %defattr(-,root,root)
  132. %doc COPYING.LIB
  133. %{_sysconfdir}/udev/rules.d/60-libpisock.rules
  134. %{_libdir}/*.so.*
  135. %if %{support_perl}
  136. %{_libdir}/perl5/vendor_perl/*/*/*/PDA
  137. %{_libdir}/perl5/vendor_perl/*/*/PDA
  138. %endif
  139. %{_datadir}/pilot-link
  140. %{_mandir}/man7/*
  141. %files devel
  142. %defattr(-, root, root)
  143. %{_libdir}/*.so
  144. #{_libdir}/*.la
  145. %{_libdir}/pkgconfig/pilot-link.pc
  146. %{_includedir}/*
  147. %{_datadir}/aclocal/*.m4
  148. %changelog
  149. * Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.5-1
  150. - new upstream release
  151. - split libraries to subpackage
  152. - built with rpm-4.8.1 for pkg-config
  153. - added URL tag
  154. * Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.4-1
  155. - new upstream release
  156. - removed static libraries from devel package
  157. - added --with-bluez to %%configure (added also BR: bluez-libs-devel)
  158. * Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.12.0-1vl5
  159. - applied new versioning policy, spec in utf-8
  160. * Sat Sep 30 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl2
  161. - add modified udev rules (Source2). <BTS:VineLinux:222>
  162. * Sat Sep 02 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl1
  163. - source update.
  164. - change Group to Applications/Other
  165. - use %%configure macro instead of ./configure
  166. - delete unused configure options for itcl and tk.
  167. - use '%%__make install' to use DESTDIR variable.
  168. - comment out '%%makeinstall -C doc/man'(not required to install man).
  169. - add 60-libpisock.rules for udev in %%files.
  170. - add pilot-link.pc in %%files for -devel.
  171. - add Requires libusb and BuildRequires libusb-devel >= 0.1.
  172. * Fri Jan 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.11.8-0vl3
  173. - rebuild for VineSeed
  174. - add "%%{epoch}:" to Requires in pilot-link-devel
  175. * Sun Nov 07 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl2
  176. - convert spec from SJIS to EUC.
  177. * Wed Nov 03 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl1
  178. - source update
  179. - add japanese translation(summary & description).
  180. - use License tag instead of Copyright.
  181. - change BuildRequires XFree86-devel to XOrg-devel.
  182. - add BuildRequires readline-devel.
  183. - add new Patch9.(avoid make error "undefined reference to `pow'")
  184. * Fri May 23 2003 Tomoya TAKA <taka@vinelinux.org> 0.11.7-0vl2
  185. - disuse %%configure macro to avoid unsuitable prefixed filename
  186. * Mon Mar 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.11.7-0vl1
  187. - source update
  188. * Fri Jan 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.5-0vl2
  189. - unfortunately added Epoch 1
  190. (the previous version was 0.9.5.pre5-0vl2. Sigh...)
  191. * Sat Oct 13 2001 <uh@u.dhis.portside.net>
  192. - 0.9.5-0vl1
  193. - upgrade to 0.9.5
  194. - add COPYING.LIB to %doc
  195. * Mon Mar 26 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.9.5-pre5-0vl1
  196. - New upstream release.
  197. - Fixed defattr stuff for devel package.
  198. - Use rpmmacros.
  199. * Wed Oct 20 1999 Preston Brown <pbrown@redhat.com>
  200. - upgrade to pilot-link 0.9.3, rewrite spec.
  201. * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
  202. - strip binaries
  203. * Tue Mar 30 1999 Preston Brown <pbrown@redhat.com>
  204. - added missing files from devel subpackage
  205. * Fri Mar 26 1999 Preston Brown <pbrown@redhat.com>
  206. - move /usr/lib/pix to /usr/lib/pilot-link (dumb, BAD name)
  207. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  208. - auto rebuild in the new build environment (release 5)
  209. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  210. - Injected new description and group.
  211. * Thu Jan 21 1999 Bill Nottingham <notting@redhat.com>
  212. - arm fix
  213. * Fri Sep 24 1998 Michael Maher <mike@redhat.com>
  214. - cleaned up spec file, updated package
  215. * Tue May 19 1998 Michael Maher <mike@redhat.com>
  216. - updated rpm
  217. * Thu Jan 29 1998 Otto Hammersmith <otto@redhat.com>
  218. - added changelog
  219. - updated to 0.8.9
  220. - removed explicit requires for /usr/bin/perl