sox-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213
  1. ##
  2. ## disable gsm for Vine Linux
  3. %define nogsm 1
  4. ## disable libmad
  5. %define nomad 1
  6. Summary: A general purpose sound file conversion tool.
  7. Summary(ja): 汎用サウンドファイル変換ツール
  8. Name: sox
  9. Version: 12.18.1
  10. Release: 1%{?_dist_release}
  11. License: LGPL
  12. Group: Applications/Multimedia
  13. Source: http://prdownloads.sourceforge.net/sox/sox-%{version}.tar.gz
  14. URL: http://sox.sourceforge.net/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: alsa-lib-devel
  17. Build%{?nomad:Conflicts}%{!?nomad:Requires}: libmad-devel
  18. Build%{?nogsm:Conflicts}%{!?nogsm:Requires}: gsm-devel
  19. %description
  20. SoX (Sound eXchange) is a sound file format converter for Linux, UNIX
  21. and DOS PCs. The 'Swiss Army knife of sound tools,' SoX can convert
  22. between many different digitized sound formats and perform simple
  23. sound manipulation functions, including sound effects.
  24. %description -l ja
  25. SoX (Sound eXchange) は Linux, UNIX, DOS PC 用サウンドファイルフォーマット
  26. 変換ツールです.SoX は「サウンドツール界のスイスアーミーナイフ」で,
  27. 様々なデジタルサウンドフォーマットを相互に変換したり,
  28. 簡単なサウンドエフェクト等の処理も行うことが出来ます.
  29. %package -n sox-devel
  30. Summary: The SoX sound file format converter libraries.
  31. Summary(ja): SoX サウンドファイル変換ライブラリ
  32. Group: Development/Libraries
  33. %description -n sox-devel
  34. This package contains the library needed for compiling applications
  35. which will use the SoX sound file format converter.
  36. Install sox-devel if you want to develop applications which will use
  37. SoX.
  38. %description -n sox-devel -l ja
  39. このパッケージには SoX サウンドファイルフォーマット変換ツールを
  40. 利用するアプリケーションをコンパイルするのに必要なライブラリが
  41. 収められています.
  42. SoX を利用するプログラムを開発する場合は sox-devel パッケージを
  43. インストールして下さい.
  44. %prep
  45. %setup -q
  46. %build
  47. %configure --includedir=%{_includedir}/sox \
  48. %{!?nogsm: --with-gsm}
  49. make
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  53. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  54. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
  55. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
  56. %makeinstall install-lib MANDIR=$RPM_BUILD_ROOT/%{_mandir}
  57. echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
  58. echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
  59. echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
  60. chmod 755 $RPM_BUILD_ROOT%{_bindir}/soxplay
  61. strip $RPM_BUILD_ROOT%{_bindir}/sox
  62. ln -snf play $RPM_BUILD_ROOT%{_bindir}/rec
  63. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
  64. ln -snf play.1 $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
  65. ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1
  66. install -m 644 play.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  67. mkdir -p $RPM_BUILD_ROOT%{_includedir}/sox
  68. install -m 644 src/*.h $RPM_BUILD_ROOT%{_includedir}/sox
  69. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  70. install -m 644 libst.3 $RPM_BUILD_ROOT%{_mandir}/man3
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %files
  74. %defattr(-,root,root)
  75. %doc Changelog README TODO INSTALL
  76. %{_bindir}/*
  77. %{_mandir}/man1/*
  78. %files -n sox-devel
  79. %defattr(-,root,root)
  80. %{_includedir}/*
  81. %{_libdir}/libst.a
  82. %{_mandir}/man3/*
  83. %changelog
  84. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 12.18.1-1vl5
  85. - applied new versioning policy, spec in utf-8
  86. * Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 12.18.1-0vl3
  87. - fix installing play.1 man page (<BTS:510>)
  88. - add BuildRequires: alsa-lib-devel (alsa stuffs are now in main repo)
  89. * Mon Sep 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 12.18.1-0vl2
  90. - add "%%define nomad 1" to disable libmad dependency
  91. * Sun Aug 25 2006 NAKAMURA Kenta <kenta@vinelinux.org> 12.18.1-0vl1
  92. - new upstream release
  93. - dropped sox-vorberr.patch and sox-CAN-2004-0557.patch
  94. * Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl2
  95. - add patch for buffer overflow in wav code (CAN-2004-0557, #128158)
  96. - fixed %files section
  97. * Thu Jul 3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl1
  98. - based on 12.17.3-12 from Rawhide
  99. - rebuild with new toolchains
  100. - to use License tag instead of Copyright
  101. - fix License (from distributable to LGPL)
  102. * Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  103. - 12.17.1-1vl1
  104. - based on 12.17.1-1 from Rawhide
  105. - use better macros (%%{_bindir}, %%{_libdir}, %%{_includedir})
  106. - added Japanese summary and description
  107. - disable gsm stuff for Vine Linux
  108. * Tue Jan 2 2001 Bill Nottingham <notting@redhat.com>
  109. - re-enable gsm stuff
  110. - update to 12.17.1
  111. * Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
  112. - rebuild because of broken fileutils
  113. * Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
  114. - update to 12.17
  115. - yank out gsm stuff
  116. * Tue Aug 7 2000 Bill Nottingham <notting@redhat.com>
  117. - fix playing of sounds on cards that don't support mono
  118. * Sat Aug 5 2000 Bill Nottingham <notting@redhat.com>
  119. - fix playing of sounds on cards that don't support 8-bit
  120. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  121. - automatic rebuild
  122. * Thu Feb 03 2000 Bill Nottingham <notting@redhat.com>
  123. - fix manpage link the Right Way(tm)
  124. * Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  125. - Fix rec manpage link - now that man pages are compressed, it should point to
  126. play.1.gz, not play.1
  127. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  128. - fix description
  129. * Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
  130. - Grrr. Arrrrgh. Fix link.
  131. * Fri Sep 24 1999 Bill Nottingham <notting@redhat.com>
  132. - add some more files to devel
  133. * Fri Sep 17 1999 Bill Nottingham <notting@redhat.com>
  134. - fix link
  135. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  136. - update to 12.16
  137. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  138. - auto rebuild in the new build environment (release 4)
  139. * Wed Jan 20 1999 Bill Nottingham <notting@redhat.com>
  140. - allow spaces in filenames for play/rec
  141. * Wed Dec 9 1998 Bill Nottingham <notting@redhat.com>
  142. - fix docs
  143. * Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
  144. - update to 12.15
  145. * Sat Oct 10 1998 Michael Maher <mike@redhat.com>
  146. - fixed broken spec file
  147. * Mon Jul 13 1998 Michael Maher <mike@redhat.com>
  148. - updated source from Chris Bagwell.
  149. * Wed Jun 23 1998 Michael Maher <mike@redhat.com>
  150. - made patch to fix the '-e' option. BUG 580
  151. - added buildroot
  152. * Fri May 08 1998 Prospector System <bugs@redhat.com>
  153. - translations modified for de, fr, tr
  154. * Thu Nov 06 1997 Erik Troan <ewt@redhat.com>
  155. - built against glibc