stone-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150
  1. # ----------------------------------------------------------
  2. # (1) Data definition
  3. # ----------------------------------------------------------
  4. %define _mandir %{_datadir}/man
  5. %define _source_dir stone-2.3d-2.3.2.7
  6. Summary: The stone is TCP and UDP packet repeater.
  7. Summary(ja): TCP & UDP パケットリピータ stone
  8. Name: stone
  9. Version: 2.3e
  10. Release: 2%{_dist_release}
  11. URL: http://www.gcd.org/sengoku/stone/
  12. Source0: http://www.gcd.org/sengoku/stone/%{name}-%{version}.tar.gz
  13. # 'rfc1321.txt', 'global.h', 'md5.h', and 'md5c.c'
  14. Source1: stone-Source1.tar.gz
  15. Source2: stone.init
  16. Source3: stone.conf
  17. Source4: stone.1.gz
  18. Source5: stone.1.ja.gz
  19. # adapted for Vine Linux
  20. Patch0: stone-%{version}-Makefile.patch
  21. License: GPL
  22. Group: Applications/Internet
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. Prefix: %{_prefix}
  25. Requires: openssl
  26. BuildRequires: openssl-devel
  27. %description
  28. Stone is a TCP/IP packet repeater in the application layer. It
  29. repeats TCP and UDP packets from inside to outside of a firewall, or
  30. from outside to inside.
  31. %description -l ja
  32. stone は、アプリケーションレベルの TCP & UDP パケットリピーターです。
  33. ファイアウォールの内から外へ、あるいは外から内へ、TCP パケットあるいは
  34. UDP パケットを中継します。
  35. # ----------------------------------------------------------
  36. # (2) Scripts
  37. # ----------------------------------------------------------
  38. # --- prep
  39. %prep
  40. rm -rf ${RPM_BUILD_ROOT}
  41. # %setup -a 1 -n ${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}
  42. %setup -a 1 -n %{_source_dir}
  43. %patch0 -p0 -b .vine
  44. # --- build
  45. %build
  46. make linux-ssl SSL_FLAGS='-DUSE_SSL' SSL_LIBS='-lssl -lcrypto'
  47. # --- install
  48. %install
  49. install -d --mode=0755 ${RPM_BUILD_ROOT}%{_bindir}
  50. install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/man1
  51. install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/ja/man1
  52. install --mode=0755 stone ${RPM_BUILD_ROOT}%{_bindir}/stone
  53. install --mode=0644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_mandir}/man1/stone.1.gz
  54. install --mode=0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_mandir}/ja/man1/stone.1.gz
  55. mkdir -p %{buildroot}/etc/rc.d/init.d
  56. install --mode=0755 %{SOURCE2} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/stone
  57. install --mode=0644 %{SOURCE3} ${RPM_BUILD_ROOT}/etc/stone.conf
  58. # --- clean
  59. %clean
  60. rm -rf ${RPM_BUILD_ROOT}
  61. # ----------------------------------------------------------
  62. # (3) File Lists
  63. # ----------------------------------------------------------
  64. %files
  65. %defattr(-,root,root)
  66. %doc README.txt README.en.txt GPL.txt rfc1321.txt
  67. %{_bindir}/stone
  68. %{_mandir}/man1/stone.1*
  69. %{_mandir}/ja/man1/stone.1*
  70. %config /etc/rc.d/init.d/stone
  71. %config(noreplace) /etc/stone.conf
  72. # ----------------------------------------------------------
  73. # (4) Change Log
  74. # ----------------------------------------------------------
  75. %changelog
  76. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3e-2
  77. - rebuild with openssl-1.0.0c
  78. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-1
  79. - new upstream release
  80. - new versioning policy and spec in UTF-8
  81. - update patch0 (_GNU_SOURCE macro is required glibc >= 2.8)
  82. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3c-0vl4
  83. - rebuild with new environment
  84. * Wed Oct 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3c-0vl3
  85. - rebuilt for Vine Linux 4.0
  86. * Fri Oct 6 2006 Takeru INOUE <takeru.inoue@ieee.org>
  87. - 2.3c-0vl1
  88. - Updated
  89. * Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3b-0vl2
  90. - rebuilt for VineSeed (4.0)
  91. * Sun Jul 16 2006 Takeru INOUE <takeru.inoue@ieee.org>
  92. - 2.3b-0vl1
  93. - Build for Vine 3.2
  94. * Sat Jul 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl2
  95. - rebuilt for VineSeed
  96. - changed Group to Applications/Internet
  97. * Mon Mar 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  98. - 2.3-0vl1
  99. - new upstream release
  100. - update Patch0
  101. - Build for Vine 3.2
  102. * Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
  103. - 2.1x-0vl0
  104. - updated
  105. - add /etc/rc.d/init.d/stone and /etc/stone.conf
  106. * Fri Dec 6 2002 Takashi `Muneharu' Sugimoto <muneharu@raug.net>
  107. - 2.1w-0vl1
  108. - change the file list
  109. * Thu Oct 31 2002 Takashi Sugimoto
  110. - 2.1w-0vl0
  111. - updated
  112. * Mon Aug 19 2002 Takashi Sugimoto
  113. - 2.1v-0vl0
  114. - updated
  115. * Wed Apr 10 2002 Takashi Sugimoto
  116. - 2.1r-0.1vl3