xalan-j2-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485
  1. # Copyright (c) 2000-2005, JPackage Project
  2. # All rights reserved.
  3. #
  4. # Redistribution and use in source and binary forms, with or without
  5. # modification, are permitted provided that the following conditions
  6. # are met:
  7. #
  8. # 1. Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # 2. Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the
  13. # distribution.
  14. # 3. Neither the name of the JPackage Project nor the names of its
  15. # contributors may be used to endorse or promote products derived
  16. # from this software without specific prior written permission.
  17. #
  18. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  19. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  20. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  21. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  22. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  23. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  24. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  25. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  26. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  27. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  28. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  29. #
  30. %define section free
  31. %define cvs_version 2_7_1
  32. Name: xalan-j2
  33. Summary: Java XSLT processor
  34. Summary(ja): Java XSLT プロセッサ
  35. Version: 2.7.1
  36. Release: 2%{?_dist_release}
  37. Group: Development/Libraries
  38. # samples/servlet/ApplyXSLTException.java is ASL 1.1
  39. # src/org/apache/xpath/domapi/XPathStylesheetDOM3Exception.java is W3C
  40. License: ASL 1.1 and ASL 2.0 and W3C
  41. URL: http://xalan.apache.org/
  42. # using binary for bootstrap
  43. #Source0: http://www.apache.org/dist/xml/xalan-j/xalan-j_2_7_1-src.tar.gz
  44. Source0: http://www.apache.org/dist/xml/xalan-j/xalan-j_2_7_1-bin-2jars.tar.gz
  45. #Source1: %{name}-serializer-MANIFEST.MF
  46. #Patch0: %{name}-noxsltcdeps.patch
  47. #Patch1: %{name}-manifest.patch
  48. #Patch2: %{name}-crosslink.patch
  49. #This patch uses xalan-j2-serializer.jar in the MANIFEST files instead of serializer
  50. #Patch3: %{name}-src-MANIFEST-MF.patch
  51. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  52. BuildArch: noarch
  53. Provides: jaxp_transform_impl
  54. Requires: jaxp_parser_impl
  55. Requires(post): alternatives
  56. Requires(preun): alternatives
  57. #BuildRequires: jpackage-utils >= 0:1.6
  58. #BuildRequires: java-devel
  59. #BuildRequires: ant
  60. #BuildRequires: bcel
  61. #BuildRequires: jlex
  62. #BuildRequires: java_cup
  63. #BuildRequires: regexp
  64. #BuildRequires: sed
  65. #BuildRequires: servlet25
  66. #BuildRequires: xerces-j2 >= 0:2.7.1
  67. #BuildRequires: xml-commons-apis >= 0:1.3
  68. #BuildRequires: xml-stylebook
  69. %description
  70. Xalan is an XSLT processor for transforming XML documents into HTML,
  71. text, or other XML document types. It implements the W3C Recommendations
  72. for XSL Transformations (XSLT) and the XML Path Language (XPath). It can
  73. be used from the command line, in an applet or a servlet, or as a module
  74. in other program.
  75. #%package xsltc
  76. #Summary: XSLT compiler
  77. #Group: Text Processing/Markup/XML
  78. #Requires: java_cup
  79. #Requires: bcel
  80. #Requires: jlex
  81. #Requires: regexp
  82. #Requires: jaxp_parser_impl
  83. #
  84. #%description xsltc
  85. #The XSLT Compiler is a Java-based tool for compiling XSLT stylesheets into
  86. #lightweight and portable Java byte codes called translets.
  87. %package manual
  88. Summary: Manual for %{name}
  89. Group: Documentation
  90. %description manual
  91. Documentation for %{name}.
  92. #%package javadoc
  93. #Summary: Javadoc for %{name}
  94. #Group: Development/Documentation
  95. #BuildRequires: java-javadoc
  96. ## for /bin/rm and /bin/ln
  97. #Requires(post): coreutils
  98. #Requires(postun): coreutils
  99. #
  100. #%description javadoc
  101. #Javadoc for %{name}.
  102. #%package demo
  103. #Summary: Demo for %{name}
  104. #Group: Text Processing/Markup/XML
  105. #Requires: %{name} = %{epoch}:%{version}-%{release}, servlet25
  106. #
  107. #%description demo
  108. #Demonstrations and samples for %{name}.
  109. %prep
  110. %setup -q -n xalan-j_%{cvs_version}
  111. %build
  112. %install
  113. rm -rf $RPM_BUILD_ROOT
  114. # jars
  115. install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
  116. install -p -m 644 xalan.jar \
  117. $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
  118. install -p -m 644 xsltc.jar \
  119. $RPM_BUILD_ROOT%{_javadir}/xsltc-%{version}.jar
  120. install -p -m 644 serializer.jar \
  121. $RPM_BUILD_ROOT%{_javadir}/%{name}-serializer-%{version}.jar
  122. (cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
  123. # javadoc
  124. #install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
  125. #cp -pr build/docs/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
  126. #ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
  127. #rm -rf build/docs/apidocs
  128. # demo
  129. #install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}
  130. #install -p -m 644 build/xalansamples.jar \
  131. # $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
  132. #install -p -m 644 build/xalanservlet.war \
  133. # $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-servlet.war
  134. #cp -pr samples $RPM_BUILD_ROOT%{_datadir}/%{name}
  135. # fix link between manual and javadoc
  136. #(cd build/docs; ln -sf %{_javadocdir}/%{name}-%{version} apidocs)
  137. # jaxp_transform_impl ghost symlink
  138. ln -s %{_sysconfdir}/alternatives \
  139. $RPM_BUILD_ROOT%{_javadir}/jaxp_transform_impl.jar
  140. %clean
  141. rm -rf $RPM_BUILD_ROOT
  142. %post
  143. /sbin/update-alternatives --install %{_javadir}/jaxp_transform_impl.jar \
  144. jaxp_transform_impl %{_javadir}/%{name}.jar 30
  145. %preun
  146. {
  147. [ $1 = 0 ] || exit 0
  148. /sbin/update-alternatives --remove jaxp_transform_impl %{_javadir}/%{name}.jar
  149. } >/dev/null 2>&1 || :
  150. #%post javadoc
  151. #rm -f %{_javadocdir}/%{name}
  152. #ln -s %{name}-%{version} %{_javadocdir}/%{name}
  153. #%postun javadoc
  154. #if [ "$1" = "0" ]; then
  155. # rm -f %{_javadocdir}/%{name}
  156. #fi
  157. %files
  158. %defattr(0644,root,root,0755)
  159. %doc LICENSE.txt NOTICE.txt readme.html
  160. %{_javadir}/%{name}-%{version}.jar
  161. %{_javadir}/%{name}.jar
  162. %{_javadir}/%{name}-serializer-%{version}.jar
  163. %{_javadir}/%{name}-serializer.jar
  164. %ghost %{_javadir}/jaxp_transform_impl.jar
  165. #%files xsltc
  166. #%defattr(0644,root,root,0755)
  167. %{_javadir}/xsltc-%{version}.jar
  168. %{_javadir}/xsltc.jar
  169. #%ghost %{_javadir}/jaxp_transform_impl.jar
  170. %files manual
  171. %defattr(0644,root,root,0755)
  172. %doc docs/*
  173. #%files javadoc
  174. #%defattr(0644,root,root,0755)
  175. #%doc %{_javadocdir}/%{name}-%{version}
  176. #%ghost %doc %{_javadocdir}/%{name}
  177. #%files demo
  178. #%defattr(0644,root,root,0755)
  179. #%{_datadir}/%{name}
  180. %changelog
  181. * Mon Aug 30 2010 Ryoichic INAGAKI <ryo1@bc.wakwak.com> 2.7.1-2
  182. - Initial build for VineLinux
  183. - using binary package for bootstrap
  184. * Wed Apr 7 2010 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-1
  185. - Update to 2.7.1.
  186. - Drop gcj_support.
  187. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-9.5
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  189. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-8.5
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  191. * Tue Feb 3 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.0-7.5
  192. - Add osgi manifest.
  193. * Sat Sep 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0:2.7.0-7.4
  194. - fix license tag
  195. * Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.0-7.3
  196. - drop repotag
  197. - fix license tag
  198. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.0-7jpp.2
  199. - Autorebuild for GCC 4.3
  200. * Fri Apr 20 2007 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.2.fc7
  201. - Rebuild to fix incomplete .db/so files due to broken aot-compile-rpm
  202. * Fri Aug 18 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.1
  203. - Resync with latest from JPP.
  204. * Fri Aug 11 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.3
  205. - Rebuild.
  206. * Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.2
  207. - Rebuild.
  208. * Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.1
  209. - Resync with latest from JPP.
  210. - Partially adopt new naming convention (.1 suffix).
  211. - Use ln and rm explicitly instead of core-utils in Requires(x).
  212. * Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 2.7.0-4jpp_5fc
  213. - Requires(post): coreutils
  214. * Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_4fc
  215. - Extend patch to cover all applicable MANIFEST files in src directory.
  216. * Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_3fc
  217. - Apply patch to replace serializer.jar in MANIFEST file with
  218. xalan-j2-serializer.jar.
  219. * Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.0-4jpp_2fc
  220. - Rebuilt
  221. * Fri Jul 21 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_1fc
  222. - Resync with latest JPP version.
  223. * Wed Jul 19 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-3jpp_1fc
  224. - Merge with latest version from jpp.
  225. - Undo ExcludeArch since eclipse available for all arch-es.
  226. - Remove jars from sources for new upstream version.
  227. - Purge unused patches from previous release.
  228. - Conditional native compilation with GCJ.
  229. - Use NVR macros wherever possible.
  230. * Wed Mar 8 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.6.0-3jpp_10fc
  231. - excluded s390[x] and ppc64 due to eclipse
  232. * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.6.0-3jpp_9fc
  233. - stop scriptlet spew
  234. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_8fc
  235. - bump again for double-long bug on ppc(64)
  236. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_7fc
  237. - rebuilt for new gcc4.1 snapshot and glibc changes
  238. * Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_6fc
  239. - rebuild again
  240. * Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.3
  241. - patch to not use target= in build.xml
  242. * Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.1
  243. - rebuild again with gcc-4.1
  244. * Fri Dec 09 2005 Warren Togami <wtogami@redhat.com> 0:2.6.0-3jpp_5fc
  245. - rebuild with gcc-4.1
  246. * Tue Nov 1 2005 Archit Shah <ashah at redhat.com> 0:2.6.0-3jpp_4fc
  247. - Exclude war which blocks aot compilation of main jar (#171005).
  248. * Tue Jul 19 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_3fc
  249. - Build on ia64, ppc64, s390 and s390x.
  250. - Switch to aot-compile-rpm (also BC-compiles xsltc and samples).
  251. * Tue Jun 28 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_2fc
  252. - Remove a tarball from the tarball too.
  253. - Fix demo subpackage's dependencies.
  254. * Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_1fc
  255. - Remove jarfiles from the tarball.
  256. * Fri May 27 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp
  257. - Add NOTICE file as per Apache License version 2.0.
  258. - Build with servletapi5.
  259. * Fri May 27 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_3fc
  260. - Remove now-unnecessary workaround for #130162.
  261. - Rearrange how BC-compiled stuff is built and installed.
  262. * Tue May 24 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_2fc
  263. - Add DOM3 stubs to classes that need them (#152255).
  264. - BC-compile the main jarfile.
  265. * Fri Apr 1 2005 Gary Benson <gbenson@redhat.com>
  266. - Add NOTICE file as per Apache License version 2.0.
  267. * Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_1fc
  268. - Sync with RHAPS.
  269. * Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-2jpp_1rh
  270. - Merge with latest community release
  271. * Thu Nov 4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.0-1jpp_2fc
  272. - Build into Fedora.
  273. * Thu Aug 26 2004 Ralph Apel <r.ape at r-apel.de> 0:2.6.0-2jpp
  274. - Build with ant-1.6.2
  275. - Try with -Djava.awt.headless=true
  276. * Mon Jul 26 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-1jpp_1rh
  277. - Merge with latest community version
  278. * Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.5.2-1jpp_2rh
  279. - add RHUG upgrade cleanup
  280. * Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.0-1jpp
  281. - Updated to 2.6.0
  282. - Patches supplied by <aleksander.adamowski@altkom.pl>
  283. * Thu Mar 4 2004 Frank Ch. Eigler <fche@redhat.com> - 0:2.5.2-1jpp_1rh
  284. - RH vacuuming
  285. * Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.2-1jpp
  286. - Update to 2.5.2.
  287. - Re-enable javadocs, new style versionless symlink handling, crosslink
  288. with local J2SE javadocs.
  289. - Spec cleanups.
  290. * Sat Jun 7 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.1-1jpp
  291. - Update to 2.5.1.
  292. - Fix jpackage-utils version in BuildRequires, add xerces-j2.
  293. - Non-versioned javadoc symlinking.
  294. - Add one missing epoch.
  295. - Clean up manifests from Class-Path's and other stuff we don't include.
  296. - xsltc no longer provides a jaxp_transform_impl because of huge classpath
  297. and general unsuitablity for production-use, system-installed transformer.
  298. - Own (ghost) %%{_javadir}/jaxp_transform_impl.jar.
  299. - Remove alternatives in preun instead of postun.
  300. - Disable javadoc subpackage for now:
  301. <http://issues.apache.org/bugzilla/show_bug.cgi?id=20572>
  302. * Thu Mar 27 2003 Nicolas Mailhot <Nicolas.Mailhot@One2team.com> 0:2.5.0.d1-1jpp
  303. - For jpackage-utils 1.5
  304. * Wed Jan 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.4.1-2jpp
  305. - bsf -> oldbsf.
  306. - Use non-versioned jar in alternative, don't remove it on upgrade.
  307. - Remove hardcoded packager tag.
  308. * Mon Nov 04 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4.1-1jpp
  309. - 2.4.1
  310. * Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4.0-1jpp
  311. - 2.4.0.
  312. * Thu Aug 22 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.4-0.D1.3jpp
  313. - corrected case for Group tag
  314. - fixed servlet classpath
  315. * Tue Aug 20 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4-0.D1.2jpp
  316. - Remove xerces-j1 runtime dependency.
  317. - Add bcel, jlex, regexp to xsltc runtime requirements:
  318. <http://xml.apache.org/xalan-j/xsltc_usage.html>
  319. - Build with -Dbuild.compiler=modern (IBM 1.3.1) to avoid stylebook errors.
  320. - XSLTC now provides jaxp_transform_impl too.
  321. - Earlier changes by Henri, from unreleased 2.4-D1.1jpp:
  322. Mon Jul 15 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4-D1.1jpp
  323. - 2.4D1
  324. - use the jlex 1.2.5-5jpp (patched by Xalan/XSLTC team) rpm
  325. - use the stylebook-1.0-b3_xalan-2.jar included in source file till it will
  326. be packaged in jpackage
  327. - use jaxp_parser_impl (possibly xerces-j2) instead of xerces-j1 for docs
  328. generation, since it's tuned for stylebook-1.0-b3_xalan-2.jar
  329. - build and provide xsltc in a separate rpm
  330. * Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-2jpp
  331. - provides jaxp_transform_impl
  332. - requires jaxp_parser_impl
  333. - stylebook already requires xml-commons-apis
  334. - jaxp_parser_impl already requires xml-commons-apis
  335. - use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
  336. * Wed Jun 26 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.3.1-2jpp
  337. - fix built classpath (bsf, bcel are existing jpackage rpms),
  338. - add buildrequires for javacup and JLex
  339. * Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-1jpp
  340. - 2.3.1
  341. - vendor, distribution, group tags
  342. * Mon Mar 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-2jpp
  343. - generic servlet support
  344. * Wed Feb 20 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-1jpp
  345. - 2.3.0
  346. - no more compat jar
  347. * Sun Jan 27 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-2jpp
  348. - adaptation to new stylebook1.0b3 package
  349. - used source tarball
  350. - section macro
  351. * Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-1jpp
  352. - 2.2.0 final
  353. - versioned dir for javadoc
  354. - no dependencies for manual and javadoc packages
  355. - stricter dependency for compat and demo packages
  356. - fixed package confusion
  357. - adaptation for new servlet3 package
  358. - requires xerces-j1 instead of jaxp_parser
  359. - xml-apis jar now in required xml-commons-apis external package
  360. * Wed Dec 5 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D14-1jpp
  361. - 2.2.D14
  362. - javadoc into javadoc package
  363. - compat.jar into compat package
  364. - compat javadoc into compat-javadoc package
  365. * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-2jpp
  366. - changed extension to jpp
  367. - prefixed xml-apis
  368. * Tue Nov 20 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-1jpp
  369. - 2.2.D13
  370. - removed packager tag
  371. * Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D11-1jpp
  372. - 2.2.D11
  373. * Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-2jpp
  374. - first unified release
  375. - s/jPackage/JPackage
  376. * Fri Sep 14 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-1mdk
  377. - cvs references
  378. - splitted demo package
  379. - moved demo files to %{_datadir}/%{name}
  380. - only manual package requires stylebook-1.0b3
  381. - only demo package requires servletapi3
  382. * Wed Aug 22 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D9-1mdk
  383. - 2.2.9
  384. - used new source packaging policy
  385. - added samples data
  386. * Wed Aug 08 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D6-1mdk
  387. - first Mandrake release