xerces-j2-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492
  1. %global cvs_version 2_9_0
  2. Name: xerces-j2
  3. Summary: Java XML parser
  4. Summary(ja): Java XML パーサ
  5. Version: 2.9.0
  6. Release: 5%{?_dist_release}
  7. Group: Development/Libraries
  8. License: ASL 2.0
  9. URL: http://xerces.apache.org/xerces2-j/
  10. # using binary for bootstrap
  11. Source0: http://archive.apache.org/dist/xml/xerces-j/Xerces-J-bin.%{version}.tar.gz
  12. #Source0: http://archive.apache.org/dist/xml/xerces-j/source/Xerces-J-src.%{version}.tar.gz
  13. Source1: %{name}-version.sh
  14. Source2: %{name}-constants.sh
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildArch: noarch
  17. #BuildRequires: java-devel >= 1:1.6.0
  18. #BuildRequires: jpackage-utils
  19. #BuildRequires: xml-commons-apis >= 1.3
  20. #BuildRequires: xml-commons-resolver >= 1.1
  21. #BuildRequires: ant
  22. #BuildRequires: xalan-j2
  23. #BuildRequires: xml-stylebook
  24. #BuildRequires: jaxp_parser_impl
  25. #BuildRequires: dejavu-sans-fonts
  26. Requires: java
  27. Requires: jpackage-utils
  28. Requires: xml-commons-apis >= 1.3
  29. #Requires: xml-commons-resolver >= 1.1
  30. Provides: jaxp_parser_impl = 1.3
  31. Requires(post): alternatives jaxp_parser_impl
  32. Requires(preun): alternatives jaxp_parser_impl
  33. # This documentation is provided by xml-commons-apis
  34. #Obsoletes: %{name}-javadoc-apis < %{version}-%{release}
  35. %description
  36. Welcome to the future! Xerces2 is the next generation of high performance,
  37. fully compliant XML parsers in the Apache Xerces family. This new version of
  38. Xerces introduces the Xerces Native Interface (XNI), a complete framework for
  39. building parser components and configurations that is extremely modular and
  40. easy to program.
  41. The Apache Xerces2 parser is the reference implementation of XNI but other
  42. parser components, configurations, and parsers can be written using the Xerces
  43. Native Interface. For complete design and implementation documents, refer to
  44. the XNI Manual.
  45. Xerces2 is a fully conforming XML Schema processor. For more information,
  46. refer to the XML Schema page.
  47. Xerces2 also provides a complete implementation of the Document Object Model
  48. Level 3 Core and Load/Save W3C Recommendations and provides a complete
  49. implementation of the XML Inclusions (XInclude) W3C Recommendation. It also
  50. provides support for OASIS XML Catalogs v1.1.
  51. Xerces2 is able to parse documents written according to the XML 1.1
  52. Recommendation, except that it does not yet provide an option to enable
  53. normalization checking as described in section 2.13 of this specification. It
  54. also handles namespaces according to the XML Namespaces 1.1 Recommendation,
  55. and will correctly serialize XML 1.1 documents if the DOM level 3 load/save
  56. APIs are in use.
  57. #%package javadoc-impl
  58. #Summary: Javadoc for %{name} implementation
  59. #Group: Documentation
  60. #
  61. #%description javadoc-impl
  62. #%{summary}.
  63. #%package javadoc-xs
  64. #Summary: Javadoc for %{name} XML schema API
  65. #Group: Documentation
  66. #
  67. #%description javadoc-xs
  68. #%{summary}.
  69. #%package javadoc-xni
  70. #Summary: Javadoc for %{name} XNI
  71. #Group: Documentation
  72. #
  73. #%description javadoc-xni
  74. #%{summary}.
  75. #%package javadoc-other
  76. #Summary: Javadoc for other %{name} components
  77. #Group: Documentation
  78. #
  79. #%description javadoc-other
  80. #%{summary}.
  81. #%package manual
  82. #Summary: Manual for %{name}
  83. #Group: Documentation
  84. #Requires: xml-commons-apis-javadoc
  85. #Requires: %{name}-javadoc-impl = %{version}-%{release}
  86. #Requires: %{name}-javadoc-xs = %{version}-%{release}
  87. #Requires: %{name}-javadoc-xni = %{version}-%{release}
  88. #Requires: %{name}-javadoc-other = %{version}-%{release}
  89. #
  90. #%description manual
  91. #%{summary}.
  92. #%package demo
  93. #Summary: Demonstrations and samples for %{name}
  94. #Group: Development/Libraries
  95. #Requires: %{name} = %{version}-%{release}
  96. #
  97. #%description demo
  98. #%{summary}.
  99. #%package scripts
  100. #Summary: Additional utility scripts for %{name}
  101. #Group: Development/Libraries
  102. #Requires: %{name} = %{version}-%{release}
  103. #
  104. #%description scripts
  105. #%{summary}.
  106. %prep
  107. %setup -q -n xerces-2_9_0
  108. #patch0 -p0 -b .orig
  109. %build
  110. %install
  111. rm -rf $RPM_BUILD_ROOT
  112. # jars
  113. install -pD -T xercesImpl.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
  114. (cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
  115. # scripts
  116. install -pD -m755 -T %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}-version
  117. install -pD -m755 -T %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}-constants
  118. # demo
  119. #install -pD -T xercesSamples.jar $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
  120. #cp -pr data $RPM_BUILD_ROOT%{_datadir}/%{name}
  121. # jaxp_parser_impl ghost symlink
  122. #ln -s %{_sysconfdir}/alternatives \
  123. # $RPM_BUILD_ROOT%{_javadir}/jaxp_parser_impl.jar
  124. %clean
  125. rm -rf $RPM_BUILD_ROOT
  126. %post
  127. /sbin/update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
  128. jaxp_parser_impl %{_javadir}/%{name}.jar 40
  129. %preun
  130. if [ $1 = 0 ]; then
  131. /sbin/update-alternatives --remove jaxp_parser_impl \
  132. %{_javadir}/%{name}.jar
  133. fi
  134. %files
  135. %defattr(-,root,root,-)
  136. %doc LICENSE NOTICE
  137. %{_javadir}/%{name}*
  138. #ghost %{_javadir}/jaxp_parser_impl.jar
  139. #%files javadoc-impl
  140. #%defattr(-,root,root,-)
  141. #%{_javadocdir}/%{name}-impl-%{version}
  142. #%{_javadocdir}/%{name}-impl
  143. #%files javadoc-xs
  144. #%defattr(-,root,root,-)
  145. #%{_javadocdir}/%{name}-xs-%{version}
  146. #%{_javadocdir}/%{name}-xs
  147. #%files javadoc-other
  148. #%defattr(-,root,root,-)
  149. #%{_javadocdir}/%{name}-other-%{version}
  150. #%{_javadocdir}/%{name}-other
  151. #%files javadoc-xni
  152. #%defattr(-,root,root,-)
  153. #%{_javadocdir}/%{name}-xni-%{version}
  154. #%{_javadocdir}/%{name}-xni
  155. #%files manual
  156. #%defattr(-,root,root,-)
  157. #%dir %{_docdir}/%{name}-%{version}
  158. #%{_docdir}/%{name}-%{version}/manual
  159. #%files demo
  160. #%defattr(-,root,root,-)
  161. #%{_datadir}/%{name}
  162. #%files scripts
  163. #%defattr(-,root,root,-)
  164. %{_bindir}/*
  165. %changelog
  166. * Fri Aug 27 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.9.0-5
  167. - Initial build for Vine Linux
  168. * Sat Jun 12 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-4
  169. - Fix broken links in manual and fix javadoc requires.
  170. - Build 1.5 bytecode instead of 1.6, for compatibility.
  171. * Fri Jan 22 2010 Andrew Overholt <overholt@redhat.com> - 2.9.0-3
  172. - Fix unversioned Provides for jaxp_parser_impl (make it 1.3).
  173. * Thu Jan 14 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-2
  174. - Add a build dep on a font package because the JDK is missing a dependency
  175. to function correctly in headless mode. See RHBZ #478480 and #521523.
  176. - Fix groups.
  177. * Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-1
  178. - Update to 2.9.0: This is the version Eclipse expects, previously the OSGi
  179. manifest was lying about its version :-o
  180. - Enable manual sub-package now xml-stylebook is in Fedora.
  181. - Drop GCJ support.
  182. - Minor changes to spec to make it more conforming to the guidelines.
  183. - Drop the libgcj patch, we don't seem to need it anymore.
  184. - Add the OSGi manifest as part of the build instead of the install.
  185. - Fix packaging bug RHBZ #472646.
  186. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-12.3
  187. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  188. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-11.3
  189. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  190. * Fri Jan 30 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-10.3
  191. - Add osgi manifest.
  192. * Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.1-10.2
  193. - drop repotag
  194. - fix license tag
  195. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.1-10jpp.1
  196. - Autorebuild for GCC 4.3
  197. * Wed Mar 28 2007 Matt Wringe <mwringe@redhat.com> 0:2.7.1-9jpp.1
  198. - Update with newest jpp version
  199. - Clean up spec file for Fedora Review
  200. * Sun Aug 13 2006 Warren Togami <wtogami@redhat.com> 0:2.7.1-7jpp.2
  201. - fix typo in preun req
  202. * Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp.1
  203. - Merge with upstream version
  204. * Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp
  205. - Add conditional native compiling
  206. - Add missing requires for javadocs
  207. - Add missing requires for post and preun
  208. - Update version to 7jpp at Fedora's request
  209. * Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.1-6jpp_9fc
  210. - Rebuilt
  211. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:2.7.1-6jpp_8fc
  212. - rebuild
  213. * Thu Mar 30 2006 Fernando Nasser <fnasser@redhat.com> 0:2.7.1-3jpp
  214. - Add missing BR for xml-stylebook
  215. * Wed Mar 22 2006 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-2jpp
  216. - First JPP-1.7 release
  217. - use tools subdir and give it as java.endorsed.dirs (for java-1.4.2-bea e.g.)
  218. * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.7.1-6jpp_7fc
  219. - stop scriptlet spew
  220. * Wed Feb 22 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.7.1-6jpp_6fc
  221. - Updated to 2.7.1
  222. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_5fc
  223. - bump again for double-long bug on ppc(64)
  224. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_4fc
  225. - rebuilt for new gcc4.1 snapshot and glibc changes
  226. * Thu Feb 2 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_3fc
  227. - build xerces without using native code
  228. * Mon Jan 9 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_2fc
  229. - rebuilt for new gcj
  230. * Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.2-6jpp_1fc
  231. - rebuilt for new gcj
  232. * Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com>
  233. - rebuilt for new gcj
  234. * Fri Oct 07 2005 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-1jpp
  235. - Upgrade to 2.7.1
  236. * Thu Jul 21 2005 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-7jpp
  237. - Include target jars-dom3
  238. - Create new subpackage dom3
  239. * Mon Jul 18 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_2fc
  240. - Build on ia64, ppc64, s390 and s390x.
  241. - Switch to aot-compile-rpm (also BC-compiles samples).
  242. * Wed Jul 13 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-6jpp
  243. - Build with Sun JDK (from <gareth.armstrong at hp.com>).
  244. * Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_1fc
  245. - Upgrade to 2.6.2-5jpp.
  246. * Tue Jun 14 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp
  247. - Remove the tools tarball, and build xjavac from source.
  248. - Patch xjavac to fix the classpath under libgcj too.
  249. * Fri Jun 10 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_8fc
  250. - Remove the tools tarball, and build xjavac from source.
  251. - Replace classpath workaround to xjavac task and use
  252. xml-commons classes again (#152255).
  253. * Thu May 26 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_7fc
  254. - Rearrange how BC-compiled stuff is built and installed.
  255. * Mon May 23 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_6fc
  256. - Add alpha to the list of build architectures (#157522).
  257. - Use absolute paths for rebuild-gcj-db.
  258. * Thu May 5 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_5fc
  259. - Add dependencies for %%post and %%postun scriptlets (#156901).
  260. * Fri Apr 29 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_4fc
  261. - BC-compile.
  262. * Thu Apr 28 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_3fc
  263. - Revert xjavac classpath workaround, and patch to use libgcj's
  264. classes instead of those in xml-commons (#152255).
  265. * Thu Apr 21 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_2fc
  266. - Add classpath workaround to xjavac task (#152255).
  267. * Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_1fc
  268. - Reenable building of classes that require javax.swing (#130006).
  269. - Sync with RHAPS.
  270. * Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.2-4jpp_1rh
  271. - Merge with upstream for 2.6.2 upgrade
  272. * Thu Nov 4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_5fc
  273. - Build into Fedora.
  274. * Thu Oct 28 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_4fc
  275. - Bootstrap into Fedora.
  276. * Fri Oct 1 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_4rh
  277. - add coreutils BuildRequires
  278. * Thu Sep 30 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_3rh
  279. - Remove xml-commons-resolver as a Requires
  280. * Thu Aug 26 2004 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-4jpp
  281. - Build with ant-1.6.2
  282. - Dropped jikes requirement, built for 1.4.2
  283. * Wed Jun 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-3jpp
  284. - Updated Patch #0 to fix breakage using BEA 1.4.2 SDK, new patch
  285. from <mwringe@redhat.com> and <vivekl@redhat.com>.
  286. * Mon Jun 21 2004 Vivek Lakshmanan <vivekl@redhat.com> 0:2.6.2-2jpp_2rh
  287. - Added new Source1 URL and added new %%setup to expand it under the
  288. expanded result of Source0.
  289. - Updated Patch0 to fix version discrepancies.
  290. - Added build requirement for xml-commons-apis
  291. * Mon Jun 14 2004 Matt Wringe <mwringe@redhat.com> 0:2.6.2-2jpp_1rh
  292. - Update to 2.6.2
  293. - made patch names comformant
  294. * Mon Mar 29 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-2jpp
  295. - Rebuilt with jikes 1.18 for java 1.3.1_11
  296. * Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_2rh
  297. - add RHUG upgrade cleanup
  298. * Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-1jpp
  299. - 2.6.2
  300. * Thu Mar 11 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_1rh
  301. - RH vacuuming
  302. - remove jikes dependency
  303. - add nonjikes-cast.patch
  304. * Sun Feb 08 2004 David Walluck <david@anti-microsoft.org> 0:2.6.1-1jpp
  305. - 2.6.1
  306. - update Source0 URL
  307. - now requires xml-commons-resolver
  308. * Fri Jan 9 2004 Kaj J. Niemi <kajtzu@fi.basen.net> - 0:2.6.0-1jpp
  309. - Update to 2.6.0
  310. - Patch #1 (xerces-j2-manifest.patch) is unnecessary (upstream)
  311. * Tue Oct 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.0-1jpp
  312. - Update to 2.5.0.
  313. - Clean up versionless javadoc dir symlinking, own (ghost) the symlinks.
  314. - Mark javadocs as %%doc.
  315. * Wed Jun 4 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.4.0-3jpp
  316. - Own (ghost) %%{_javadir}/jaxp_parser_impl.jar.
  317. - Remove alternatives in preun instead of postun.
  318. * Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-2jpp
  319. - bug #17325 fixed upstream
  320. * Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-1jpp
  321. - 2.4.0
  322. - BuildRequires: jikes
  323. - update for JPackage 1.5
  324. - re-diff'ed build patch for 2.4.0
  325. - bug #17325 handled by perl now
  326. - scripts: s|find-jar|build-classpath| and don't test for java-functions
  327. * Wed Mar 26 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> - 2.3.0-2jpp
  328. - For jpackage-utils 1.5
  329. - zapped manual, since it doesn't want to build
  330. - as a consequence, removed uneeded dependencies
  331. * Mon Feb 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.3.0-1jpp
  332. - Update to 2.3.0.
  333. - Add a crude patch to work around invalid XML in doc sources, see
  334. <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17325>.
  335. - Built with IBM's 1.3.1 SR3.
  336. * Sat Dec 28 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-2jpp
  337. - Add upstream patch which fixes problems with Tomcat's webapps.
  338. <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13282>
  339. <http://marc.theaimsgroup.com/?l=xerces-cvs&m=103791990130308>
  340. - Separate scripts subpackage.
  341. * Fri Nov 15 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-1jpp
  342. - Update to 2.2.1.
  343. - Change alternative to point to non-versioned jar.
  344. - Don't remove alternative on upgrade.
  345. - Fix Group tag for demo, javadoc and manual subpackages.
  346. - Add version and constants scripts.
  347. - Some spec file cleanup.
  348. * Sun Oct 6 2002 Ville Skyttä <ville.skytta at iki.fi> 2.2.0-2jpp
  349. - Fix bad permissions for main jar.
  350. * Sun Sep 29 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
  351. - Update to 2.2.0.
  352. * Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-2jpp
  353. - Rebuild with -Dcompiler=modern, not a Jikes bug this time, but sloppy code
  354. that is tolerated by javac. See <http://www-124.ibm.com/developerworks/bugs/?func=detailbug&bug_id=3218&group_id=10> for details.
  355. * Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
  356. - 2.1.0.
  357. - Updated description.
  358. - Changed javadoc and manual group to Documentation.
  359. - Spec file cleanups.
  360. * Fri Jul 12 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-4jpp
  361. - add BuildRequires xerces-j1 and xalan-j2
  362. - removed BuildRequires xml-commons-api since ant require jaxp_parser_impl
  363. which in turn require xml-commons-api ;)
  364. * Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-3jpp
  365. - vendor, distribution, group tags
  366. - provides jaxp_parser_impl
  367. - dropped api jar
  368. - renamed lone jar to %%{name}.jar
  369. - priority bumped to 40
  370. - fixed stylebook build (add xerces-j1 in classpath)
  371. * Wed Jun 26 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-2jpp
  372. - rebuild for missing symlinks
  373. - use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
  374. * Mon Jun 24 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-1jpp
  375. - 2.0.2
  376. * Sun Mar 10 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.1-1jpp
  377. - 2.0.1
  378. - provides jaxp_parser2 virtual resource
  379. - drop wrapper
  380. * Sun Feb 03 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.0-1jpp
  381. - first JPackage release