xinetd-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563
  1. %define _use_internal_dependency_generator 0
  2. %define __find_requires %{SOURCE99}
  3. Summary: A secure replacement for inetd.
  4. Name: xinetd
  5. Version: 2.3.14
  6. Release: 1%{?_dist_release}
  7. License: Distributable (BSD-like)
  8. Group: System Environment/Daemons
  9. Source: http://www.xinetd.org/xinetd-%{version}.tar.gz
  10. Source1: xinetd.init
  11. Source2: xinetd.conf
  12. Source3: xinetd-inetdconvert
  13. Source4: xinetd-ttime
  14. Source5: xinetd-utime
  15. Source6: xinetd-tdtime
  16. Source7: xinetd-udtime
  17. Source8: xinetd-echo
  18. Source9: xinetd-uecho
  19. Source10: xinetd-chargen
  20. Source11: xinetd-uchargen
  21. Source12: xinetd.sysconf
  22. Source13: xinetd-services
  23. Source99: filter-requires-xinetd.sh
  24. Patch0: xinetd-2.3.11-pie.patch
  25. Patch1: xinetd-2.3.13-libwrap.patch
  26. Patch2: xinetd-2.3.12-tcp_rpc.patch
  27. Prereq: chkconfig initscripts
  28. Requires: initscripts setup fileutils
  29. URL: http://www.xinetd.org/
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. Provides: inetd
  32. %description
  33. Xinetd is a secure replacement for inetd, the Internet services
  34. daemon. Xinetd provides access control for all services based on the
  35. address of the remote host and/or on time of access and can prevent
  36. denial-of-access attacks. Xinetd provides extensive logging, has no
  37. limit on the number of server arguments, and lets you bind specific
  38. services to specific IP addresses on your host machine. Each service
  39. has its own specific configuration file for Xinetd; the files are
  40. located in the /etc/xinetd.d directory.
  41. %prep
  42. %setup -q
  43. #%patch0 -p0 -b .pie
  44. #%patch1 -p1 -b .libwrap
  45. %patch2 -p1 -b .tcp_rpc
  46. %build
  47. libtoolize --copy --force
  48. %configure --with-loadavg --with-inet6 --with-libwrap
  49. make
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  53. mkdir -p $RPM_BUILD_ROOT/%{_mandir}
  54. %makeinstall DAEMONDIR=$RPM_BUILD_ROOT/usr/sbin MANDIR=$RPM_BUILD_ROOT/%{_mandir}
  55. mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d/
  56. install -m 755 %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/xinetd
  57. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/etc/xinetd.conf
  58. install -m 755 %SOURCE3 $RPM_BUILD_ROOT/usr/sbin/inetdconvert
  59. install -m 644 %SOURCE4 $RPM_BUILD_ROOT/etc/xinetd.d/time
  60. install -m 644 %SOURCE5 $RPM_BUILD_ROOT/etc/xinetd.d/time-udp
  61. install -m 644 %SOURCE6 $RPM_BUILD_ROOT/etc/xinetd.d/daytime
  62. install -m 644 %SOURCE7 $RPM_BUILD_ROOT/etc/xinetd.d/daytime-udp
  63. install -m 644 %SOURCE8 $RPM_BUILD_ROOT/etc/xinetd.d/echo
  64. install -m 644 %SOURCE9 $RPM_BUILD_ROOT/etc/xinetd.d/echo-udp
  65. install -m 644 %SOURCE10 $RPM_BUILD_ROOT/etc/xinetd.d/chargen
  66. install -m 644 %SOURCE11 $RPM_BUILD_ROOT/etc/xinetd.d/chargen-udp
  67. install -m 644 %SOURCE13 $RPM_BUILD_ROOT/etc/xinetd.d/services
  68. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/itox*
  69. rm -f $RPM_BUILD_ROOT/usr/sbin/itox
  70. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/xconv.pl*
  71. rm -f $RPM_BUILD_ROOT/usr/sbin/xconv.pl
  72. rm -f $RPM_BUILD_ROOT/%{_mandir}/*.3
  73. mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
  74. install -m 644 %SOURCE12 $RPM_BUILD_ROOT/etc/sysconfig/xinetd
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %post
  78. if [ $1 = 1 ]; then
  79. /sbin/chkconfig --add xinetd
  80. fi
  81. %preun
  82. if [ $1 = 0 ]; then
  83. /sbin/service xinetd stop > /dev/null 2>&1
  84. /sbin/chkconfig --del xinetd
  85. fi
  86. %postun
  87. if [ $1 -ge 1 ]; then
  88. /sbin/service xinetd condrestart >/dev/null 2>&1
  89. fi
  90. %files
  91. %defattr(-,root,root)
  92. %doc INSTALL CHANGELOG COPYRIGHT README xinetd/sample.conf
  93. %config(noreplace) /etc/xinetd.conf
  94. %config(noreplace) /etc/sysconfig/xinetd
  95. %{_sbindir}/xinetd
  96. %{_sbindir}/inetdconvert
  97. %{_mandir}/*/*
  98. %config /etc/rc.d/init.d/xinetd
  99. %config(noreplace) /etc/xinetd.d/*
  100. %changelog
  101. * Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.14-1vl5
  102. - applied new versioning policy
  103. * Sun Nov 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.3.14-0vl2
  104. - fix dependencies ([VineSeed:11559,12368], <bts:398>)
  105. - remove Conflicts: inetd
  106. - add Provides: inetd
  107. * Wed Mar 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.14-0vl1
  108. - new upstream release
  109. - drop patch1
  110. - remove Provides: inetd
  111. * Sun Feb 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.13-2vl3
  112. - remove Obosletes: inetd, add Conflicts: inetd
  113. * Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl2
  114. - rebuild
  115. * Sat Sep 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl1
  116. - build for VineSeed
  117. - remove Epoch
  118. - remove patch0
  119. - remove Requires: filesystem >= 2.0.1
  120. - remove BuildRequires: glibc-devel (included in build-essential)
  121. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  122. - rebuilt
  123. * Thu Jan 29 2004 Jay Fenlason <fenlason@redhat.com> 2.3.13-1
  124. - Upgrade to new upstream version, which obsoletes most patches.
  125. - Add new tcp_rpc patch, to turn on the nolibwrap flag on tcp rpc services,
  126. since libwrap cannot be used on them.
  127. * Sun Dec 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  128. - use new technology to filter python dep for inetdconvert instead
  129. of changing the -x bit on file permissions
  130. * Wed Nov 12 2003 Jay Fenlason <fenlason@redhat.com> 2.3.12-3
  131. - build in HEAD for pre FC-2
  132. - merge from xinetd-3E-branch to fix bugzilla #103009
  133. also includes:
  134. New upstream version, which obsoletes most of my patches
  135. Remove %{_mandir}/man8/xconv.pl* fixing #90730
  136. Remove the servers service, which was removed from 2.3.12
  137. Change localization: instead of using en_US in /etc/rc.d/init.d/xinetd
  138. (overriding the system default and preventing any customization),
  139. /etc/sysconfig/xinetd sets XINETD_LANG, which is either a locale to use
  140. or the word "none", which causes all locale environment variables to be
  141. cleared before xinetd is started. This fixes #91403
  142. #77724 was fixed by the upgrade to 2.3.12
  143. include post 2.3.12 patch from upstream (originally by
  144. Matthias Andree <ma+xi@dt.e-technik.uni-dortmund.de>) to add a new
  145. "libwrap" parameter.
  146. This closes bugs (#91555,#91135,#77724) by making xinetd's behavior
  147. documented and user-configurable.
  148. Removed the old libwrap/TCP/wait patch. If anyone actually cares,
  149. they can add "flags = NOLIBWRAP" to the configuration of TCP/wait
  150. services to get the old behavior.
  151. Mark /etc/sysconfig/xinetd as a config file in xinetd.spec
  152. Add pie support
  153. * Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  154. - allow compiling without tcp_wrappers
  155. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  156. - rebuilt
  157. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  158. - rebuilt
  159. * Fri Feb 21 2003 Jay Fenlason <fenlason@redhat.com> 2.3.10-5
  160. - Merge various patches from xinetd-CVS, since 2.3.11 won't be
  161. out in time for our Red Hat Linux release. One improves range checking
  162. on file descriptors. (A potential security problem.) Another
  163. fixes bugzilla #84840: tcpmux doesn't work at all. A third improves
  164. error checking on tcpmux service entries. The last improves error
  165. checking on service startup.
  166. * Tue Feb 11 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-4
  167. - rebuild
  168. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-3
  169. - rebuild
  170. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  171. - rebuilt
  172. * Tue Jan 7 2003 Jay Fenlason <fenlason.redhat.com> 2.3.10-1
  173. - Fix #81770, #80612, #79219, #79274: New upstream version
  174. - May also fix #79085, #78903, #78699, #77781, #77760, #76727
  175. - ... #73805, #60049, #58881, #58855
  176. - Fix #79999: remove xinetd-ipv6 executable
  177. - Fix #82021: changed preun to turn off the server
  178. - try to Fix #74198 by quoting "${NETWORKING}" in xinetd.init
  179. * Tue Dec 10 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-6
  180. - Fix Service startup script to check for id=0
  181. * Tue Nov 19 2002 Bill Nottingham <notting@redhat.com> 2.3.7-5
  182. - add new stream_wait patch (#74696)
  183. * Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-4
  184. - Fix Service Descriptions
  185. * Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-3
  186. - Fix #77710 Fix Service Descriptions
  187. * Thu Aug 15 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 2.3.7-2
  188. - Fix #71506 (mixed internal services)
  189. * Mon Aug 12 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.7-1
  190. - 2.3.7 - this fixes #70504
  191. * Mon Aug 5 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-6
  192. - Initscript fixes (#70730)
  193. * Wed Jul 17 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-5
  194. - Add patch for improved cross compiling (#55927)
  195. * Wed Jul 3 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-4
  196. - #67701
  197. * Wed Jun 26 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5=3
  198. - Fix maks for access control (#65743)
  199. - some fixes for config file parsing
  200. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  201. - automated rebuild
  202. * Thu May 30 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-1
  203. - 2.3.5
  204. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  205. - automated rebuild
  206. * Mon Apr 22 2002 Trond Eivind Glomsr綬d <teg@redhat.com>
  207. - 2.3.4 final (bah, never announced... has been out for 3 weeks)
  208. * Thu Apr 4 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.8
  209. - Add a patch to avoid fam haunting the system
  210. * Tue Apr 2 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.7
  211. - Add patch from Alex Larson in order not to use tcp_wrappers on tcp/wait -
  212. they'd always be 0.0.0.0
  213. * Thu Mar 28 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.6
  214. - 2002-03-26. 2.3.4 final RSN
  215. * Fri Mar 1 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.5
  216. - 2002-02-28-1
  217. * Sun Jan 6 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.4
  218. - 2002-01-04
  219. - Update URLs
  220. * Fri Dec 14 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.3
  221. - 2001-12-13
  222. * Mon Dec 3 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.2
  223. - 2001-12-03 (fixes #57001, #55738)
  224. * Fri Nov 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.1
  225. - 2001-11-29, which fixes #56487
  226. - Add configuration files for the xinetd internal services listing
  227. current servers and services. It's off by default, and restricted
  228. to localhost when enabled (#52707)
  229. - Use SIGHUP for configuration reload (change in program)
  230. * Wed Aug 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.3-1
  231. - 2.3.3
  232. - parser patch now obsolete
  233. * Thu Aug 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.2-1
  234. - 2.3.2, which contains the memory overwrite patch,
  235. the audit fixes, the conn_free patch and the filelog patch.
  236. - Fix handling of rpc_version with ranges (like "1-2") (#51737)
  237. * Wed Aug 15 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-7
  238. - Don't apply the skipjunk patch anymore - xinetd now skips files with ".",
  239. which include .rpmsave etc.
  240. - fix memory overwrite bug in env.c:grow()
  241. * Mon Aug 13 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-6
  242. - conn_free was called twice...
  243. - add cps = 25 30 to xinetd.conf. Thus, if a service has many
  244. connections (25 in a 1 second period), it will be disabled
  245. for 30 seconds. Without this, 10 connections to a service in
  246. a second would permanently disable the service (#49122)
  247. * Thu Aug 9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-5
  248. - add the patch from "Solar Designer"'s audit
  249. * Thu Aug 9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-4
  250. - Make it handle stop and status when IPv6 is enabled (#49621)
  251. * Mon Jul 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  252. - Add IPv6 support - separate binary, invoked if
  253. NETWORKING_IPV6 is set (#49621)
  254. - Make inetdconvert handle the "/usr/sbin/in.telnetd in.telnetd"
  255. scenario of inetd (#46449)
  256. * Tue Jul 3 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  257. - redo skipjunkfile patch
  258. * Fri Jun 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  259. - 2.3.0
  260. * Thu Jun 21 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  261. - 2.1.8.9pre16
  262. * Mon Jun 4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  263. - Remove explicit dependancy on initscripts version
  264. * Sun May 20 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  265. - 2.1.8.9pre15, which should fix wait=yes with tcp (linuxconf is
  266. the only program I know of using this)
  267. - fix some problems with UDP internal services (#38669)
  268. - make /etc/xinetd.conf noreplace
  269. * Wed Apr 25 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  270. - Add the tcp wait=yes patch from the xinetd version in a different tree
  271. * Wed Apr 4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  272. - Add /etc/sysconfig/xinetd so users can add extra options (#34321)
  273. * Tue Feb 27 2001 Preston Brown <pbrown@redhat.com>
  274. - noreplace the xinetd.d files
  275. * Mon Feb 5 2001 Preston Brown <pbrown@redhat.com>
  276. - built against newer tcp_wrappers that fixes name resolution problem (#16949)
  277. * Mon Feb 5 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  278. - Patch from nalin@redhat.com for terminating the environment variables properly
  279. * Tue Jan 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  280. - remove PID from log_on_failure flags (#22687)
  281. * Tue Jan 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  282. - improve gettextization
  283. - add "UNLISTED" to the internal udp services (#24279)
  284. * Thu Jan 18 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  285. - 2.1.8.9pre14
  286. * Wed Jan 17 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  287. - gettextize
  288. * Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
  289. - remove python dependency.
  290. * Tue Dec 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  291. - remove RECORD from xinetd.conf for security reasons
  292. (no known holes, but better safe than sorry #22687)
  293. * Mon Dec 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  294. - unset a couple of environment variables(HOME,MAIL) in the initscript.
  295. This should avoid problems like bug #21663
  296. * Fri Dec 01 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  297. - rebuild
  298. * Tue Nov 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  299. - 2.1.8.9pre13, which should fix #19355
  300. - changes to initscript - set all locale environment variables
  301. to en_US, as the server doesn't know what locale the client
  302. expects and error messages can otherwise be confusing
  303. (partially #20566)
  304. * Thu Nov 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  305. - fix mismatch in documentation vs. reality, introduced
  306. when we changed the behaviour of the access control
  307. to use server names (#20567)
  308. * Tue Oct 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  309. - obsolete netkit-base, which was inetd's home until 6.2
  310. * Thu Oct 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  311. - 2.1.8.9pre12, which has a new "-stayalive" option so
  312. xinetd stays alive even if no services are enabled.
  313. - use the above in the initscript (#18819)
  314. * Tue Oct 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  315. - 2.1.8.9pre11, which includes the previous bugfixes.
  316. - don't convert the internal services, include
  317. such files with xinetd (#17331, #18899)
  318. * Mon Oct 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  319. - Add patch to fix segfault problem (#18686)
  320. * Fri Oct 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  321. - apply patch from nalin@redhat.com for handling tcp
  322. connections with wait=yes properly
  323. * Tue Sep 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  324. - add explicit dependency on a modern version of initscripts
  325. (#17533)
  326. * Wed Aug 30 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  327. - 2.1.8.9pre10 - remove tcpwrapper and pidfile patches,
  328. as they are now in.
  329. - change default startup position to 56, so it
  330. starts after bind (#17047)
  331. * Thu Aug 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  332. - use the server name not the service name for libwrap
  333. checking (#16516). The new way was better, but
  334. this is sacrificed so old systems will continue to work
  335. and the documentation for tcp_wrappers can be correct.
  336. * Wed Aug 16 2000 Than Ngo <than@redhat.com>
  337. - fix initscript, test network file before source it (Bug #16247)
  338. * Tue Aug 15 2000 Trond Eivind Glomsr綬d <teg@redhat.com
  339. - make the pidfile 0644, not 0300 (#16256)
  340. * Tue Aug 08 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  341. - added support for "-pidfile" option (#15531)
  342. * Fri Aug 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  343. - added patch to ignore .rpmsave, .rpmorig, .rpmnew, ~
  344. suffixed files (#15304)
  345. * Thu Aug 03 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  346. - 2.1.8.9pre9, old patches are now integrated.
  347. * Wed Aug 02 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  348. - fix converting of "wait" argument (#13884)
  349. - remove tcpd and /usr/sbin/tcpd from inetd.conf services
  350. before converting - xinetd is linked against tcp_wrappers
  351. * Mon Jul 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  352. - fix linuxconf restart problem (#14856)
  353. - fix conditional restart
  354. - mark /etc/xinetd.conf as a configuration file
  355. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  356. - um, we *need* to prereq /etc/init.d
  357. * Mon Jul 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  358. - Don't require /etc/init.d
  359. * Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
  360. - rebuild
  361. * Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  362. - fix the sections of the man pages (#14244)
  363. * Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  364. - remove itox, as it wouldn't do the right thing with our
  365. configuration
  366. - same with xconv.pl
  367. - some changes to the installation process
  368. * Mon Jul 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  369. - move initscript back to /etc/rc.d/init.d
  370. * Fri Jul 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  371. - change process name in init file
  372. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  373. - automatic rebuild
  374. * Fri Jul 7 2000 Nalin Dahyabhai <nalin@redhat.com>
  375. - start the daemon with the "-reuse" flag
  376. * Thu Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  377. - "Prereq:", not "Requires:" for /etc/init.d
  378. * Wed Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  379. - require /etc/init.d
  380. * Wed Jul 5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  381. - upper the number of instances to 60
  382. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  383. - fix a memory-allocation bug
  384. * Wed Jun 28 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  385. - 2.1.8.9pre8
  386. * Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  387. - moved to /etc/init.d
  388. * Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  389. - changed specfile and initfile to implement conditional
  390. restart
  391. * Sun Jun 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  392. - 2.1.8.9pre7
  393. - now obsoletes inetd
  394. - use %%{_tmppath}
  395. * Sun Jun 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  396. - 2.1.8.9pre6
  397. - added converter script which can convert specified or
  398. remaing uncoverted services
  399. - use %%{_mandir}
  400. - removed +x on xinetd.conf
  401. * Wed May 24 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  402. - 2.1.8.9pre4
  403. - authpriv patch no longer needed
  404. * Tue May 23 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  405. - /etc/xinetd.d is now part of the filesystem package
  406. - more fixes to xinetd.init
  407. * Mon May 22 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  408. - fixed some obvious bugs in xinetd.init
  409. - added a default xinetd.conf
  410. - patched xinetd to understand LOG_AUTHPRIV
  411. * Fri May 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  412. - updated version
  413. - removed a define %ver (we already have %version)
  414. - removed some extra CFLAGS declarations
  415. - added configuration directory, /etc/xinetd.d
  416. * Mon Feb 21 2000 Tim Powers <timp@redhat.com>
  417. - fixed broken postun sections, should have been *preun*
  418. - fixed broken gzip of manpages
  419. * Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  420. - 2.1.8.8p8
  421. - Fix the init script (Bug #7277)
  422. - remove our patches (no longer required)
  423. * Tue Sep 21 1999 Bill Nottingham <notting@redhat.com>
  424. - add -lnsl
  425. * Tue Sep 7 1999 Tim Powers <timp@redhat.com>
  426. - modification top install routine
  427. * Mon Jul 26 1999 Tim Powers <timp@redhat.com>
  428. - updated source to 2.1.8.6b6
  429. - built for 6.1
  430. * Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
  431. - update to 2.1.8.6b5
  432. - build for PowerTools
  433. * Mon Jan 10 1999 Bill Nottingham <notting@redhat.com>
  434. - update to 2.1.8.5p2
  435. * Tue Dec 1 1998 Bill Nottingham <notting@redhat.com>
  436. - intial build