xulrunner-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836
  1. %define nspr_version 4.8.6
  2. %define nss_version 3.12
  3. %define cairo_version 1.8.6
  4. %define libnotify_version 0.4
  5. %define tarballdir mozilla-1.9.2
  6. %define build_vine6 0
  7. %define build_vine5 0
  8. %if "%{?_dist_release}" == "vl6"
  9. %define build_vine6 1
  10. %define build_vine5 1
  11. %endif
  12. %if "%{?_dist_release}" == "vl5"
  13. %define build_vine5 1
  14. %endif
  15. %if %build_vine6
  16. %define sqlite_version 3.7.2
  17. %endif
  18. %define version_internal 1.9.2
  19. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  20. # Separated plugins are supported on x86(64) only
  21. %ifarch %{ix86} x86_64
  22. %define separated_plugins 1
  23. %else
  24. %define separated_plugins 0
  25. %endif
  26. Summary: XUL Runtime for Gecko Applications
  27. Summary(ja): Gecko アプリケーションのための XUL ランタイム
  28. Name: xulrunner
  29. Version: 1.9.2.15
  30. Release: 1%{?_dist_release}
  31. URL: http://www.mozilla.org/projects/xulrunner/
  32. License: MPLv1.1 or GPLv2+ or LGPLv2+
  33. Group: Applications/Internet
  34. Source0: %{name}-%{version}.source.tar.bz2
  35. Source10: %{name}-mozconfig
  36. Source11: %{name}-mozconfig-vine5
  37. Source12: %{name}-vine-default-prefs.js
  38. Source21: %{name}.sh.in
  39. Source23: %{name}.1
  40. # locale sources
  41. %define MOZ_BUILD_LOCALES "ja"
  42. Source1000: xulrunner-%{version}-ja.tar.bz2
  43. # build patches
  44. Patch0: xulrunner-version.patch
  45. Patch1: mozilla-build.patch
  46. Patch3: mozilla-jemalloc.patch
  47. Patch7: xulrunner-1.9.2.1-build.patch
  48. #Patch8: mozilla-plugin.patch
  49. Patch9: mozilla-build-sbrk.patch
  50. Patch10: mozilla-libjpeg-turbo.patch
  51. # patches from Fedora
  52. Patch100: mozilla-192-pkgconfig.patch
  53. # Upstream patches
  54. # ---------------------------------------------------
  55. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  56. BuildRequires: nspr-devel >= %{nspr_version}
  57. BuildRequires: nss-devel >= %{nss_version}
  58. BuildRequires: cairo-devel >= %{cairo_version}
  59. BuildRequires: libpng-devel
  60. BuildRequires: libjpeg-turbo-devel
  61. BuildRequires: bzip2-devel
  62. BuildRequires: zlib-devel
  63. BuildRequires: lcms-devel
  64. BuildRequires: libIDL-devel
  65. BuildRequires: gtk2-devel
  66. BuildRequires: gnome-vfs2-devel
  67. BuildRequires: libgnome-devel
  68. BuildRequires: libgnomeui-devel
  69. BuildRequires: pango-devel
  70. BuildRequires: freetype2-devel >= 2.1.9
  71. BuildRequires: libXt-devel
  72. BuildRequires: libXrender-devel
  73. %if %{build_vine6}
  74. BuildRequires: sqlite3-devel >= %{sqlite_version}
  75. %endif
  76. BuildRequires: libnotify-devel >= %{libnotify_version}
  77. BuildRequires: startup-notification-devel
  78. BuildRequires: alsa-lib-devel
  79. BuildRequires: lcms-devel
  80. BuildRequires: zip
  81. # For -sqlite.patch
  82. BuildRequires: autoconf213
  83. Requires: nspr >= %{nspr_version}
  84. Requires: nss >= %{nss_version}
  85. Provides: gecko-libs = %{version}
  86. %description
  87. XULRunner provides the XUL Runtime environment for Gecko applications.
  88. %package devel
  89. Summary: Development files for Gecko
  90. Group: Development/Libraries
  91. Obsoletes: mozilla-devel
  92. Obsoletes: firefox-devel < 2.1
  93. Obsoletes: xulrunner-devel-unstable
  94. Provides: gecko-devel = %{version}
  95. Provides: gecko-devel-unstable = %{version}
  96. Requires: xulrunner = %{version}-%{release}
  97. Requires: nspr-devel >= %{nspr_version}
  98. Requires: nss-devel >= %{nss_version}
  99. Requires: cairo-devel >= %{cairo_version}
  100. Requires: libjpeg-turbo-devel
  101. Requires: zip
  102. Requires: bzip2-devel
  103. Requires: zlib-devel
  104. Requires: lcms-devel
  105. Requires: libIDL-devel
  106. Requires: gtk2-devel
  107. Requires: gnome-vfs2-devel
  108. Requires: libgnome-devel
  109. Requires: libgnomeui-devel
  110. Requires: pango-devel
  111. Requires: freetype2-devel >= 2.1.9
  112. Requires: libXt-devel
  113. Requires: libXrender-devel
  114. %if %{build_vine6}
  115. Requires: sqlite3-devel >= %{sqlite_version}
  116. %endif
  117. Requires: startup-notification-devel
  118. Requires: alsa-lib-devel
  119. %description devel
  120. Gecko development files.
  121. #---------------------------------------------------------------------
  122. %prep
  123. %setup -q -c -b 1000
  124. cd %{tarballdir}
  125. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
  126. %{P:%%PATCH0} > version.patch
  127. %{__patch} -p1 -b --suffix .version < version.patch
  128. %patch1 -p1 -b .build
  129. %patch3 -p1 -b .jemalloc
  130. %patch7 -p2 -b .del
  131. #%patch8 -p1 -b .plugin
  132. %patch9 -p2 -b .sbrk
  133. %patch10 -p1 -b .libjpeg-turbo
  134. %patch100 -p1 -b .pkgconfig
  135. %{__rm} -f .mozconfig
  136. %if %{build_vine6}
  137. %{__cp} %{SOURCE10} .mozconfig
  138. %else
  139. %{__cp} %{SOURCE11} .mozconfig
  140. %endif
  141. %if !%{?separated_plugins}
  142. echo "ac_add_options --disable-ipc" >> .mozconfig
  143. %endif
  144. #---------------------------------------------------------------------
  145. %build
  146. cd %{tarballdir}
  147. INTERNAL_GECKO=%{version_internal}
  148. MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
  149. # Mozilla builds with -Wall with exception of a few warnings which show up
  150. # everywhere in the code; so, don't override that.
  151. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
  152. export CFLAGS=$MOZ_OPT_FLAGS
  153. export CXXFLAGS=$MOZ_OPT_FLAGS
  154. export PREFIX='%{_prefix}'
  155. export LIBDIR='%{_libdir}'
  156. MOZ_SMP_FLAGS=-j1
  157. %ifnarch ppc ppc64 s390 s390x
  158. [ -z "$RPM_BUILD_NCPUS" ] && \
  159. RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
  160. [ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
  161. %endif
  162. export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
  163. make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  164. make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  165. # build locales
  166. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  167. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  168. for dir in $LOCALEDIRS
  169. do
  170. for lang in %{MOZ_BUILD_LOCALES} ; do
  171. make -C $dir/locales AB_CD=$lang
  172. done
  173. done
  174. #---------------------------------------------------------------------
  175. %install
  176. cd %{tarballdir}
  177. %{__rm} -rf $RPM_BUILD_ROOT
  178. INTERNAL_GECKO=%{version_internal}
  179. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  180. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  181. INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
  182. MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
  183. #DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  184. DESTDIR=$RPM_BUILD_ROOT make install
  185. %{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
  186. $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  187. $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
  188. %{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
  189. %{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
  190. # set up our default preferences
  191. %{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
  192. %{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
  193. %{__rm} vl-default-prefs
  194. # Start script install
  195. %{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
  196. %{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
  197. $RPM_BUILD_ROOT%{_bindir}/%{name}
  198. %{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
  199. %{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
  200. cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
  201. find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
  202. cd -
  203. # install locales
  204. for lang in %{MOZ_BUILD_LOCALES} ; do
  205. %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
  206. done
  207. # Prepare our devel package
  208. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  209. %{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
  210. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  211. %{__cp} -rL dist/include/* \
  212. $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  213. # Copy pc files (for compatibility with 1.9.1)
  214. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
  215. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
  216. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
  217. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
  218. # Fix multilib devel conflicts...
  219. %ifarch x86_64 ia64 s390x ppc64
  220. %define mozbits 64
  221. %else
  222. %define mozbits 32
  223. %endif
  224. function install_file() {
  225. genheader=$*
  226. mv ${genheader}.h ${genheader}%{mozbits}.h
  227. cat > ${genheader}.h << EOF
  228. // This file exists to fix multilib conflicts
  229. #if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
  230. #include "${genheader}64.h"
  231. #else
  232. #include "${genheader}32.h"
  233. #endif
  234. EOF
  235. }
  236. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  237. install_file "mozilla-config"
  238. popd
  239. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  240. install_file "jsautocfg"
  241. popd
  242. %{__install} -p -c -m 755 dist/bin/xpcshell \
  243. dist/bin/xpidl \
  244. dist/bin/xpt_dump \
  245. dist/bin/xpt_link \
  246. $RPM_BUILD_ROOT/${MOZ_APP_DIR}
  247. %{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
  248. %{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
  249. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  250. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  251. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  252. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  253. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  254. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  255. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  256. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  257. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  258. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  259. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  260. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  261. find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
  262. find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
  263. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
  264. pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
  265. for i in *.so; do
  266. ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
  267. done
  268. popd
  269. # GRE stuff
  270. %ifarch x86_64 ia64 ppc64 s390x
  271. %define gre_conf_file gre64.conf
  272. %else
  273. %define gre_conf_file gre.conf
  274. %endif
  275. MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
  276. %{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
  277. $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  278. chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  279. # Library path
  280. %ifarch x86_64 ia64 ppc64 s390x
  281. %define ld_conf_file xulrunner-64.conf
  282. %else
  283. %define ld_conf_file xulrunner-32.conf
  284. %endif
  285. %{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
  286. %{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
  287. ${MOZ_APP_DIR}
  288. EOF
  289. # Copy over the LICENSE
  290. %{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
  291. # Use the system hunspell dictionaries
  292. %{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  293. ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  294. # ghost files
  295. %{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
  296. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
  297. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
  298. #---------------------------------------------------------------------
  299. %clean
  300. %{__rm} -rf $RPM_BUILD_ROOT
  301. #---------------------------------------------------------------------
  302. %post
  303. /sbin/ldconfig
  304. %postun
  305. /sbin/ldconfig
  306. %preun
  307. # is it a final removal?
  308. if [ $1 -eq 0 ]; then
  309. %{__rm} -rf ${MOZ_APP_DIR}/components
  310. fi
  311. %files
  312. %defattr(-,root,root,-)
  313. %{_bindir}/xulrunner
  314. %dir /etc/gre.d
  315. /etc/gre.d/%{gre_conf_file}
  316. %dir %{mozappdir}
  317. %doc %attr(644, root, root) %{mozappdir}/LICENSE
  318. %doc %attr(644, root, root) %{mozappdir}/README.txt
  319. %{mozappdir}/chrome
  320. %{mozappdir}/dictionaries
  321. %dir %{mozappdir}/components
  322. %ghost %{mozappdir}/components/compreg.dat
  323. %ghost %{mozappdir}/components/xpti.dat
  324. %{mozappdir}/components/*.so
  325. %{mozappdir}/components/*.xpt
  326. %attr(644, root, root) %{mozappdir}/components/*.js
  327. %{mozappdir}/defaults
  328. %{mozappdir}/greprefs
  329. %dir %{mozappdir}/icons
  330. %attr(644, root, root) %{mozappdir}/icons/*
  331. %{mozappdir}/modules
  332. %{mozappdir}/plugins
  333. %{mozappdir}/res
  334. %{mozappdir}/*.so
  335. %{mozappdir}/mozilla-xremote-client
  336. %{mozappdir}/run-mozilla.sh
  337. %{mozappdir}/regxpcom
  338. %{mozappdir}/xulrunner
  339. %{mozappdir}/xulrunner-bin
  340. %{mozappdir}/xulrunner-stub
  341. %if %{?separated_plugins}
  342. %{mozappdir}/plugin-container
  343. %endif
  344. %{mozappdir}/platform.ini
  345. %{mozappdir}/dependentlibs.list
  346. %{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
  347. # XXX See if these are needed still
  348. %{mozappdir}/updater*
  349. %exclude %{mozappdir}/update.locale
  350. %exclude %{mozappdir}/components/components.list
  351. %files devel
  352. %defattr(-,root,root,-)
  353. %dir %{_datadir}/idl/%{name}*%{version_internal}
  354. %{_datadir}/idl/%{name}*%{version_internal}/*
  355. %{_includedir}/%{name}*%{version_internal}
  356. %dir %{_libdir}/%{name}-sdk-*
  357. %dir %{_libdir}/%{name}-sdk-*/sdk
  358. %{_libdir}/%{name}-sdk-*/*
  359. %{_libdir}/%{name}-sdk-*/sdk/*
  360. %{_libdir}/pkgconfig/*.pc
  361. %{mozappdir}/xpcshell
  362. %{mozappdir}/xpidl
  363. %{mozappdir}/xpt_dump
  364. %{mozappdir}/xpt_link
  365. #---------------------------------------------------------------------
  366. %changelog
  367. * Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
  368. - update to 1.9.2.15 (sync with firefox-3.6.15)
  369. * Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
  370. - update to 1.9.2.14 (sync with firefox-3.6.14)
  371. * Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
  372. - update to 1.9.2.13 (sync with firefox-3.6.13)
  373. * Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
  374. - update to 1.9.2.11 (sync with firefox-3.6.11)
  375. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
  376. - rebuild with rpm-4.8.1 for pkg-config file
  377. * Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
  378. - update to 1.9.2.9 (sync with firefox-3.6.9)
  379. - add patch10 to build with libjpeg-turbo
  380. - build with sqlite-3.7.2
  381. - BR: nspr >= 4.8.6
  382. * Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
  383. - update tp 1.9.2.8 (sync with firefox-3.6.8)
  384. * Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
  385. - update tp 1.9.2.7 (sync with firefox-3.6.7)
  386. * Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
  387. - enable ipc only on ix86/x86_64 arches
  388. * Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
  389. - update to 1.9.2.4 (sync with firefox-3.6.4)
  390. - add patch10 to fix build failure
  391. * Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
  392. - update to 1.9.2.3 (sync with firefox-3.6.3)
  393. * Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
  394. - update to 1.9.2.2 (sync with firefox-3.6.2)
  395. - add patch7,9 for fix build failure
  396. * Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
  397. - enable libnotify support
  398. - add ac_add_options --enable-libnotify
  399. - disable Necko wifi monitor
  400. - add ac_add_options --disable-necko-wifi
  401. - remove BR: wireless-tools-devel
  402. - fix %%files devel
  403. - add patch3,5 to fix jemalloc alignment assertion
  404. - add Patch8 to fix mozilla-plugin.pc
  405. * Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
  406. - add BR: libnotify-devel, wireless-tools-devel
  407. * Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  408. - update to 1.9.2 (sync with firefox-3.6)
  409. - obsoletes xulrunner-devel-unstable
  410. * Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
  411. - use internal sqlite3 on vine5
  412. * Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
  413. - update to 1.9.1.7
  414. * Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
  415. - update to 1.9.1.6
  416. - build with sqlite3-3.6.21
  417. * Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
  418. - update to 1.9.1.5
  419. * Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
  420. - update to 1.9.1.3
  421. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
  422. - really update to 1.9.1.2 (<BTS:0748>)
  423. * Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
  424. - update to 1.9.1.2 (sync with firefox-3.5.2)
  425. * Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
  426. - update to 1.9.1.1 (sync with firefox-3.5.1)
  427. - add missing Requires to -devel
  428. - add missing BR
  429. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
  430. - enable-system-cairo
  431. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
  432. - update to 1.9.1 (based on firefox 3.5)
  433. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
  434. - update to 1.9.1rc3 (sync with firefox 3.5rc3)
  435. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
  436. - update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
  437. - remove old patches
  438. - require nspr >= 4.8
  439. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
  440. - new upstream release
  441. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
  442. - update mozconfig
  443. - disable-system-cairo for stability
  444. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
  445. - new upstream release
  446. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
  447. - new upstream release
  448. - add ja locale
  449. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
  450. - new upstream release
  451. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
  452. - new upstream release
  453. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
  454. - add Patch3
  455. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
  456. - update to xulrunner 1.9.0.2 byild 6
  457. - build with gnome-2.24
  458. * Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
  459. - new upstream release
  460. * Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
  461. - initial build for Vine Linux
  462. * Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
  463. - Update to 1.9 final
  464. * Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
  465. - Simplify PS/PDF operators
  466. * Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
  467. - Upstream patch to fsync() less
  468. * Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
  469. - Ensure we enable startup notification; add BR and modify config
  470. (bug #445543)
  471. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
  472. - Some files moved to mozilla-filesystem; kill them and add the Req
  473. * Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
  474. - Clean up the %%files list and get rid of the executable bit on some files
  475. * Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
  476. - Fix font scaling
  477. * Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
  478. - Enabled phishing protection (#443403)
  479. * Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
  480. - Changed "__ppc64__" to "__powerpc64__",
  481. "__ppc64__" doesn't work anymore
  482. - Added fix for #443725 - Critical hanging bug with fix
  483. available upstream (mozbz#429903)
  484. * Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
  485. - Fixed multilib issues, added starting script instead of a symlink
  486. to binary (#436393)
  487. * Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
  488. - Add upstream patches for dpi, toolbar buttons, and invalid keys
  489. - Re-enable system cairo
  490. * Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
  491. - Spec cleanups
  492. * Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
  493. - Beta 5
  494. * Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
  495. - Beta 5 RC2
  496. * Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
  497. - Update to latest trunk (2008-03-27)
  498. * Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
  499. - Update to latest trunk (2008-03-26)
  500. * Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
  501. - Update to latest trunk (2008-03-25)
  502. * Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
  503. - Update to latest trunk (2008-03-24)
  504. * Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
  505. - Update to latest trunk (2008-03-20)
  506. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
  507. - Update to latest trunk (2008-03-17)
  508. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
  509. - Revert to trunk from the 15th to fix crashes on HTTPS sites
  510. * Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
  511. - Update to latest trunk (2008-03-16)
  512. - Add patch to negate a11y slowdown on some pages (#431162)
  513. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
  514. - Update to latest trunk (2008-03-15)
  515. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
  516. - Avoid conflicts between gecko debuginfo packages
  517. * Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
  518. - Update to latest trunk (2008-03-12)
  519. * Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
  520. - Update to latest trunk (2008-03-11)
  521. * Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
  522. - Update to latest trunk (2008-03-10)
  523. * Sun Mar 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
  524. - Update to latest trunk (2008-03-09)
  525. * Fri Mar 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
  526. - Update to latest trunk (2008-03-07)
  527. * Thu Mar 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
  528. - Update to latest trunk (2008-03-06)
  529. * Tue Mar 4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
  530. - Update to latest trunk (2008-03-04)
  531. * Sun Mar 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
  532. - Update to latest trunk (2008-03-02)
  533. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
  534. - Update to latest trunk (2008-03-01)
  535. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
  536. - Update to latest trunk (2008-02-29)
  537. * Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
  538. - Update to latest trunk (2008-02-28)
  539. * Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
  540. - Update to latest trunk (2008-02-27)
  541. * Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
  542. - Update to latest trunk (2008-02-26)
  543. * Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
  544. - Update to latest trunk (2008-02-23)
  545. * Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
  546. - Update to latest trunk (2008-02-22)
  547. * Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
  548. - Update to latest trunk (2008-02-21)
  549. * Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
  550. - Update to latest trunk (2008-02-20)
  551. * Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
  552. - Update to latest trunk (2008-02-17)
  553. * Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
  554. - Update to latest trunk (2008-02-15)
  555. * Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
  556. - Update to latest trunk (2008-02-14)
  557. - Use system hunspell
  558. * Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
  559. - Update to latest trunk (2008-02-11)
  560. * Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
  561. - STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
  562. you know, debuginfo.
  563. * Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
  564. - Update to latest trunk (2008-02-10)
  565. * Sat Feb 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
  566. - Update to latest trunk (2008-02-09)
  567. * Wed Feb 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
  568. - Update to latest trunk (2008-02-06)
  569. * Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
  570. - Update to latest trunk (2008-01-30)
  571. * Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
  572. - rebuild agains new nss
  573. - enabled gnome vfs
  574. * Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
  575. - fixed stable pkg-config files (#429654)
  576. - removed sqlite patch
  577. * Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
  578. - Update to latest trunk (2008-01-21)
  579. * Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
  580. - Update to latest trunk (2008-01-15)
  581. - Now with system extensions directory support
  582. * Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
  583. - Update to latest trunk (2008-01-13)
  584. - Use CFLAGS instead of configure arguments
  585. - Random cleanups: BuildRequires, scriptlets, prefs, etc.
  586. * Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
  587. - Provide gecko-devel-unstable as well
  588. * Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
  589. - divided devel package to devel and devel-unstable
  590. * Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
  591. - removed fedora specific pkg-config files
  592. - updated to the latest trunk (2008-01-07)
  593. - removed unnecessary patches
  594. - fixed idl dir (#427965)
  595. * Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
  596. - Re-enable camellia256 support now that NSS supports it
  597. * Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
  598. - updated to the latest trunk (2008-01-03)
  599. * Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
  600. - Don't Provide webclient (xulrunner is not itself a webclient)
  601. - Don't Obsolete old firefox, only firefox-devel
  602. - Kill legacy obsoletes (phoenix, etc) that were never in rawhide
  603. * Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
  604. - added java and plugin subdirs to plugin includes
  605. * Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
  606. - dependency fixes, obsoletes firefox < 3 and firefox-devel now
  607. * Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
  608. - updated to Beta 2.
  609. - moved SDK to xulrunner-sdk
  610. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
  611. - fixed mozilla-plugin.pc (#412971)
  612. * Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
  613. - export /etc/gre.d/gre.conf (it's used by python gecko applications)
  614. * Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
  615. - added xulrunner/js include dir to xulrunner-js
  616. * Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
  617. - update to beta 1
  618. * Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
  619. - packed all gecko libraries (#389391)
  620. * Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
  621. - registered xulrunner libs system-wide
  622. - added xulrunner-gtkmozembed.pc
  623. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
  624. - added proper nss/nspr dependencies
  625. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
  626. - more build fixes, use system nss libraries
  627. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
  628. - build fixes
  629. * Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
  630. - updated to the latest trunk
  631. * Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
  632. - build fixes for ppc/ppc64
  633. * Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
  634. - removed conflicts with the current gecko-based apps
  635. - added updated ppc64 patch
  636. * Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
  637. - build fixes
  638. * Wed Sep 5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
  639. - Initial cut at XULRunner 1.9 Alpha 7
  640. - Temporarily revert camellia 256 support since our nss doesn't support it yet