expat-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name expat
  3. %define version 2.2.9
  4. %define release 1%{?_dist_release}
  5. Summary: Expat is an XML 1.0 parser written in C
  6. Summary(ja): C で書かれた XML 1.0 パーサ
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. License: MIT/X
  11. Group: Applications/Text
  12. URL: http://www.libexpat.org/
  13. Source: http://download.sourceforge.net/expat/%{name}-%{version}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. Requires: lib%{name} = %{version}-%{release}
  16. BuildRequires: libtool
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. This is Expat, a C library for parsing XML, written by James Clark.
  21. Expat is a stream-oriented XML parser. This means that you register
  22. handlers with the parser before starting the parse. These handlers
  23. are called when the parser discovers the associated structures in the
  24. document being parsed. A start tag is an example of the kind of
  25. structures for which you may register handlers.
  26. %package -n lib%{name}
  27. Summary: Runtime library of expat
  28. Summary(ja): Expat のための実行ライブラリ
  29. Group: System Environment/Libraries
  30. %description -n lib%{name}
  31. This package contains the runtime, shared library of expat, the C
  32. library for parsing XML.
  33. %description -n lib%{name} -l ja
  34. Expat を動作させるために必用となるライブラリです.
  35. %package devel
  36. Summary: Development environment for the expat XML parser
  37. Summary(ja): expat XML パーサ用開発環境
  38. Group: Development/Libraries
  39. Requires: lib%{name} = %{version}-%{release}
  40. Requires: pkgconfig
  41. %description devel
  42. Development environment for the expat XML parser
  43. %description devel -l ja
  44. expat XML パーサ用開発環境です.
  45. ## to build compat32 for x86_64 architecture support
  46. %package -n compat32-lib%{name}
  47. Summary: Runtime library of expat
  48. Summary(ja): Expat のための実行ライブラリ
  49. Group: System Environment/Libraries
  50. Requires: lib%{name} = %{version}-%{release}
  51. %description -n compat32-lib%{name}
  52. This package contains the runtime, shared library of expat, the C
  53. library for parsing XML.
  54. %description -n compat32-lib%{name} -l ja
  55. Expat を動作させるために必用となるライブラリです.
  56. %package -n compat32-%{name}-devel
  57. Summary: Development environment for the expat XML parser
  58. Summary(ja): expat XML パーサ用開発環境
  59. Group: Development/Libraries
  60. Requires: %{name}-devel = %{version}-%{release}
  61. Requires: compat32-lib%{name} = %{version}-%{release}
  62. %description -n compat32-%{name}-devel
  63. Development environment for the expat XML parser
  64. %description -n compat32-%{name}-devel -l ja
  65. expat XML パーサ用開発環境です.
  66. %prep
  67. %setup -q
  68. %build
  69. export CFLAGS="$RPM_OPT_FLAGS -fPIC"
  70. %configure --enable-shared
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. rm -f examples/*.dsp
  75. chmod 644 AUTHORS README.md COPYING Changes doc/* examples/*
  76. make DESTDIR=$RPM_BUILD_ROOT install
  77. rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
  78. rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/expat
  79. mkdir -p %{buildroot}%{_mandir}/man1
  80. install -m644 doc/xmlwf.1 %{buildroot}%{_mandir}/man1/
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %post -n lib%{name} -p /sbin/ldconfig
  84. %postun -n lib%{name} -p /sbin/ldconfig
  85. %post -n compat32-lib%{name} -p /sbin/ldconfig
  86. %postun -n compat32-lib%{name} -p /sbin/ldconfig
  87. %files
  88. %defattr(-,root,root)
  89. %license COPYING
  90. %doc AUTHORS Changes README.md
  91. %{_bindir}/xmlwf
  92. %{_mandir}/man1/xmlwf.1*
  93. %files -n lib%{name}
  94. %defattr(-,root,root)
  95. %license COPYING
  96. %doc AUTHORS Changes README.md
  97. %{_libdir}/libexpat.so.*
  98. %files devel
  99. %defattr(-,root,root)
  100. %license COPYING
  101. %doc AUTHORS Changes README.md
  102. %doc doc/* examples
  103. %{_includedir}/*
  104. %{_libdir}/libexpat.a
  105. %{_libdir}/libexpat.so
  106. %{_libdir}/pkgconfig/%{name}.pc
  107. ## to build compat32 for x86_64 architecture support
  108. %if %{build_compat32}
  109. %files -n compat32-lib%{name}
  110. %defattr(-,root,root)
  111. %{_libdir}/libexpat.so.*
  112. %files -n compat32-%{name}-devel
  113. %defattr(-,root,root)
  114. %{_libdir}/libexpat.a
  115. %{_libdir}/libexpat.so
  116. %endif
  117. %changelog
  118. * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
  119. - new upstream release.
  120. * Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-1
  121. - new upstream release.
  122. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
  123. - new upstream release.
  124. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
  125. - new upstream release.
  126. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
  127. - rebuild with VineSeed environment
  128. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
  129. - update to 2.1.0
  130. - remove old patches
  131. * Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
  132. - update patch100 to regrassion fix (same as debian bug #561658)
  133. - add Vendor and Distribution tags
  134. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
  135. - rebuilt with rpm-4.8.1-3
  136. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
  137. - rebuilt with gcc-4.4.3-3 on ppc
  138. * Mon Feb 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
  139. - rebuilt with new toolchains (for VineSeed)
  140. * Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
  141. - add patch110 for fix CVE-2009-3720 (xml parser)
  142. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
  143. - add Patch100 for fix CVE-2009-3560 (xml parser)
  144. * Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
  145. - added Requires: tag to compat32-* sub-packages.
  146. - removed unnecessary %%configure CC='gcc -m32' option
  147. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
  148. - applied new versioning policy and spec in utf-8
  149. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
  150. - removed %%if !%%{build_compat32} case condition
  151. * Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
  152. - new upstream release
  153. - drop Patch0
  154. - drop .la
  155. - chmod 644 the documentation
  156. - strip DSP files from examples
  157. - update description and drop description-ja
  158. - add -fPIC
  159. * Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
  160. - rebuilt
  161. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
  162. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  163. * Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
  164. - added compat32* packages for x86_64 architecture support
  165. * Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
  166. - add missing header file (expat_external.h) to %%files.
  167. * Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
  168. - updated/revised Patch1 (%%install will fail without this patch)
  169. * Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
  170. - new upstream release
  171. -- dropped patch1
  172. * Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
  173. - updated to 1.95.7
  174. - changed URL and Group
  175. - fixed License to MIT/X (based on rpm package at sourceforge)
  176. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
  177. - version up to 1.95.6
  178. - drop expat-xmlwf-dynamiclink.patch (Patch0)
  179. - add expat-1.95.6-mandir.patch for installing manpage (Patch0)
  180. - add manpage (xmlwf.1)
  181. * Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
  182. - fixed license ( s/MPL or GPL/distributable/ )
  183. - use License tag
  184. * Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
  185. - new sub-package libexpat.
  186. - added BuildPreReq: libtool
  187. * Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
  188. - updated to 1.95.2 release
  189. * Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  190. - 1.95.1-3vl1
  191. - based on 1.95.1-3mdk from Mandrake 8.0
  192. - added Japanese summary and description
  193. - modified spec macros for Vine
  194. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
  195. - real version is 1.95.1
  196. - reenable optimisations
  197. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
  198. - release .
  199. * Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
  200. - Don't try to use optimizations
  201. - Bzip2 sources
  202. * Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
  203. - first version