123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405 |
- # pkg/libsmbios.spec. Generated from libsmbios.spec.in by configure.
- # required by suse build system
- # norootforbuild
- # these are all substituted by autoconf
- %define major 2
- %define minor 3
- %define micro 0
- %define extra %{nil}
- %define pot_file libsmbios
- %define lang_dom libsmbios-2.3-x86_64
- %define release_version 2.3.0
- %define release_name libsmbios
- Name: %{release_name}
- Version: %{release_version}
- Release: 1%{?_dist_release}
- Summary: Libsmbios C/C++ shared libraries
- Summary(ja): Libsmbios C/C++ 共有ライブラリ
- License: GPLv2+ or OSL 2.1
- Group: System Environment/Libraries
- URL: http://linux.dell.com/libsmbios/main
- Source: http://linux.dell.com/libsmbios/download/libsmbios/libsmbios-%{version}/libsmbios-%{version}.tar.xz
- Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: strace libxml2-devel gcc-c++ gettext doxygen cppunit-devel pkgconfig python-devel
- # libsmbios only ever makes sense on intel compatible arches
- # no DMI tables on ppc, s390, etc.
- ExclusiveArch: x86_64 ia64 %{ix86}
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: shaolin, daisuke
- %description
- Libsmbios is a library and utilities that can be used by client programs to get
- information from standard BIOS tables, such as the SMBIOS table.
- This package provides the C-based libsmbios library, with a C interface.
- This package also has a C++-based library, with a C++ interface. It is not
- actively maintained, but provided for backwards compatibility. New programs
- should use the libsmbios C interface.
- %package -n python-smbios
- Summary: Python interface to Libsmbios C library
- Summary(ja): libsmbios C ライブラリへの Python インターフェース
- Group: System Environment/Libraries
- Requires: %{release_name} = %{version}-%{release}
- Requires: python
- %description -n python-smbios
- This package provides a Python interface to libsmbios
- %package -n smbios-utils
- Summary: Meta-package that pulls in all smbios binaries and python scripts
- Summary(ja): すべての smbios プログラムと python スクリプトをインストールするための仮想パッケージ
- Group: Applications/System
- Requires: smbios-utils-bin
- Requires: smbios-utils-python
- %description -n smbios-utils
- This is a meta-package that pulls in the binary libsmbios executables as well
- as the python executables.
- %package -n smbios-utils-bin
- Summary: Binary utilities that use libsmbios
- Summary(ja): libsmbios を用いたユーティリティ集
- Group: Applications/System
- Requires: %{release_name} = %{version}-%{release}
- %description -n smbios-utils-bin
- Get BIOS information, such as System product name, product id, service tag and
- asset tag.
- %package -n smbios-utils-python
- Summary: Python executables that use libsmbios
- Summary(ja): libsmbios を用いた Python スクリプト集
- Group: Applications/System
- Requires: python-smbios = %{version}-%{release}
- %description -n smbios-utils-python
- Get BIOS information, such as System product name, product id, service tag and
- asset tag. Set service and asset tags on Dell machines. Manipulate wireless
- cards/bluetooth on Dell laptops. Set BIOS password on select Dell systems.
- Update BIOS on select Dell systems. Set LCD brightness on select Dell laptops.
- # name the devel package libsmbios-devel regardless of package name, per suse/fedora convention
- %package -n libsmbios-devel
- Summary: Development headers and archives
- Summary(ja): libsmbios の開発用ヘッダファイルとライブラリ
- Group: Development/Libraries
- Requires: %{release_name} = %{version}-%{release}
- %description -n libsmbios-devel
- Libsmbios is a library and utilities that can be used by client programs to get
- information from standard BIOS tables, such as the SMBIOS table.
- This package contains the headers and .a files necessary to compile new client
- programs against libsmbios.
- %prep
- %setup -q -n libsmbios-%{version}
- find . -type d -exec chmod -f 755 {} \;
- find doc src -type f -exec chmod -f 644 {} \;
- chmod 755 src/cppunit/*.sh
- %build
- # this line lets us build an RPM directly from a git tarball
- # and retains any customized version information we might have
- [ -e ./configure ] || ./autogen.sh --no-configure
- mkdir _build
- cd _build
- echo '../configure "$@"' > configure
- chmod +x ./configure
- %configure
- mkdir -p out/libsmbios_c
- mkdir -p out/libsmbios_c++
- make %{?_smp_mflags} 2>&1 | tee build-%{_arch}.log
- echo \%doc _build/build-%{_arch}.log > buildlogs.txt
- %install
- rm -rf %{buildroot}
- mkdir %{buildroot}
- cd _build
- TOPDIR=..
- make install DESTDIR=%{buildroot} INSTALL="%{__install} -p"
- mkdir -p %{buildroot}/%{_includedir}
- mkdir -p %{buildroot}/%{_bindir}
- cp -a $TOPDIR/src/include/* %{buildroot}/%{_includedir}/
- cp -a out/public-include/* %{buildroot}/%{_includedir}/
- rm -f %{buildroot}/%{_libdir}/lib*.{la,a}
- find %{buildroot}/%{_includedir} out/libsmbios_c++ out/libsmbios_c -exec touch -r $TOPDIR/configure.ac {} \;
- mv out/libsmbios_c++ out/libsmbios_c++-%{_arch}
- mv out/libsmbios_c out/libsmbios_c-%{_arch}
- rename %{pot_file}.mo %{lang_dom}.mo $(find %{buildroot}/%{_datadir} -name %{pot_file}.mo)
- %find_lang %{lang_dom}
- touch files-yum-dellsysid
- touch files-smbios-utils-python
- touch files-python-smbios
- # backwards compatible:
- ln -s %{_sbindir}/dellWirelessCtl %{buildroot}/%{_bindir}/dellWirelessCtl
- ln -s smbios-sys-info %{buildroot}/%{_sbindir}/getSystemId
- ln -s smbios-wireless-ctl %{buildroot}/%{_sbindir}/dellWirelessCtl
- ln -s smbios-lcd-brightness %{buildroot}/%{_sbindir}/dellLcdBrightness
- ln -s smbios-rbu-bios-update %{buildroot}/%{_sbindir}/dellBiosUpdate
- cat > files-python-smbios <<-EOF
- %doc COPYING-GPL COPYING-OSL README
- %{python_sitelib}/*
- EOF
- cat > files-smbios-utils-python <<-EOF
- %doc COPYING-GPL COPYING-OSL README
- %doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
- %doc doc/pkgheader.sh
- %dir %{_sysconfdir}/libsmbios
- %config(noreplace) %{_sysconfdir}/libsmbios/*
-
- # python utilities
- %{_sbindir}/smbios-sys-info
- %{_sbindir}/smbios-token-ctl
- %{_sbindir}/smbios-passwd
- %{_sbindir}/smbios-wakeup-ctl
- %{_sbindir}/smbios-wireless-ctl
- %{_sbindir}/smbios-rbu-bios-update
- %{_sbindir}/smbios-lcd-brightness
- %{_sbindir}/smbios-keyboard-ctl
- %{_sbindir}/smbios-thermal-ctl
- # symlinks: backwards compat
- %{_sbindir}/dellLcdBrightness
- %{_sbindir}/getSystemId
- %{_sbindir}/dellWirelessCtl
- %{_sbindir}/dellBiosUpdate
- # used by HAL in old location, so keep it around until HAL is updated.
- %{_bindir}/dellWirelessCtl
- # data files
- %{_datadir}/smbios-utils
- EOF
- %clean
- rm -rf %{buildroot}
- %post -n %{release_name} -p /sbin/ldconfig
- %postun -n %{release_name} -p /sbin/ldconfig
- %files -f _build/%{lang_dom}.lang
- %defattr(-,root,root,-)
- %{_libdir}/libsmbios_c.so.*
- %{_libdir}/libsmbios.so.*
- %files -n libsmbios-devel -f _build/buildlogs.txt
- %defattr(-,root,root,-)
- %doc COPYING-GPL COPYING-OSL README src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
- %{_includedir}/smbios
- %{_includedir}/smbios_c
- %{_libdir}/libsmbios.so
- %{_libdir}/libsmbios_c.so
- %{_libdir}/pkgconfig/*.pc
- %doc _build/out/libsmbios_c++-%{_arch}
- %doc _build/out/libsmbios_c-%{_arch}
- %files -n smbios-utils
- # opensuse 11.1 enforces non-empty file list :(
- %defattr(-,root,root,-)
- %doc COPYING-GPL COPYING-OSL README
- # no other files.
- %files -n smbios-utils-bin
- %defattr(-,root,root,-)
- %doc COPYING-GPL COPYING-OSL README
- %doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
- %doc doc/pkgheader.sh
- #
- # legacy C++
- %{_sbindir}/dellBiosUpdate-compat
- %{_sbindir}/dellLEDCtl
- %ifnarch ia64
- %{_sbindir}/dellMediaDirectCtl
- %endif
- #
- # new C utilities
- %{_sbindir}/smbios-state-byte-ctl
- %{_sbindir}/smbios-get-ut-data
- %{_sbindir}/smbios-upflag-ctl
- %{_sbindir}/smbios-sys-info-lite
- %files -n python-smbios -f _build/files-python-smbios
- %defattr(-,root,root,-)
- %files -n smbios-utils-python -f _build/files-smbios-utils-python
- %defattr(-,root,root,-)
- %changelog
- * Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-1
- - new upstream release.
- * Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.28-2
- - rebuilt on current VineSeed
- - added Japanese summary
- * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.28-1
- - update to 2.2.28
- * Sun Apr 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.26-1
- - merged with upstream package
- * Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-3
- - initial build for Vine Linux
- * Mon Sep 27 2010 Matt Domsch <mdomsch@fedoraproject.org> - 2.2.26-3
- - build for Fedora 15
- * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.2.19-2
- - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
- * Fri Jul 06 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.26-1
- - implement CSV export of token settings from smbios-token-ctl
- * Fri Jul 06 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.25-1
- - Fix breakage resulting from improperly fixing up constructors for MemoryAccess/CmosAccess. Fixes CLI utilities.
- * Fri Jun 11 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.23-1
- - Fixup ABI break where a couple functions that should have been exported were not marked.
- * Thu Jun 10 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.22-1
- - Fixup bug in reading asset and service tag where it A) read checksum from wrong location and B) used wrong comparison check to validate it
- - enable service tag SET for machines that still set service tag in CMOS
- - ABI/API - change to -fvisibility=hidden for libsmbios_c.so.*, mark public api's. This removes all non-public symbols that were not formerly part of the ABI from the dynamic link table.
- * Mon May 18 2009 Matt Domsch <Matt_Domsch@dell.com> - 2.2.16-3
- - split yum plugin into yum-dellsysid package
- * Mon Mar 24 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.16-1
- - add gcc 4.4 support
- * Mon Mar 24 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.15-1
- - update to lastest upstream.
- - fixes bug in bios update on systems with versions like x.y.z.
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.13-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Tue Feb 3 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.12-1
- - Add feature to turn on debugging printf()'s without recompiling by setting
- certain environment variables:
- LIBSMBIOS_C_DEBUG_OUTPUT_ALL -- all debugging output
- or, per module:
- LIBSMBIOS_C_DEBUG_CONSTRUCTOR_C
- LIBSMBIOS_C_DEBUG_SYSINFO_C
- LIBSMBIOS_C_DEBUG_SMBIOS_C
- LIBSMBIOS_C_DEBUG_TOKEN_C
- LIBSMBIOS_C_DEBUG_MEMORY_C
- LIBSMBIOS_C_DEBUG_CMOS_C
- LIBSMBIOS_C_DEBUG_SMI_C
- * Mon Feb 2 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.12-1
- - Add pkgconfig files to -devel
- - fixup yum plugin to not parse certain data that causes a crash on some machines (Optiplex 755, others may be affected)
- * Thu Jan 15 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.8-1
- - revert change in upstream renaming rpm to libsmbios2
- * Thu Jan 15 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.7-1
- - change source to bz2 format
- - Update to latest upstream release. Many changes in the new release:
- - python interface
- - libsmbios_c interface almost fully implemented
- - libsmbios c++ interface deprecated
- * Tue Oct 28 2008 Michael E Brown <michael_e_brown at dell.com> - 2.2.0-1
- - Spec updates
- * Mon Apr 21 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2.1
- - obsolete libsmbios-libs as well
- * Mon Mar 3 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2
- - properly obsolete older versions
- * Wed Feb 13 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1
- - Fixup GCC 4.3 compile issues.
- * Wed Jan 9 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.0
- - ABI incompatible, minor API changes
- - sync up libsmbios soname with version #
- - move binaries to /usr/sbin as they are only runnable by root
- - drop libsmbiosxml lib as it was mostly unused.
- - drop autotools generated files out of git and add autogen.sh
- - drop tokenCtl binary-- pysmbios has a *much* improved version
- * Wed Aug 22 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.9
- - Fix a couple of failure-to-check-return on fopen. most were unit-test code
- only, but two or three were in regular code.
- - Add hinting to the memory class, so that it can intelligently close /dev/mem
- file handle when it is not needed (which is most of the time). it only
- leaves it open when it is scanning, so speed is not impacted.
- * Tue Aug 6 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.8
- - new upstream
- * Tue Apr 3 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.6
- - critical bugfix for dellBiosUpdate utility for packet mode
- - autoconf/automake support for automatically building docs
- - more readable 'make' lines by splitting out env vars
- - remove run_cppunit option... always run unit tests.
- - update autoconf/automake utilities to latest version
- - fix LDFLAGS to not overwrite user entered LDFLAGS
- - add automatic doxygen build of docs
- - fix urls of public repos
- - remove yum repo page in favor of official page from docs
- - split dmi table entry point from smbios table entry point
- - support legacy _DMI_ tables
- - fix support for EFI-based imacs without proper _SM_ anchor
- * Tue Mar 20 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.5
- - rpmlint cleanups
- - Add dellLEDCtl binary
- - update AUTHORS file to add credit for dellLEDCtl
- - update doc/DellToken.txt to add a few more useful tokens.
- - updated build system to create documentation
- - skip cppunit dep on .elX builds (not in EPEL yet)
- * Mon Mar 12 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.4-1
- - Added dellWirelessCtl binary
- - Added 'static' makefile target to build static binaries and clean them as well
- - fix for signed/unsigned bug in probes binary. CPU temp misreported
- - simplify interface for DELL_CALLING_INTERFACE_SMI, autodetect Port/Magic
- - document all of the tokens for controlling wireless on dell notebooks
- - enums for SMI args/res to make code match docs better (cbRES1 = res[0], which
- was confusing.
- - helper functions isTokenActive() and activateToken() to simplify token API.
- - Added missing windows .cpp files to the dist tarball for those who compile
- windows from dist tarball vs source control
- - Add support for EFI based machines without backwards compatible smbios table
- entry point in 0xF0000 block.
- - Added wirelessSwitchControl() and wirelessRadioControl() API for newer
- laptops.
- - fixed bug in TokenDA activate() code where it wasnt properly using SMI
- (never worked, but apparently wasnt used until now.)
- * Tue Oct 3 2006 Michael E Brown <Michael_E_Brown@Dell.com> - 0.13.0-1
- - autotools conversion
- - add Changelog
- * Tue Sep 26 2006 Michael E Brown <michael_e_brown at dell.com> - 0.12.4-1
- - Changes per Fedora Packaging Guidelines to prepare to submit to Extras.
- - Add in a changelog entry per Fedora Packaging Guidelines...
|