sudo-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351
  1. Summary: Allows command execution as root for specified users
  2. Summary(ja): スーパーユーザ権限でのコマンドの実行
  3. Name: sudo
  4. Version: 1.8.28
  5. Release: 1%{?_dist_release}
  6. License: ISC-style
  7. Group: Applications/System
  8. URL: http://www.sudo.ws/sudo/
  9. # master is toooooooooooooooo slow.
  10. # Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
  11. Source0: http://core.ring.gr.jp/archives/misc/sudo/sudo-%{version}.tar.gz
  12. Source1: sudo-sudoers-vine
  13. # don't strip
  14. Patch1: sudo-1.6.7p5-strip.patch
  15. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: pam-devel
  17. BuildRequires: groff
  18. BuildRequires: flex
  19. BuildRequires: bison
  20. BuildRequires: openldap-devel
  21. BuildRequires: automake autoconf libtool
  22. BuildRequires: libcap-devel
  23. BuildRequires: zlib-devel
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. Sudo (superuser do) allows a system administrator to give certain users
  28. (or groups of users) the ability to run some (or all) commands as root while
  29. logging all commands and arguments. Sudo operates on a per-command basis,
  30. it is not a replacement for the shell.
  31. %description -l ja
  32. sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
  33. いくつかのコマンド操作を行うことを許可するためのプログラムです。
  34. %prep
  35. %setup -q
  36. %patch1 -p1 -b .strip
  37. rm -rf zlib/
  38. %build
  39. autoreconf -I m4 -fv --install
  40. F_PIE=-fpie
  41. export CFLAGS="$RPM_OPT_FLAGS $F_PIE" LDFLAGS="-pie -Wl,-z,relro -Wl,-z,now"
  42. %configure \
  43. --prefix=%{_prefix} \
  44. --sbindir=%{_sbindir} \
  45. --libdir=%{_libdir} \
  46. --sysconfdir=%{_sysconfdir} \
  47. --docdir=%{_datadir}/doc/%{name}-%{version} \
  48. --with-iologdir=/var/log/sudo-io \
  49. --with-pam \
  50. --with-pam-login \
  51. --with-logging=syslog \
  52. --with-logfac=authpriv \
  53. --with-tty-tickets \
  54. --with-ignore-dot \
  55. --with-editor=/bin/vi \
  56. --with-env-editor \
  57. --with-ldap \
  58. --with-passprompt="[sudo] password for %p: " \
  59. --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
  60. --without-interfaces \
  61. --without-selinux
  62. make %{?_smp_mflags}
  63. %install
  64. rm -rf %{buildroot}
  65. mkdir %{buildroot}
  66. make install DESTDIR="%{buildroot}" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
  67. chmod 755 %{buildroot}%{_bindir}/* %{buildroot}%{_sbindir}/*
  68. install -p -d -m 700 %{buildroot}/var/run/sudo
  69. install -p -d -m 700 %{buildroot}/var/db/sudo/lectured
  70. install -p -d -m 700 %{buildroot}/var/log/sudo-io
  71. install -p -d -m 750 %{buildroot}/etc/sudoers.d
  72. install -p -c -m 0440 %{SOURCE1} %{buildroot}/etc/sudoers
  73. chmod +x %{buildroot}%{_libexecdir}/sudo/*.so # for stripping, reset in %%files
  74. mv -f %{buildroot}%{_docdir}/sudo-%{version} docdir
  75. mv -f %{buildroot}%{_sysconfdir}/sudoers.dist docdir/
  76. rm -f docdir/LICENSE
  77. #Remove all .la files
  78. find %{buildroot} -name '*.la' -exec rm -f {} ';'
  79. %find_lang sudo
  80. %find_lang sudoers
  81. cat sudo.lang sudoers.lang > sudo_all.lang
  82. rm sudo.lang sudoers.lang
  83. mkdir -p %{buildroot}/etc/pam.d
  84. cat > %{buildroot}/etc/pam.d/sudo << EOF
  85. #%PAM-1.0
  86. auth include system-auth
  87. account include system-auth
  88. password include system-auth
  89. session optional pam_keyinit.so revoke
  90. session required pam_limits.so
  91. session include system-auth
  92. EOF
  93. cat > %{buildroot}/etc/pam.d/sudo-i << EOF
  94. #%PAM-1.0
  95. auth include sudo
  96. account include sudo
  97. password include sudo
  98. session optional pam_keyinit.so force revoke
  99. session include sudo
  100. EOF
  101. %clean
  102. rm -rf %{buildroot}
  103. %files -f sudo_all.lang
  104. %defattr(-,root,root)
  105. %license doc/LICENSE
  106. %doc docdir/*
  107. %doc plugins/sample/sample_plugin.c
  108. %attr(0440,root,root) %config(noreplace) /etc/sudoers
  109. %attr(0750,root,root) %dir /etc/sudoers.d/
  110. %config(noreplace) /etc/pam.d/sudo
  111. %config(noreplace) /etc/pam.d/sudo-i
  112. %dir /var/run/sudo
  113. %dir /var/db/sudo
  114. %dir /var/db/sudo/lectured
  115. %attr(0750,root,root) %dir /var/log/sudo-io
  116. %{_bindir}/cvtsudoers
  117. %attr(4111,root,root) %{_bindir}/sudo
  118. %{_bindir}/sudoedit
  119. %attr(0111,root,root) %{_bindir}/sudoreplay
  120. %attr(0755,root,root) %{_sbindir}/visudo
  121. %dir %{_libexecdir}/sudo
  122. %attr(0644,root,root) %{_libexecdir}/sudo/sudo_noexec.so
  123. %attr(0644,root,root) %{_libexecdir}/sudo/sudoers.so
  124. %attr(0644,root,root) %{_libexecdir}/sudo/group_file.so
  125. %attr(0644,root,root) %{_libexecdir}/sudo/system_group.so
  126. %attr(0644,root,root) %{_libexecdir}/sudo/libsudo_util.so.?.?.?
  127. %{_libexecdir}/sudo/libsudo_util.so.?
  128. %{_libexecdir}/sudo/libsudo_util.so
  129. %{_mandir}/man1/cvtsudoers.1*
  130. %{_mandir}/man5/sudoers*.5*
  131. %{_mandir}/man5/sudo.conf.5*
  132. %{_mandir}/man8/sudo.8*
  133. %{_mandir}/man8/sudoedit.8*
  134. %{_mandir}/man8/sudoreplay.8*
  135. %{_mandir}/man8/visudo.8*
  136. # should be splitted to -devel?
  137. %{_includedir}/sudo_plugin.h
  138. %{_mandir}/man8/sudo_plugin.8*
  139. %post
  140. /bin/chmod 0440 /etc/sudoers || :
  141. %changelog
  142. * Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.28-1
  143. - updated to 1.8.28.
  144. - dropped Patch2.
  145. * Sat Jul 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.17p1-1
  146. - updated to 1.8.17p1.
  147. - added Patch2.
  148. - dropped Patch4.
  149. * Mon Feb 3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.6p8-1
  150. - update to 1.8.6p8
  151. * Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-3
  152. - fix permission of sudoreplay
  153. * Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-2
  154. - add /var/log/sudo-io
  155. - add some comments to default sudoers
  156. * Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-1
  157. - update to 1.8.6p7
  158. - drop unneeded patches.
  159. * Sat May 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-5
  160. - add patch120 for fix CVE-2012-2337 (netmask match)
  161. * Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p7-4
  162. - update sudoers
  163. - enable "%wheel ALL=(ALL) ALL" by default.
  164. * Thu Feb 10 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-3
  165. - add patch110,111 for fix CVE-2011-0010 ("-g" option)
  166. * Wed Sep 8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-2
  167. - add Patch100 for fix CVE-2010-2956 (sudo Runas)
  168. - add _smp_mflags flag into make section
  169. - fix doc filelist (no longer exist BUGS, CHANGSE)
  170. * Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
  171. - new upstream release with security fix (CVE-2010-1646)
  172. - change specfile name (-vl)
  173. * Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
  174. - new upstream release with security fix (CVE-2010-1163)
  175. - add sudoers.ldap.5 into files section
  176. * Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
  177. - new upstream release with security fix (CVE-2010-0426)
  178. - update Patch3
  179. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
  180. - new upstream release
  181. * Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
  182. - new upstream release
  183. - update patches
  184. - disable "Defaults requiretty"
  185. * Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
  186. - rebuilt with openldap-2.4.11
  187. * Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
  188. - new upstream release with security fix (CVE 2009-0034)
  189. * Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
  190. - new upstream release
  191. - merge some changes from fedoraproject
  192. - include [sudo] in password prompt
  193. - compiled with secure path
  194. - also use getgrouplist() to determine group membership
  195. - add sudoers file
  196. - add command aliases, default environment config
  197. - build with openldap
  198. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
  199. - applied new versioning policy, spec in utf-8
  200. * Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
  201. - change PAM configuration to use system-auth
  202. - add --with-ignore-dot, --with-editor and --with-env-editor to
  203. configure option.
  204. * Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
  205. - new upstream release (included security fix)
  206. - add patch1 for fix CVE-2006-0151
  207. * Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
  208. - new upstream release
  209. - use macros
  210. - build with pam
  211. * Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
  212. - new upstream release
  213. * Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
  214. - SECURITY FIX: new upstream release
  215. - update rpmnonroot.patch ( Patch0 )
  216. - add new man page: sudoedit(8)
  217. * Wed Sep 1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
  218. - new upstream release
  219. - update rpmnonroot.patch ( Patch0 )
  220. - change Copyrigh tag to License tag
  221. - update License
  222. - update URL and Source0: official web site moved.
  223. - new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
  224. * Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
  225. - upstream release
  226. * Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
  227. - fixed changelog
  228. -- don't expand macros in changelog ;P
  229. * Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
  230. - changed to use configure in build section
  231. (can't build on sparc)
  232. * Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
  233. - upstream release
  234. - fix security hole : buffer over flow
  235. * Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
  236. - upstream release
  237. - updated sudo.rpmnonroot.diff
  238. * Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
  239. - upstream release
  240. - added configure script option '--disable-root-mailer'
  241. * Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
  242. - upstream release
  243. - eliminated FAQ from %doc
  244. * Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
  245. - upstream release
  246. - added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
  247. - updated sudo.rpmnonroot.diff
  248. * Wed May 09 2001 <sagami@vinelinux.org>
  249. - 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
  250. * Fri Mar 02 2001 sagami@vinelinux.org
  251. - 1.6.3p7-0vl1
  252. - use better macros
  253. * Thu Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
  254. - 1.6.3p6-0vl1
  255. - changed sudo.rpmnonroot.diff for 1.6.3p6
  256. * Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  257. - 1.6.1-2vl5
  258. - patch -p1 -> patch -p0
  259. * Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
  260. - 1.6.1-2vl4
  261. - fix uid/gid to root.root
  262. - add sudo.rpmnonroot.diff to built by non-root users
  263. * Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
  264. - 1.6.1-2vl3
  265. - fix attr
  266. * Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
  267. - 1.6.1-2vl2
  268. - enable to build by non-root useres
  269. * Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  270. - 1.6.1-2vl1
  271. - modified %files section to handle compressed man page(s)
  272. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  273. - change group
  274. * Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
  275. - version 1.6.1
  276. - build for Vine Linux 2.0
  277. * Fri May 14 1999 Takeda Eiji <keda@flatout.org>
  278. - sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
  279. * Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
  280. - Initial Release