tix-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294
  1. %{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
  2. %{!?tcl_sitearch: %global tcl_sitearch %{_libdir}/tcl%{tcl_version}}
  3. %{!?tcl_sitelib: %global tcl_sitelib %{_datadir}/tcl%{tcl_version}}
  4. %define tcl_major 8.6
  5. %define tk_major 8.6
  6. %define thread_major 2.8
  7. %define tix_major 8.4
  8. %define tixversion %{tix_major}.3
  9. ## can't find all provides
  10. #define _use_internal_dependency_generator 0
  11. Summary: A Tcl/Tk development environment: tix
  12. Summary(ja): Tcl/Tk 開発環境: tix
  13. Name: tix
  14. Version: %{tixversion}
  15. Release: 5%{?_dist_release}
  16. Group: Development/Languages
  17. License: BSD
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. URL: http://tix.sourceforge.net/
  21. Source0: Tix%{tixversion}-src.tar.gz
  22. # 0: Fixes BZ#81297 (soname of libraries)
  23. Patch0: tix-8.4.2-link.patch
  24. Patch1: tix-8.4.3-tcl86.patch
  25. Patch2: tix-8.4.3-covscan-fixes.patch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: tcl-devel >= %{tcl_major}
  28. BuildRequires: tk-devel >= %{tk_major}
  29. BuildRequires: tcl-thread
  30. BuildRequires: libX11-devel
  31. Requires: tcl >= %{tcl_major}
  32. Requires: tk >= %{tk_major}
  33. Requires: tcl-thread
  34. %description
  35. Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
  36. extensive set of over 40 widgets. In general, Tix widgets are more
  37. complex and more capable than the widgets provided in Tk. Tix widgets
  38. include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
  39. FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
  40. directory tree and a file manager.
  41. Install the tix package if you want to try out more complicated widgets
  42. for Tk. You'll also need to have the tcl and tk packages installed.
  43. %description -l ja
  44. Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
  45. は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
  46. Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
  47. コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
  48. ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
  49. ディレクトリツリー、ファイルマネージャを含んでいます。
  50. Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
  51. してください。tcl と tk のパッケージもインストールする必要があります。
  52. %prep
  53. %setup -q -n Tix%{tixversion}
  54. %patch0 -p1 -b .link
  55. %patch1 -p1 -b .tcl86
  56. %patch2 -p1 -b .covscan-fixes
  57. # Remove executable permission of images in html documentation
  58. chmod ugo-x docs/html/gif/tix/*.png docs/html/gif/tix/*.gif \
  59. docs/html/gif/tix/*/*.gif
  60. # Fix end-of-line encoding
  61. sed -i 's/\r//' docs/Release-8.4.0.txt
  62. %build
  63. # make the libraries reentrant
  64. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
  65. %configure \
  66. --libdir=%{tcl_sitearch} \
  67. --with-tcl=%{_libdir} \
  68. --with-tk=%{_libdir} \
  69. --enable-shared \
  70. --disable-threads \
  71. ;
  72. make %{?_smp_mflags} all PKG_LIB_FILE=libTix.so
  73. %install
  74. rm -rf ${RPM_BUILD_ROOT}
  75. make install DESTDIR=$RPM_BUILD_ROOT PKG_LIB_FILE=libTix.so
  76. # move shared lib to tcl sitearch
  77. mv $RPM_BUILD_ROOT%{tcl_sitearch}/Tix%{version}/libTix.so \
  78. $RPM_BUILD_ROOT%{tcl_sitearch}/
  79. # make links
  80. ln -sf ../libTix.so \
  81. $RPM_BUILD_ROOT%{tcl_sitearch}/Tix%{version}/libTix.so
  82. ln -sf tcl%{tcl_version}/Tix%{version}/libTix.so $RPM_BUILD_ROOT%{_libdir}/libTix.so
  83. ln -sf tcl%{tcl_version}/Tix%{version}/libTix.so $RPM_BUILD_ROOT%{_libdir}/libtix.so
  84. install -d $RPM_BUILD_ROOT%{_mandir}/man1
  85. install -d $RPM_BUILD_ROOT%{_mandir}/mann
  86. install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
  87. install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
  88. install -d $RPM_BUILD_ROOT%{_includedir}
  89. install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
  90. ## others
  91. SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
  92. install -d $SHAREDDIR/demos/bitmaps
  93. install -d $SHAREDDIR/demos/samples
  94. install -m 755 demos/widget $SHAREDDIR/demos
  95. install -m 644 demos/{*.tcl,tclIndex} $SHAREDDIR/demos
  96. install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
  97. install -m 644 demos/samples/* $SHAREDDIR/demos/samples
  98. cp -a tests $SHAREDDIR
  99. %post -p /sbin/ldconfig
  100. %postun -p /sbin/ldconfig
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %files
  104. %defattr(-,root,root,-)
  105. %{tcl_sitearch}/libTix.so
  106. %{tcl_sitearch}/Tix%{version}
  107. %{_datadir}/tix-%{tixversion}
  108. %{_mandir}/man1/tixwish.1.gz
  109. %{_libdir}/libtix.so
  110. %{_libdir}/libTix.so
  111. %{_includedir}/*.h
  112. %{_mandir}/mann/*.n.gz
  113. %doc ChangeLog README.txt man/html man/index.html
  114. %changelog
  115. * Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.3-5
  116. - moved .so to fix warnings of ldconfig.
  117. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.3-4
  118. - rebuilt with tcl/tk-8.6.9.
  119. - dropped all patches.
  120. - imported Patch0-2 from rawhide.
  121. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.4.3-3
  122. - rebuilt with tcl/tk 8.5.15 and thread 2.7.1
  123. * Thu Feb 24 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-2
  124. - added BR: libX11-devel
  125. * Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
  126. - updated tix to 8.4.3
  127. - dropt tix-8.1.4-perf.patch
  128. - dropt tix-8.2.0b1-dirtree.patch
  129. - added "cp -p libTix8.4.3.so libtix8.4.so"
  130. - rebuilt with file-5.05-2
  131. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
  132. - rebuilt with tcl/tk-8.4.19-2
  133. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
  134. - applied new versioning policy
  135. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
  136. - rebuild with tcl/tk-8.4.18
  137. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
  138. - rebuild with tcl/tk-8.4.16
  139. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
  140. - updated tix to 8.4.2
  141. - rebuilt with new toolchain
  142. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
  143. - rebuild for tcl/tk-8.4.12, and x86_64 architecture support
  144. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
  145. - changed url to http://tix.sourceforge.net/download.shtml
  146. - rebuild for tcl/tk-8.4.11
  147. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
  148. - rebuild for tcl/tk-8.4.6
  149. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
  150. - rebuild for tcl/tk-8.4.5
  151. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
  152. - update based on BitWalk's tcltk-8.4.2-83bw
  153. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  154. - splite source package
  155. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  156. - expand some macros.. (FIXME)
  157. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  158. - use %configure macros
  159. - add Patch 47,50
  160. * Thu May 31 2001 <sagami@vinelinux.org>
  161. - 8.0.5_jp-10
  162. - unexpand old %%{configure}, new one causes build failure
  163. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  164. - install manpages into %%{_mandir} and mode 644
  165. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  166. - 8.0.5_jp-9
  167. - modified %install section to handle compressed man pages
  168. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  169. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  170. - changed default fonts
  171. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  172. - added defattr
  173. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  174. - added some symlinks, such as libtcl8.0.so.
  175. - obsoletes version number using _jp, now 8.0.5-31vl1
  176. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  177. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  178. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  179. - fix tclX symlinks.
  180. - compile on systems where SIGPWR == SIGLOST.
  181. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  182. - update tcl/tk to 8.0.5.
  183. - avoid "containing" in Tix (#2332).
  184. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  185. - use /usr/bin/write in kibitz (#1320).
  186. - use cirrus.sprl.umich.edu in weather (#1926).
  187. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  188. - auto rebuild in the new build environment (release 28)
  189. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  190. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  191. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  192. - expect does unaligned access on alpha (#989)
  193. - upgrade tcl/tk/tclX to 8.0.4
  194. - upgrade expect to 5.28.
  195. - add itcl 3.0.1
  196. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  197. - call libtoolize to allow building on the arm
  198. - build for glibc 2.1
  199. - strip binaries
  200. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  201. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  202. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  203. - expect: mkpasswd needs delay before sending password (problem #576)
  204. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  205. - translations modified for de, fr, tr
  206. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  207. - fixed expect binaries exec permissions
  208. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  209. - updated to Tix 4.1.0.006
  210. - updated version numbers of tcl/tk to relflect includsion of p2
  211. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  212. - updated tcl/tk to patch level 2
  213. - updated tclX to 8.0.2
  214. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  215. - fixed filelist for tix... replacing path to the expect binary in scripts
  216. was leaving junk files around.
  217. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  218. - added patch to remove libieee test in configure.in for tcl and tk.
  219. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  220. solution for all systems
  221. - fixed src urls
  222. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  223. - removed version numbers from descriptions
  224. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  225. - updated to tcl/tk 8.0 and related versions of packages
  226. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  227. - built against glibc
  228. - fixed dangling tclx/tkx symlinks