medit-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199
  1. %define name medit
  2. %define version 1.0.5
  3. Name: %{name}
  4. Version: %{version}
  5. Release: 2%{?_dist_release}
  6. Summary: Multiplatform GTK+2 text editor
  7. Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
  8. Group: Applications/Editors
  9. License: GPLv2+
  10. URL: http://mooedit.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
  12. Source1: medit_ja.po
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Buildrequires: cairo-devel
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: gettext
  17. BuildRequires: gtk2-devel glib2-devel
  18. BuildRequires: intltool
  19. BuildRequires: libxml2-devel
  20. BuildRequires: libX11-devel libXext-devel libICE-devel
  21. BuildRequires: libSM-devel
  22. Buildrequires: perl-XML-Parser pango-devel
  23. BuildRequires: pcre-devel
  24. BuildRequires: python-devel
  25. BuildRequires: pygtk2-devel
  26. %description
  27. Medit is a multiplatform GTK+2 text editor.
  28. Features:
  29. * Configurable syntax highlighting.
  30. * Configurable keyboard accelerators.
  31. * Multiplatform - works both on unix and windows.
  32. * Plugins: can be written in C or Python.
  33. * Configurable tools available from the main and context menus.
  34. They can be written in Python or Lua, or it can be a shell script.
  35. * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
  36. %description -l ja
  37. Medit はマルチプラットフォームな GTK+2 テキストエディタです。
  38. 機能一覧:
  39. * 設定可能な構文強調機能。
  40. * 設定可能なキーボードアクセラレータ。
  41. * マルチプラットフォーム - unix と windows の両者で動作。
  42. * プラグイン: C あるいは Python で作成可能。
  43. * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
  44. Python あるいは lua 、シェルスクリプトで作成可能。
  45. * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
  46. %prep
  47. %setup -q
  48. sed -i 's|fr|fr\nja|g' po/LINGUAS
  49. %__cp -f %{SOURCE1} po/ja.po
  50. %build
  51. %configure
  52. make %{?_smp_mflags}
  53. %install
  54. rm -rf %{buildroot}
  55. make install DESTDIR=$RPM_BUILD_ROOT
  56. desktop-file-install --vendor="" \
  57. --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
  58. --mode 0644 \
  59. $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
  60. %post
  61. update-desktop-database %{_datadir}/applications
  62. touch --no-create %{_datadir}/icons/hicolor
  63. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  64. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  65. fi
  66. %postun
  67. update-desktop-database %{_datadir}/applications
  68. touch --no-create %{_datadir}/icons/hicolor
  69. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  70. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  71. fi
  72. %clean
  73. rm -rf %{buildroot}
  74. %files
  75. %defattr(-,root,root)
  76. %doc COPYING README
  77. %{_bindir}/*
  78. %{_datadir}/applications/%{name}.desktop
  79. %{_datadir}/%{name}-1/*
  80. %{_datadir}/icons/hicolor/48x48/
  81. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  82. %{_datadir}/locale/*
  83. %{_docdir}/%{name}-1/*
  84. %{_mandir}/man?/
  85. %changelog
  86. * Tue Feb 21 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-2
  87. - rebuilt with python-2.7
  88. * Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-1
  89. - new upstream release
  90. * Sun Sep 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-1
  91. - new upstream release
  92. * Sat Apr 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.3-1
  93. - new upstream release
  94. * Mon Feb 28 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1-1
  95. - new upstream release
  96. * Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.0-1
  97. - new upstream release
  98. - updated Source1
  99. - dropt BuildRequires: cmake
  100. - added BuildRequires: libSM-devel
  101. - fixed %%files
  102. * Sun Oct 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-2
  103. - updated Source1
  104. * Fri Oct 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-1
  105. - new upstream release
  106. - cleaned up spec
  107. * Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
  108. - updated Source1
  109. - added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
  110. - changed BuildRequires: cmake >= 2.6
  111. * Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
  112. - new upstream release
  113. - added Japanese language file
  114. - added man directory in %files
  115. * Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  116. - new upstream release
  117. - applied new naming policy to spec
  118. * Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
  119. - initial build for VineSeed
  120. * Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
  121. + Revision: 155675
  122. - New version 0.9.2
  123. - rediff patch0
  124. + Olivier Blin <oblin@mandriva.com>
  125. - restore BuildRoot
  126. + Thierry Vignaud <tvignaud@mandriva.com>
  127. - kill re-definition of %%buildroot on Pixel's request
  128. * Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
  129. + Revision: 114221
  130. - New version 0.9.0
  131. * Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
  132. + Revision: 109208
  133. - New release 0.8.11
  134. * Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
  135. + Revision: 59667
  136. - New version 0.8.10
  137. * Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
  138. + Revision: 57568
  139. - New version 0.8.9
  140. * Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
  141. + Revision: 51500
  142. - Fix file list
  143. - New version
  144. * Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
  145. + Revision: 39539
  146. - SILent renew tarball
  147. - New version
  148. - New version
  149. add dirty patch that skips update-icon-cache and mime database when building
  150. + Jérôme Soyer <saispo@mandriva.org>
  151. - Import medit
  152. * Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
  153. - new release
  154. * Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
  155. - first spec for Mandriva