python-simplejson-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180
  1. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %global _use_internal_dependency_generator 0
  3. %global __find_provides /bin/sh -c "%{_rpmconfigdir}/find-provides | grep -v -E '(_speedups.so)' || /bin/true"
  4. %global __find_requires /bin/sh -c "%{_rpmconfigdir}/find-requires | grep -v -E '(_speedups.so)' || /bin/true"
  5. Name: python-simplejson
  6. Version: 2.1.2
  7. Release: 1%{?_dist_release}
  8. Summary: Simple, fast, extensible JSON encoder/decoder for Python
  9. Group: System Environment/Libraries
  10. # The main code is licensed MIT.
  11. # The docs include jquery which is licensed MIT or GPLv2
  12. License: MIT and (MIT or GPLv2)
  13. URL: http://undefined.org/python/#simplejson
  14. Source0: http://pypi.python.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: python-devel
  17. BuildRequires: python-setuptools
  18. BuildRequires: python-nose
  19. %description
  20. simplejson is a simple, fast, complete, correct and extensible JSON
  21. <http://json.org> encoder and decoder for Python 2.5+. It is pure Python code
  22. with no dependencies, but includes an optional C extension for a serious speed
  23. boost.
  24. simplejson is the externally maintained development version of the json library
  25. included with Python 2.6 and Python 3.0, but maintains backwards compatibility
  26. with Python 2.5.
  27. The encoder may be subclassed to provide serialization in any kind of
  28. situation, without any special support by the objects to be serialized
  29. (somewhat like pickle).
  30. The decoder can handle incoming JSON strings of any specified encoding (UTF-8
  31. by default).
  32. %prep
  33. %setup -q -n simplejson-%{version}
  34. %build
  35. %{__python} setup.py build
  36. %install
  37. %__rm -rf $RPM_BUILD_ROOT
  38. %{__python} setup.py install --skip-build --root=$RPM_BUILD_ROOT
  39. %check
  40. nosetests -q
  41. %clean
  42. %__rm -rf $RPM_BUILD_ROOT
  43. %files
  44. %defattr(-,root,root,-)
  45. %doc docs LICENSE.txt
  46. %dir %{python_sitearch}/simplejson
  47. %{python_sitearch}/simplejson-*.egg-info
  48. %{python_sitearch}/simplejson/*.py*
  49. %{python_sitearch}/simplejson/tests/*.py*
  50. %{python_sitearch}/simplejson/_speedups.so
  51. %changelog
  52. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> - 2.1.2-1
  53. - updated simplejson to 2.1.2
  54. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 2.1.1-1
  55. - initial build based on Fedora development
  56. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.1-3
  57. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  58. * Wed Jun 30 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 2.1.1-2
  59. - Filter unnecessary provides
  60. - License tag update
  61. - Minor spec file cleanups
  62. * Mon Jun 21 2010 Kyle VanderBeek <kylev@kylev.com> - 2.1.1-1
  63. - Update to 2.1.1
  64. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.9-3
  65. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  66. * Fri Jun 5 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-2
  67. - Remove ill-advised gcc BuildRequires
  68. * Thu Jun 4 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-1
  69. - Update to 2.0.9
  70. - Make sure to require gcc to the speedups get compiled
  71. - Fix description since we're not "pure" python
  72. - Change to pypi instead of cheesehop
  73. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.7-2
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  75. * Tue Jan 06 2009 Luke Macken <lmacken@redhat.com> 2.0.7-1
  76. - Update to 2.0.7
  77. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.3-3
  78. - Rebuild for Python 2.6
  79. * Thu Oct 23 2008 Luke Macken <lmacken@redhat.com> 2.0.3-2
  80. - Use nose to run the simplejson test suite
  81. * Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-1
  82. - update to 2.0.3
  83. * Wed Oct 01 2008 Luke Macken <lmacken@redhat.com> - 2.0.1-1
  84. - Update to 2.0.1, which contains many optimizations and bugfixes
  85. * Wed Sep 24 2008 Luke Macken <lmacken@redhat.com> - 1.9.3-1
  86. - Update to 1.9.3, which includes a significant decoding speed boost, and
  87. various bug fixes.
  88. * Tue May 06 2008 Luke Macken <lmacken@redhat.com> - 1.9.1-1
  89. - Update to 1.9.1
  90. * Wed Apr 02 2008 Luke Macken <lmacken@redhat.com> - 1.8.1-1
  91. - Update to 1.8.1
  92. * Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 1.7.4-1
  93. - Update to 1.7.4
  94. * Fri Feb 8 2008 Luke Macken <lmacken@redhat.com> - 1.7.3-3
  95. - Rebuild for gcc 4.3
  96. * Wed Oct 24 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-2
  97. - Include the LICENSE.txt
  98. * Wed Oct 3 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-1
  99. - 1.7.3
  100. * Sun Sep 2 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-3
  101. - Update for python-setuptools changes in rawhide
  102. * Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-2
  103. - Rebuild
  104. * Sun Jul 8 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-1
  105. - 1.7.1
  106. * Wed Mar 21 2007 Luke Macken <lmacken@redhat.com> - 1.7-2
  107. - Use python_sitearch instead of sitelib
  108. * Tue Mar 20 2007 Luke Macken <lmacken@redhat.com> - 1.7-1
  109. - 1.7 (Bug #233212)
  110. * Sat Mar 3 2007 Luke Macken <lmacken@redhat.com> - 1.5
  111. - 1.5
  112. * Sat Dec 9 2006 Luke Macken <lmacken@redhat.com> - 1.4-4
  113. - Add python-devel to BuildRequires
  114. * Sat Dec 9 2006 Luke Macken <lmacken@redhat.com> - 1.4-2
  115. - Rebuild for new python
  116. * Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 1.4-1
  117. - 1.4
  118. * Sun Sep 3 2006 Luke Macken <lmacken@redhat.com> - 1.3-4
  119. - Rebuild for FC6
  120. * Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 1.3-3
  121. - Include .pyo's instead of just ghosting them
  122. * Wed Jul 12 2006 Luke Macken <lmacken@redhat.com> - 1.3-2
  123. - Add --single-version-externally-managed flag to install
  124. * Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 1.3-1
  125. - Initial package