gd-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A graphics library for drawing .png files.
  3. Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
  4. Name: gd
  5. Version: 2.1.0
  6. Release: 1%{_dist_release}
  7. Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
  8. Patch0: gd-2.1.0-multilib.patch
  9. Patch1: gd-2.1.0-fonts-vine.patch
  10. License: BSD-style
  11. URL: http://www.libgd.org/
  12. Group: System Environment/Libraries
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: libjpeg-devel zlib-devel freetype2-devel
  15. BuildRequires: libpng-devel >= 2:1.2.5
  16. BuildRequires: libX11-devel libXpm-devel
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: daisuke
  20. %description
  21. Gd is a graphics library for drawing .png files. Gd allows your code to
  22. quickly draw images (lines, arcs, text, multiple colors, cutting and
  23. pasting from other images, flood fills) and write out the result as a
  24. .png file. Gd is particularly useful in web applications, where .pngs
  25. are commonly used as inline images. Note, however, that gd is not a
  26. paint program.
  27. Install gd if you are developing applications which need to draw .png
  28. files. If you install gd, you'll also need to install the gd-devel
  29. package.
  30. %description -l ja
  31. GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
  32. 画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
  33. 簡単に描写して、PNGファイルへ結果を出力することができます。
  34. Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
  35. 便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
  36. ん。
  37. PNGファイルを描写する必要のあるアプリケーションを開発する場合、
  38. Gdをインストールしてください。gdをインストールした場合、gd-devel
  39. パッケージも必要になります。
  40. %package progs
  41. Summary: Utility programs that use libgd.
  42. Summary(ja): libgd を用いたユーティリティプログラム
  43. Group: Applications/Graphics
  44. Requires: gd = %{version}, perl
  45. %description progs
  46. These are utility programs supplied with gd, the .png graphics library.
  47. If you install these, you must install gd.
  48. %description progs -l ja
  49. これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
  50. プログラムです。これをインストールするには, gdをインストールする必要
  51. があります。
  52. %package devel
  53. Requires: gd = %{version}
  54. Summary: The development libraries and header files for gd.
  55. Summary(ja): gd用の開発ライブラリとヘッダファイル
  56. Group: Development/Libraries
  57. %description devel
  58. These are the development libraries and header files for gd, the .png
  59. graphics library.
  60. If you're installing the gd graphics library, you must install gd-devel.
  61. %description devel -l ja
  62. これらは開発ライブラリです。
  63. PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
  64. です。
  65. gdをインストールした場合、gd-develパッケージも必要になります。
  66. ## to build compat32 for x86_64 architecture support
  67. %package -n compat32-%{name}
  68. Summary: A graphics library for drawing .png files.
  69. Group: System Environment/Libraries
  70. %description -n compat32-%{name}
  71. Gd is a graphics library for drawing .png files. Gd allows your code to
  72. quickly draw images (lines, arcs, text, multiple colors, cutting and
  73. pasting from other images, flood fills) and write out the result as a
  74. .png file. Gd is particularly useful in web applications, where .pngs
  75. are commonly used as inline images. Note, however, that gd is not a
  76. paint program.
  77. Install gd if you are developing applications which need to draw .png
  78. files. If you install gd, you'll also need to install the gd-devel
  79. package.
  80. %package -n compat32-%{name}-devel
  81. Summary: The development libraries and header files for gd.
  82. Group: Development/Libraries
  83. %description -n compat32-%{name}-devel
  84. These are the development libraries and header files for gd, the .png
  85. graphics library.
  86. If you're installing the gd graphics library, you must install gd-devel.
  87. %prep
  88. %setup -q -n libgd-%{version}
  89. %patch0 -p1 -b .mlib
  90. %patch1 -p1 -b .fonts-vine
  91. %build
  92. %configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H"
  93. make %{?_smp_mflags}
  94. %install
  95. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  96. make DESTDIR=$RPM_BUILD_ROOT install
  97. ## remove unuse files
  98. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  99. %clean
  100. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  101. %post -p /sbin/ldconfig
  102. %postun -p /sbin/ldconfig
  103. %if %{build_compat32}
  104. %post -n compat32-%{name} -p /sbin/ldconfig
  105. %postun -n compat32-%{name} -p /sbin/ldconfig
  106. %endif
  107. %files
  108. %defattr(-,root,root)
  109. %doc ChangeLog COPYING NEWS docs/*
  110. %{_libdir}/*.so.*
  111. %files progs
  112. %defattr(-,root,root)
  113. %{_bindir}/*
  114. %exclude %{_bindir}/gdlib-config
  115. %files devel
  116. %defattr(-,root,root)
  117. %{_bindir}/gdlib-config
  118. %{_includedir}/*
  119. %{_libdir}/*.so
  120. %{_libdir}/pkgconfig/*.pc
  121. %if %{build_compat32}
  122. %files -n compat32-%{name}
  123. %defattr(-,root,root)
  124. %{_libdir}/*.so.*
  125. %files -n compat32-%{name}-devel
  126. %defattr(-,root,root)
  127. %{_libdir}/*.so
  128. %endif
  129. %changelog
  130. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
  131. - new upstream release.
  132. - dropped unnecessary patches.
  133. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
  134. - import patches from fedora package
  135. - modified font path patch for Vine Linux
  136. - drop static library
  137. - remove "-DJISX0208"
  138. - add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
  139. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
  140. - move gdlib-config from gd-progs subpackage to gd-devel subpackage
  141. * Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
  142. - build on current VineSeed
  143. * Tue Nov 3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
  144. - fix build_compat32 if-endif sections
  145. * Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
  146. - add patch2 for fix CVE-2009-3546 (_gdGetColors())
  147. * Wed Apr 8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
  148. - updated URL
  149. - changed progs Group to Applications/Graphics
  150. - added %%postun section
  151. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
  152. - removed *.la
  153. - spec in utf-8
  154. * Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
  155. - add patch1 from centos5
  156. - new versioning policy
  157. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
  158. - new upstream release with security fix (CVE-2007-2756)
  159. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
  160. - new upstream release with security fix
  161. - change source tarball format gz -> bz2
  162. * Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
  163. - added compat32-* packages for x86_64 architecture support
  164. * Sat Nov 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
  165. - source upgrade
  166. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
  167. - source update
  168. - added -DJISX0208 flag
  169. * Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
  170. - source upgrade
  171. - BuildPrereq: XOrg-devel instead of XFree86-devel
  172. * Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
  173. - source upgrade
  174. - remove patch0 (no need for freetype2-2.1.7)
  175. * Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
  176. - add patch0 to build against freetype2-2.1.7
  177. * Sat Jun 7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
  178. - source upgrade
  179. - add URL
  180. - remove all patches
  181. - use %%configure script
  182. - add BuildPrereq: freetype2-devel XFree86-devel
  183. - remove BuildPrereq: VFlib-devel
  184. - update %%files
  185. - update Requires:
  186. - use License tag instead of Copyright
  187. * Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
  188. - rebuild with libpng-devel-1.2.5-0vl1
  189. * Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
  190. - rebuild with new toolchain
  191. * Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  192. - 1.8.3-0vl2
  193. - symlink to libgd.so.1 (for backward compatibility)
  194. * Tue Jun 6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  195. - first gd 1.8.x release for Vine from rawhide.
  196. - enable freetype support and defined JISX208 macro.
  197. * Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  198. - break out a -progs subpackage
  199. - disable freetype support
  200. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  201. - update to latest version (1.8.2)
  202. - disable xpm support
  203. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  204. - auto rebuild in the new build environment (release 6)
  205. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  206. - auto rebuild in the new build environment (release 5)
  207. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  208. - buiuld for glibc 2.1
  209. * Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
  210. - built for 5.2