libgnomeuimm-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. Summary: A C++ interface for libgnomeui
  2. Name: libgnomeuimm
  3. Version: 2.28.0
  4. Release: 2%{?_dist_release}
  5. License: LGPL
  6. Group: System Environment/Libraries
  7. Source: ftp://download.sourceforge.net/gtkmm/%{name}-%{version}.tar.bz2
  8. URL: http://gtkmm.sourceforge.net/
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: libgnomeui-devel >= 2.7.1
  11. BuildRequires: libgnomemm-devel >= 2.16.0
  12. BuildRequires: libgnomecanvasmm-devel >= 2.6.0
  13. BuildRequires: gconfmm-devel >= 2.6.0
  14. BuildRequires: libglademm2-devel >= 2.4.0
  15. BuildRequires: gnome-vfsmm-devel >= 2.16.0
  16. BuildRequires: libSM-devel
  17. %description
  18. This package provides a C++ interface for GnomeUI. It is a subpackage
  19. of the Gtk-- project. The interface provides a convenient interface for C++
  20. programmers to create Gnome GUIs with GTK+'s flexible object-oriented
  21. framework.
  22. %package devel
  23. Summary: Headers for developing programs that will use libgnomeuimm.
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}
  26. Requires: libgnomeui-devel >= 2.7.1
  27. Requires: libgnomemm-devel >= 2.16.0
  28. Requires: libgnomecanvasmm-devel >= 2.6.0
  29. Requires: gconfmm-devel >= 2.6.0
  30. Requires: libglademm2-devel >= 2.4.0
  31. Requires: gnome-vfsmm-devel >= 2.16.0
  32. %description devel
  33. This package contains the headers that programmers will need to develop
  34. applications which will use Gnome--, part of Gtk-- the C++ interface to
  35. the GTK+ (the Gimp ToolKit) GUI library.
  36. %prep
  37. %setup -q
  38. %build
  39. # ...hope this can be removed soon
  40. %ifarch alpha
  41. ARCH_FLAGS="--host=alpha-linux-gnu"
  42. %endif
  43. export CXXFLAGS="$RPM_OPT_FLAGS -shared -fPIC"
  44. %configure --enable-shared --disable-static --enable-docs
  45. make %{?_smp_mflags}
  46. if [ "$SMP" != "" ]; then
  47. make -j$SMP "MAKE=make -j$SMP"
  48. make
  49. else
  50. make
  51. fi
  52. %install
  53. if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
  54. %makeinstall
  55. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  56. %post -p /sbin/ldconfig
  57. %postun -p /sbin/ldconfig
  58. %clean
  59. if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
  60. %files
  61. %defattr(-, root, root)
  62. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
  63. %{_libdir}/*.so.*
  64. %files devel
  65. %defattr(-, root, root)
  66. %{_includedir}/libgnomeuimm-2.6
  67. #{_libdir}/*.la
  68. #{prefix}/lib/*.a # uncomment this one for static libs
  69. %{_libdir}/*.so
  70. %{_libdir}/libgnomeuimm-2.6
  71. %{_libdir}/pkgconfig/*.pc
  72. %changelog
  73. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.0-2
  74. - build with rpm-4.8.1-1 for pkg-config file
  75. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  76. - new upstream release
  77. - add BuildRequires: libSM-devel
  78. * Sat Oct 4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1vl5
  79. - new upstream release
  80. * Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.0-1vl5
  81. - applied new versioning policy
  82. * Sat Jun 2 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.18.0-0vl4
  83. - build all object files with -fPIC so that sharlib is PIC
  84. * Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
  85. - rebuilt without libstdc++2_10
  86. * Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
  87. - rebuilt with new toolchain
  88. - added -shared option to CXXFLAGS
  89. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl1
  90. - new upstream release
  91. * Sat Nov 4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1vl1
  92. - initial build for Vine Linux
  93. * Sun Dec 21 2003 Eric Bourque <ericb@computer.org>
  94. - fixed dependency to gtkmm2 instead of gtkmm
  95. * Thu Sep 25 2003 Eric Bourque <ericb@computer.org>
  96. - updated for libgnomeuimm-2.0
  97. * Tue Mar 20 2001 Eric Bourque <ericb@computer.org>
  98. - added gnome--.m4 to files devel section
  99. * Sat Mar 10 2001 Herbert Valerio Riedel <hvr@gnu.org>
  100. - improved examples.conf
  101. - fixed example build problems
  102. * Thu May 11 2000 Herbert Valerio Riedel <hvr@gnu.org>
  103. - removed lib/gtkmm from files section
  104. - removed empty obsolete tags
  105. * Sun Jan 30 2000 Karl Einar Nelson <kenelson@sourceforge.net>
  106. - adapted from gtk--.spec