nginx-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.4.1
  26. Release: 2%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 20130213
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
  48. %define nginx_accept_language_module_version 02262ce
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. %define passenger_version 3.0.19
  51. Source1020: passenger-%{passenger_version}.tar.gz
  52. %define upstream_fair_version 2131c73
  53. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  54. %define mod_wsgi_version 6975f0ec7eeb
  55. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  56. # removes -Werror in upstream build scripts. -Werror conflicts with
  57. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  58. Patch0: nginx-auto-cc-gcc.patch
  59. # configuration patch to match all the Vine Linux paths for logs, pid files
  60. # etc.
  61. Patch1: nginx-conf.patch
  62. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  63. BuildRequires: pcre-devel
  64. BuildRequires: zlib-devel
  65. BuildRequires: openssl-devel
  66. BuildRequires: gd-devel
  67. BuildRequires: perl
  68. BuildRequires: perl(ExtUtils::Embed)
  69. BuildRequires: libxml2-devel
  70. BuildRequires: libxslt-devel
  71. BuildRequires: curl-devel
  72. %if %{with geoip}
  73. BuildRequires: GeoIP-devel
  74. %endif
  75. %if "%{?_dist_release}" == "vl4"
  76. Requires: perl >= 5.8.6
  77. %else
  78. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  79. %endif
  80. # for /usr/sbin/useradd
  81. Requires(pre): shadow-utils
  82. Requires(post): chkconfig
  83. # for /sbin/service
  84. Requires(preun): chkconfig, initscripts
  85. Requires(postun): initscripts
  86. %if "%{_dist_release}" > "vl6"
  87. Requires(pre): www-common
  88. %endif
  89. Provides: webserver
  90. Vendor: Project Vine
  91. Distribution: Vine Linux
  92. Packager: daisuke
  93. %description
  94. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  95. proxy server written by Igor Sysoev.
  96. %description -l ja
  97. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  98. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  99. - HTTP(S) サーバ
  100. - HTTP(S) リバースプロキシサーバ
  101. - IMAP/POP3 プロキシサーバ
  102. %package passenger
  103. Summary: Nginx with mod_passenger support
  104. Summary(ja): Passenger サポート入りの Nginx
  105. Group: System Environment/Daemons
  106. BuildRequires: ruby, rubygem-rake
  107. Requires: ruby, rubygem-rake
  108. %if "%{_dist_release}" >= "vl7"
  109. BuildRequires: ruby-devel, ruby-rubygems
  110. Requires: ruby-rubygems
  111. %else
  112. BuildRequires: rubygems
  113. Requires: rubygems
  114. %endif
  115. Requires: nginx
  116. %description passenger
  117. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  118. This package contains nginx server with passenger support.
  119. %description -l ja passenger
  120. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  121. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  122. - HTTP(S) サーバ
  123. - HTTP(S) リバースプロキシサーバ
  124. - IMAP/POP3 プロキシサーバ
  125. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  126. %prep
  127. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  128. %patch0 -p0
  129. %patch1 -p1
  130. %build
  131. # nginx does not utilize a standard configure script. It has its own
  132. # and the standard configure options cause the nginx configure script
  133. # to error out. This is is also the reason for the DESTDIR environment
  134. # variable. The configure script(s) have been patched (Patch1 and
  135. # Patch2) in order to support installing into a build environment.
  136. export DESTDIR=%{buildroot}
  137. CONFIGOPTS="\
  138. --user=%{nginx_user} \
  139. --group=%{nginx_group} \
  140. --prefix=%{nginx_datadir} \
  141. --sbin-path=%{_sbindir}/%{name} \
  142. --conf-path=%{nginx_confdir}/%{name}.conf \
  143. --error-log-path=%{nginx_logdir}/error.log \
  144. --http-log-path=%{nginx_logdir}/access.log \
  145. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  146. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  147. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  148. --pid-path=%{_localstatedir}/run/%{name}.pid \
  149. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  150. --with-file-aio \
  151. --with-ipv6 \
  152. --with-http_ssl_module \
  153. --with-http_spdy_module \
  154. --with-http_realip_module \
  155. --with-http_addition_module \
  156. --with-http_xslt_module \
  157. --with-http_image_filter_module \
  158. --with-http_sub_module \
  159. --with-http_dav_module \
  160. --with-http_flv_module \
  161. --with-http_mp4_module \
  162. --with-http_gzip_static_module \
  163. --with-http_random_index_module \
  164. --with-http_secure_link_module \
  165. --with-http_degradation_module \
  166. --with-http_stub_status_module \
  167. --with-http_perl_module \
  168. --with-http_degradation_module \
  169. %if %{with geoip}
  170. --with-http_geoip_module \
  171. %endif
  172. --with-mail \
  173. --with-mail_ssl_module \
  174. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  175. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  176. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  177. %if %{with wsgi}
  178. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  179. %endif
  180. %ifarch i686
  181. --with-cpu-opt=pentiumpro \
  182. --with-zlib-asm=pentiumpro \
  183. --with-md5-asm \
  184. --with-sha1-asm \
  185. %endif
  186. "
  187. ## build with passenger
  188. ./configure \
  189. $CONFIGOPTS \
  190. --with-cc-opt="%{optflags}" \
  191. --add-module=passenger-%{passenger_version}/ext/nginx
  192. make %{?_smp_mflags}
  193. mv objs/nginx objs/nginx.passenger
  194. ## build without passenger
  195. ./configure \
  196. $CONFIGOPTS \
  197. --with-cc-opt="%{optflags}"
  198. make %{?_smp_mflags}
  199. %install
  200. rm -rf %{buildroot}
  201. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  202. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  203. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  204. find %{buildroot} -type f -empty -exec rm -f {} \;
  205. find %{buildroot} -type f -exec chmod 0644 {} \;
  206. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  207. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  208. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  209. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  210. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  211. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  212. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  213. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  214. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  215. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  216. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  217. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  218. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  219. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  220. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  221. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  222. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  223. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  224. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  225. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  226. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  227. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  228. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  229. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  230. %if %{with wsgi}
  231. %{__install} -p -m 0644 \
  232. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  233. %{buildroot}%{nginx_confdir}
  234. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  235. %endif
  236. # upstream fair module document
  237. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  238. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  239. # convert to UTF-8 all files that give warnings.
  240. for textfile in CHANGES
  241. do
  242. mv $textfile $textfile.old
  243. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  244. rm -f $textfile.old
  245. done
  246. %clean
  247. rm -rf %{buildroot}
  248. %post
  249. if [ $1 == 1 ]; then
  250. /sbin/chkconfig --add %{name}
  251. fi
  252. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  253. %post passenger
  254. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  255. %preun
  256. if [ $1 = 0 ]; then
  257. /sbin/service %{name} stop >/dev/null 2>&1
  258. /sbin/chkconfig --del %{name}
  259. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  260. fi
  261. %preun passenger
  262. if [ $1 = 0 ]; then
  263. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  264. fi
  265. %postun
  266. if [ $1 == 2 ]; then
  267. /sbin/service %{name} upgrade || :
  268. fi
  269. %files
  270. %defattr(-,root,root,-)
  271. %doc LICENSE CHANGES README
  272. %doc README.upstream_fair
  273. %doc %{?with_wsgi:README.mod_wsgi}
  274. %{nginx_datadir}/
  275. %{_sbindir}/%{name}.normal
  276. %{_mandir}/man3/%{name}.3pm.gz
  277. %{_initrddir}/%{name}
  278. %dir %{nginx_confdir}
  279. %dir %{nginx_confdir}/conf.d
  280. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  281. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  282. %config(noreplace) %{nginx_confdir}/sites.d/*
  283. %config(noreplace) %{nginx_confdir}/win-utf
  284. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  285. %config(noreplace) %{nginx_confdir}/mime.types.default
  286. %config(noreplace) %{nginx_confdir}/fastcgi_params
  287. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  288. %config(noreplace) %{nginx_confdir}/koi-win
  289. %config(noreplace) %{nginx_confdir}/koi-utf
  290. %config(noreplace) %{nginx_confdir}/%{name}.conf
  291. %config(noreplace) %{nginx_confdir}/mime.types
  292. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  293. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  294. %config(noreplace) %{nginx_confdir}/scgi_params
  295. %config(noreplace) %{nginx_confdir}/scgi_params.default
  296. %config(noreplace) %{nginx_confdir}/uwsgi_params
  297. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  298. %if %{with wsgi}
  299. %config(noreplace) %{nginx_confdir}/wsgi_vars
  300. %endif
  301. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  302. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  303. %dir %{perl_vendorarch}/auto/%{name}
  304. %{perl_vendorarch}/%{name}.pm
  305. %{perl_vendorarch}/auto/%{name}/%{name}.so
  306. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  307. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  308. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  309. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  310. %files passenger
  311. %defattr(-,root,root,-)
  312. %doc passenger-%{passenger_version}/doc/*.txt
  313. %doc passenger-%{passenger_version}/doc/*.html
  314. %doc passenger-%{passenger_version}/doc/template
  315. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  316. %doc passenger-%{passenger_version}/doc/images
  317. %{_sbindir}/%{name}.passenger
  318. %changelog
  319. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  320. - rebuilt with gd-2.1.0.
  321. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  322. - update to 1.4.1
  323. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  324. - update to 1.4.0
  325. - enable SPDY module
  326. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  327. - new upstream release
  328. - update passenger to 3.0.19
  329. - update ngx-fancyindex to upstream git master
  330. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  331. - new upstream release
  332. - update passenger to 3.0.17
  333. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  334. - rebuild with pcre-8.31
  335. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  336. - added http_geoip_module.
  337. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  338. - update to 1.2.4
  339. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  340. - update to 1.2.2
  341. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  342. - update to 1.2.1
  343. - change nginx user from nginx to www-data
  344. - R(pre): www-common
  345. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  346. - update to 1.2.0
  347. - update passenger to 3.0.12
  348. - drop http_upstream_keepalive
  349. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  350. - new upstream release
  351. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  352. - update to 1.0.12
  353. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  354. - update to 1.0.11
  355. - update passenger to 3.0.11
  356. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  357. - update to 1.0.10
  358. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  359. - update passenger to 3.0.9
  360. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  361. - update to 1.0.6
  362. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  363. - update to 1.0.4
  364. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  365. - add gnosek-nginx-upstream-fair module
  366. - add ngx_http_upstream_keepalive module
  367. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  368. - add nginx-passenger sub pakckage
  369. - use alternatives to choose nginx with or without passenger
  370. - add BR: ruby, rubygems, rubygem-rake
  371. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  372. - update to 1.0.2
  373. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  374. - update to 1.0.1
  375. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  376. - add bcond_with wsgi for mod_wsgi
  377. - add bcond_with passenger
  378. - you need to install rake.gem to build with this option.
  379. - add Provides: webserver
  380. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  381. - new upstream release 1.0.0!
  382. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  383. - rebuild with perl-5.12.3
  384. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  385. - update to 0.8.54
  386. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  387. - update to 0.8.53
  388. - add nginx_accept_language_module
  389. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  390. - update to 0.8.50
  391. - update ngx-fancyindex to 0.3
  392. - add BR: libxml2-devel, libxslt-devel
  393. - add scgi_params* and uwsgi_params* to %%files
  394. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  395. - update to 0.8.35 (development version)
  396. - add sites.d/ to store vitualhost settings
  397. - split out default server settings to sites.d/default
  398. - add fancyindex module
  399. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  400. - new upstream release
  401. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  402. - update to 0.7.62 (included security fix: VU#180065)
  403. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  404. - fix typo
  405. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  406. - add translated descriptions
  407. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  408. - update 404.html/50x.html to use powered by vine logo.
  409. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  410. - initial build for Vine Linux
  411. - update to 0.7.61
  412. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  413. - init script updates from Gena Makhomed
  414. - remove nginx-upstream-fair
  415. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  416. - update to 0.6.36
  417. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  418. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  419. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  420. - rebuild
  421. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  422. - update to 0.6.35
  423. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  424. - rebuild with new openssl
  425. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  426. - update to 0.6.34
  427. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  428. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  429. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  430. - update to 0.6.33
  431. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  432. - update to 0.6.32
  433. - nginx now supports DESTDIR so removed the patches that enabled it
  434. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  435. - init script fixes
  436. - resolve 'listen 80 default' [#447873]
  437. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  438. - update to 0.6.31
  439. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  440. - upate to new upstream stable branch 0.6
  441. - added 3rd party module nginx-upstream-fair
  442. - added default webpages
  443. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  444. - update init script to match recommended guidelines
  445. - add /etc/nginx/conf.d support [#443280]
  446. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  447. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  448. - add Requires for versioned perl (libperl.so)
  449. - drop silly file Requires
  450. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  451. - Autorebuild for GCC 4.3
  452. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  453. - update to 0.5.35
  454. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  455. - update to 0.5.34
  456. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  457. - Rebuild for deps
  458. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  459. - update to 0.5.33
  460. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  461. - updated to 0.5.32
  462. - fixed rpmlint UTF-8 complaints.
  463. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  464. - added --with-http_stub_status_module build option.
  465. - added --with-http_sub_module build option.
  466. - added use of pcre-config --cflags
  467. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  468. - Update to 0.5.31
  469. - specify license is BSD
  470. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  471. - Add BuildRequires: perl-devel - fixing rawhide build
  472. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  473. - Update to 0.5.30
  474. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  475. - Update to 0.5.29
  476. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  477. - Update to 0.5.28
  478. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  479. - Update to 0.5.27
  480. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  481. - Update to 0.5.26
  482. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  483. - Update to 0.5.19
  484. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  485. - Update to 0.5.17
  486. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  487. - Update to 0.5.16
  488. - add ownership of /usr/share/nginx/html (#233950)
  489. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  490. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  491. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  492. - fixed package review bugs (#233522) given by kevin@tummy.com
  493. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  494. - create patches to assist with building for Fedora
  495. - initial packaging for Fedora