yaml-cpp-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255
  1. %bcond_with static_lib
  2. %global sover 0.6
  3. Name: yaml-cpp
  4. Version: 0.6.3
  5. Release: 4%{?_dist_release}
  6. Summary: A YAML parser and emitter for C++
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: MIT
  11. URL: https://github.com/jbeder/yaml-cpp
  12. Source0: https://github.com/jbeder/yaml-cpp/archive/%{name}-%{version}.tar.gz
  13. Patch0: CVE-2017-5950.patch
  14. BuildRequires: cmake gcc gcc-c++
  15. %description
  16. yaml-cpp is a YAML parser and emitter in C++ written around the YAML 1.2 spec.
  17. %package devel
  18. Summary: Development files for %{name}
  19. Group: programming
  20. License: MIT
  21. Requires: %{name}%{?_isa} = %{version}-%{release}
  22. Requires: pkgconfig
  23. %if %{with static_lib}
  24. Obsoletes: %{name}-static < %{version}-%{release}
  25. %endif
  26. %description devel
  27. The %{name}-devel package contains libraries and header files for
  28. developing applications that use %{name}.
  29. %package static
  30. Summary: Static library for %{name}
  31. License: MIT
  32. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  33. %description static
  34. The %{name}-static package contains the static library for %{name}.
  35. %debug_package
  36. %prep
  37. %autosetup -p1 -n %{name}-%{name}-%{version}
  38. %build
  39. %if %{with static_lib}
  40. %cmake -DYAML_CPP_BUILD_TOOLS=OFF \
  41. -DYAML_BUILD_SHARED_LIBS=OFF \
  42. -DYAML_CPP_BUILD_TESTS=OFF
  43. %cmake_build
  44. mv %{_vpath_builddir} build_static
  45. %endif
  46. %cmake -DYAML_CPP_BUILD_TOOLS=OFF \
  47. -DYAML_BUILD_SHARED_LIBS=ON \
  48. -DYAML_CPP_BUILD_TESTS=OFF
  49. %cmake_build
  50. %install
  51. %if %{with static_lib}
  52. pushd build_static
  53. %make_install yaml-cpp
  54. popd
  55. # Move files so they don't get trampled
  56. mv %{buildroot}%{_libdir}/cmake/%{name} \
  57. %{buildroot}%{_libdir}/cmake/%{name}-static
  58. mv %{buildroot}%{_libdir}/pkgconfig/%{name}.pc \
  59. %{buildroot}%{_libdir}/pkgconfig/%{name}-static.pc
  60. %endif
  61. %cmake_install
  62. %files
  63. %doc CONTRIBUTING.md README.md
  64. %license LICENSE
  65. %{_libdir}/*.so.%{sover}*
  66. %files devel
  67. %{_includedir}/yaml-cpp/
  68. %{_libdir}/*.so
  69. %{_libdir}/cmake/%{name}
  70. %{_libdir}/pkgconfig/%{name}.pc
  71. %if %{with static_lib}
  72. %files static
  73. %license LICENSE
  74. %{_libdir}/*.a
  75. %{_libdir}/cmake/%{name}-static
  76. %{_libdir}/pkgconfig/%{name}-static.pc
  77. %endif
  78. %changelog
  79. * Thu Sep 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.3-4
  80. - rebuilt with current environment.
  81. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.3-3
  82. - rebuilt with current environment.
  83. * Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.3-2
  84. - initial build for Vine Linux.
  85. * Tue Oct 15 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.3-1
  86. - Update to 0.6.3.
  87. * Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.2-3
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  89. * Sun Jun 09 2019 Till Hofmann <thofmann@fedoraproject.org> - 0.6.2-2
  90. - Remove unused boost dependency
  91. * Sun Jun 09 2019 Till Hofmann <thofmann@fedoraproject.org> - 0.6.2-1
  92. - Update to 0.6.2
  93. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-6
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  95. * Thu Jan 24 2019 Jonathan Wakely <jwakely@redhat.com> - 0.6.1-5
  96. - Rebuilt for Boost 1.69
  97. * Sun Sep 16 2018 Richard Shaw <hobbes1069@gmail.com> - 0.6.1-4
  98. - Add patch for CVE-2017-5950.
  99. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-3
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  101. * Mon Apr 09 2018 Richard Shaw <hobbes1069@gmail.com> - 0.6.1-2
  102. - Fixes improperly generated cmake config files, RHBZ#1558637.
  103. * Sun Feb 18 2018 Richard Shaw <hobbes1069@gmail.com> - 0.6.1-1
  104. - Update to 0.6.1.
  105. * Sun Feb 11 2018 Richard Shaw <hobbes1069@gmail.com> - 0.6.0-1
  106. - Update to 0.6.0.
  107. - Add static library subpackage.
  108. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-10
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  110. * Wed Jan 31 2018 Richard Shaw <hobbes1069@gmail.com> - 0.5.3-9
  111. - Install yaml cmake files, fixes RHBZ#1509421.
  112. * Tue Jan 23 2018 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-8
  113. - Rebuilt for Boost 1.66
  114. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-7
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  116. * Wed Jul 19 2017 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-6
  117. - Rebuilt for s390x binutils bug
  118. * Tue Jul 04 2017 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-5
  119. - Rebuilt for Boost 1.64
  120. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-4
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  122. * Fri Jan 27 2017 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-3
  123. - Rebuilt for Boost 1.63
  124. * Fri Jan 27 2017 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-2
  125. - Rebuilt for Boost 1.63
  126. * Tue Aug 23 2016 Richard Shaw <hobbes1069@gmail.com> - 0.5.3-1
  127. - Update to latest upstream release.
  128. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-13
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  130. * Sat Jan 16 2016 Jonathan Wakely <jwakely@redhat.com> - 0.5.1-12
  131. - Rebuilt for Boost 1.60
  132. * Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 0.5.1-11
  133. - Rebuilt for Boost 1.59
  134. * Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-10
  135. - Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
  136. * Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 0.5.1-9
  137. - rebuild for Boost 1.58
  138. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-8
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  140. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.5.1-7
  141. - Rebuilt for GCC 5 C++11 ABI change
  142. * Thu Feb 26 2015 Guido Grazioli <guido.grazioli@gmail.com> - 0.5.1-6
  143. - Rebuild for gcc switching default to -std=gnu11
  144. * Tue Jan 27 2015 Petr Machata <pmachata@redhat.com> - 0.5.1-5
  145. - Rebuild for boost 1.57.0
  146. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-4
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  148. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-3
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  150. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 0.5.1-2
  151. - Rebuild for boost 1.55.0
  152. * Thu Nov 14 2013 Richard Shaw <hobbes1069@gmail.com> - 0.5.1-1
  153. - Update to latest upstream release.
  154. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-4
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  156. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
  157. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  158. * Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-2
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  160. * Fri Feb 10 2012 Richard Shaw <hobbes1069@gmail.com> - 0.3.0-1
  161. - Update to latest release.
  162. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  163. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  164. * Fri Sep 30 2011 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.7-1
  165. - Update to 0.2.7
  166. - Remove gcc 4.6 patch fixed upstream
  167. * Mon May 09 2011 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.6-1
  168. - Upstream 0.2.6
  169. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.5-2
  170. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  171. * Fri Apr 02 2010 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.5-1
  172. - Upstream 0.2.5
  173. * Fri Jan 15 2010 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.4-1
  174. - Upstream 0.2.4
  175. * Sat Oct 17 2009 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.2-2
  176. - Remove duplicate file
  177. * Wed Oct 14 2009 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.2-1
  178. - Initial packaging