device-mapper-multipath-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288
  1. Summary: Tools to manage multipath devices using device-mapper
  2. Summary(ja): Device-mapper を使用してマルチパスデバイスを管理するためのツール集
  3. Name: device-mapper-multipath
  4. Version: 0.4.9
  5. Release: 5%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Base
  8. URL: http://christophe.varoqui.free.fr/
  9. Source0: multipath-tools-%{version}.tar.bz2
  10. Source1: multipath.conf
  11. # patch that should go upstream
  12. Patch1: 0001-for-upstream-add-tpg_pref-prioritizer.patch
  13. # RH patches
  14. Patch1007: 0007-RH-do-not-remove.patch
  15. Patch1008: 0008-RH-Make-build-system-RH-Fedora-friendly.patch
  16. Patch1009: 0009-RH-multipathd-blacklist-all-by-default.patch
  17. Patch1010: 0010-RH-multipath-rules-udev-changes.patch
  18. Patch1014: 0014-RH-add-hp_tur-checker.patch
  19. Patch1017: 0017-RHBZ-554592-man-page-note.patch
  20. Patch1018: 0018-RHBZ-554596-SUN-6540-config.patch
  21. Patch1019: 0019-RHBZ-554598-fix-multipath-locking.patch
  22. Patch1020: 0020-RHBZ-554605-fix-manual-failover.patch
  23. Patch1021: 0021-RHBZ-548874-add-find-multipaths-2.patch
  24. Patch1022: 0022-RHBZ-557845-RHEL5-style-partitions-2.patch
  25. Patch1023: 0023-RHBZ-557810-emc-invista-config.patch
  26. Patch1024: 0024-RHBZ-565933-checker-timeout-2.patch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  28. Requires(post): chkconfig
  29. Requires(preun): chkconfig
  30. Requires: kpartx = %{version}-%{release}
  31. Requires: device-mapper >= 1.02.39
  32. BuildRequires: libsysfs-devel
  33. BuildRequires: device-mapper-devel
  34. #BuildRequires: libselinux-devel, libsepol-devel
  35. BuildRequires: readline-devel, ncurses-devel
  36. BuildRequires: libaio-devel
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. Packager: daisuke
  40. %description
  41. %{name} provides tools to manage multipath devices by instructing the
  42. device-mapper multipath kernel module what to do.
  43. The tools are :
  44. * multipath : Scan the system for multipath devices and assemble them.
  45. * multipathd : Detects when paths fail and execs multipath to update things.
  46. %package -n kpartx
  47. Summary: Partition device manager for device-mapper devices
  48. Summary(ja): Device-mapper デバイス用のパーティションデバイスマネージャー
  49. Group: System Environment/Base
  50. Provides: kpartx = %{version}-%{release}
  51. %description -n kpartx
  52. kpartx manages partition creation and removal for device-mapper devices.
  53. %prep
  54. %setup -q -c
  55. %patch1 -p1
  56. %patch1007 -p1
  57. %patch1008 -p1
  58. %patch1009 -p1
  59. %patch1010 -p1
  60. %patch1014 -p1
  61. %patch1017 -p1
  62. %patch1018 -p1
  63. %patch1019 -p1
  64. %patch1020 -p1
  65. %patch1021 -p1
  66. %patch1022 -p1
  67. %patch1023 -p1
  68. %patch1024 -p1
  69. %build
  70. make LIB=%{_lib}
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. make install \
  74. DESTDIR=$RPM_BUILD_ROOT \
  75. bindir=%{_syssbindir} \
  76. syslibdir=/%{_lib} \
  77. libdir=/%{_lib}/multipath \
  78. rcdir=%{_initrddir}
  79. install -d %{buildroot}/etc/multipath
  80. install -m644 %{SOURCE1} %{buildroot}/etc/multipath.conf
  81. install -m755 multipathd/multipathd.init.redhat %{buildroot}%{_initrddir}/multipathd
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %post
  85. /sbin/ldconfig
  86. /sbin/chkconfig --add multipathd
  87. if [ "$1" -gt "1" -a ! -e /etc/multipath/bindings -a \
  88. -f /var/lib/multipath/bindings ]; then
  89. mv /var/lib/multipath/bindings /etc/multipath/bindings
  90. ln -s /etc/multipath/bindings /var/lib/multipath/bindings
  91. fi
  92. %preun
  93. if [ "$1" = 0 ]; then
  94. /sbin/service multipathd stop /dev/null 2>&1
  95. /sbin/chkconfig --del multipathd
  96. fi
  97. %postun
  98. /sbin/ldconfig
  99. if [ "$1" -ge "1" ]; then
  100. /sbin/service multipathd condrestart >/dev/null 2>&1 || :
  101. fi
  102. %files
  103. %defattr(-,root,root,-)
  104. %doc AUTHOR COPYING README* FAQ
  105. %doc multipath.conf.annotated multipath.conf.defaults
  106. %doc multipath.conf.synthetic
  107. %{_syssbindir}/multipath
  108. %{_syssbindir}/multipathd
  109. %{_syssbindir}/mpathconf
  110. %config /lib/udev/rules.d/40-multipath.rules
  111. %{_mandir}/man8/multipath.8.gz
  112. %{_mandir}/man8/multipathd.8.gz
  113. %{_mandir}/man5/multipath.conf.5.gz
  114. %config /etc/rc.d/init.d/multipathd
  115. %config(noreplace) /etc/multipath.conf
  116. %dir /etc/multipath
  117. /%{_lib}/libmultipath.so*
  118. %dir /%{_lib}/multipath
  119. /%{_lib}/multipath/*
  120. %files -n kpartx
  121. %defattr(-,root,root,-)
  122. %{_syssbindir}/kpartx
  123. %{_mandir}/man8/kpartx.8.gz
  124. %changelog
  125. * Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.9-5
  126. - rebuilt with readline 6.3
  127. - changed BuildRequires: libsysfs-devel instead of sysfsutils-devel
  128. - added Japanese summary
  129. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.9-4
  130. - rebuild with VineSeed environment
  131. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-3
  132. - import patches from RH package
  133. * Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-2
  134. - install multipath libraries to %%{_lib}/multipath
  135. * Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-1
  136. - update to 0.4.9
  137. - drop static version
  138. - add BR: libaio-devel
  139. * Sun Sep 07 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.7-12vl5
  140. - applied new versioning policy
  141. * Thu Feb 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.7-11vl1
  142. - initial build for VineSeed
  143. - add Patch100 to disable linking to libselinux and libsepol
  144. * Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 0.4.7-11.fc7
  145. - Add build dependency on new device-mapper-devel package.
  146. - Add dependency on device-mapper.
  147. * Wed Jan 31 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-10.fc7
  148. - Update BuildRoot and PreReq lines.
  149. * Mon Jan 15 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-9.fc7
  150. - Fixed spec file.
  151. * Mon Jan 15 2007 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-8.fc7
  152. - Update to latest code (t0_4_7_head2)
  153. * Wed Dec 13 2006 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-7.fc7
  154. - Update to latest code (t0_4_7_head1)
  155. * Thu Sep 7 2006 Peter Jones <pjones@redhat.com> - 0.4.7-5
  156. - Fix kpartx to handle with drives >2TB correctly.
  157. * Thu Aug 31 2006 Peter Jones <pjones@redhat.com> - 0.4.7-4.1
  158. - Split kpartx out into its own package so dmraid can use it without
  159. installing multipathd
  160. - Fix a segfault in kpartx
  161. * Mon Jul 17 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-4.0
  162. - Updated to latest source. Fixes bug in default multipath.conf
  163. * Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.1
  164. - Added ncurses-devel to BuildRequires
  165. * Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.0
  166. - Updated to latest source. deals with change in libsysfs API
  167. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.4.7-2.2.1
  168. - rebuild
  169. * Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.2
  170. - fix tagging issue.
  171. * Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.1
  172. - changed BuildRequires from sysfsutils-devel to libsysfs-devel
  173. * Wed Jun 28 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.0
  174. - Updated to latest upstream source, fixes kpartx udev rule issue
  175. * Tue Jun 06 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-1.0
  176. - Updated to Christophe's latest source
  177. * Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-16.0
  178. - Newer upstream source (t0_4_5_post59).
  179. * Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-12.3
  180. - BuildRequires: libsepol-devel, readline-devel
  181. * Mon Feb 27 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.5-12.2
  182. - Prereq: chkconfig
  183. * Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 0.4.5-12.1
  184. - BuildRequires: libselinux-devel
  185. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-12.0.1
  186. - bump again for double-long bug on ppc(64)
  187. * Tue Feb 07 2006 Benjamin Marzinski <bmarzins@redhat.com> -0.4.5-12.0
  188. - Updated to latest upstream source (t0_4_5_post56)
  189. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-9.1.1
  190. - rebuilt for new gcc4.1 snapshot and glibc changes
  191. * Mon Dec 19 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.1
  192. - added patch for fedora changes
  193. * Fri Dec 16 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.0
  194. - Updated to latest upstream source (t)_4_5_post52)
  195. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  196. - rebuilt
  197. * Sun Dec 4 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.6
  198. - rebuild for newer libs
  199. * Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.5
  200. - unsplit kpartx. parted knows how to do this now, so we don't
  201. need this in a separate package.
  202. * Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.4
  203. - split kpartx out into its own package
  204. * Fri May 06 2005 Bill Nottingham <notting@redhat.com> - 0.4.4-2.3
  205. - Fix last fix.
  206. * Thu May 05 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.2
  207. - Fix last fix.
  208. * Wed May 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.1
  209. - By default, disable the multipathd service.
  210. * Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.0
  211. - Fix core dump from last build.
  212. * Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-1.0
  213. - Move cache file into /var/cache/multipath.
  214. * Fri Apr 08 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.1
  215. - Remove pp_balance_units.
  216. * Mon Apr 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.0
  217. - Incorporate numerous upstream fixes.
  218. - Update init script to distribution standards.
  219. * Tue Mar 01 2005 Alasdair Kergon <agk@redhat.com> - 0.4.2-1.0
  220. - Initial import based on Christophe Varoqui's spec file.