tzdata-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368
  1. %bcond_with java18
  2. Summary: Timezone data
  3. Summary(ja): タイムゾーンのデータ
  4. Name: tzdata
  5. Version: 2015e
  6. %define tzdata_version 2015e
  7. %define tzcode_version 2015e
  8. Release: 1%{?_dist_release}
  9. License: Public Domain
  10. Group: System Environment/Base
  11. URL: https://www.iana.org/time-zones
  12. # These are official upstream.
  13. Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
  14. Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
  15. Source2: javazic.tar.gz
  16. Source3: javazic-1.8-37392f2f5d59.tar.xz
  17. Patch100: javazic-fixup.patch
  18. Patch101: rebase-01.patch
  19. Patch102: rebase-02.patch
  20. Patch103: 7090844.patch
  21. Patch104: 7133138.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildArch: noarch
  24. BuildRequires: gawk, glibc, perl
  25. BuildRequires: java-devel
  26. BuildRequires: glibc-common >= 2.5.90-7
  27. Conflicts: glibc-common <= 2.3.2-63
  28. %description
  29. This package contains data files with rules for various timezones around
  30. the world.
  31. %description -l ja
  32. このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
  33. %package java
  34. Summary: Timezone data for Java
  35. Group: System Environment/Base
  36. %description java
  37. This package contains timezone information for use by Java runtimes.
  38. %prep
  39. %setup -q -c -a 1
  40. mkdir javazic
  41. tar zxf %{SOURCE2} -C javazic
  42. pushd javazic
  43. %patch100
  44. %patch101
  45. %patch102
  46. %patch103
  47. %patch104
  48. # Hack alert! sun.tools may be defined and installed in the
  49. # VM. In order to guarantee that we are using IcedTea/OpenJDK
  50. # for creating the zoneinfo files, rebase all the packages
  51. # from "sun." to "rht.". Unfortunately, gcj does not support
  52. # any of the -Xclasspath options, so we must go this route
  53. # to ensure the greatest compatibility.
  54. mv sun rht
  55. find . -type f -name '*.java' -print0 \
  56. | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
  57. -e 's:sun\.util\.:rht.util.:g'
  58. popd
  59. tar xf %{SOURCE3}
  60. echo "%{name}%{tzdata_version}" >> VERSION
  61. %build
  62. FILES="africa antarctica asia australasia europe northamerica southamerica
  63. pacificnew etcetera backward"
  64. mkdir zoneinfo/{,posix,right}
  65. zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
  66. zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
  67. zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
  68. grep -v tz-art.htm tz-link.htm > tz-link.html
  69. # Java 6/7 tzdata
  70. pushd javazic
  71. javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
  72. popd
  73. java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
  74. -d javazi \
  75. $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
  76. %if %{with java18}
  77. # Java 8 tzdata
  78. pushd javazic-1.8
  79. javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
  80. popd
  81. java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
  82. -srcdir . -dstfile tzdb.dat \
  83. -verbose \
  84. $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
  85. %endif
  86. %install
  87. rm -fr $RPM_BUILD_ROOT
  88. install -d $RPM_BUILD_ROOT%{_datadir}
  89. cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
  90. install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
  91. cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
  92. %if %{with java18}
  93. mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
  94. install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
  95. %endif
  96. %clean
  97. rm -fr $RPM_BUILD_ROOT
  98. %files
  99. %defattr(-,root,root)
  100. %{_datadir}/zoneinfo
  101. %doc README
  102. %doc Theory
  103. %doc tz-link.html
  104. %files java
  105. %defattr(-,root,root)
  106. %{_datadir}/javazi
  107. %if %{with java18}
  108. %{_datadir}/javazi-1.8
  109. %endif
  110. %changelog
  111. * Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
  112. - updated to 2015e.
  113. * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
  114. - update to tzdata-2012c, tzcode-2012b
  115. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
  116. - rebuilt with rpm-4.8.1-3
  117. * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
  118. - update to tzdata-2010l, tzcode-2010l
  119. - added java subpackage
  120. * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
  121. - update to tzdata-2009d, tzcode-2009d
  122. - spec in utf-8
  123. * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
  124. - update to tzdata-2008b, tzcode-2008a
  125. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
  126. - initial build for VineSeed
  127. * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
  128. - Upstream 2007d
  129. - Mongolia has abolished DST.
  130. - Turkey will use EU rules this year, changing at 01:00 UTC rather
  131. than 01:00 standard time.
  132. - Cuba observed DST starting Sunday.
  133. - Resolute, Nunavut switched from Central to Eastern time last
  134. November.
  135. * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
  136. - Upstream 2007c
  137. - Pulaski County, Indiana, switched back to eastern time.
  138. - Turkey switches at 01:00 standard time, not at 01:00 UTC.
  139. - Upstream 2007b
  140. - Changes to the commentary in "leapseconds".
  141. - Upstream 2007a
  142. - Updates to Bahamas, they will be in sync with 2007 US DST change
  143. - New zone Australia/Eucla
  144. - Africa/Asmera renamed to Africa/Asmara, link created
  145. - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
  146. * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
  147. - Upstream 2006p
  148. - Covers changes from 2006m-2 and 2006m-3
  149. - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
  150. * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
  151. - Patch for Western Australia DST trial
  152. * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
  153. - Proposed upstream patch (#210058)
  154. - Jordan will switch to winter time on October 27, not September 29
  155. - Brazil's DST this year is the first Sunday in November to the last
  156. Sunday in February. (Thanks to Frederico A. C. Neves.)
  157. - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
  158. - Commentary and past timestamps changes
  159. * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
  160. - Upstream 2006m:
  161. - Adjustments for Egypt, Palestine, Uruguay
  162. - Better description of `until' field in zic (8) manpage
  163. * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
  164. - Upstream 2006k, 2006l:
  165. - Adjustments for Egypt, Palestine, Cuba, Honduras
  166. - Documentation changes
  167. * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
  168. - Upstream 2006j
  169. - Honduras stopped observing DST on Monday at 00:00
  170. - America/Bermuda will follow the US's lead next year
  171. - America/Moncton will use US-style rules next year
  172. - New Zone America/Blanc-Sablon, for Canadians who observe AST all
  173. year
  174. - New zone: America/Atikokan instead of America/Coral_Harbour
  175. - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
  176. - Historical changes
  177. - Commentary updates
  178. - Upstream 2006i
  179. - localtime.c fixes
  180. - Upstream 2006h
  181. - zic leapsecond fix
  182. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
  183. - rebuild
  184. * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
  185. - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
  186. - Nicaragua updates
  187. * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
  188. - Upstream 2006f
  189. - America/Guatemala observes DST between Apr/30 and Oct/1
  190. - Historical changes for Nicaragua
  191. - Update of America/Indiana/Vincennes in zone table
  192. * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
  193. - Upstream 2006d
  194. - Haiti observes DST
  195. - Sri Lanka change actually took effect Apr/15
  196. - All Canada is now scheduled for 2007 US DST rules
  197. - Some historical fixes
  198. * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
  199. - Upstream 2006c
  200. - Time-related changes:
  201. - dozens of historical and commentary changes
  202. - Iran stopped observing DST
  203. - Sri Lanka switches from UTC+6 to UTC+5:30
  204. - America/Thule and America/Edmonton will adopt new US rules,
  205. starting 2007
  206. - Tunisia is adopting regular DST
  207. - Code:
  208. - asctime.c: Chages in format strings to silent gcc warnings
  209. - removing K&R notation from function signatures
  210. - few fixes across the code
  211. * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
  212. - Patch for Sri Lanka time zone change (#184514)
  213. * Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
  214. - Upstream 2006b:
  215. - using tz64code version, as 32 is legacy according to tzdata ML
  216. - new manual pages for ctime, strftime, tzset
  217. - some source code reorganizations
  218. - no timezone/dst rule updates
  219. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
  220. - Small changes in tst-timezone.c
  221. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
  222. - Upstream 2006a:
  223. - private.h(scheck): changing char* to char const*
  224. - Rule changes for Palestine, zone changes for Indiana/US, both
  225. changes for Canada.
  226. - Many related doc changes.
  227. - Naming scheme in spec file doesn't use %%{name}, but tzdata.
  228. * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
  229. - 2005r-3
  230. - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
  231. so that it won't clash across updates.
  232. * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
  233. - 2005r
  234. - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
  235. northamerica to guard against old files with obsolete information
  236. being left in the time zone binary directory.
  237. - Changes for countries that are supposed to join 2007 US DST
  238. change. This includes most of Canada, however entries already in
  239. the database (Alberta, British Columbia, Newfoundland, Northwest
  240. Territories, and Yukon) were left alone for the time being.
  241. - Fixes in zdump.c (abbrok): conditions are chained, and the string
  242. is checked for emptiness.
  243. * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
  244. - 2005q
  245. - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
  246. - SystemV timezone changes
  247. * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
  248. - 2005n
  249. - changes for Kyrgyzstan and Uruguay
  250. - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
  251. make check), update tst-timezone.c from glibc CVS (#172102)
  252. * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
  253. - 2005m
  254. - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
  255. Australia, Kazakhstan
  256. - historical timezone data changes for Japan, Poland, Northern Ireland and
  257. Mali
  258. - timezone name change for East Timor
  259. * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
  260. - 2005k
  261. - leap seconds update
  262. * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
  263. - 2005i
  264. - updates for Iran, Haiti and Nicaragua
  265. * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
  266. - 2005h
  267. - fixes for Kazakhstan
  268. * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
  269. - 2005g
  270. - fixes for Uruguay
  271. - include README and Theory from tzcode tarball in %{_docdir};
  272. Theory includes a good summary of how the timezone data files
  273. are supposed to be named
  274. * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
  275. - 2005f
  276. - more updates for Israel, updates for Azerbaijan
  277. * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
  278. - 2005c
  279. - updates for Israel and Paraguay
  280. * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
  281. - 2004g (#141107)
  282. - updates for Cuba
  283. * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
  284. - 2004e (#135194)
  285. - updates for Brazil, Uruguay and Argentina
  286. * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
  287. - 2004b
  288. * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
  289. - 2003d
  290. * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
  291. - 2003c
  292. - updates for Brazil (#104840)
  293. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
  294. - rebuilt
  295. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
  296. - initial package