moonlight-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329
  1. %define mono_dir %{_prefix}/lib/mono
  2. %define monodoc_dir %{_prefix}/lib/monodoc
  3. %define moonlight_dir %{_prefix}/lib/moonlight
  4. %define pkgconfigdir %{_datadir}/pkgconfig
  5. %define included_mono 2.6.1
  6. %define included_basic 2.6
  7. Summary: An open source implementation of Silverlight
  8. Summary(ja): Silverlight のオープンソースによる実装
  9. Name: moonlight
  10. Version: 2.3
  11. Release: 1%{?_dist_release}
  12. Group: Applications/Multimedia
  13. License: LGPL v2.0 only ; MIT License (or similar) ; Ms-Pl
  14. URL: http://go-mono.com/moonlight/
  15. Source0: ftp://ftp.novell.com/pub/mono/sources/moon/%{version}/moonlight-%{version}.tar.bz2
  16. Source1: ftp://ftp.novell.com/pub/mono/sources/moon/%{version}/mono-%{included_mono}.tar.bz2
  17. Source2: ftp://ftp.novell.com/pub/mono/sources/moon/%{version}/mono-basic-%{included_basic}.tar.bz2
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. #Patch0: missing-files.patch
  20. #BuildRequires: mono-devel >= 2.6
  21. #BuildRequires: monodoc
  22. BuildRequires: gtk-sharp2
  23. BuildRequires: rsvg2-sharp
  24. BuildRequires: wnck-sharp
  25. BuildRequires: gcc-c++
  26. BuildRequires: gtk2-devel
  27. BuildRequires: alsa-lib-devel
  28. BuildRequires: xulrunner-devel
  29. BuildRequires: bison
  30. #BuildRequires: autoconf
  31. #BuildRequires: automake
  32. ExclusiveArch: %ix86 x86_64
  33. %description
  34. Moonlight is an open source implementation of Microsoft Silverlight for
  35. Unix systems.
  36. %description -l ja
  37. Moonlight は Unix 系システムのための,Microsoft Silverlight のオープン
  38. ソースな実装です.
  39. %package libs
  40. Summary: Moonlight libmoon
  41. Group: System Environment/Libraries
  42. License: LGPL v2.0 only
  43. %description libs
  44. Moonlight libmoon
  45. %package devel
  46. Summary: Moonlight libmoon C/C++ development files
  47. Group: Development/Libraries
  48. License: LGPL v2.0 only
  49. Requires: %{name}-libs == %{version}
  50. %description devel
  51. Development files for libmoon
  52. %package tools
  53. Summary: Moonlight tools
  54. Group: Development/Tools
  55. Requires: %{name}-libs == %{version}
  56. %description tools
  57. Moonlight tools (mopen, xamlg, xaml2html, mxap, respack, svg2xaml)
  58. %package plugin
  59. Summary: Moonlight browser plugin
  60. Group: Applications/Internet
  61. Requires: %{name}-libs == %{version}
  62. %description plugin
  63. Browser plugin for Novell Moonlight
  64. %package web-devel
  65. Summary: Development files for Moonlight Web
  66. Group: Development/Libraries
  67. License: MIT License (or similar) ; Ms-Pl
  68. Requires: %{name}-plugin == %{version}
  69. %description web-devel
  70. Development files for creating Moonlight web applications.
  71. %package desktop
  72. Summary: Mono bindings for Moonlight Desktop
  73. Group: Development/Libraries
  74. License: MIT License (or similar) ; Ms-Pl
  75. Requires: %{name}-libs == %{version}
  76. %description desktop
  77. Mono bindings for Novell Moonlight.
  78. %package desktop-devel
  79. Summary: Development files for Moonlight Desktop
  80. Group: Development/Libraries
  81. License: MIT License (or similar) ; Ms-Pl
  82. Requires: %{name}-libs == %{version}
  83. Requires: glib2-devel
  84. Requires: gtk-sharp2
  85. Requires: %{name}-desktop == %{version}
  86. Requires: %{name}-tools == %{version}
  87. %description desktop-devel
  88. Development files for Moonlight Desktop.
  89. %package sharp
  90. Summary: Moonlight sharp
  91. Group: Development/Libraries
  92. Requires: %{name}-libs == %{version}
  93. %description sharp
  94. Provides a gtk-sharp object that can be used to embed a moonlight surface in a desktop application.
  95. %prep
  96. %setup -q
  97. %setup -q -T -D -b 1 -n %{name}-%{version}
  98. %setup -q -T -D -b 2 -n %{name}-%{version}
  99. %build
  100. # The plugin requires a complete build of it's own mono
  101. pushd ../mono-%{included_mono}
  102. ./configure \
  103. --prefix=%{_builddir}/install \
  104. --with-mcs-docs=no \
  105. --with-ikvm-native=no \
  106. ;
  107. # mono is not strictly -j safe
  108. %{__make} EXTERNAL_MCS=false EXTERNAL_RUNTIME=false
  109. %{__make} install
  110. find %{_builddir}/install -name \*.la -delete
  111. popd
  112. # Configure against the junk install of mono
  113. export PATH=%{_builddir}/install/bin:${PATH}
  114. export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
  115. export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
  116. # Only needed when there are Makefile.am or configure.ac patches
  117. #autoreconf -f -i -Wnone
  118. %configure \
  119. --with-ffmpeg=no \
  120. --with-cairo=system \
  121. --with-curl=system \
  122. --with-mcspath=%{_builddir}/mono-%{included_mono}/mcs \
  123. --with-mono-basic-path=%{_builddir}/mono-basic-%{included_basic} \
  124. --with-ff3=yes \
  125. --with-testing=no \
  126. --with-performance=no \
  127. --with-examples=no \
  128. --with-debug=no \
  129. --with-sanity-checks=no \
  130. ;
  131. export MONO_GAC_PREFIX=%{_builddir}/install:%{_prefix}
  132. %{__make} %{?_smp_mflags}
  133. %install
  134. rm -rf $RPM_BUILD_ROOT
  135. export PATH=%{_builddir}/install/bin:${PATH}
  136. export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
  137. export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
  138. make install DESTDIR=${RPM_BUILD_ROOT} pkgconfigdir=%{pkgconfigdir}
  139. mkdir -p $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  140. ln -s %{_libdir}/moonlight/plugin/libmoonloader.so \
  141. $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/libmoonloader.so
  142. # remove unuse files
  143. rm -f $RPM_BUILD_ROOT%{_libdir}/libshocker.so
  144. find %{buildroot} -name \*.la -delete
  145. %post libs -p /sbin/ldconfig
  146. %postun libs -p /sbin/ldconfig
  147. %clean
  148. rm -rf $RPM_BUILD_ROOT
  149. %files libs
  150. %defattr(-, root, root)
  151. %doc AUTHORS COPYING ChangeLog README TODO NEWS
  152. %{_libdir}/libmoon.so.*
  153. %files devel
  154. %defattr(-, root, root)
  155. %{_libdir}/libmoon.so
  156. %files tools
  157. %defattr(-, root, root)
  158. %{_bindir}/mopen
  159. %{_bindir}/munxap
  160. %{_bindir}/mxap
  161. %{_bindir}/respack
  162. %{_bindir}/sockpol
  163. %{_bindir}/unrespack
  164. %{_bindir}/xaml2html
  165. %{_bindir}/xamlg
  166. %dir %{_libdir}/moonlight
  167. %{_libdir}/moonlight/mopen.exe*
  168. %{_libdir}/moonlight/munxap.exe
  169. %{_libdir}/moonlight/mxap.exe
  170. %{_libdir}/moonlight/respack.exe
  171. %{_libdir}/moonlight/xaml2html.exe
  172. %{_libdir}/moonlight/xamlg.exe
  173. %{_libdir}/moonlight/sockpol.exe
  174. %{_mandir}/man1/mopen.1.gz
  175. %{_mandir}/man1/mxap.1.gz
  176. %{_mandir}/man1/respack.1.gz
  177. %{_mandir}/man1/svg2xaml.1.gz
  178. %{_mandir}/man1/xamlg.1.gz
  179. %{_mandir}/man1/sockpol.1.gz
  180. %files plugin
  181. %defattr(-, root, root)
  182. %dir %{_libdir}/moonlight/plugin
  183. %{_libdir}/moonlight/plugin/Microsoft.VisualBasic.dll
  184. %{_libdir}/moonlight/plugin/System.Core.dll*
  185. %{_libdir}/moonlight/plugin/System.Net.dll*
  186. %{_libdir}/moonlight/plugin/System.Runtime.Serialization.dll*
  187. %{_libdir}/moonlight/plugin/System.ServiceModel.Web.dll*
  188. %{_libdir}/moonlight/plugin/System.ServiceModel.dll*
  189. %{_libdir}/moonlight/plugin/System.Windows.Browser.dll*
  190. %{_libdir}/moonlight/plugin/System.Windows.dll*
  191. %{_libdir}/moonlight/plugin/System.Xml.dll*
  192. %{_libdir}/moonlight/plugin/System.dll*
  193. %{_libdir}/moonlight/plugin/libmoonloader.so
  194. %{_libdir}/moonlight/plugin/libmoonplugin-curlbridge.so
  195. %{_libdir}/moonlight/plugin/libmoonplugin-ff3bridge.so
  196. %{_libdir}/moonlight/plugin/libmoonplugin.so
  197. %{_libdir}/moonlight/plugin/mscorlib.dll*
  198. %{_libdir}/mozilla/plugins/libmoonloader.so
  199. %files web-devel
  200. %defattr(-, root, root)
  201. %{_bindir}/smcs
  202. %dir %{moonlight_dir}/2.0-redist
  203. %{moonlight_dir}/2.0-redist/System.Windows.Controls.Data.dll*
  204. %{moonlight_dir}/2.0-redist/System.Windows.Controls.dll*
  205. %{moonlight_dir}/2.0-redist/System.Xml.Linq.dll*
  206. %dir %{moonlight_dir}/2.0
  207. %{moonlight_dir}/2.0/Microsoft.VisualBasic.dll*
  208. %{moonlight_dir}/2.0/Mono.CompilerServices.SymbolWriter.dll*
  209. %{moonlight_dir}/2.0/System.Core.dll*
  210. %{moonlight_dir}/2.0/System.Net.dll*
  211. %{moonlight_dir}/2.0/System.Runtime.Serialization.dll*
  212. %{moonlight_dir}/2.0/System.ServiceModel.Web.dll*
  213. %{moonlight_dir}/2.0/System.ServiceModel.dll*
  214. %{moonlight_dir}/2.0/System.Windows.Browser.dll*
  215. %{moonlight_dir}/2.0/System.Windows.dll*
  216. %{moonlight_dir}/2.0/System.Xml.dll*
  217. %{moonlight_dir}/2.0/System.dll*
  218. %{moonlight_dir}/2.0/mscorlib.dll*
  219. %{moonlight_dir}/2.0/respack.exe*
  220. %{moonlight_dir}/2.0/smcs
  221. %{moonlight_dir}/2.0/smcs.exe*
  222. %{moonlight_dir}/2.0/buildversion
  223. %{pkgconfigdir}/moonlight-web-2.0.pc
  224. %files desktop
  225. %defattr(-, root, root)
  226. %{mono_dir}/gac/Moon.Windows.Desktop
  227. %{mono_dir}/gac/Moonlight.Gtk
  228. %{mono_dir}/gac/System.Windows
  229. %{mono_dir}/gac/System.Windows.Browser
  230. %{mono_dir}/gac/System.Windows.Controls
  231. %{mono_dir}/gac/System.Windows.Controls.Data
  232. %files desktop-devel
  233. %defattr(-, root, root)
  234. %dir %{mono_dir}/moonlight
  235. %{mono_dir}/moonlight/Moon.Windows.Desktop.dll*
  236. %{mono_dir}/moonlight/System.Windows.Browser.dll*
  237. %{mono_dir}/moonlight/System.Windows.Controls.Data.dll*
  238. %{mono_dir}/moonlight/System.Windows.Controls.dll*
  239. %{mono_dir}/moonlight/System.Windows.dll*
  240. %{pkgconfigdir}/moonlight-desktop-2.0.pc
  241. # It may make sense in the future to have a moonlight-gtk package
  242. %{mono_dir}/moonlight/Moonlight.Gtk.dll*
  243. %{monodoc_dir}/sources/moonlight-gtk.source
  244. %{monodoc_dir}/sources/moonlight-gtk.tree
  245. %{monodoc_dir}/sources/moonlight-gtk.zip
  246. %{pkgconfigdir}/moonlight-gtk-2.0.pc
  247. %changelog
  248. * Tue Oct 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.3-1
  249. - updated moonlightautoconf to 2.3
  250. - updated mono to 2.6.1
  251. - updated mono-basic to 2.6
  252. - added BR: bison
  253. * Wed Sep 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.0-3
  254. - export PATH, LD_LIBRARY_PATH, PKG_CONFIG_PATH, MONO_GAC_PREFIX
  255. * Sat Sep 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-2
  256. - fixed Group
  257. - added BR: wnck-sharp
  258. * Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
  259. - updated moonlight to 2.0
  260. * Thu Jul 09 2009 Shu KONNO <owa@bg.wakwak.com> 1.0.1-1
  261. - updated moon to 1.0.1
  262. - dropt missing-files.patch (included in source)
  263. - built with latest rpm to update mono-dependencies
  264. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.1-2
  265. - changed plugin Group to Applications/Internet
  266. - changed other sub packages Group to Development/Libraries
  267. - added %%pkgconfigdir macro
  268. * Sat Sep 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1
  269. - new upstream release
  270. - added missing-files.patch from suse
  271. - added --with-managed=desktop
  272. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 0.8-1
  273. - initial build for VineSeed
  274. - moonlight 0.8
  275. - vine versioning policy
  276. - spec in utf-8