coreutils-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736
  1. Summary: The GNU core utilities: a set of tools commonly used in shell scripts
  2. Summary(ja): GNU コアユーティリティ: シェルスクリプトで用いるツール集
  3. Name: coreutils
  4. Version: 9.4
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: system
  8. Url: https://www.gnu.org/software/coreutils/
  9. Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
  10. Source101: coreutils-DIR_COLORS
  11. Source102: coreutils-DIR_COLORS.lightbgcolor
  12. Source103: coreutils-DIR_COLORS.256color
  13. Source105: coreutils-colorls.sh
  14. Source106: coreutils-colorls.csh
  15. # Vine sources
  16. Source1000: coreutils-8.10-ja.po
  17. # revert a gnulib patch that broke the build
  18. Patch1: coreutils-9.3-gnulib-strtol.patch
  19. # disable the test-lock gnulib test prone to deadlock
  20. Patch100: coreutils-8.26-test-lock.patch
  21. # require_selinux_(): use selinuxenabled(8) if available
  22. Patch105: coreutils-8.26-selinuxenable.patch
  23. # downstream changes to default DIR_COLORS
  24. Patch102: coreutils-8.32-DIR_COLORS.patch
  25. #df --direct
  26. Patch104: coreutils-df-direct.patch
  27. # (sb) lin18nux/lsb compliance - multibyte functionality patch
  28. Patch800: coreutils-9.4-i18n.patch
  29. #SELINUX Patch - implements Redhat changes
  30. #(upstream did some SELinux implementation unlike with RedHat patch)
  31. #Patch950: coreutils-selinux.patch
  32. # do not make coreutils-single depend on /usr/bin/coreutils
  33. %global __requires_exclude ^%{_bindir}/coreutils$
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. BuildRequires: gettext libtermcap-devel bison
  36. BuildRequires: texinfo >= 4.3
  37. BuildRequires: autoconf >= 2.58, automake >= 1.11.2
  38. BuildRequires: libcap-devel
  39. BuildRequires: libattr-devel
  40. BuildRequires: libacl-devel
  41. BuildRequires: gmp-devel
  42. # Require a C library that doesn't put LC_TIME files in our way.
  43. Conflicts: glibc < 2.2
  44. Provides: fileutils = %version, sh-utils = %version, stat, textutils = %version
  45. Obsoletes: fileutils sh-utils stat textutils
  46. Provides: mktemp = %version
  47. Obsoletes: mktemp
  48. %description
  49. These are the GNU core utilities. This package is the combination of
  50. the old GNU fileutils, sh-utils, and textutils packages.
  51. %description -l ja
  52. このパッケージには GNU のコアユーティリティが収録されています。
  53. コアユーティリティ(coreutilsパッケージ)は従来の fileutils,
  54. sh-utils, textutils を統合したパッケージです。
  55. %debug_package
  56. %prep
  57. %autosetup -N
  58. # will be regenerated in the build directories
  59. rm -f src/fs.h
  60. # will be further modified by coreutils-8.32-DIR_COLORS.patch
  61. sed src/dircolors.hin \
  62. -e 's| 00;36$| 01;36|' \
  63. > DIR_COLORS
  64. sed src/dircolors.hin \
  65. -e 's| 01;31$| 00;31|' \
  66. -e 's| 01;35$| 00;35|' \
  67. > DIR_COLORS.lightbgcolor
  68. # apply all patches
  69. %autopatch -p1
  70. (echo ">>> Fixing permissions on tests") 2>/dev/null
  71. find tests -name '*.sh' -perm 0644 -print -exec chmod 0755 '{}' '+'
  72. (echo "<<< done") 2>/dev/null
  73. autoreconf -fiv
  74. # copy updated ja.po
  75. #mv po/ja.po po/ja.po.orig
  76. #cp -f %{SOURCE1000} po/ja.po
  77. %build
  78. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fpic"
  79. # Upstream suggests to build with -Dlint for static analyzers:
  80. # https://lists.gnu.org/archive/html/coreutils/2018-06/msg00110.html
  81. # ... and even for production binary RPMs:
  82. # https://lists.gnu.org/archive/html/bug-gnulib/2020-05/msg00130.html
  83. # There is currently no measurable performance drop or other known downside.
  84. CFLAGS="$CFLAGS -Dlint"
  85. # make mknod work again in chroot without /proc being mounted (#1811038)
  86. export ac_cv_func_lchmod="no"
  87. %{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1 -DGNULIB_MBFILE }
  88. %configure --enable-largefile \
  89. --enable-install-program=arch \
  90. --enable-no-install-program=kill,uptime \
  91. --with-tty-group \
  92. DEFAULT_POSIX2_VERSION=200112 alternative=199209 || :
  93. %__make all %{?_smp_mflags}
  94. # XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
  95. sed -i -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi
  96. %install
  97. rm -rf $RPM_BUILD_ROOT
  98. %__make DESTDIR=$RPM_BUILD_ROOT install
  99. # man pages are not installed with make install
  100. %__make mandir=$RPM_BUILD_ROOT%{_mandir} install-man
  101. # let be compatible with old fileutils, sh-utils and textutils packages :
  102. mkdir -p $RPM_BUILD_ROOT{/bin,%_bindir,%_sbindir,/sbin}
  103. for f in basename cat chgrp chmod chown cp cut date dd df echo env false \
  104. link ln ls mkdir mknod mktemp mv nice pwd rm rmdir sleep sort \
  105. stty sync touch true uname unlink
  106. do
  107. mv $RPM_BUILD_ROOT/{%_bindir,bin}/$f
  108. done
  109. # chroot was in /usr/sbin :
  110. mv $RPM_BUILD_ROOT/{%_bindir,%_sbindir}/chroot
  111. # {cat,sort,cut} were previously moved from bin to /usr/bin and linked into
  112. for i in env cut; do ln -sf ../../bin/$i $RPM_BUILD_ROOT/usr/bin; done
  113. mkdir -p $RPM_BUILD_ROOT/etc/profile.d
  114. install -p -c -m644 %SOURCE101 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS
  115. install -p -c -m644 %SOURCE102 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.lightbgcolor
  116. install -p -c -m644 %SOURCE103 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.256color
  117. install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.sh
  118. install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
  119. # These come from util-linux and/or procps.
  120. for i in hostname uptime kill ; do
  121. rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/$i.1}
  122. done
  123. %find_lang %name
  124. # Add the %%lang(xyz) ownership for the LC_TIME dirs as well...
  125. grep LC_TIME %name.lang | cut -d'/' -f1-6 | sed -e 's/) /) %%dir /g' >>%name.lang
  126. # (sb) Deal with Installed (but unpackaged) file(s) found
  127. rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
  128. %check
  129. # this test will fail on non-real filesystem (overlayfs, etc.).
  130. perl -pi -e 's|^.*inotify-dir-recreate.*$|\\|' tests/local.mk
  131. make check %{?_smp_mflags}
  132. %clean
  133. rm -rf $RPM_BUILD_ROOT
  134. %files -f %{name}.lang
  135. %defattr(-,root,root)
  136. %config(noreplace) %{_sysconfdir}/DIR_COLORS*
  137. %config(noreplace) %{_sysconfdir}/profile.d/*
  138. %license COPYING
  139. %doc ABOUT-NLS NEWS README THANKS TODO
  140. /bin/*
  141. %{_bindir}/*
  142. %{_libexecdir}/coreutils
  143. %{_infodir}/coreutils*
  144. %{_mandir}/man*/*
  145. %{_sbindir}/chroot
  146. %changelog
  147. * Tue Sep 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4-1
  148. - new upstream release.
  149. * Tue Oct 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0-1
  150. - new upstream release.
  151. - re-imported fedora patches.
  152. - dropped scriptlets.
  153. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.32-1
  154. - new upstream release.
  155. - updated all patches.
  156. * Fri May 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.25-1
  157. - update to 8.25
  158. - remove Patch1,102
  159. - import patches from fedora package
  160. - update Patch104,800
  161. - add Patch801,803,804
  162. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.23-1
  163. - update to 8.23
  164. - add Patch1 (coreutils-8.23-chroot-chdir.patch) from fedora
  165. - update Patch100,104,800
  166. - remove Requires: util-linux (BTS:2854)
  167. * Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.20-2
  168. - rebuild with VineSeed environment
  169. * Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.20-1
  170. - update to 8.20
  171. * Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-2
  172. - update ja.po
  173. - add BR: libcap-devel, gmp-devel, libattr-devel, libacl-devel
  174. * Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-1
  175. - update to 8.10
  176. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.11-2
  177. - rebuilt against curent toolchain
  178. - spec in UTF-8
  179. * Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 6.11-1
  180. - new upstream release
  181. - drop obsolete patches
  182. - import some patched from fedora-devel
  183. - add Obsoletes/Provides mktemp
  184. * Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.96-0vl1
  185. - new upstream release
  186. * Mon May 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.95-0vl1
  187. - new upstream release
  188. * Thu May 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.94-0vl1
  189. - new upstream release
  190. - drop opsolete patches
  191. - import some patches from FC
  192. * Sun Nov 13 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-40vl5
  193. - now readlink is kept as it is, since tetex-3.0 don't have readlink.
  194. * Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2.1-40vl4
  195. - updated ja.po
  196. * Sat Feb 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl3
  197. - remove selinux related pam-module from /etc/pam.d/su
  198. * Fri Feb 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl2
  199. - update ja.po
  200. * Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl1
  201. - initial build for Vine Linux
  202. - some modifications are merged from fileutils-4.1-10.1vl4
  203. - disable make check
  204. * Sat Feb 5 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-40
  205. - Undo last change (bug #145266).
  206. * Fri Feb 4 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-38
  207. - Special case for ia32e in uname (bug #145266).
  208. * Thu Jan 13 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-37
  209. - Fixed zh_CN translation (bug #144845). Patch from Mitrophan Chin.
  210. * Tue Dec 28 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-36
  211. - Fix to only setdefaultfilecon if not overridden by command line
  212. * Mon Dec 27 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-35
  213. - Change install to restorecon if it can
  214. * Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
  215. - Fixed small bug in i18n patch.
  216. * Mon Dec 6 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-34
  217. - Don't set fs uid until after pam_open_session (bug #77791).
  218. * Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-33
  219. - Fixed colorls.csh (bug #139988). Patch from Miloslav Trmac.
  220. * Mon Nov 8 2004 Tim Waugh <twaugh@redhat.com>
  221. - Updated URL (bug #138279).
  222. * Mon Oct 25 2004 Steve Grubb <sgrubb@redhat.com> 5.2.1-32
  223. - Handle the return code of function calls in runcon.
  224. * Mon Oct 18 2004 Tim Waugh <twaugh@redhat.com>
  225. - Prevent compiler warning in coreutils-i18n.patch (bug #136090).
  226. * Tue Oct 5 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-31
  227. - getgrouplist() patch from Ulrich Drepper.
  228. - The selinux patch should be applied last.
  229. * Mon Oct 4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-30
  230. - Mv runuser to /sbin
  231. * Mon Oct 4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28
  232. - Fix runuser man page.
  233. * Mon Oct 4 2004 Tim Waugh <twaugh@redhat.com>
  234. - Fixed build.
  235. * Fri Sep 24 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-26
  236. - Add runuser as similar to su, but only runable by root
  237. * Fri Sep 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-25
  238. - chown(1) patch from Ulrich Drepper.
  239. * Tue Sep 14 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-24
  240. - SELinux patch fix: don't display '(null)' if getfilecon() fails
  241. (bug #131196).
  242. * Fri Aug 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-23
  243. - Fixed colorls.csh quoting (bug #102412).
  244. - Fixed another join LSB test failure (bug #121153).
  245. * Mon Aug 16 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-22
  246. - Fixed sort -t LSB test failure (bug #121154).
  247. - Fixed join LSB test failure (bug #121153).
  248. * Wed Aug 11 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-21
  249. - Apply upstream patch to fix 'cp -a' onto multiply-linked files (bug #128874).
  250. - SELinux patch fix: don't error out if lgetfilecon() returns ENODATA.
  251. * Tue Aug 10 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-20
  252. - Added 'konsole' TERM to DIR_COLORS (bug #129544).
  253. * Wed Aug 4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-19
  254. - Added 'gnome' TERM to DIR_COLORS (bug #129112).
  255. - Worked around a bash bug #129128.
  256. - Fixed an i18n patch bug in cut (bug #129114).
  257. * Tue Aug 3 2004 Tim Waugh <twaugh@redhat.com>
  258. - Fixed colorls.{sh,csh} so that the l. and ll aliases are always defined
  259. (bug #128948).
  260. * Tue Jul 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-18
  261. - Fixed field extraction in sort (bug #127694).
  262. * Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com>
  263. - Added 'TERM screen.linux' to DIR_COLORS (bug #78816).
  264. * Wed Jun 23 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-17
  265. - Move pam-xauth to after pam-selinux
  266. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  267. - rebuilt
  268. * Mon Jun 7 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-15
  269. - Fix ls -Z (bug #125447).
  270. * Fri Jun 4 2004 Tim Waugh <twaugh@redhat.com>
  271. - Build requires bison (bug #125290).
  272. * Fri Jun 4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-14
  273. - Fix selinux patch causing problems with ls --format=... (bug #125238).
  274. * Thu Jun 3 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-13
  275. - Change su to use pam_selinux open and pam_selinux close
  276. * Wed Jun 2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-12
  277. - Don't call access() on symlinks about to be removed (bug #124699).
  278. * Wed Jun 2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-11
  279. - Fix ja translation (bug #124862).
  280. * Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 5.2.1-10
  281. - rebuild
  282. * Mon May 17 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-9
  283. - Mention pam in the info for su (bug #122592).
  284. - Remove wheel group rant again (bug #122886).
  285. - Change default behaviour for chgrp/chown (bug #123263). Patch from
  286. upstream.
  287. * Mon May 17 2004 Thomas Woerner <twoerner@redhat.com> 5.2.1-8
  288. - compiling su PIE
  289. * Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
  290. - Build requires new versions of autoconf and automake (bug #123098).
  291. * Tue May 4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-7
  292. - Fix join -t (bug #122435).
  293. * Tue Apr 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-6
  294. - Fix 'ls -Z' displaying users/groups if stat() failed (bug #121292).
  295. * Fri Apr 9 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-5
  296. - Add ls -LZ fix
  297. - Fix chcon to handle "."
  298. * Wed Mar 17 2004 Tim Waugh <twaugh@redhat.com>
  299. - Apply upstream fix for non-zero seconds for --date="10:00 +0100".
  300. * Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-3
  301. - If preserve fails, report as warning unless user requires preserve
  302. * Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-2
  303. - Make mv default to preserve on context
  304. * Sat Mar 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-1
  305. - 5.2.1.
  306. * Fri Mar 12 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-9
  307. - Add '-Z' to 'ls --help' output (bug #118108).
  308. * Fri Mar 5 2004 Tim Waugh <twaugh@redhat.com>
  309. - Fix deref-args test case for rebuilding under SELinux (bug #117556).
  310. * Wed Feb 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-8
  311. - kill(1) offloaded to util-linux altogether.
  312. * Tue Feb 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-7
  313. - Ship the real '[', not a symlink.
  314. * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-6
  315. - Apply Paul Eggert's chown patch (bug #116536).
  316. - Merged chdir patch into pam patch where it belongs.
  317. * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-5
  318. - Fixed i18n patch bug causing sort -M not to work (bug #116575).
  319. * Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-4
  320. - Reinstate kill binary, just not its man page (bug #116463).
  321. * Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-3
  322. - Updated ls-stat patch.
  323. * Fri Feb 20 2004 Dan Walsh <dwalsh@redhat.com> 5.2.0-2
  324. - fix chcon to ignore . and .. directories for recursing
  325. * Fri Feb 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-1
  326. - Patch ls so that failed stat() is handled gracefully (Ulrich Drepper).
  327. - 5.2.0.
  328. * Thu Feb 19 2004 Tim Waugh <twaugh@redhat.com>
  329. - More AFS patch tidying.
  330. * Wed Feb 18 2004 Dan Walsh <dwalsh@redhat.com> 5.1.3-0.2
  331. - fix chcon to handle -h qualifier properly, eliminate potential crash
  332. * Wed Feb 18 2004 Tim Waugh <twaugh@redhat.com>
  333. - Stop 'sort -g' leaking memory (i18n patch bug #115620).
  334. - Don't ship kill, since util-linux already does.
  335. - Tidy AFS patch.
  336. * Mon Feb 16 2004 Tim Waugh <twaugh@redhat.com> 5.1.3-0.1
  337. - 5.1.3.
  338. - Patches ported forward or removed.
  339. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 5.0-40
  340. - rebuilt
  341. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-39
  342. - Change /etc/pam.d/su to remove preservuser and add multiple
  343. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-38
  344. - Change is_selinux_enabled to is_selinux_enabled > 0
  345. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-37
  346. - Add pam_selinux to pam file to allow switching of roles within selinux
  347. * Fri Jan 16 2004 Tim Waugh <twaugh@redhat.com>
  348. - The textutils-2.0.17-mem.patch is no longer needed.
  349. * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 5.0-36
  350. - Fixed autoconf test causing builds to fail.
  351. * Tue Dec 9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-35
  352. - Fix copying to non xattr files
  353. * Thu Dec 4 2003 Tim Waugh <twaugh@redhat.com> 5.0-34.sel
  354. - Fix column widths problems in ls.
  355. * Tue Dec 2 2003 Tim Waugh <twaugh@redhat.com> 5.0-33.sel
  356. - Speed up md5sum by disabling speed-up asm.
  357. * Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-32.sel
  358. - Try again
  359. * Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-31.sel
  360. - Fix move on non SELinux kernels
  361. * Fri Nov 14 2003 Tim Waugh <twaugh@redhat.com> 5.0-30.sel
  362. - Fixed useless acl dependencies (bug #106141).
  363. * Fri Oct 24 2003 Dan Walsh <dwalsh@redhat.com> 5.0-29.sel
  364. - Fix id -Z
  365. * Tue Oct 21 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28.sel
  366. - Turn on SELinux
  367. - Fix chcon error handling
  368. * Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28
  369. - Turn off SELinux
  370. * Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27.sel
  371. - Turn on SELinux
  372. * Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27
  373. - Turn off SELinux
  374. * Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-26.sel
  375. - Turn on SELinux
  376. * Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  377. - allow compiling without pam support
  378. * Fri Oct 10 2003 Tim Waugh <twaugh@redhat.com> 5.0-23
  379. - Make split(1) handle large files (bug #106700).
  380. * Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-22
  381. - Turn off SELinux
  382. * Wed Oct 8 2003 Dan Walsh <dwalsh@redhat.com> 5.0-21.sel
  383. - Cleanup SELinux patch
  384. * Fri Oct 3 2003 Tim Waugh <twaugh@redhat.com> 5.0-20
  385. - Restrict ACL support to only those programs needing it (bug #106141).
  386. - Fix default PATH for LSB (bug #102567).
  387. * Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 5.0-19
  388. - Turn off SELinux
  389. * Wed Sep 10 2003 Dan Walsh <dwalsh@redhat.com> 5.0-18.sel
  390. - Turn on SELinux
  391. * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 5.0-17
  392. - Turn off SELinux
  393. * Tue Sep 2 2003 Dan Walsh <dwalsh@redhat.com> 5.0-16.sel
  394. - Only call getfilecon if the user requested it.
  395. - build with selinux
  396. * Wed Aug 20 2003 Tim Waugh <twaugh@redhat.com> 5.0-14
  397. - Documentation fix (bug #102697).
  398. * Tue Aug 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-13
  399. - Made su use pam again (oops).
  400. - Fixed another i18n bug causing sort --month-sort to fail.
  401. - Don't run dubious stty test, since it fails when backgrounded
  402. (bug #102033).
  403. - Re-enable make check.
  404. * Fri Aug 8 2003 Tim Waugh <twaugh@redhat.com> 5.0-12
  405. - Don't run 'make check' for this build (build environment problem).
  406. - Another uninitialized variable in i18n (from bug #98683).
  407. * Wed Aug 6 2003 Dan Walsh <dwalsh@redhat.com> 5.0-11
  408. - Internationalize runcon
  409. - Update latest chcon from NSA
  410. * Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com>
  411. - Re-enable make check.
  412. * Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-9
  413. - Don't run 'make check' for this build (build environment problem).
  414. * Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-8
  415. - Actually use the ACL patch (bug #100519).
  416. * Fri Jul 18 2003 Dan Walsh <dwalsh@redhat.com> 5.0-7
  417. - Convert to SELinux
  418. * Mon Jun 9 2003 Tim Waugh <twaugh@redhat.com>
  419. - Removed samefile patch. Now the test suite passes.
  420. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  421. - rebuilt
  422. * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-5
  423. - Both kon and kterm support colours (bug #83701).
  424. - Fix 'ls -l' alignment in zh_CN locale (bug #88346).
  425. * Mon May 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-4
  426. - Prevent file descriptor leakage in du (bug #90563).
  427. - Build requires recent texinfo (bug #90439).
  428. * Wed Apr 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-3
  429. - Allow obsolete options unless POSIXLY_CORRECT is set.
  430. * Sat Apr 12 2003 Tim Waugh <twaugh@redhat.com>
  431. - Fold bug was introduced by i18n patch; fixed there instead.
  432. * Fri Apr 11 2003 Matt Wilson <msw@redhat.com> 5.0-2
  433. - fix segfault in fold (#88683)
  434. * Sat Apr 5 2003 Tim Waugh <twaugh@redhat.com> 5.0-1
  435. - 5.0.
  436. * Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com>
  437. - Use _smp_mflags.
  438. * Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-2
  439. - Remove overwrite patch.
  440. - No longer seem to need nolibrt, errno patches.
  441. * Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com>
  442. - No longer seem to need danglinglink, prompt, lug, touch_errno patches.
  443. * Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-1
  444. - 4.5.11.
  445. - Use packaged readlink.
  446. * Wed Mar 19 2003 Tim Waugh <twaugh@redhat.com> 4.5.10-1
  447. - 4.5.10.
  448. - Update lug, touch_errno, acl, utmp, printf-ll, i18n, test-bugs patches.
  449. - Drop fr_fix, LC_TIME, preserve, regex patches.
  450. * Wed Mar 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-21
  451. - Fixed another i18n patch bug (bug #82032).
  452. * Tue Mar 11 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-20
  453. - Fix sort(1) efficiency in multibyte encoding (bug #82032).
  454. * Tue Feb 18 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-19
  455. - Ship readlink(1) (bug #84200).
  456. * Thu Feb 13 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-18
  457. - Deal with glibc < 2.2 in %%pre scriplet (bug #84090).
  458. * Wed Feb 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-16
  459. - Require glibc >= 2.2 (bug #84090).
  460. * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 4.5.3-15
  461. - fix group (#84095)
  462. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.5.3-14
  463. - rebuilt
  464. * Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com>
  465. - Fix rm(1) man page.
  466. * Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-13
  467. - Fix re_compile_pattern check.
  468. - Fix su hang (bug #81653).
  469. * Tue Jan 14 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-11
  470. - Fix memory size calculation.
  471. * Tue Dec 17 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-10
  472. - Fix mv error message (bug #79809).
  473. * Mon Dec 16 2002 Tim Powers <timp@redhat.com> 4.5.3-9
  474. - added PreReq on grep
  475. * Fri Dec 13 2002 Tim Waugh <twaugh@redhat.com>
  476. - Fix cp --preserve with multiple arguments.
  477. * Thu Dec 12 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-8
  478. - Turn on colorls for screen (bug #78816).
  479. * Mon Dec 9 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-7
  480. - Fix mv (bug #79283).
  481. - Add patch27 (nogetline).
  482. * Sun Dec 1 2002 Tim Powers <timp@redhat.com> 4.5.3-6
  483. - use the su.pamd from sh-utils since it works properly with multilib systems
  484. * Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-5
  485. - Fix test suite quoting problems.
  486. * Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-4
  487. - Fix scriplets.
  488. - Fix i18n patch so it doesn't break uniq.
  489. - Fix several other patches to either make the test suite pass or
  490. not run the relevant tests.
  491. - Run 'make check'.
  492. - Fix file list.
  493. * Thu Nov 28 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-3
  494. - Adapted for Red Hat Linux.
  495. - Self-host for help2man.
  496. - Don't ship readlink just yet (maybe later).
  497. - Merge patches from fileutils and sh-utils (textutils ones are already
  498. merged it seems).
  499. - Keep the binaries where the used to be (in particular, id and stat).
  500. * Sun Nov 17 2002 Stew Benedict <sbenedict@mandrakesoft.com> 4.5.3-2mdk
  501. - LI18NUX/LSB compliance (patch800)
  502. - Installed (but unpackaged) file(s) - /usr/share/info/dir
  503. * Thu Oct 31 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.3-1mdk
  504. - new release
  505. - rediff patch 180
  506. - merge patch 150 into 180
  507. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-6mdk
  508. - move su back to /bin
  509. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-5mdk
  510. - patch 0 : lg locale is illegal and must be renamed lug (pablo)
  511. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-4mdk
  512. - fix conflict with procps
  513. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-3mdk
  514. - patch 105 : fix install -s
  515. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-2mdk
  516. - fix build
  517. - don't chmode two times su
  518. - build with large file support
  519. - fix description
  520. - various spec cleanups
  521. - fix chroot installation
  522. - fix missing /bin/env
  523. - add old fileutils, sh-utils & textutils ChangeLogs
  524. * Fri Oct 11 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-1mdk
  525. - initial release (merge fileutils, sh-utils & textutils)
  526. - obsoletes/provides: sh-utils/fileutils/textutils
  527. - fileutils stuff go in 1xx range
  528. - sh-utils stuff go in 7xx range
  529. - textutils stuff go in 5xx range
  530. - drop obsoletes patches 1, 2, 10 (somes files're gone but we didn't ship
  531. most of them)
  532. - rediff patches 103, 105, 111, 113, 180, 706
  533. - temporary disable patch 3 & 4
  534. - fix fileutils url