OpenColorIO-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246
  1. %bcond_with doc
  2. # Filter provides from Python libraries
  3. %{?filter_setup:
  4. %filter_provides_in %{python3_sitearch}.*\.so$
  5. %filter_setup
  6. }
  7. Name: OpenColorIO
  8. Version: 2.1.0
  9. Release: 1%{?_dist_release}
  10. Summary: Enables color transforms and image display across graphics apps
  11. Summary(ja): アプリケーション間での色変換と画像表示を行うためのライブラリ
  12. Group: system
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. License: BSD
  16. URL: https://opencolorio.org/
  17. # Github archive was generated on the fly using the following URL:
  18. # https://github.com/imageworks/OpenColorIO/tarball/v1.0.8
  19. Source0: https://github.com/AcademySoftwareFoundation/OpenColorIO/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  20. # https://github.com/AcademySoftwareFoundation/OpenColorIO/issues/1296
  21. Patch0: ocio-install.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: cmake
  24. BuildRequires: git
  25. BuildRequires: help2man
  26. BuildRequires: python3-devel
  27. BuildRequires: python3-rpm-macros
  28. %if %{with doc}
  29. BuildRequires: texlive-collection-fontsrecommended
  30. BuildRequires: texlive-collection-latexextra
  31. BuildRequires: texlive-collection-latexrecommended
  32. %endif
  33. # Libraries
  34. BuildRequires: OpenEXR-devel
  35. BuildRequires: libboost-devel
  36. BuildRequires: expat-devel
  37. BuildRequires: freeglut-devel
  38. BuildRequires: glew-devel
  39. BuildRequires: libX11-devel libXmu-devel libXi-devel
  40. BuildRequires: mesa-libGL-devel mesa-libGLU-devel
  41. #BuildRequires: opencv-devel
  42. BuildRequires: pybind11-devel
  43. BuildRequires: python3-devel
  44. BuildRequires: python3-pip
  45. #BuildRequires: pystring-devel
  46. BuildRequires: zlib-devel
  47. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  48. # If an ABI incompatible update is done in one, the other also needs to be
  49. # rebuilt.
  50. BuildRequires: OpenImageIO-devel
  51. #######################
  52. # Unbundled libraries #
  53. #######################
  54. BuildRequires: lcms2-devel
  55. #BuildRequires: yaml-cpp-devel
  56. # The following bundled projects are only used for document generation.
  57. #BuildRequires: python-docutils
  58. #BuildRequires: python-jinja2
  59. #BuildRequires: python-pygments
  60. #BuildRequires: python-setuptools
  61. #BuildRequires: python-sphinx
  62. %if ! %{with doc}
  63. Obsoletes: %{name}-doc < %{version}-%{release}
  64. %endif
  65. %description
  66. OCIO enables color transforms and image display to be handled in a consistent
  67. manner across multiple graphics applications. Unlike other color management
  68. solutions, OCIO is geared towards motion-picture post production, with an
  69. emphasis on visual effects and animation color pipelines.
  70. %package devel
  71. Summary: Development libraries and headers for %{name}
  72. Summary(ja): %{name} の開発用ライブラリおよびヘッダファイル
  73. Group: programming
  74. Requires: %{name} = %{version}-%{release}
  75. %description devel
  76. Development libraries and headers for %{name}.
  77. %package doc
  78. Summary: API Documentation for %{name}
  79. Summary(ja): %{name} API のドキュメント
  80. Group: documentation
  81. BuildArch: noarch
  82. Requires: %{name} = %{version}-%{release}
  83. %description doc
  84. API documentation for %{name}.
  85. %debug_package
  86. %prep
  87. %autosetup -p1
  88. %build
  89. rm -rf %{_vpath_builddir}
  90. export CXXFLAGS="%{optflags} -Wno-deprecated-declarations -Wno-cast-function-type -Wno-unused-function"
  91. %cmake \
  92. -DPYTHON=%{__python3} \
  93. -DPYLIB_INSTALL_DIR:PATH=%{python3_sitearch} \
  94. -DOCIO_BUILD_STATIC=OFF \
  95. %if %{with doc}
  96. -DOCIO_BUILD_DOCS=ON \
  97. %else
  98. -DOCIO_BUILD_DOCS=OFF \
  99. %endif
  100. -DOCIO_BUILD_TESTS=ON \
  101. -DOCIO_USE_HEADLESS=ON \
  102. -DOCIO_PYGLUE_SONAME=OFF \
  103. -DUSE_EXTERNAL_YAML=FALSE \
  104. -DUSE_EXTERNAL_LCMS=TRUE \
  105. %ifnarch x86_64
  106. -DOCIO_USE_SSE=OFF \
  107. %endif
  108. -DOpenGL_GL_PREFERENCE=GLVND
  109. %cmake_build
  110. %install
  111. rm -rf %{buildroot}
  112. %cmake_install
  113. # Remove static libs
  114. find %{buildroot} -type f -name "*.a" -exec rm -f {} \;
  115. # Generate man pages
  116. pushd %{_vpath_builddir}/src/apps
  117. mkdir -p %{buildroot}%{_mandir}/man1
  118. for app in ociobakelut ociocheck ociochecklut ocioconvert ociolutimage ociomakeclf ocioperf ociowrite; do \
  119. help2man -N -s 1 %{?fedora:--version-string=%{version}} \
  120. -o %{buildroot}%{_mandir}/man1/$app.1 \
  121. $app/$app
  122. done
  123. popd
  124. # Move installed documentation back so it doesn't conflict with the main package
  125. %if %{with doc}
  126. rm -rf _tmpdoc
  127. mkdir -p _tmpdoc
  128. mv %{buildroot}%{_docdir}/%{name}/* _tmpdoc/
  129. %endif
  130. %check
  131. # Testing passes locally in mock but fails on the fedora build servers.
  132. #pushd build && make test
  133. %clean
  134. rm -rf %{buildroot}
  135. %files
  136. %license LICENSE
  137. %doc CHANGELOG* README*
  138. %{_bindir}/*
  139. %{_libdir}/*.so.*
  140. %dir %{_datadir}/ocio
  141. %{_datadir}/ocio/setup_ocio.sh
  142. %{_mandir}/man1/*
  143. %{python3_sitearch}/*.so
  144. %files devel
  145. %{_includedir}/OpenColorIO/
  146. %{_libdir}/*.so
  147. %dir %{_libdir}/pkgconfig
  148. %{_libdir}/pkgconfig/%{name}.pc
  149. %dir %{_libdir}/cmake
  150. %{_libdir}/cmake/*
  151. %if %{with doc}
  152. %files doc
  153. %doc _tmpdoc/*
  154. %endif
  155. %changelog
  156. * Wed Sep 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.1.0-1
  157. - new upstream release.
  158. - dropped ldconfig scriptlets.
  159. - dropped Patch1.
  160. - imported Patch0 from rawhide.
  161. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.1-1
  162. - new upstream release.
  163. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.8-8
  164. - rebuild with gcc-5.4.0
  165. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.8-7
  166. - Initial build for Vine Linux
  167. - used bundled yaml-cpp
  168. * Mon Sep 23 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-6
  169. - Rebuild against yaml-cpp03 compatibility package.
  170. * Mon Aug 26 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-5
  171. - Fix for new F20 feature, unversion doc dir. Fixes BZ#1001264
  172. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-3
  173. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  174. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-2
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  176. * Tue Dec 11 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-1
  177. - Update to latest upstream release.
  178. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  180. * Thu Apr 26 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-4
  181. - Only use SSE instructions on x86_64.
  182. * Wed Apr 25 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-3
  183. - Misc spec cleanup for packaging guidelines.
  184. - Disable testing for now since it fails on the build servers.
  185. * Wed Apr 18 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-1
  186. - Latest upstream release.
  187. * Thu Apr 05 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.6-1
  188. - Latest upstream release.
  189. * Wed Nov 16 2011 Richard Shaw <hobbes1069@gmail.com> - 1.0.2-1
  190. - Initial release.