OpenImageIO-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317
  1. %bcond_with external_pugixml
  2. %global subname oiio
  3. Name: OpenImageIO
  4. Version: 2.2.18.0
  5. Release: 1%{?_dist_release}
  6. Summary: Library for reading and writing images
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. URL: https://sites.google.com/site/openimageio/home
  12. Source0: https://github.com/OpenImageIO/oiio/archive/v%{version}.tar.gz#/oiio-%{version}.tar.gz
  13. # Images for test suite
  14. #Source1: oiio-images.tar.gz
  15. BuildRequires: cmake
  16. BuildRequires: git
  17. BuildRequires: txt2man
  18. BuildRequires: qt5-qtbase-devel
  19. BuildRequires: fmt-devel
  20. BuildRequires: robin-map-devel
  21. BuildRequires: libboost-devel
  22. BuildRequires: libboost-python3
  23. BuildRequires: libboost-filesystem
  24. #BuildRequires: glew-devel
  25. BuildRequires: OpenEXR-devel
  26. BuildRequires: python3-devel
  27. BuildRequires: python3-rpm-macros
  28. # BuildRequires: openssl-devel
  29. BuildRequires: libpng-devel libtiff-devel openjpeg2-devel giflib-devel
  30. BuildRequires: libwebp-devel
  31. BuildRequires: Field3D-devel
  32. BuildRequires: hdf5-devel
  33. BuildRequires: zlib-devel
  34. BuildRequires: jasper-devel
  35. BuildRequires: LibRaw-devel
  36. %if %{with external_pugixml}
  37. BuildRequires: pugixml-devel
  38. %endif
  39. BuildRequires: pybind11-devel
  40. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  41. # If an ABI incompatible update is done in one, the other also needs to be
  42. # rebuilt.
  43. BuildRequires: OpenColorIO-devel
  44. Obsoletes: python-OpenImageIO
  45. # We don't want to provide private python extension libs
  46. %{?filter_setup:
  47. %filter_provides_in %{python3_sitearch}/.*\.so$
  48. %filter_setup
  49. }
  50. %description
  51. OpenImageIO is a library for reading and writing images, and a bunch of related
  52. classes, utilities, and applications. Main features include:
  53. - Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
  54. writing 2D images that is format agnostic.
  55. - Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
  56. DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
  57. PNM/PPM/PGM/PBM, Field3d.
  58. - An ImageCache class that transparently manages a cache so that it can access
  59. truly vast amounts of image data.
  60. %package -n python3-%{name}
  61. Summary: Python 3 bindings for %{name}
  62. Group: programming
  63. Requires: %{name} = %{version}-%{release}
  64. %description -n python3-%{name}
  65. Python3 bindings for %{name}.
  66. %package utils
  67. Summary: Command line utilities for %{name}
  68. Group: graphics
  69. Requires: %{name} = %{version}-%{release}
  70. %description utils
  71. Command-line tools to manipulate and get information on images using the
  72. %{name} library.
  73. %package iv
  74. Summary: %{name} based image viewer
  75. Group: graphics
  76. Requires: %{name} = %{version}-%{release}
  77. %description iv
  78. A really nice image viewer, iv, based on %{name} classes (and so will work
  79. with any formats for which plugins are available).
  80. %package devel
  81. Summary: Documentation for %{name}
  82. Group: programming
  83. Requires: %{name} = %{version}-%{release}
  84. %description devel
  85. Development files for package %{name}
  86. %debug_package
  87. %prep
  88. %setup -q -n oiio-%{version}
  89. %if %{with external_pugixml}
  90. # Remove bundled pugixml
  91. rm -f src/include/OpenImageIO/pugixml.hpp \
  92. src/include/OpenImageIO/pugiconfig.hpp \
  93. src/libutil/OpenImageIO/pugixml.cpp
  94. %endif
  95. # Remove bundled tbb
  96. %{__rm} -rf src/include/tbb
  97. # Install test images
  98. #rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
  99. #tar --strip-components=1 -xzf %{SOURCE1}
  100. %build
  101. %{__rm} -rf %{_vpath_builddir}
  102. # CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
  103. # CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
  104. %cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  105. -DCMAKE_CXX_STANDARD=17 \
  106. -DCMAKE_SKIP_RPATH:BOOL=TRUE \
  107. -DBUILDSTATIC=OFF \
  108. -DLINKSTATIC=OFF \
  109. -DPYTHON_VERSION=%{python3_version} \
  110. -DINSTALL_DOCS:BOOL=FALSE \
  111. -DINSTALL_FONTS:BOOL=FALSE \
  112. %if %{with external_pugixml}
  113. -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
  114. %endif
  115. -DUSE_TBB:BOOL=FALSE \
  116. -DUSE_OPENSSL:BOOL=TRUE \
  117. -DSTOP_ON_WARNING:BOOL=FALSE \
  118. -DJPEG_INCLUDE_DIR=%{_includedir} \
  119. -DOPENJPEG_INCLUDE_DIR=$(pkg-config --variable=includedir libopenjp2) \
  120. -DOpenGL_GL_PREFERENCE=GLVND \
  121. -DVERBOSE=TRUE
  122. %cmake_build
  123. %install
  124. %cmake_install
  125. # # Move man pages to the right directory
  126. # mkdir -p %{buildroot}%{_mandir}/man1
  127. # cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
  128. %files
  129. %license LICENSE*
  130. %doc CHANGES.md CONTRIBUTING.md README.md
  131. %{_libdir}/libOpenImageIO.so.*
  132. %{_libdir}/libOpenImageIO_Util.so.*
  133. %files -n python3-%{name}
  134. %{python3_sitearch}/OpenImageIO*.so
  135. %files utils
  136. %exclude %{_bindir}/iv
  137. %{_bindir}/*
  138. # %exclude %{_mandir}/man1/iv.1.gz
  139. # %{_mandir}/man1/*.1.gz
  140. %files iv
  141. %{_bindir}/iv
  142. # %{_mandir}/man1/iv.1.gz
  143. %files devel
  144. %{_libdir}/libOpenImageIO.so
  145. %{_libdir}/libOpenImageIO_Util.so
  146. %dir %{_libdir}/pkgconfig
  147. %{_libdir}/pkgconfig/OpenImageIO.pc
  148. %dir %{_datadir}/cmake
  149. %dir %{_datadir}/cmake/Modules
  150. %dir %{_libdir}/cmake/OpenImageIO
  151. %{_datadir}/cmake/Modules/FindOpenImageIO.cmake
  152. %{_libdir}/cmake/OpenImageIO/*
  153. %{_includedir}/*
  154. %changelog
  155. * Wed Sep 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.18.0-1
  156. - new upstream release.
  157. - dropped ldconfig scriptlets.
  158. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.11.1-1
  159. - new upstream release.
  160. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9.0-1
  161. - new upstream release.
  162. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6.1-1
  163. - new upstream release.
  164. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.10.1-1
  165. - new upstream release.
  166. - built with boost-1.72.0.
  167. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.11-1
  168. - new upstream release.
  169. * Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
  170. - update to 1.8.17
  171. * Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
  172. - update to 1.8.16
  173. - change BuildRequires: qt4-devel to qt5-qtbase-devel
  174. - drop BuildRequires: openssl-devel
  175. * Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
  176. - update to 1.7.19
  177. - using macro
  178. * Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
  179. - rebuild with hdf5-1.8.20
  180. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
  181. - update to 1.7.17
  182. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
  183. - rebuilt with LibRaw-0.17.2.
  184. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
  185. - rebuild with gcc-5.4.0
  186. * Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  187. - new upstream release
  188. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
  189. - new upstream release
  190. - remove Patch0
  191. - create python-%%{name} subpackage
  192. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
  193. - rebuild with glew-1.13.0
  194. * Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
  195. - initial build for Vine Linux
  196. - add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
  197. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
  198. - rebuild (openexr)
  199. * Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
  200. - Update to latest upstream release.
  201. * Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
  202. - Update to latest upstream release.
  203. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
  204. - Rebuild for Field3D 1.4.3.
  205. * Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
  206. - Rebuild for pugixml 1.4
  207. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
  208. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  209. * Fri Aug 1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
  210. - Update to latest upstream release.
  211. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
  212. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  213. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
  214. - Rebuild for boost 1.55.0
  215. * Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
  216. - rebuild for boost 1.55.0
  217. * Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
  218. - Update to latest upstream release.
  219. * Tue Jan 7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
  220. - Update to latest upstream release.
  221. - Add libgif as build requirement.
  222. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
  223. - rebuild (openexr)
  224. * Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
  225. - rebuilt for GLEW 1.10
  226. * Wed Nov 6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
  227. - Update to latest upstream release.
  228. - Fix ppc builds (BZ#1021977).
  229. - Add conditionals to build requirements for EPEL 6.
  230. * Wed Oct 2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
  231. - Update to latest upstream release.
  232. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
  233. - rebuild (ilmbase/openexr)
  234. * Thu Aug 8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  235. - Update to latest upstream release.
  236. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  237. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  238. * Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
  239. - Rebuild for boost 1.54.0