gnome-sharp2-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %define mono_dir %(/usr/bin/monodir)
  2. %define _name gnome-sharp
  3. Summary: .Net Language Bindings for Gnome
  4. Summary(ja): Mono 用 GNOME バインディング
  5. Name: gnome-sharp2
  6. Version: 2.24.1
  7. Release: 6%{?_dist_release}
  8. License: GNU General ublic License (GPL), GNU Library General Public License v. 2.0 and 2.1 (LGPL)
  9. Group: Development/Libraries
  10. URL: http://gtk-sharp.sf.net
  11. Source: %{_name}-%{version}.tar.bz2
  12. Patch2: gnome-sharp-find_gtkhtml_ver.patch
  13. Patch3: gnome-sharp-2.24.1-TestXfer.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk-sharp2 gtk-sharp2-gapi
  16. BuildRequires: librsvg2-devel
  17. BuildRequires: mono-devel monodoc
  18. BuildRequires: vte-devel gtkhtml3-devel
  19. %define env_options export MONO_SHARED_DIR=/tmp
  20. %description
  21. This package contains Mono bindings for Gnome.
  22. %package -n gnome-sharp2-complete
  23. Group: Development/Libraries
  24. Summary: GTK+ and GNOME bindings for Mono (virtual package)
  25. Requires: art-sharp2 = %{version}-%{release}
  26. Requires: gconf-sharp2 = %{version}-%{release}
  27. Requires: gnome-sharp2 = %{version}-%{release}
  28. Requires: gnome-vfs-sharp2 = %{version}-%{release}
  29. #Requires: glib-sharp2 >= 2.10.3
  30. %description -n gnome-sharp2-complete
  31. Gtk# is a library that allows you to build fully native graphical GNOME
  32. applications using Mono. Gtk# is a binding to GTK+, the cross platform
  33. user interface toolkit used in GNOME. It includes bindings for Gtk,
  34. Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas. (Virtual
  35. package which depends on all gtk-sharp2 subpackages)
  36. %package -n gnome-vfs-sharp2
  37. Summary: Mono bindings for gnomevfs
  38. Group: Development/Libraries
  39. Requires: gnome-vfs2
  40. %description -n gnome-vfs-sharp2
  41. This package contains Mono bindings gnomevfs.
  42. %package -n art-sharp2
  43. Summary: Mono bindings for libart
  44. Group: Development/Libraries
  45. Requires: libart_lgpl
  46. %description -n art-sharp2
  47. This package contains Mono bindings for libart.
  48. %package -n gconf-sharp2
  49. Summary: Mono bindings for gconf
  50. Group: Development/Libraries
  51. %description -n gconf-sharp2
  52. This package contains Mono bindings for gconf and gconf peditors.
  53. %prep
  54. %setup -q -n %{_name}-%{version}
  55. %patch3 -p1 -b .TestXfer
  56. autoreconf -f -i
  57. %build
  58. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  59. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  60. %configure \
  61. --libexecdir=%{_prefix}/lib \
  62. --enable-debug
  63. make
  64. %install
  65. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  66. %makeinstall
  67. ## remove unuse files
  68. rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
  69. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
  70. rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %files -n gnome-sharp2-complete
  74. %defattr(-, root, root)
  75. ## This is the 'base' package so we put the common dirs of all in this package
  76. # Otherwise, this package doesn't get created!
  77. %dir %{mono_dir}/gtk-sharp-2.0
  78. %dir %{_prefix}/lib/gtk-sharp-2.0
  79. %files -n gnome-sharp2
  80. %defattr(-,root,root)
  81. %{_libdir}/libgnomesharpglue-2.so
  82. %{_libdir}/pkgconfig/gnome-sharp-2.0.pc
  83. %{mono_dir}/gac/*gnome-sharp
  84. %{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
  85. %{_datadir}/gapi-2.0/gnome-api.xml
  86. %files -n gnome-vfs-sharp2
  87. %defattr(-,root,root)
  88. %{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
  89. %{mono_dir}/gac/*gnome-vfs-sharp
  90. %{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
  91. %{_datadir}/gapi-2.0/gnome-vfs-api.xml
  92. %files -n art-sharp2
  93. %defattr(-,root,root)
  94. %{_libdir}/pkgconfig/art-sharp-2.0.pc
  95. %{mono_dir}/gac/*art-sharp
  96. %{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
  97. %{_datadir}/gapi-2.0/art-api.xml
  98. %files -n gconf-sharp2
  99. %defattr(-, root, root)
  100. %{_bindir}/gconfsharp2-schemagen
  101. %{_libdir}/pkgconfig/gconf-sharp-2.0.pc
  102. %{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
  103. %{mono_dir}/gac/*gconf-sharp
  104. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
  105. # Other distros place these in gnome-sharp2??
  106. %{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
  107. %{mono_dir}/gac/*gconf-sharp-peditors
  108. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
  109. %changelog
  110. * Sat Oct 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-6
  111. - added gnome-sharp-2.24.1-TestXfer.patch
  112. - rebuilt with mono-2.8
  113. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.1-5
  114. - build with rpm-4.8.1-1 for pkg-config file
  115. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-4
  116. - rebuilt with new environment
  117. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
  118. - rebuilt with latest rpm to update mono-dependencies
  119. - dropt BR: libgnomedb-devel
  120. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
  121. - changed Group to Development/Libraries
  122. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
  123. - updated to 2.24.1
  124. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
  125. - initial build for VineSeed
  126. - updated gnome-sharp2 to 2.20.0
  127. - added japanese summary
  128. - applied vine versioning policy
  129. - spec in utf-8
  130. * Thu Apr 24 2008 wberrier@suse.de
  131. - Update to 2.12.1
  132. * Bugfix in GLib ref management for Gnome.Program crash in
  133. gnome-sharp
  134. * Thu Apr 3 2008 wberrier@novell.com
  135. - Can now build 2.16 and 2.20 from the same spec
  136. - Update to 2.20.0
  137. - Updated bindings to coincide with gtk# 2.12
  138. - Removed bindings: gtkhtml#, rsvg#, and vte#
  139. * Wed Mar 26 2008 wberrier@novell.com
  140. - Update to 2.16.1
  141. - Allow storage of empty lists in gconf
  142. - Bug fixes:
  143. - [GConf] Impossible to set empty list values (bnc#325516)
  144. - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
  145. * Tue Jul 3 2007 wberrier@suse.de
  146. - Initial package of gnome-sharp2 2.16.0
  147. - (Split from gtk-sharp 2.8.3)