gtk-sharp2-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176
  1. %define mono_dir %(/usr/bin/monodir)
  2. %define _name gtk-sharp
  3. Name: gtk-sharp2
  4. Version: 2.12.10
  5. Release: 4%{?_dist_release}
  6. Summary: GTK+ bindings for Mono
  7. Summary(ja): Mono 用 GTK+ バインディング
  8. Group: System Environment/Libraries
  9. License: LGPL
  10. URL: http://gtk-sharp.sf.net
  11. Source: http://ftp.gnome.org/pub/gnome/sources/%{_name}/2.12/%{_name}-%{version}.tar.bz2
  12. Patch1: gtk-sharp2-vtelibs.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: mono-devel
  15. BuildRequires: monodoc
  16. BuildRequires: glib2-devel >= 2.12.0
  17. BuildRequires: pango-devel
  18. BuildRequires: atk-devel
  19. BuildRequires: gtk2-devel >= 2.12.0
  20. BuildRequires: libglade2-devel
  21. BuildRequires: automake, libtool
  22. # Mono only availible on these:
  23. ExclusiveArch: %{ix86} x86_64 ppc ia64 armv4l sparc s390 s390x
  24. %description
  25. This package provides a library that allows you to build
  26. fully native graphical GNOME applications using Mono. Gtk#
  27. is a binding to GTK+, the cross platform user interface
  28. toolkit used in GNOME. It includes bindings for Gtk, Atk,
  29. Pango, Gdk, libgnome, libgnomeui and libgnomecanvas. Gtk#
  30. 2.4.x binds GTK+ 2.4.
  31. %package gapi
  32. Group: Development/Languages
  33. Summary: Glib and GObject C source parser and C generator for the creation and maintenance of managed bindings for Mono and .NET
  34. Requires: perl-XML-LibXML-Common perl-XML-LibXML perl-XML-SAX
  35. %description gapi
  36. This package provides developer tools for the creation and
  37. maintainance of managed bindings to native libraries which utilize
  38. glib and GObject. Some examples of libraries currently bound using
  39. the GAPI tools and found in Gtk# include Gtk, Atk, Pango, Gdk,
  40. libgnome, libgnomeui and libgnomecanvas.
  41. %prep
  42. %setup -q -n %{_name}-%{version}
  43. %if 0
  44. %patch1 -p1 -b .vte
  45. ## need to re-automake for gtk-sharp2-vtelibs.patch
  46. aclocal-1.7
  47. libtoolize --force
  48. automake-1.7 --add-missing
  49. autoconf
  50. %endif
  51. %build
  52. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  53. %configure
  54. make
  55. %install
  56. %{__rm} -rf $RPM_BUILD_ROOT
  57. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  58. make install DESTDIR=$RPM_BUILD_ROOT GACUTIL_FLAGS="/package gtk-sharp /gacdir %{_prefix}/lib /root ${RPM_BUILD_ROOT}%{_prefix}/lib"
  59. ## remove unused files
  60. %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.a
  61. %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
  62. mv $RPM_BUILD_ROOT%{mono_dir}/gtk-sharp $RPM_BUILD_ROOT%{mono_dir}/gtk-sharp-2.0
  63. %clean
  64. %{__rm} -rf $RPM_BUILD_ROOT
  65. %files
  66. %defattr(-,root,root,-)
  67. %doc COPYING ChangeLog README
  68. %{_libdir}/libatksharpglue-2.so
  69. %{_libdir}/libgdksharpglue-2.so
  70. %{_libdir}/libgladesharpglue-2.so
  71. %{_libdir}/libglibsharpglue-2.so
  72. %{_libdir}/libgtksharpglue-2.so
  73. %{_libdir}/libpangosharpglue-2.so
  74. %{_libdir}/pkgconfig/*-sharp-2.0.pc
  75. %{_libdir}/pkgconfig/gtk-dotnet-2.0.pc
  76. %dir %{_prefix}/lib/gtk-sharp-2.0
  77. %{mono_dir}/gac/atk-sharp
  78. %{mono_dir}/gac/gdk-sharp
  79. %{mono_dir}/gac/glade-sharp
  80. %{mono_dir}/gac/glib-sharp
  81. %{mono_dir}/gac/gtk-dotnet
  82. %{mono_dir}/gac/gtk-sharp
  83. %{mono_dir}/gac/pango-sharp
  84. %{mono_dir}/gac/policy.2.10.*
  85. %{mono_dir}/gac/policy.2.4.*
  86. %{mono_dir}/gac/policy.2.6.*
  87. %{mono_dir}/gac/policy.2.8.*
  88. %{mono_dir}/gtk-sharp-2.0
  89. %{_prefix}/lib/monodoc/sources/gtk-sharp-docs.*
  90. %files gapi
  91. %defattr(-,root,root,-)
  92. %{_bindir}/gapi2-codegen
  93. %{_bindir}/gapi2-fixup
  94. %{_bindir}/gapi2-parser
  95. %{_prefix}/lib/gtk-sharp-2.0/gapi-fixup.exe
  96. %{_prefix}/lib/gtk-sharp-2.0/gapi-parser.exe
  97. %{_prefix}/lib/gtk-sharp-2.0/gapi_codegen.exe
  98. %{_prefix}/lib/gtk-sharp-2.0/gapi2xml.pl
  99. %{_prefix}/lib/gtk-sharp-2.0/gapi_pp.pl
  100. %{_libdir}/pkgconfig/gapi-2.0.pc
  101. %{_prefix}/share/gapi-2.0
  102. %changelog
  103. * Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.10-4
  104. - rebuilt with mono-2.8
  105. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.12.10-3
  106. - build with rpm-4.8.1-1 for pkg-config file
  107. * Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.10-2
  108. - updated build dependencies
  109. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.10-1
  110. - updated gtk-sharp to 2.12.10
  111. * Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.12.9-2
  112. - rebuilt with mono-2.6.1
  113. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.12.9-1
  114. - updated gtk-sharp to 2.12.9
  115. - built with latest rpm to update mono-dependencies
  116. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.12.8-1vl5
  117. - updated gtk-sharp to 2.12.8
  118. * Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.5-1vl5
  119. - updated gtk-sharp to 2.12.5
  120. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.3-1vl5
  121. - updated gtk-sharp to 2.12.3
  122. - dropt gtk-sharp2-vtelibs.patch
  123. - built with mono-2.0
  124. * Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 2.8.2-2vl5
  125. - applied new versioning policy, spec in utf-8
  126. - use automake-1.7
  127. * Sun Apr 2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.8.2-1vl1
  128. - rebuilt for Vine Linux
  129. * Fri Mar 3 2006 Christopher Aillon <caillon@redhat.com> - 2.8.2-1
  130. - Update to 2.8.2 to fix an issue with marshalling on x86-64
  131. * Fri Feb 10 2006 Christopher Aillon <caillon@redhat.com> - 2.8.1-1
  132. - Update to 2.8.1
  133. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.8.0-1.1
  134. - rebuilt for new gcc4.1 snapshot and glibc changes
  135. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> 2.8.0-1
  136. - Update to 2.8.0
  137. * Thu Jan 19 2006 Alexander Larsson <alexl@redhat.com> 2.4.0-3
  138. - Mono now builds on s390x
  139. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 2.4.0-2
  140. - Fix vte build
  141. * Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 2.4.0-1
  142. - Initial version