mono-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803
  1. Summary: .NET runtime environment
  2. Summary(ja): .NET ランタイム環境
  3. Name: mono
  4. Version: 2.8
  5. Release: 1%{?_dist_release}
  6. Group: Development/Languages
  7. License: GPL, LGPL, MIT X11
  8. URL: http://www.mono-project.com/
  9. Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
  10. Source1: monodir.c
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: bison
  13. BuildRequires: glib2-devel
  14. BuildRequires: pkgconfig
  15. BuildRequires: libicu-devel
  16. BuildRequires: libgdiplus-devel >= 2.0
  17. BuildRequires: zlib-devel
  18. # JIT only availible on these:
  19. ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
  20. Obsoletes: %{name}-jscript < 2.8
  21. Obsoletes: %{name}-data-sybase < 2.8
  22. Obsoletes: %{name}-data-firebird < 2.8
  23. Obsoletes: bytefx-data-mysql < 2.8
  24. %description
  25. The Mono runtime implements a JIT engine for the ECMA CLI
  26. virtual machine (as well as a byte code interpreter, the
  27. class loader, the garbage collector, threading system and
  28. metadata access libraries.
  29. %description -l ja
  30. Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
  31. コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
  32. およびメタデータアクセスライブラリの機能を持ちます。
  33. %package core
  34. Summary: The Mono CIL runtime, suitable for running .NET code
  35. Summary(ja): .NET の実行に適した Mono CIL ランタイム
  36. Group: Development/Languages
  37. Requires: libgdiplus
  38. %description core
  39. This package contains the core of the Mono runtime including its
  40. Virtual Machine, Just-in-time compiler, C# compiler, security
  41. tools and libraries (corlib, XML, System.Security, ZipLib,
  42. I18N, Cairo and Mono.*).
  43. %package devel
  44. Summary: Development tools for Mono
  45. Summary(ja): Mono 開発ツール
  46. Group: Development/Languages
  47. Requires: mono-core = %{version}-%{release}
  48. Requires: glib2-devel
  49. %description devel
  50. This package completes the Mono developer toolchain with the mono profiler,
  51. assembler and other various tools.
  52. %package nunit
  53. Summary: NUnit Testing Framework
  54. Summary(ja): NUnit テストフレームワーク
  55. Group: Development/Languages
  56. Requires: mono-core = %{version}-%{release}
  57. Requires: glib2-devel
  58. %description nunit
  59. NUnit is a unit-testing framework for all .NET languages. Initially
  60. ported from JUnit, the current release, version 2.2, is the fourth
  61. major release of this Unit based unit testing tool for Microsoft .NET.
  62. It is written entirely in C# and has been completely redesigned to
  63. take advantage of many .NET language features, for example
  64. custom attributes and other reflection related capabilities. NUnit
  65. brings xUnit to all .NET languages.
  66. %package locale-extras
  67. Summary: Extra locale information for Mono
  68. Summary(ja): Mono 用追加ロケール情報
  69. Group: Development/Languages
  70. Requires: mono-core = %{version}-%{release}
  71. %description locale-extras
  72. This package contains assemblies to support I18N applications for
  73. non-latin alphabets.
  74. %package extras
  75. Summary: Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
  76. Group: Development/Languages
  77. Requires: mono-core = %{version}-%{release}
  78. %description extras
  79. This package provides the libary and application to run services
  80. and daemons with Mono. It also includes stubs for the following
  81. .NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
  82. System.Configuration.Install, System.Management, System.Messaging.
  83. %package winforms
  84. Summary: Windows Forms implementation for Mono
  85. Group: Development/Languages
  86. Requires: mono-core = %{version}-%{release}
  87. %description winforms
  88. This package provides a fully managed implementation of
  89. System.Windows.Forms, the default graphical toolkit for .NET
  90. applications.
  91. %package web
  92. Summary: ASP.NET, Remoting, and Web Services for Mono
  93. Group: Development/Languages
  94. Requires: mono-core = %{version}-%{release}
  95. %description web
  96. This package provides the ASP.NET libraries and runtime for
  97. development of web application, web services and remoting support.
  98. %package data
  99. Summary: Database connectivity for Mono
  100. Group: Development/Languages
  101. Requires: mono-core = %{version}-%{release}
  102. %description data
  103. This package provides a Mono assembly to facilitate data access
  104. and manipulation with databases, LDAP compatible directory servers
  105. and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
  106. System.DirectoryServices assemblies, it also includes a command
  107. line sql application as well as the Microsoft SQL Server and ODBC
  108. data providers.
  109. %package data-sqlite
  110. Summary: sqlite database connectivity for Mono
  111. Group: Development/Languages
  112. Requires: mono-core = %{version}-%{release}
  113. Requires: sqlite
  114. %description data-sqlite
  115. This package contains the ADO.NET Data provider for the sqlite
  116. database.
  117. %package data-oracle
  118. Summary: Oracle database connectivity for Mono
  119. Group: Development/Languages
  120. Requires: mono-core = %{version}-%{release}
  121. %description data-oracle
  122. This package contains the ADO.NET Data provider for the Oracle
  123. database.
  124. %package data-postgresql
  125. Summary: Postgresql database connectivity for Mono
  126. Group: Development/Languages
  127. Requires: mono-core = %{version}-%{release}
  128. %description data-postgresql
  129. This package contains the ADO.NET Data provider for the PostgreSQL
  130. database.
  131. %package -n ibm-data-db2
  132. Summary: IBM DB2 database connectivity for Mono
  133. Group: Development/Languages
  134. Requires: mono-core = %{version}-%{release}
  135. %description -n ibm-data-db2
  136. This package contains the ADO.NET Data provider for the IBM DB2
  137. Universal database.
  138. %package -n monodoc
  139. Summary: The Mono documentation system
  140. Group: Development/Tools
  141. Requires: mono-core = %{version}-%{release}
  142. Requires: libgluezilla >= 2.4
  143. Obsoletes: monodoc-core <= 2.0-1vl5
  144. %description -n monodoc
  145. monodoc is the documentation package for the mono .NET environment
  146. ## macros
  147. %define mono_dir %{_prefix}/lib/mono
  148. %define mono_doc %{_prefix}/lib/monodoc
  149. %define bin_and_exe(bin, exe) %{_bindir}/%{1} \
  150. %{mono_dir}/%{2}.exe \
  151. %{mono_dir}/%{2}.exe.* \
  152. %{nil}
  153. %define gac_and_1dll(dll) %{mono_dir}/gac/%{1} \
  154. %{mono_dir}/%{2}/%{1}.dll \
  155. %{nil}
  156. %define gac_and_2dll(dll) %{mono_dir}/gac/%{1} \
  157. %{mono_dir}/%{2}/%{1}.dll \
  158. %{mono_dir}/%{3}/%{1}.dll \
  159. %{nil}
  160. %define gac_and_3dll(dll) %{mono_dir}/gac/%{1} \
  161. %{mono_dir}/%{2}/%{1}.dll \
  162. %{mono_dir}/%{3}/%{1}.dll \
  163. %{mono_dir}/%{4}/%{1}.dll \
  164. %{nil}
  165. %prep
  166. %setup -q
  167. ## These are only needed if there are patches to the runtime
  168. #rm -f libgc/libtool.m4
  169. #autoreconf --force --install
  170. #autoreconf --force --install libgc
  171. # Remove prebuilt binaries
  172. rm -rf mcs/class/lib/monolite/*
  173. %build
  174. gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
  175. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  176. %configure \
  177. --with-jit=yes \
  178. --with-ikvm=yes \
  179. --with-sigaltstack=no \
  180. ;
  181. # don't use parallel builds
  182. # make %{?_smp_mflags}
  183. make
  184. %install
  185. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
  186. make install DESTDIR=%{buildroot}
  187. install monodir %{buildroot}%{_bindir}
  188. ## Remove unused files
  189. %{__rm} -f %{buildroot}%{_libdir}/*.la
  190. %{__rm} -f %{buildroot}%{_libdir}/*.a
  191. %{__rm} -f %{buildroot}%{_bindir}/mono-find-provides
  192. %{__rm} -f %{buildroot}%{_bindir}/mono-find-requires
  193. ## This was removed upstream:
  194. %{__rm} -rf %{buildroot}%{mono_dir}/gac/Mono.Security.Win32/2*
  195. %{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
  196. %{__rm} -rf %{buildroot}%{_datadir}/libgc-mono
  197. %{__rm} -rf %{buildroot}%{_datadir}/mono-2.0/mono/cil
  198. %{__rm} -f %{buildroot}%{_bindir}/prj2make
  199. %{__rm} -f %{buildroot}%{_mandir}/man1/prj2make.*
  200. %{__rm} -f %{buildroot}%{_mandir}/man1/cilc.*
  201. %find_lang mcs
  202. %clean
  203. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
  204. %post core -p /sbin/ldconfig
  205. %postun core -p /sbin/ldconfig
  206. %post devel -p /sbin/ldconfig
  207. %postun devel -p /sbin/ldconfig
  208. %files core -f mcs.lang
  209. %defattr(-,root,root,-)
  210. %doc AUTHORS COPYING.LIB ChangeLog NEWS README
  211. %{_bindir}/mcs
  212. %{_bindir}/mono
  213. %{_bindir}/monodir
  214. %{_bindir}/mono-api-*
  215. %{_bindir}/mono-configuration-crypto
  216. %{_bindir}/mono-heapviz
  217. %{_bindir}/mono-sgen
  218. %{_bindir}/peverify
  219. %{_bindir}/mono-test-install
  220. %{_libdir}/libMonoPosixHelper.so
  221. %{_libdir}/libmono-2.0.so.*
  222. %{_libdir}/libmonosgen-2.0.so.*
  223. %{_libdir}/libmono-profiler-aot.so.*
  224. %{_libdir}/libmono-profiler-cov.so.*
  225. %{_libdir}/libmono-profiler-iomap.so.*
  226. %{_libdir}/libmono-profiler-logging.so.*
  227. %dir %{mono_dir}
  228. %dir %{mono_dir}/4.0
  229. %dir %{mono_dir}/3.5
  230. %dir %{mono_dir}/2.0
  231. %dir %{mono_dir}/gac
  232. %dir %{mono_dir}/compat-4.0
  233. %dir %{mono_dir}/compat-2.0
  234. %bin_and_exe ccrewrite 4.0/ccrewrite
  235. %bin_and_exe csharp 4.0/csharp
  236. %bin_and_exe csharp2 2.0/csharp
  237. %bin_and_exe certmgr 4.0/certmgr
  238. %bin_and_exe chktrust 4.0/chktrust
  239. %bin_and_exe dmcs 4.0/dmcs
  240. %bin_and_exe lc 4.0/lc
  241. %bin_and_exe gacutil 4.0/gacutil
  242. %bin_and_exe gacutil2 2.0/gacutil
  243. %bin_and_exe gmcs 2.0/gmcs
  244. %bin_and_exe installvst 4.0/installvst
  245. %bin_and_exe mconfig 4.0/mconfig
  246. %bin_and_exe mod 4.0/mod
  247. %bin_and_exe mono-cil-strip 4.0/mono-cil-strip
  248. %bin_and_exe monolinker 2.0/monolinker
  249. %bin_and_exe mozroots 4.0/mozroots
  250. %bin_and_exe setreg 4.0/setreg
  251. %bin_and_exe sn 4.0/sn
  252. %bin_and_exe sqlmetal 4.0/sqlmetal
  253. %bin_and_exe svcutil 4.0/svcutil
  254. %{mono_dir}/4.0/browsercaps-updater.exe*
  255. %{mono_dir}/4.0/monolinker.exe*
  256. %{mono_dir}/4.0/ictool.exe*
  257. %{mono_dir}/4.0/installutil.exe*
  258. %{mono_dir}/4.0/mono-api-info.exe
  259. %{mono_dir}/4.0/mscorlib.dll*
  260. %{mono_dir}/2.0/mscorlib.dll*
  261. %{mono_dir}/3.5/Microsoft.Build.*
  262. %{mono_dir}/4.0/Microsoft.CSharp.targets
  263. %{mono_dir}/3.5/Microsoft.CSharp.targets
  264. %{mono_dir}/2.0/Microsoft.CSharp.targets
  265. %{mono_dir}/4.0/Microsoft.Common.targets
  266. %{mono_dir}/3.5/Microsoft.Common.targets
  267. %{mono_dir}/2.0/Microsoft.Common.targets
  268. %{mono_dir}/4.0/Microsoft.VisualBasic.targets
  269. %{mono_dir}/3.5/Microsoft.VisualBasic.targets
  270. %{mono_dir}/2.0/Microsoft.VisualBasic.targets
  271. %{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
  272. %{mono_dir}/gac/Mono.Cecil
  273. %{mono_dir}/gac/Mono.Cecil.Mdb
  274. %{mono_dir}/mono-configuration-crypto/4.0/Mono.Configuration.Crypto.dll*
  275. %{mono_dir}/mono-configuration-crypto/4.0/mono-configuration-crypto.exe*
  276. %gac_and_2dll cscompmgd 4.0 2.0
  277. %gac_and_2dll Commons.Xml.Relaxng 4.0 2.0
  278. %gac_and_2dll CustomMarshalers 4.0 2.0
  279. %gac_and_2dll I18N 4.0 2.0
  280. %gac_and_2dll I18N.West 4.0 2.0
  281. %gac_and_2dll ICSharpCode.SharpZipLib 4.0 2.0
  282. %gac_and_1dll Microsoft.CSharp 4.0
  283. %gac_and_2dll Mono.C5 4.0 2.0
  284. %gac_and_2dll Mono.Cairo 4.0 2.0
  285. %gac_and_2dll Mono.CompilerServices.SymbolWriter 4.0 2.0
  286. %gac_and_2dll Mono.Posix 4.0 2.0
  287. %gac_and_2dll Mono.Security 4.0 2.0
  288. %gac_and_1dll Mono.Security.Win32 4.0
  289. %gac_and_2dll Mono.CSharp 4.0 2.0
  290. %gac_and_1dll Mono.CodeContracts 4.0
  291. %gac_and_1dll Mono.Debugger.Soft 2.0
  292. %gac_and_2dll Mono.Management 4.0 2.0
  293. %gac_and_2dll Mono.Simd 4.0 2.0
  294. %gac_and_2dll Mono.Tasklets 4.0 2.0
  295. %gac_and_2dll System 4.0 2.0
  296. %gac_and_2dll System.Configuration 4.0 2.0
  297. %gac_and_1dll System.Dynamic 4.0
  298. %gac_and_2dll System.Drawing 4.0 2.0
  299. %gac_and_2dll System.Core 4.0 2.0
  300. %gac_and_1dll System.ComponentModel.Composition 4.0
  301. %gac_and_2dll System.ComponentModel.DataAnnotations 4.0 2.0
  302. %gac_and_2dll System.IdentityModel 4.0 2.0
  303. %gac_and_2dll System.IdentityModel.Selectors 4.0 2.0
  304. %gac_and_1dll System.Numerics 4.0
  305. %gac_and_1dll System.Runtime.Caching 4.0
  306. %gac_and_1dll System.Runtime.DurableInstancing 4.0
  307. %gac_and_2dll System.Runtime.Serialization 4.0 2.0
  308. %gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
  309. %gac_and_2dll System.Security 4.0 2.0
  310. %gac_and_1dll System.Xaml 4.0
  311. %gac_and_2dll System.Xml 4.0 2.0
  312. %gac_and_2dll System.Xml.Linq 4.0 2.0
  313. %gac_and_2dll OpenSystem.C 4.0 2.0
  314. %gac_and_2dll WindowsBase 4.0 2.0
  315. %dir %{_sysconfdir}/mono
  316. %dir %{_sysconfdir}/mono/4.0
  317. %dir %{_sysconfdir}/mono/2.0
  318. %dir %{_sysconfdir}/mono/mconfig
  319. %config (noreplace) %{_sysconfdir}/mono/config
  320. %config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
  321. %config (noreplace) %{_sysconfdir}/mono/4.0/machine.config
  322. %config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
  323. %config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
  324. %config (noreplace) %{_sysconfdir}/mono/4.0/settings.map
  325. %{_prefix}/lib/mono-source-libs/
  326. %{_mandir}/man1/ccrewrite.1.gz
  327. %{_mandir}/man1/certmgr.1.gz
  328. %{_mandir}/man1/chktrust.1.gz
  329. %{_mandir}/man1/csharp.1.gz
  330. %{_mandir}/man1/gacutil.1.gz
  331. %{_mandir}/man1/lc.1.gz
  332. %{_mandir}/man1/mconfig.1.gz
  333. %{_mandir}/man1/mcs.1.gz
  334. %{_mandir}/man1/mono.1.gz
  335. %{_mandir}/man1/monolinker.1.gz
  336. %{_mandir}/man1/mozroots.1.gz
  337. %{_mandir}/man1/setreg.1.gz
  338. %{_mandir}/man1/sn.1.gz
  339. %{_mandir}/man1/resgen.1.gz
  340. %{_mandir}/man1/mono-api-info.1.gz
  341. %{_mandir}/man1/mono-cil-strip.1.gz
  342. %{_mandir}/man1/mono-configuration-crypto.1.gz
  343. %{_mandir}/man5/mono-config.5.gz
  344. %files devel
  345. %defattr(-,root,root,-)
  346. %{_bindir}/genxs
  347. %{_bindir}/mkbundle
  348. %{_bindir}/mono-gdb.py
  349. %{_bindir}/monodis
  350. %{_bindir}/monograph
  351. %{_bindir}/pedump
  352. ##{_bindir}/prj2make
  353. %{_bindir}/xbuild
  354. %{_libdir}/libmono-2.0.so
  355. %{_libdir}/libmono-profiler-aot.so
  356. %{_libdir}/libmono-profiler-cov.so
  357. %{_libdir}/libmono-profiler-iomap.so
  358. %{_libdir}/libmono-profiler-logging.so
  359. %{_libdir}/libmonosgen-2.0.so
  360. %{_libdir}/libMonoSupportW.so
  361. %{_libdir}/libikvm-native.so
  362. %{mono_dir}/4.0/mkbundle.exe*
  363. %{mono_dir}/2.0/mkbundle.exe*
  364. %{mono_dir}/4.0/genxs.exe*
  365. %{mono_dir}/2.0/genxs.exe*
  366. %{mono_dir}/2.0/ilasm.exe*
  367. %bin_and_exe al 4.0/al
  368. %bin_and_exe al2 2.0/al
  369. %bin_and_exe caspol 4.0/caspol
  370. %bin_and_exe cert2spc 4.0/cert2spc
  371. %bin_and_exe dtd2xsd 4.0/dtd2xsd
  372. %bin_and_exe dtd2rng 4.0/dtd2rng
  373. %bin_and_exe sgen 4.0/sgen
  374. %bin_and_exe ilasm 4.0/ilasm
  375. %bin_and_exe macpack 4.0/macpack
  376. %bin_and_exe makecert 4.0/makecert
  377. %bin_and_exe monop 4.0/monop
  378. %bin_and_exe monop2 2.0/monop
  379. %bin_and_exe mono-shlib-cop 4.0/mono-shlib-cop
  380. %bin_and_exe mono-xmltool 4.0/mono-xmltool
  381. %bin_and_exe pdb2mdb 4.0/pdb2mdb
  382. %bin_and_exe permview 4.0/permview
  383. %bin_and_exe resgen 4.0/resgen
  384. %bin_and_exe resgen2 2.0/resgen
  385. %bin_and_exe secutil 4.0/secutil
  386. %bin_and_exe signcode 4.0/signcode
  387. %{mono_dir}/xbuild
  388. %{mono_dir}/4.0/xbuild.*
  389. %{mono_dir}/3.5/xbuild.*
  390. %{mono_dir}/2.0/xbuild.*
  391. %{mono_dir}/4.0/culevel.exe*
  392. %{mono_dir}/2.0/culevel.exe*
  393. %{mono_dir}/4.0/MSBuild/*.xsd
  394. %{mono_dir}/3.5/MSBuild/*.xsd
  395. %{mono_dir}/2.0/MSBuild/*.xsd
  396. %{mono_dir}/4.0/Microsoft.Build.xsd
  397. %{mono_dir}/3.5/Microsoft.Build.xsd
  398. %{mono_dir}/2.0/Microsoft.Build.xsd
  399. %{mono_dir}/4.0/Microsoft.*.targets
  400. %{mono_dir}/3.5/Microsoft.*.targets
  401. %{mono_dir}/2.0/Microsoft.*.targets
  402. %{mono_dir}/4.0/Microsoft.Common.tasks
  403. %{mono_dir}/3.5/Microsoft.Common.tasks
  404. %{mono_dir}/2.0/Microsoft.Common.tasks
  405. %gac_and_2dll PEAPI 4.0 2.0
  406. %gac_and_3dll Microsoft.Build.Engine 4.0 3.5 2.0
  407. %gac_and_3dll Microsoft.Build.Framework 4.0 3.5 2.0
  408. %gac_and_1dll Microsoft.Build.Tasks 2.0
  409. %gac_and_1dll Microsoft.Build.Tasks.v4.0 4.0
  410. %gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
  411. %gac_and_1dll Microsoft.Build.Utilities 2.0
  412. %gac_and_1dll Microsoft.Build.Utilities.v4.0 4.0
  413. %gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
  414. %gac_and_2dll Microsoft.VisualC 4.0 2.0
  415. %{_libdir}/pkgconfig/dotnet.pc
  416. %{_libdir}/pkgconfig/mono-cairo.pc
  417. %{_libdir}/pkgconfig/mono.pc
  418. %{_libdir}/pkgconfig/mono-2.pc
  419. %{_libdir}/pkgconfig/cecil.pc
  420. %{_libdir}/pkgconfig/dotnet35.pc
  421. %{_libdir}/pkgconfig/mono-lineeditor.pc
  422. %{_libdir}/pkgconfig/mono-options.pc
  423. %{_libdir}/pkgconfig/wcf.pc
  424. %{_includedir}/mono-2.0
  425. %{_mandir}/man1/al.1.gz
  426. %{_mandir}/man1/cert2spc.1.gz
  427. ##{_mandir}/man1/cilc.1.gz
  428. %{_mandir}/man1/dtd2xsd.1.gz
  429. %{_mandir}/man1/genxs.1.gz
  430. %{_mandir}/man1/ilasm.1.gz
  431. %{_mandir}/man1/macpack.1.gz
  432. %{_mandir}/man1/makecert.1.gz
  433. %{_mandir}/man1/mkbundle.1.gz
  434. %{_mandir}/man1/mono-shlib-cop.1.gz
  435. %{_mandir}/man1/mono-xmltool.1.gz
  436. %{_mandir}/man1/monodis.1.gz
  437. %{_mandir}/man1/monop.1.gz
  438. %{_mandir}/man1/pdb2mdb.1.gz
  439. %{_mandir}/man1/permview.1.gz
  440. ##{_mandir}/man1/prj2make.1.gz
  441. %{_mandir}/man1/secutil.1.gz
  442. %{_mandir}/man1/sgen.1.gz
  443. %{_mandir}/man1/signcode.1.gz
  444. %{_mandir}/man1/xbuild.1.gz
  445. %files nunit
  446. %defattr(-,root,root,-)
  447. %bin_and_exe nunit-console 4.0/nunit-console
  448. %bin_and_exe nunit-console2 2.0/nunit-console
  449. %gac_and_2dll nunit.core 4.0 2.0
  450. %gac_and_2dll nunit.framework 4.0 2.0
  451. %gac_and_2dll nunit.util 4.0 2.0
  452. %gac_and_2dll nunit.mocks 4.0 2.0
  453. %gac_and_2dll nunit-console-runner 4.0 2.0
  454. %gac_and_2dll nunit.core.extensions 4.0 2.0
  455. %gac_and_2dll nunit.core.interfaces 4.0 2.0
  456. %gac_and_2dll nunit.framework.extensions 4.0 2.0
  457. %{_libdir}/pkgconfig/mono-nunit.pc
  458. %files locale-extras
  459. %defattr(-,root,root,-)
  460. %gac_and_2dll I18N.MidEast 4.0 2.0
  461. %gac_and_2dll I18N.Rare 4.0 2.0
  462. %gac_and_2dll I18N.CJK 4.0 2.0
  463. %gac_and_2dll I18N.Other 4.0 2.0
  464. %files extras
  465. %defattr(-,root,root,-)
  466. %{_mandir}/man1/mono-service.1.gz
  467. %bin_and_exe mono-service 4.0/mono-service
  468. %bin_and_exe mono-service2 2.0/mono-service
  469. %{mono_dir}/gac/mono-service
  470. %gac_and_2dll System.Configuration.Install 4.0 2.0
  471. %gac_and_2dll System.Management 4.0 2.0
  472. %gac_and_2dll System.Messaging 4.0 2.0
  473. %gac_and_2dll System.ServiceProcess 4.0 2.0
  474. %gac_and_2dll System.ServiceModel 4.0 2.0
  475. %gac_and_1dll System.ServiceModel.Discovery 4.0
  476. %gac_and_1dll System.ServiceModel.Routing 4.0
  477. %gac_and_2dll Mono.Messaging.RabbitMQ 4.0 2.0
  478. %gac_and_2dll Mono.Messaging 4.0 2.0
  479. %gac_and_2dll RabbitMQ.Client 4.0 2.0
  480. %{mono_dir}/4.0/RabbitMQ.Client.Apigen.exe*
  481. %{mono_dir}/2.0/RabbitMQ.Client.Apigen.exe*
  482. %files winforms
  483. %defattr(-,root,root,-)
  484. %gac_and_2dll Accessibility 4.0 2.0
  485. %gac_and_2dll System.Design 4.0 2.0
  486. %gac_and_2dll System.Drawing.Design 4.0 2.0
  487. %gac_and_2dll System.Windows.Forms 4.0 2.0
  488. %gac_and_1dll System.Windows.Forms.DataVisualization 4.0
  489. %files web
  490. %defattr(-,root,root,-)
  491. %{mono_dir}/2.0/xsd.exe*
  492. %{mono_dir}/compat-2.0/System.Web.Extensions*dll
  493. %{mono_dir}/compat-2.0/System.Web.Mvc.dll
  494. %bin_and_exe disco 4.0/disco
  495. %bin_and_exe soapsuds 4.0/soapsuds
  496. %bin_and_exe xsd 4.0/xsd
  497. %bin_and_exe wsdl 4.0/wsdl
  498. %bin_and_exe wsdl2 2.0/wsdl
  499. %bin_and_exe httpcfg 4.0/httpcfg
  500. %gac_and_2dll Mono.Http 4.0 2.0
  501. %gac_and_2dll Mono.Web 4.0 2.0
  502. %gac_and_2dll Mono.WebBrowser 4.0 2.0
  503. %gac_and_2dll System.Runtime.Remoting 4.0 2.0
  504. %gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
  505. %gac_and_2dll System.ServiceModel.Web 4.0 2.0
  506. %gac_and_2dll System.Web 4.0 2.0
  507. %gac_and_1dll System.Web.ApplicationServices 4.0
  508. %gac_and_2dll System.Web.Abstractions 4.0 2.0
  509. %gac_and_2dll System.Web.DynamicData 4.0 2.0
  510. %gac_and_1dll System.Web.Mvc 2.0
  511. %gac_and_2dll System.Web.Routing 4.0 2.0
  512. %gac_and_2dll System.Web.Services 4.0 2.0
  513. %gac_and_3dll System.Web.Extensions.Design 4.0 3.5 2.0
  514. %gac_and_2dll System.Web.Extensions 4.0 2.0
  515. %{_mandir}/man1/disco.1.gz
  516. %{_mandir}/man1/soapsuds.1.gz
  517. %{_mandir}/man1/wsdl.1.gz
  518. %{_mandir}/man1/xsd.1.gz
  519. %config (noreplace) %{_sysconfdir}/mono/browscap.ini
  520. %config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
  521. %config (noreplace) %{_sysconfdir}/mono/4.0/DefaultWsdlHelpGenerator.aspx
  522. %config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
  523. %config (noreplace) %{_sysconfdir}/mono/4.0/web.config
  524. %config (noreplace) %{_sysconfdir}/mono/2.0/web.config
  525. %{_mandir}/man1/httpcfg.1.gz
  526. %{_libdir}/pkgconfig/mono.web.pc
  527. %{_libdir}/pkgconfig/system.web.extensions_1.0.pc
  528. %{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
  529. %{_libdir}/pkgconfig/system.web.mvc.pc
  530. %{_libdir}/pkgconfig/system.web.mvc2.pc
  531. %files data
  532. %defattr(-,root,root,-)
  533. %bin_and_exe sqlsharp 4.0/sqlsharp
  534. %gac_and_2dll System.Data 4.0 2.0
  535. %gac_and_2dll System.Data.DataSetExtensions 4.0 2.0
  536. %gac_and_2dll System.Data.Linq 4.0 2.0
  537. %gac_and_2dll System.Data.Services 4.0 2.0
  538. %gac_and_2dll Mono.Data.Tds 4.0 2.0
  539. %gac_and_2dll System.EnterpriseServices 4.0 2.0
  540. %gac_and_2dll Novell.Directory.Ldap 4.0 2.0
  541. %gac_and_2dll System.DirectoryServices 4.0 2.0
  542. %gac_and_2dll System.Transactions 4.0 2.0
  543. %{mono_dir}/gac/System.Data.Services.Client
  544. %{_mandir}/man1/sqlsharp.1.gz
  545. %files data-sqlite
  546. %defattr(-,root,root,-)
  547. %gac_and_2dll Mono.Data.Sqlite 4.0 2.0
  548. %files data-oracle
  549. %defattr(-,root,root,-)
  550. %gac_and_2dll System.Data.OracleClient 4.0 2.0
  551. %files data-postgresql
  552. %defattr(-,root,root,-)
  553. %gac_and_2dll Npgsql 4.0 2.0
  554. %files -n ibm-data-db2
  555. %defattr(-,root,root,-)
  556. %gac_and_2dll IBM.Data.DB2 4.0 2.0
  557. %files -n monodoc
  558. %defattr(-, root, root)
  559. %bin_and_exe mdoc 4.0/mdoc
  560. %{_bindir}/mdoc-*
  561. %{_bindir}/mdass*
  562. %{_bindir}/mdval*
  563. %{_bindir}/mod
  564. %{_bindir}/monodoc*
  565. %{mono_dir}/gac/monodoc
  566. %{mono_dir}/monodoc/monodoc.dll
  567. %{mono_doc}/*
  568. %{_mandir}/man1/md*
  569. %{_mandir}/man1/monodoc*
  570. %{_mandir}/man5/mdoc*
  571. %{_libdir}/pkgconfig/monodoc.pc
  572. %changelog
  573. * Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
  574. - updated mono to 2.8
  575. - modified macros used in %%files
  576. - removed below:
  577. - packages:
  578. %{name}-jscript, %{name}-data-sybase, %{name}-data-firebird, bytefx-data-mysql
  579. - libraries:
  580. ByteFX.Data, FirebirdSql.Data.Firebird
  581. Mono.Data Mono.Data.TdsClient, Mono.Data.SybaseClient, Mono.Data.SqliteClient
  582. Microsoft.JScript, Microsoft.Vsa
  583. - commands:
  584. cilc, mjs, prj2make (replaced by xbuild)
  585. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.7-2
  586. - build with rpm-4.8.1-1 for pkg-config file
  587. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
  588. - updated mono to 2.6.7
  589. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
  590. - updated mono to 2.6.4
  591. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
  592. - updated mono to 2.6.3
  593. added RabbitMQ.Client.Apigen.exe
  594. * Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
  595. - unuse _smp_mflags
  596. * Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
  597. - updated mono to 2.6.1
  598. - simplified macros
  599. * Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
  600. - updated mono to 2.4.3
  601. added %%{mono_dir}/2.0/lc.exe*
  602. added %%gac_dll System.Web.Mvc
  603. added %%{mono_dir}/xbuild/*
  604. added %%{_mandir}/man1/lc.1.gz
  605. added %%{_mandir}/man1/xbuild.1.gz
  606. * Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
  607. - updated mono to 2.4.2.3
  608. * Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
  609. - updated mono to 2.4.2.2
  610. * Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
  611. - new upstream release
  612. - build with latest rpm to update mono-dependencies
  613. * Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
  614. - updated mono to 2.4.2
  615. * Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
  616. - fix temporary workaround against build failure on ppc,
  617. from RH bugzilla #494026
  618. - statically link mono to libmono: remove "--disable-static" from configure
  619. - ensure removing *.a files in the install section
  620. - remove prebuilt binaries under mcs/class/lib/monolite/ before building
  621. * Sun Apr 5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
  622. - fixed paths using %%mono_dir, %%mono_doc macros
  623. - added Requires:libgluezilla >= 2.4 in monodoc
  624. * Sat Apr 4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
  625. - new upstream release
  626. - added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
  627. * Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
  628. - new upstream release
  629. - dropt %%{_bindir}/mono-find-{provides,requires}
  630. - added --with-libgdiplus=installed
  631. * Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
  632. - update to mono-2.0 released source
  633. - BR: libgdiplus-devel >= 2.0
  634. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
  635. - removed *.la
  636. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
  637. - updated mono to 2.0
  638. - updated url
  639. - changed macro %%monodir to %%mono_dir
  640. - dropt mono-1.1.13.4-selinux-ia64.patch
  641. - dropt mono-1.1.13.4-ppc-threading.patch
  642. - dropt mono-1.2.3-use-monodir.patch
  643. * Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
  644. - applied new versioning policy, spec in utf-8
  645. - dropt mono-1.2.5-libdir.patch
  646. - reverted monodir macro to using %%{_prefix}/lib/mono
  647. * Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
  648. - updated monodir to %%{_libdir}/mono
  649. * Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
  650. - new upstream release
  651. - splited mono-basic package
  652. * Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
  653. - new upstream release
  654. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
  655. - new upstream release
  656. * Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
  657. - disabled Patch2 on Vine/ppc environment
  658. * Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
  659. - updated source and sub-packages based on Fedora packages
  660. * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
  661. - new upstream version(mono-1.0.6)
  662. * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
  663. - new upstream version(mono-1.0.5)
  664. * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
  665. - new upstream version(mono-1.0.4)
  666. -- changed to use configure
  667. * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
  668. - rebuild for Vine Linux (based on mono.spec inside src archive)
  669. - Fixed BuildRequires: gc-devel, libicu-devel
  670. - add Japanese translation
  671. * Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
  672. - rebuild for ppc TLS issue (#184446)
  673. * Fri Mar 3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
  674. - Update to 1.1.13.4
  675. - Add patch so mono doesn't segfault on PPC SMP machines
  676. - Minor spec cleanup
  677. * Thu Mar 2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
  678. - Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
  679. for bug 182965)
  680. * Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
  681. - Updated patch from Paolo Molaro <lupus@ximian.com>
  682. * Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
  683. - Patch from Jakub to make work with SELinux better
  684. * Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
  685. - Rebuild
  686. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
  687. - rebuilt for new gcc4.1 snapshot and glibc changes
  688. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
  689. - Update to 1.1.13.2
  690. * Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
  691. - Update to 1.13
  692. - Add libgdiplus dep to mono-core
  693. - Add s390x to build
  694. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
  695. - Update to 1.1.12.1
  696. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
  697. - rebuild
  698. * Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
  699. - Disable s390 due to some build failure
  700. * Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
  701. - Build on s390 and x86-64 now
  702. * Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
  703. - Initial version