xsp-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. %define mono_dir %(/usr/bin/monodir)
  2. Summary: Small Web Server Hosting ASP.NET
  3. Summary(ja): ASP.NET を提供する小さなウェブサーバ
  4. Name: xsp
  5. URL: http://go-mono.com/
  6. License: GNU General Public License (GPL)
  7. Group: Applications/Internet
  8. Version: 2.8
  9. Release: 1%{?_dist_release}
  10. Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildArch: noarch
  13. BuildRequires: mono-devel mono-web
  14. BuildRequires: mono-data-sqlite mono-data-oracle mono-extras mono-nunit
  15. BuildRequires: pkgconfig
  16. # One of the test runs requires this
  17. BuildRequires: sqlite
  18. # This must be manually entered according to xsp's protocol version
  19. # Since this package is currently noarch, and mod_mono's name is different
  20. # on different distros, we can't use this... yet
  21. #Requires: mod_mono >= %{version}
  22. %description
  23. The XSP server is a small Web server that hosts the Mono System.Web
  24. classes for running what is commonly known as ASP.NET.
  25. %prep
  26. %setup -q
  27. %build
  28. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  29. # Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
  30. ./configure \
  31. --prefix=%{_prefix} \
  32. --libexecdir=%{_prefix}/lib \
  33. --libdir=%{_prefix}/lib \
  34. --mandir=%{_prefix}/share/man \
  35. --infodir=%{_prefix}/share/info \
  36. --sysconfdir=%{_sysconfdir}
  37. make
  38. %install
  39. rm -rf $RPM_BUILD_ROOT
  40. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  41. make install DESTDIR=$RPM_BUILD_ROOT
  42. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
  43. mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %files
  47. %defattr(-,root,root)
  48. %doc NEWS README
  49. %{_bindir}/*
  50. %{_prefix}/lib/xsp
  51. %{mono_dir}/gac/Mono.WebServer2
  52. %{mono_dir}/gac/fastcgi-mono-server2
  53. %{mono_dir}/gac/fastcgi-mono-server4
  54. %{mono_dir}/gac/mod-mono-server2
  55. %{mono_dir}/gac/mod-mono-server4
  56. %{mono_dir}/gac/xsp2
  57. %{mono_dir}/gac/xsp4
  58. %{mono_dir}/2.0/Mono.WebServer2.dll
  59. %{mono_dir}/2.0/fastcgi-mono-server2.exe
  60. %{mono_dir}/2.0/mod-mono-server2.exe
  61. %{mono_dir}/2.0/xsp2.exe
  62. %{mono_dir}/4.0/Mono.WebServer2.dll
  63. %{mono_dir}/4.0/fastcgi-mono-server4.exe
  64. %{mono_dir}/4.0/mod-mono-server4.exe
  65. %{mono_dir}/4.0/xsp4.exe
  66. %{_prefix}/lib/monodoc/sources/Mono.WebServer.*
  67. %{_datadir}/pkgconfig/*
  68. %{_mandir}/*/*
  69. %changelog
  70. * Fri Oct 08 2010 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
  71. - updated xsp to 2.8
  72. - rebuilt with mono-2.8
  73. - dropt BR: mono-jscript
  74. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-2
  75. - rebuild with rpm-4.8.1 for pkg-config file
  76. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
  77. - updated xsp to 2.6.5
  78. * Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
  79. - updated xsp to 2.6.4
  80. * Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
  81. - updated xsp to 2.6.3
  82. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
  83. - updated to 2.6
  84. - rebuilt with new toolchain
  85. * Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
  86. - updated to 2.4.3
  87. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
  88. - changed Group to Applications/Internet
  89. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
  90. - updated to 2.4
  91. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
  92. - initial build for VineSeed
  93. - updated xsp to 2.0
  94. - added japanese summary
  95. - applied vine versioning policy
  96. - spec in utf-8
  97. * Tue Apr 22 2008 wberrier@suse.de
  98. - update to 1.9.1 (bugfix release)
  99. - Output date header (instead of asp.net doing it)
  100. * Tue Mar 25 2008 wberrier@suse.de
  101. - update to 1.9
  102. - minor test updates
  103. - BaseRequestBroker fix: Check if the request ID is valid inside
  104. the lock.
  105. * Mon Jan 14 2008 wberrier@suse.de
  106. - update to 1.2.6
  107. - FastCGI support
  108. * Thu Aug 30 2007 wberrier@suse.de
  109. - xsp_1.2.5_p5_final.patch: Fix for regression in the request
  110. broker
  111. * Fri Aug 17 2007 wberrier@suse.de
  112. - xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
  113. - bugs: 81699, 81906, 82379, 82057
  114. - fixes ability to handle large (GB) uploads (needed for iFolder)
  115. * Fri Aug 3 2007 wberrier@suse.de
  116. - Update to 1.2.5
  117. - More robust exception handling
  118. - Fixed permissions bits for non executable scripts
  119. - virtual host support
  120. - New Documentation for Mono.WebServer
  121. - Improved event handling
  122. * Tue Jun 5 2007 wberrier@novell.com
  123. - Remove unnecessary path defines (prefix, sysconfdir)
  124. - Update to 1.2.4
  125. - fix some race conditions and crashes
  126. - add tracing support
  127. * Fri Apr 13 2007 wberrier@novell.com
  128. - add %%debug_package so debug packages get created
  129. * Wed Apr 11 2007 wberrier@novell.com
  130. - Add mono dep/req for older distros
  131. * Thu Mar 1 2007 wberrier@suse.de
  132. - Update Update to 1.2.3
  133. - Bug fix #80230 (prevents possible nullref)
  134. - Support for response header encoding
  135. * Mon Jan 22 2007 ro@suse.de
  136. - drop requires for gnome-filesystem
  137. * Sat Dec 2 2006 wberrier@suse.de
  138. - Update to 1.2.1 (Fate #301111)
  139. - Bugfixes:
  140. - close the connection if there's an error reading the headers
  141. (including assembly loading exceptions due to a bad installation).
  142. - kill the warning that everyone is worried about.
  143. * Fri Oct 20 2006 wberrier@suse.de
  144. - Update to 1.1.18
  145. - 2.0 updates
  146. * Thu Oct 19 2006 wberrier@suse.de
  147. - Add mono-devel to fix bnc #213576 (missing provides)
  148. * Tue Sep 5 2006 wberrier@suse.de
  149. - Update to 1.1.17.1 bugfix release
  150. - Read from the stream, not the socket as the socket data is
  151. encrypted when using SSL.
  152. * Wed Aug 30 2006 wberrier@suse.de
  153. - Update to 1.1.17
  154. - Added support for X.509 client certificates
  155. - Update to handle newly created AppDomains
  156. * Mon Jul 31 2006 wberrier@suse.de
  157. - update to 1.1.16.1
  158. - better connection handling
  159. - fixes bugs: 77698,78034,78621
  160. * Tue Apr 25 2006 wberrier@suse.de
  161. - Security update (remove all the duplicated slashes
  162. and don't do an extra Replace on non-windows.) and minor fix for
  163. [#78034].
  164. * Wed Jan 25 2006 mls@suse.de
  165. - converted neededforbuild to BuildRequires
  166. * Fri Jan 6 2006 wberrier@suse.de
  167. - Update to 1.1.13, clean up deps
  168. * Thu Nov 10 2005 wberrier@suse.de
  169. - Update to 1.1.10, set libdir to lib/
  170. * Fri Oct 7 2005 wberrier@suse.de
  171. - Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
  172. libexec, so I disabled the patch)
  173. * Tue Jul 19 2005 sbrabec@suse.cz
  174. - Build as noarch (#81109).
  175. * Fri Jul 15 2005 sbrabec@suse.cz
  176. - Updated to version 1.0.9 (#96776).
  177. * Mon Feb 21 2005 clahey@suse.de
  178. - Updated to 1.0.6.
  179. * Sun Feb 6 2005 ro@suse.de
  180. - use /usr/lib/mono
  181. * Mon Dec 13 2004 clahey@suse.de
  182. - New package.