totem-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566
  1. # build browser plugins
  2. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  3. # define versions
  4. %define _glib_ver 2.34.0
  5. %define _gtk_ver 3.4.0
  6. %define _gnomeicon_ver 3.4.0
  7. %define _gnome_doc_utils_ver 0.20.0
  8. %define _dbus_ver 1.4.0
  9. %define _gst_ver 0.11.93
  10. %define _gstpb_ver 0.11.93
  11. %define _gstpg_ver 0.11.93
  12. %define _gstpbad_ver 0.11.93
  13. %define _xulrunner_ver 1.9
  14. %define _nautilus_ver 3.4.0
  15. %define _shared_mime_info_ver 0.17
  16. %define _unique_ver 1.0
  17. %define _totem_pl_parser_ver 2.32.0
  18. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  19. %define mozplug_dir %{_libdir}/mozilla/plugins
  20. Summary: Movie player for GNOME 3
  21. Summary(ja): GNOME3 用動画プレイヤー
  22. Name: totem
  23. Version: 3.6.0
  24. Release: 1%{?_dist_release}
  25. License: GPL
  26. Group: Applications/Multimedia
  27. URL: http://www.gnome.org/projects/totem/
  28. Source0: http://ftp.gnome.org/pub/GNOME/sources/totem/3.6/totem-%{version}.tar.xz
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: Takemikaduchi
  33. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  34. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  35. BuildRequires: dbus-devel >= %{_dbus_ver}
  36. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  37. BuildRequires: gettext, scrollkeeper
  38. BuildRequires: perl-XML-Parser
  39. BuildRequires: iso-codes
  40. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  41. BuildRequires: grilo-devel
  42. BuildRequires: bluez-libs-devel >= 4.15
  43. BuildRequires: lirc
  44. BuildRequires: unique-devel >= %{_unique_ver}
  45. BuildRequires: python-devel
  46. BuildRequires: pylint
  47. BuildRequires: pygobject3-devel
  48. BuildRequires: libpeas-devel
  49. BuildRequires: libXtst-devel
  50. BuildRequires: gsettings-desktop-schemas-devel
  51. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  52. BuildRequires: gstreamer1-devel >= %{_gst_ver}
  53. BuildRequires: gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  54. BuildRequires: gstreamer1-plugins-good >= %{_gstpg_ver}
  55. BuildRequires: gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
  56. BuildRequires: clutter-gtk-devel
  57. BuildRequires: clutter-gst-devel
  58. BuildRequires: libmx-devel
  59. %if %{build_plugin}
  60. BuildRequires: xulrunner-devel >= %{_xulrunner_ver}
  61. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  62. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  63. %endif
  64. Requires: gstreamer1 >= %{_gst_ver}
  65. Requires: gstreamer1-plugins-base >= %{_gstpb_ver}
  66. Requires: gstreamer1-plugins-good >= %{_gstpg_ver}
  67. Requires: iso-codes
  68. Obsoletes: nautilus-media
  69. Obsoletes: %{name}-gstreamer < 2.30.1-2
  70. Obsoletes: %{name}-xine < 2.30.1-2
  71. Obsoletes: %{name}-common < 2.30.1-3
  72. Provides: nautilus-media
  73. Provides: %{name}-common = %{version}-%{release}
  74. Requires(post): ldconfig, scrollkeeper, desktop-file-utils, GConf2
  75. Requires(postun): ldconfig, scrollkeeper, desktop-file-utils
  76. Requires(preun): GConf2
  77. %description
  78. Totem is simple movie player for the Gnome desktop. It features a
  79. simple playlist, a full-screen mode, seek and volume controls, as well as
  80. a pretty complete keyboard navigation.
  81. %if %{build_plugin}
  82. %package mozilla
  83. Summary: Totem movie plugin for Mozilla
  84. Summary(ja): Mozilla 用 Totem 動画プラグイン
  85. Group: Applications/Internet
  86. Requires: %{name} = %{version}-%{release}
  87. Obsoletes: %{name}-mozilla-common
  88. Obsoletes: %{name}-mozilla-gstreamer
  89. Obsoletes: %{name}-mozilla-xine
  90. %description mozilla
  91. Totem is simple movie player for the Gnome desktop. It features a
  92. simple playlist, a full-screen mode, seek and volume controls, as well as
  93. a pretty complete keyboard navigation.
  94. This package contains a Totem video plugin for Mozilla. It allows Totem
  95. movie player to be embedded into a web browser.
  96. %endif
  97. %package devel
  98. Summary: Plugin writer's documentation for totem
  99. Group: Development/Libraries
  100. Requires: %{name} = %{version}-%{release}
  101. %description devel
  102. The %{name}-devel package contains API documentation for
  103. developing developing plugins for %{name}.
  104. %prep
  105. %setup -q
  106. %build
  107. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
  108. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  109. %configure \
  110. --disable-scrollkeeper \
  111. --enable-python \
  112. --disable-vala \
  113. --enable-nautilus \
  114. --enable-gmp-plugin \
  115. --enable-narrowspace-plugin \
  116. --enable-mully-plugin \
  117. --disable-vegas-plugin \
  118. %if %{build_plugin}
  119. --enable-browser-plugins
  120. %else
  121. --disable-browser-plugins
  122. %endif
  123. make %{?_smp_mflags}
  124. %install
  125. rm -rf $RPM_BUILD_ROOT
  126. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  127. make install DESTDIR=$RPM_BUILD_ROOT
  128. # remove unneeded files
  129. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  130. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  131. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  132. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  133. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  134. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  135. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  136. # remove unused file
  137. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  138. %find_lang %{name} --with-gnome
  139. # save space by linking identical images in translated docs
  140. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  141. for f in $helpdir/C/figures/*.png; do
  142. b="$(basename $f)"
  143. for d in $helpdir/*; do
  144. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  145. g="$d/figures/$b"
  146. if [ -f "$g" ]; then
  147. if cmp -s $f $g; then
  148. rm "$g"; ln -s "../../C/figures/$b" "$g"
  149. fi
  150. fi
  151. fi
  152. done
  153. done
  154. %clean
  155. %__rm -rf %{buildroot}
  156. %post
  157. %{_bindir}/scrollkeeper-update -q
  158. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  159. touch %{_datadir}/icons/hicolor
  160. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  161. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  162. fi
  163. %postun
  164. %{_bindir}/scrollkeeper-update -q
  165. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  166. touch %{_datadir}/icons/hicolor
  167. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  168. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  169. fi
  170. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  171. %posttrans
  172. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  173. %files -f %{name}.lang
  174. %defattr(-,root,root,-)
  175. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  176. %{_bindir}/totem
  177. %{_bindir}/totem-audio-preview
  178. %{_bindir}/totem-video-thumbnailer
  179. %{_datadir}/GConf/gsettings/opensubtitles.convert
  180. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  181. %{_datadir}/GConf/gsettings/totem.convert
  182. %{_datadir}/applications/%{name}.desktop
  183. %{_datadir}/glib-2.0/schemas/*.xml
  184. %{_datadir}/icons/*/*/*/*
  185. %{_datadir}/thumbnailers/totem.thumbnailer
  186. %{_datadir}/%{name}
  187. %{_datadir}/gtk-doc/html/totem
  188. %{_libdir}/libtotem.so.*
  189. %{_libdir}/girepository-1.0/*.typelib
  190. %dir %{_libdir}/totem
  191. %dir %{_libdir}/totem/plugins
  192. %{_libdir}/totem/plugins/apple-trailers/
  193. %{_libdir}/totem/plugins/autoload-subtitles
  194. %{_libdir}/totem/plugins/brasero-disc-recorder
  195. %{_libdir}/totem/plugins/chapters
  196. %{_libdir}/totem/plugins/dbus
  197. %{_libdir}/totem/plugins/grilo
  198. %{_libdir}/totem/plugins/gromit
  199. %{_libdir}/totem/plugins/lirc
  200. %{_libdir}/totem/plugins/media-player-keys
  201. %{_libdir}/totem/plugins/ontop
  202. %{_libdir}/totem/plugins/opensubtitles
  203. %{_libdir}/totem/plugins/properties
  204. %{_libdir}/totem/plugins/pythonconsole
  205. %{_libdir}/totem/plugins/recent
  206. %{_libdir}/totem/plugins/screensaver
  207. %{_libdir}/totem/plugins/screenshot
  208. %{_libdir}/totem/plugins/skipto
  209. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  210. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  211. %{_libdir}/totem/plugins/save-file/libsave-file.so
  212. %{_libdir}/totem/plugins/save-file/save-file.plugin
  213. %if %{build_plugin}
  214. %{_libdir}/nautilus/extensions-3.0/*.so*
  215. %endif
  216. %{_libexecdir}/%{name}/totem-bugreport.py
  217. %{_mandir}/man1/*
  218. %if %{build_plugin}
  219. %files mozilla
  220. %defattr(-,root,root,-)
  221. %{mozplug_dir}/*
  222. %{_libexecdir}/totem-plugin-viewer
  223. %endif
  224. %files devel
  225. %defattr(-, root, root,-)
  226. %{_includedir}/totem
  227. %{_libdir}/libtotem.so
  228. %{_libdir}/pkgconfig/totem.pc
  229. %{_datadir}/gir-1.0/Totem-1.0.gir
  230. %{_datadir}/gtk-doc/html/totem
  231. %changelog
  232. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  233. - new upstream release
  234. - add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
  235. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  236. - new upstream release
  237. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  238. - add configure option (--disable-vegas-plugin)
  239. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  240. - new upstream release
  241. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  242. - new upstream release
  243. - add BuildRequires: pylint
  244. - remove BuildRequires: libgdata-devel
  245. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  246. - new upstream release
  247. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  248. - new upstream release
  249. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  250. - new upstream release
  251. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  252. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  253. - new upstream release
  254. - change BuildRequires: gtk3-devel instead of gtk2-devel
  255. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  256. clutter-gst-devel, libmx-devel
  257. - change configure option (--disable-vala)
  258. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  259. - new upstream release
  260. - fix %files
  261. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  262. - new upstream release
  263. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  264. - clean up spec file
  265. - remove totem-common and merged to totem main package.
  266. - add Obsoletes: totem-common
  267. - remove unneeded BR: and R:
  268. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  269. - libmusicbrainz, alternatives
  270. - remove explicit dependency
  271. - gtk2, glib2, dbus
  272. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  273. - add R: gstreamer-plugins-good
  274. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  275. - rebuild with libgdata (add youtube plugin)
  276. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  277. - add Obsolete: totem-gstreamer, totem-xine)
  278. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  279. - new upstream release
  280. - chagnge _gst_ver from 0.10.19 to 0.10.29
  281. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  282. - new upstream release
  283. - drop totem-tracker package
  284. - add BuildRequires: unique-devel
  285. - remove BuildRequires: hal-devel
  286. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  287. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  288. - remove unneeded autoreconf
  289. - add BR: lirc
  290. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  291. - new upstream release
  292. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  293. - remove bemused plugin
  294. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  295. - new upstream release
  296. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  297. - added tracker video search sub-package
  298. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  299. - new upstream release
  300. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  301. - new upstream release
  302. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  303. - remove libxine dependency from totem-common
  304. - build xine backend with minimum dependency
  305. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  306. - add BR: bluez-libs-devel >= 4.15
  307. - fix typo in %%postun xine
  308. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  309. - rebuild with bluez-libs-devel-4.15
  310. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  311. - new upstream release
  312. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  313. - new upstream release
  314. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  315. - new upstream release
  316. - add patch1 to build with xulrunner-1.9
  317. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  318. - new upstream release
  319. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  320. - new upstream release
  321. - disabled devel package (replaced by totem-pl-parser-devel)
  322. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  323. - new upstream release
  324. - update version macros
  325. - enable browser plugins on x86_64
  326. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  327. - new upstream release
  328. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  329. - upstream release
  330. - drop obsolete ja.po.patch (patch0)
  331. - revert change of 1.4.4-0vl2
  332. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  333. - upstream release
  334. - enable browser plugins (exclude x86_64 arch)
  335. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  336. - upstream release
  337. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  338. - update configure options
  339. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  340. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  341. - fix mistranslation (patch0)
  342. - add icon symlink
  343. - add BuildRequires: gstreamer-plugins-good
  344. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  345. - upstream release
  346. - update %%_glib_ver, %%_xine_ver
  347. - add BuildRequires: hal
  348. - update %%configure options
  349. - update %%files
  350. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  351. - upstream release
  352. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  353. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  354. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  355. - upstream release
  356. - drop obsolete patch0
  357. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  358. - upstream release
  359. - add patch0 to build with intltool-0.35
  360. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  361. - upstream release
  362. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  363. - upstream release
  364. - update alternatives entry
  365. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  366. - upstream release
  367. - drop fix-sort-function.patch (was merged to upstream, #331426)
  368. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  369. - rebuild with gnome-2.14rc
  370. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  371. - upstream release
  372. - add macros
  373. - _gtk_ver, _glib_ver
  374. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  375. - _dbus_ver
  376. - _gst_ver, gstpb_ver, _xine_ver
  377. - add fix-sort-function.patch to build with glib < 2.9.1
  378. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  379. - upstream release
  380. - add BuildRequires:
  381. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  382. - gnome-vfs2-devel >= 2.9.92
  383. - dbus-devel >= 0.35
  384. - use gstreamer-0.10 as backend for totem-gstreamer
  385. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  386. - use gstreamer08 instead of gstreamer
  387. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  388. - upstream release
  389. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  390. - fix missing links
  391. - update file list
  392. - update update-alternatives scripts
  393. - fix totem-gstreamer's %%postun script
  394. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  395. - upstream release
  396. - add BuildRequires: iso-codes, libmusicbrainz-devel
  397. - add Requires: iso-codes, libmusicbrains to -common package
  398. - remove BuildRequires: nautilus-cd-burner
  399. - remove Requires: nautilus-cd-burner from -common package
  400. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  401. - totem-gstreamer obsoletes nautilus-media
  402. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  403. - upstream release
  404. - add Requires(post,postun): alternatives for gstreamer,xine
  405. - add Requires(postun,triggers): alternatives for common
  406. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  407. - upstream release
  408. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  409. - build xine backend
  410. - move common files to common package
  411. - move GStreamer related files to gstreamer package
  412. - install xine related files to xine package
  413. - fix scripts
  414. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  415. - upstream release
  416. - update URL
  417. - move *.{a,la} to devel package
  418. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  419. - fix %%{post,preun} script (video-thumbnail.schemas)
  420. - sync with Fedora Core's 1.0.1-1
  421. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  422. - Update to upstream version 1.0.1
  423. - Break out devel package
  424. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  425. - add %%{post,pre}un script
  426. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  427. - initial build for Vine Linux
  428. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  429. - fix %%post
  430. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  431. - Obsolete nautilus-media
  432. - Install property page and thumbnailer
  433. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  434. - Update to 0.101
  435. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  436. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  437. missing menu entry (144088)
  438. - Remove workaround for desktop file being misinstalled, fixed
  439. by above patch
  440. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  441. - New upstream version 0.100
  442. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  443. - update to 0.99.22
  444. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  445. - Add patch to remove removed items from package from help
  446. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  447. - New upstream 0.99.19
  448. - Fixes crasher with CD playback (see NEWS)
  449. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  450. - Call update-desktop-database in post
  451. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  452. - update to 0.99.18
  453. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  454. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>