perl-Net_SSLeay-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168
  1. %define real_name Net-SSLeay
  2. Summary: Perl module for using OpenSSL via Network
  3. Summary(ja): OpenSSL を Network にて用いる為の perl モジュール
  4. Name: perl-Net_SSLeay
  5. Version: 1.36
  6. Release: 2%{?_dist_release}
  7. License: BSDish
  8. Group: Development/Libraries
  9. Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/Net/%{real_name}-%{version}.tar.gz
  10. Source1: COPYRIGHT.SSLeay-0.9.0
  11. BuildRequires: perl, openssl-devel >= 0.9.6b
  12. BuildRequires: zlib-devel
  13. Requires: perl, openssl >= 0.9.6b
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. %description
  16. Perl module for using OpenSSL via Network, Net::SSLeay.
  17. %description -l ja
  18. OpenSSL を Network にて用いる為の perl モジュール, Net::SSLeay
  19. %prep
  20. %setup -q -n %{real_name}-%{version}
  21. cp -p %{SOURCE1} .
  22. # openssl_path is /usr here, therefore don't -I/usr/include and
  23. # especially don't (badly) hardcode standard library search path
  24. # /usr/lib
  25. if [[ "%{_prefix}" = "/usr" ]]; then
  26. perl -pi -e "s@-[LI]\\\$openssl_path[^\s\"]*@@g" Makefile.PL INSTALLDIRS=vendor
  27. fi
  28. %build
  29. # note the %{_prefix} which must passed to Makefile.PL, weird but necessary :-(
  30. perl Makefile.PL %{_prefix} INSTALLDIRS=vendor
  31. make OPTIMIZE="$RPM_OPT_FLAGS" PREFIX=%{_prefix}
  32. perl -p -i -e 's|/usr/local/bin|/usr/bin|g;' *.pm examples/*
  33. %install
  34. rm -rf %{buildroot}
  35. #mkdir -p %{buildroot}%{perl_archlib}
  36. #make install PREFIX=%{buildroot}%{_prefix} \
  37. # SITEPREFIX=%{buildroot}%{_prefix} \
  38. # VENDORPREFIX=%{buildroot}%{_prefix} \
  39. # INSTALLPRIVLIB=%{buildroot}%{perl_privlib} \
  40. # INSTALLSITELIB=%{buildroot}%{perl_sitelib} \
  41. # INSTALLVENDORLIB=%{buildroot}%{perl_vendorlib} \
  42. # INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
  43. # INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
  44. # INSTALLVENDORARCH=%{buildroot}%{perl_vendorarch} \
  45. # INSTALLBIN=%{buildroot}%{_bindir} \
  46. # INSTALLSITEBIN=%{buildroot}%{_bindir} \
  47. # INSTALLVENDORBIN=%{buildroot}%{_bindir} \
  48. # INSTALLSCRIPT=%{buildroot}%{_bindir} \
  49. # INSTALLMAN1DIR=%{buildroot}%{_mandir}/man1 \
  50. # INSTALLSITEMAN1DIR=%{buildroot}%{_mandir}/man1 \
  51. # INSTALLVENDORMAN1DIR=%{buildroot}%{_mandir}/man1 \
  52. # INSTALLMAN3DIR=%{buildroot}%{_mandir}/man3 \
  53. # INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3 \
  54. # INSTALLVENDORMAN3DIR=%{buildroot}%{_mandir}/man3
  55. make install DESTDIR=%{buildroot}
  56. sed -e "s@^%{buildroot}@@g" < %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist > .packlist
  57. mv -f .packlist %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist
  58. #if [ -f %{buildroot}%{perl_archlib}/perllocal.pod ] ; then
  59. # mv %{buildroot}%{perl_archlib}/perllocal.pod .
  60. #else
  61. # touch perllocal.pod
  62. #fi
  63. perllocalfile=`find %{buildroot} -name perllocal.pod`
  64. echo "mv $perllocalfile ."
  65. mv $perllocalfile .
  66. {
  67. find %{buildroot} \
  68. -type f -o -type l | sed -e "s@^%{buildroot}@@g" -e 's@^\(.*/man/.*\)$@\1*@g'
  69. } > %{name}.files
  70. %clean
  71. rm -rf %{buildroot}
  72. #check
  73. #make test
  74. %files -f %{name}.files
  75. %defattr(-,root,root)
  76. %doc Changes Credits QuickRef README COPYRIGHT.SSLeay-0.9.0 perllocal.pod
  77. #%dir %{perl_vendorarch}/auto/Net
  78. #%dir %{perl_vendorarch}/auto/Net/SSLeay
  79. #%dir %{perl_vendorarch}/Net
  80. #%dir %{perl_vendorarch}/Net/SSLeay
  81. %changelog
  82. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-2
  83. - rebuild with perl-5.12.3
  84. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-1
  85. - new upstream release
  86. - change BuildRequires: openssl-devel instead of openssl
  87. - add BuildRequires: zlib-devel
  88. * Wed Jul 8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.35-1
  89. - new upstream release
  90. * Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.30-2
  91. - spec in utf-8
  92. * Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-1
  93. - rebuilt with perl-5.10.0
  94. - applied new versioning policy
  95. * Sun Jun 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl2
  96. - rebuilt with openssl-0.9.8e
  97. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl1
  98. - updated to 1.30
  99. * Sat Sep 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.25-0vl4
  100. - installed files to vendor_perl
  101. - changed Group to Development/Libraries
  102. * Mon Nov 29 2004 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl3
  103. - build on perl-5.8.6-0vl1
  104. * Wed Dec 10 2003 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl2
  105. - build with perl-5.8.2
  106. - add %%{perl_sitearch}/{Net,Net/SSLeay} directories in %%files
  107. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.25-0vl1
  108. - new upstream version
  109. - built on perl-5.8.1
  110. * Thu May 08 2003 Tomoya TAKA <taka@vinelinux.org> 1.22-0vl5
  111. - fixed install man dir, again
  112. * Tue May 06 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl4
  113. - fixed install dir of perllocal.pod
  114. * Thu May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl3
  115. - fixed install man dir
  116. * Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl2
  117. - comment out "make test"
  118. * Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl1
  119. - updated to 1.22
  120. * Fri Feb 15 2002 Toru Sagami <sagami@vinelinux.org> 1.13-0vl1
  121. - updated to 1.13
  122. - BuildPreReq/Requires: perl, openssl-0.9.6b
  123. - rewrite a better spec with License/Group
  124. * Mon Jul 16 2001 <sagami@vinelinux.org>
  125. - 1.07-0vl3: rebuilt with openssl-0.9.6b
  126. - erase unneeeded files from %%doc
  127. - use _prefix, not prefix
  128. * Thu Jul 05 2001 <sagami@vinelinux.org>
  129. - 1.07-0vl2: built with perl-5.6.1
  130. * Thu Jun 7 2001 Yasuhide OMORI <omori@m-t.com>
  131. - 1.07
  132. * Fri Sep 1 2000 Yoshishiro Kajiki <kajiki@ylug.org>
  133. - first version of rpm.