perl-Test-Unit-vl.spec 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. Summary: a unit testing interface for Perl
  2. Name: perl-Test-Unit
  3. Version: 0.25
  4. Release: 2%{?_dist_release}
  5. License: Perl's
  6. Group: Development/Libraries
  7. Source0: http://prdownloads.sourceforge.net/perlunit/Test-Unit-%{version}.tar.gz
  8. Url: http://perlunit.sourceforge.net/
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: perl >= 5.004
  11. BuildRequires: perl-Class-Inner
  12. BuildRequires: perl-Devel-Symdump
  13. BuildRequires: perl-Error
  14. Requires: perl >= 5.004
  15. Requires: perl-Error
  16. Requires: perl-Devel-Symdump
  17. Requires: perl-Class-Inner
  18. Requires: perl-Tk
  19. BuildArch: noarch
  20. %description
  21. Test::Unit is the procedural style interface to a sophisticated
  22. unit testing framework for Perl that is derived from the JUnit
  23. testing framework for Java by Kent Beck and Erich Gamma.
  24. %prep
  25. %setup -q -n Test-Unit-%{version}
  26. %build
  27. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  28. make
  29. %install
  30. rm -rf $RPM_BUILD_ROOT
  31. mkdir -p $RPM_BUILD_ROOT%{_prefix}
  32. make DESTDIR=$RPM_BUILD_ROOT install
  33. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  34. sed "s@^$RPM_BUILD_ROOT@@g" |
  35. grep -v ^%{_mandir} |
  36. grep -v perllocal.pod |
  37. grep -v "\.packlist" > %{name}.files
  38. if [ "$(cat %{name}.files)X" = "X" ] ; then
  39. echo "ERROR: EMPTY FILE LIST"
  40. exit -1
  41. fi
  42. %check
  43. make test
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %files -f %{name}.files
  47. %defattr(-,root,root)
  48. %doc Changes README doc examples *.pl AUTHORS ChangeLog
  49. %{_mandir}/*/*
  50. %dir %{perl_vendorlib}/Test
  51. %dir %{perl_vendorlib}/Test/Unit
  52. %dir %{perl_vendorlib}/Test/Unit/Assertion
  53. %dir %{perl_vendorlib}/Test/Unit/Runner
  54. %changelog
  55. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25-2
  56. - rebuild with perl-5.12.3
  57. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.25-1vl5
  58. - applied new versioning policy
  59. - added BuildRequires: perl-Class-Inner, perl-Devel-Symdump, perl-Error
  60. * Thu Feb 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.25-0vl1
  61. - updated to 0,25
  62. - changed Group to Development/Libraires
  63. - added Requires: perl-Tk
  64. * Sat May 10 2003 IWAI Masaharu <iwai@alib.jp> 0.24-0vl1
  65. - version up to 0.24
  66. - replace Copyright tag with License tag
  67. - clarify the License
  68. - update Requires:
  69. add perl-Error, perl-Devel-Symdump and perl-Class-Inner
  70. * Fri Apr 5 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.14-0vl1
  71. - first release for Vine Linux