openssl-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 10
  3. %define version 1.0.2m
  4. %define release 1%{_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl
  7. Version: %{version}
  8. Release: %{release}
  9. Source: ftp://ftp.openssl.org/source/openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source6: make-dummy-cert
  12. Source7: renew-dummy-cert
  13. # Patch0: openssl-1.0.2-soversion.patch
  14. # Patch2: openssl-1.0.1-rpm_opt.patch
  15. Patch0: openssl-1.0.2g-rpmbuild.patch
  16. Patch4: openssl-1.0.2g-enginesdir.patch
  17. Patch5: openssl-1.0.2a-version-add-engines.patch
  18. Patch8: openssl-1.0.1c-perlfind.patch
  19. # security fix
  20. # nothing ;-)
  21. License: BSDish
  22. Group: System Environment/Libraries
  23. URL: http://www.openssl.org/
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: perl, sed
  26. BuildRequires: zlib-devel, krb5-devel
  27. Requires: mktemp
  28. Requires: ca-certificates
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. Packager: daisuke, iwamoto
  32. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  33. %description
  34. The OpenSSL certificate management tool and the shared libraries that
  35. provide various cryptographic algorithms and protocols.
  36. %package devel
  37. Summary: OpenSSL libraries and development headers.
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: krb5-devel
  41. %description devel
  42. The static libraries and include files needed to compile apps
  43. with support for various the cryptographic algorithms and protocols
  44. supported by OpenSSL.
  45. Patches for many networking apps can be found at:
  46. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  47. %package static
  48. Summary: Libraries for static linking of applications which will use OpenSSL
  49. Group: Development/Libraries
  50. Requires: %{name}-devel = %{version}-%{release}
  51. %description static
  52. OpenSSL is a toolkit for supporting cryptography. The openssl-static
  53. package contains static libraries needed for static linking of
  54. applications which support various cryptographic algorithms and
  55. protocols.
  56. %package perl
  57. Summary: OpenSSL scripts which require Perl.
  58. Group: Applications/Internet
  59. Requires: perl
  60. Requires: %{name} = %{version}-%{release}
  61. %description perl
  62. Perl scripts provided with OpenSSL for converting certificates and keys
  63. from other formats to those used by OpenSSL.
  64. ## to build compat32 for x86_64 architecture support
  65. %package -n compat32-%{name}
  66. Summary: Secure Sockets Layer Toolkit
  67. Group: System Environment/Libraries
  68. Requires: %{name} = %{version}-%{release}
  69. %description -n compat32-%{name}
  70. The OpenSSL certificate management tool and the shared libraries that
  71. provide various cryptographic algorithms and protocols.
  72. %package -n compat32-%{name}-devel
  73. Summary: OpenSSL libraries and development headers.
  74. Group: Development/Libraries
  75. Requires: compat32-%{name} = %{version}-%{release}
  76. Requires: compat32-krb5-devel
  77. %description -n compat32-%{name}-devel
  78. The static libraries and include files needed to compile apps
  79. with support for various the cryptographic algorithms and protocols
  80. supported by OpenSSL.
  81. %prep
  82. %setup -q -n openssl-%{version}
  83. %patch0 -p1 -b .soversion
  84. %patch4 -p1 -b .enginesdir
  85. %patch5 -p1 -b .version-add-engines
  86. %patch8 -p1 -b .perlfind
  87. # security fix
  88. # nothing ;-)
  89. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  90. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  91. # chmod 644 doc/openssl_button.html doc/openssl_button.gif
  92. chmod 644 doc/ssleay.txt
  93. %build
  94. PATH=${PATH}:${PWD}/bin
  95. TOPDIR=${PWD}
  96. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  97. # Modify the various perl scripts to reference perl in the right location.
  98. perl util/perlpath.pl `dirname %{__perl}`
  99. # Generate a table with the compile settings for my perusal.
  100. touch Makefile
  101. make TABLE PERL=%{__perl}
  102. # Figure out which flags we want to use.
  103. # default
  104. sslarch=%{_os}-%{_target_cpu}
  105. #
  106. %ifarch %ix86
  107. sslarch=linux-elf
  108. if ! echo %{_target} | grep -q i686 ; then
  109. sslflags="no-asm 386"
  110. fi
  111. %endif
  112. %ifarch sparcv9
  113. sslarch=linux-sparcv9
  114. sslflags=no-asm
  115. %endif
  116. %ifarch sparc64
  117. sslarch=linux64-sparcv9
  118. sslflags=no-asm
  119. %endif
  120. %ifarch alpha alphaev56 alphaev6 alphaev67
  121. sslarch=linux-alpha-gcc
  122. %endif
  123. %ifarch s390 sh3eb sh4eb
  124. sslarch="linux-generic32 -DB_ENDIAN"
  125. %endif
  126. %ifarch s390x
  127. sslarch="linux64-s390x"
  128. %endif
  129. %ifarch %{arm} sh3 sh4
  130. sslarch=linux-generic32
  131. %endif
  132. # ia64/x86_64/ppc\ppc64 are OK by default.
  133. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  134. # usable on all platforms. The Configure script already knows to use -fPIC and
  135. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  136. ./Configure \
  137. --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
  138. zlib-dynamic enable-camellia enable-seed enable-tlsext \
  139. enable-rfc3779 enable-cms enable-md2 \
  140. --enginesdir=%{_libdir}/openssl/engines \
  141. --with-krb5-flavor=MIT --with-krb5-dir=/usr \
  142. shared ${sslarch}
  143. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  144. # marked as not requiring an executable stack.
  145. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  146. make depend
  147. make all build-shared
  148. # Generate hashes for the included certs.
  149. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  150. export LD_LIBRARY_PATH
  151. make rehash build-shared
  152. # Verify that what was compiled actually works.
  153. make -C test apps tests
  154. # Relink the main binary to get it dynamically linked.
  155. rm apps/openssl
  156. make all build-shared
  157. %install
  158. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  159. # Install OpenSSL.
  160. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
  161. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  162. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  163. # added for lib64
  164. # mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  165. mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
  166. # mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  167. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  168. mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
  169. rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
  170. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  171. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  172. chmod 755 ${lib}
  173. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  174. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  175. done
  176. # install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  177. # Install a makefile for generating keys and self-signed certs, and a script
  178. # for generating them on the fly.
  179. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
  180. install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
  181. install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
  182. install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
  183. # Make sure we actually include the headers we built against.
  184. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  185. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  186. install -m644 include/openssl/`basename ${header}` ${header}
  187. fi
  188. done
  189. # Rename man pages so that they don't conflict with system man pages. We used
  190. # to change the file extensions, but that only prevents file conflicts. The
  191. # man viewer still can't select either of the two unless we physically change
  192. # the directory.
  193. for section in 1 2 3 4 5 6 7 8 ; do
  194. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  195. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  196. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  197. fi
  198. done
  199. # Pick a CA script.
  200. pushd $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
  201. mv CA.sh CA
  202. popd
  203. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
  204. mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
  205. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
  206. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
  207. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
  208. # Ensure the openssl.cnf timestamp is identical across builds to avoid
  209. # mulitlib conflicts and unnecessary renames on upgrade
  210. touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
  211. %clean
  212. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  213. %files
  214. %defattr(-,root,root)
  215. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  216. %doc doc/README doc/c-indentation.el doc/openssl.txt
  217. %doc doc/openssl_button.html doc/openssl_button.gif
  218. %doc doc/ssleay.txt
  219. %{_sysconfdir}/pki/tls/certs/make-dummy-cert
  220. %{_sysconfdir}/pki/tls/certs/renew-dummy-cert
  221. %{_sysconfdir}/pki/tls/certs/Makefile
  222. %{_sysconfdir}/pki/tls/misc/CA
  223. %dir %{_sysconfdir}/pki/CA
  224. %dir %{_sysconfdir}/pki/CA/private
  225. %dir %{_sysconfdir}/pki/CA/certs
  226. %dir %{_sysconfdir}/pki/CA/crl
  227. %dir %{_sysconfdir}/pki/CA/newcerts
  228. %{_sysconfdir}/pki/tls/misc/c_*
  229. %dir %{_sysconfdir}/pki/tls
  230. %dir %{_sysconfdir}/pki/tls/certs
  231. %dir %{_sysconfdir}/pki/tls/misc
  232. %dir %{_sysconfdir}/pki/tls/private
  233. %config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
  234. %attr(0755,root,root) %{_bindir}/openssl
  235. %attr(0755,root,root) /%{_lib}/*.so.*
  236. %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
  237. %attr(0755,root,root) %dir %{_mandir}/man1*
  238. %attr(0644,root,root) %{_mandir}/man1*/*
  239. %attr(0755,root,root) %dir %{_mandir}/man5*
  240. %attr(0644,root,root) %{_mandir}/man5*/*
  241. %attr(0755,root,root) %dir %{_mandir}/man7*
  242. %attr(0644,root,root) %{_mandir}/man7*/*
  243. %files devel
  244. %defattr(-,root,root)
  245. %{_prefix}/include/openssl
  246. %exclude %{_libdir}/lib*.a
  247. %attr(0755,root,root) %{_libdir}/*.so
  248. %attr(0755,root,root) %dir %{_mandir}/man3*
  249. %attr(0644,root,root) %{_mandir}/man3*/*
  250. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  251. %files static
  252. %defattr(-,root,root)
  253. %attr(0644,root,root) %{_libdir}/*.a
  254. %files perl
  255. %defattr(-,root,root)
  256. %attr(0755,root,root) %{_bindir}/c_rehash
  257. %attr(0755,root,root) %dir %{_mandir}/man1*
  258. %attr(0644,root,root) %{_mandir}/man1*/*.pl*
  259. %{_sysconfdir}/pki/tls/misc/*.pl
  260. #%{_sysconfdir}/pki/tls/misc/tsget
  261. %doc apps/tsget
  262. ## to build compat32 for x86_64 architecture support
  263. %if %{build_compat32}
  264. %files -n compat32-%{name}
  265. %defattr(-,root,root)
  266. %attr(0755,root,root) /%{_lib}/*.so.*
  267. %files -n compat32-%{name}-devel
  268. %defattr(-,root,root)
  269. %exclude %{_libdir}/lib*.a
  270. %attr(0755,root,root) %{_libdir}/*.so
  271. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  272. %endif
  273. %post -p /sbin/ldconfig
  274. %postun -p /sbin/ldconfig
  275. %post -n compat32-%{name} -p /sbin/ldconfig
  276. %postun -n compat32-%{name} -p /sbin/ldconfig
  277. %changelog
  278. * Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
  279. - new upstream release with security fixes
  280. * Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
  281. - new upstream release with security fixes
  282. * Thu May 5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
  283. - new upstream release with security fixes
  284. * Wed Mar 9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
  285. - new upstream release 1.0.2 with security fixes
  286. - Patch2 is merged into Patch0
  287. * Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
  288. - new upstream release with security fixes
  289. * Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
  290. - new upstream release with security fixes
  291. * Wed Jul 1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
  292. - new upstream release
  293. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
  294. - merged into Vine6
  295. * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
  296. - new upstream release with security fixes
  297. - update Patch2,5
  298. * Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
  299. - new upstream release with security fixes
  300. * Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
  301. - new upstream release with security fixes
  302. - add patch8 from fc21 (fix perl find.pl)
  303. * Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
  304. - new upstream release with security fixes.
  305. * Tue Apr 8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
  306. - new upstream release with security fixes
  307. * Thu Jan 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
  308. - new upstream release with security fixes
  309. * Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
  310. - move root CA bundle to ca-certificates package
  311. * Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
  312. - update to 1.0.1e
  313. - 1.0.1d has major regressions from 1.0.1c
  314. * Sat Feb 9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
  315. - remove tsget script to delete dependency perl(WWW::Curl::Easy)
  316. - openssl-perl package contains it in docdir
  317. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
  318. - new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
  319. - fixed %%files
  320. * Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
  321. - update to 1.0.1c
  322. - enable configure options:
  323. enable-camellia enable-seed enable-tlsext enable-rfc3779
  324. enable-cms enable-md2
  325. - remove no-asm option from ai64/x86_64/ppc/ppc64/i686
  326. - generate a table with the compile settings before configure
  327. * Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
  328. - new upstream release with security fix (CVE-2012-0050)
  329. * Fri Jan 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
  330. - new upstream release with security fix
  331. (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
  332. * Wed Sep 7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
  333. - new upstream release with security fix (CVE-2011-3207, 3210)
  334. * Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
  335. - rebuild with krb5-libs 1.8
  336. * Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
  337. - new upstream release with security fix
  338. * Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
  339. - use upstream openssl.pc instead of vine original one (SOURCE6)
  340. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
  341. - move tsget to docs to delete dependency perl(WWW::Curl::Easy)
  342. * Sat Jan 1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
  343. - add R: krb5-devel into devel pkg
  344. - add R: compat32-krb5-devel into compat32-devel pkg
  345. * Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
  346. - new upstream release 1.0.0x
  347. - separate static libs into static package
  348. - change configure options
  349. - change so version 10
  350. - add tsget into perl package
  351. - update all patches
  352. * Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
  353. - fix changelog typo...
  354. * Tue Dec 7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
  355. - new upstream release with security fix (CVE-2010-4180)
  356. * Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
  357. - new upstream release with security fix (CVE-2010-3864)
  358. - drop patches included in new release
  359. - update patch4
  360. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  361. - add patch12 for fix CVE-2009-3555 (renegotiation)
  362. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  363. - add patch11 for fix CVE-2009-4355 (memory leak)
  364. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  365. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  366. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  367. - removed unnecessary %%if %{build_compat32} statements
  368. - removed lib*.a from devel package
  369. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  370. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  371. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  372. - new upstream release with security fix (CVE-2008-5077)
  373. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  374. - new upstream release
  375. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  376. - new upstream release
  377. - new versioning policy
  378. * Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  379. - new upstream release
  380. - drop patch10,20 which is merged in upstream
  381. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  382. - add security patch in advance for CVE-2007-5135
  383. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  384. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  385. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  386. - add security patch for CVE-2007-3108
  387. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  388. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  389. - new upstream release
  390. * Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  391. - update (fix) openssl.pc <BTS:437>
  392. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  393. - new upstream release (with security fix)
  394. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  395. - new upstream release
  396. - add patch2 to use RPM_OPT macro
  397. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  398. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  399. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  400. - added compat32-* packages for x86_64 architecture support
  401. - added openssl-0.9.7i.Configure-compat32.patch
  402. - changed '/lib' to '/%{_lib}'
  403. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  404. - new upstream release
  405. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  406. - rebuild on VineSeed
  407. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  408. - added a security patch from Gentoo.
  409. - Patch1: openssl-0.9.7c-tempfile.patch
  410. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  411. - sslarch for ppc was missing... added.
  412. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  413. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  414. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  415. - new upstream version
  416. - clean up of spec file
  417. -- removed old patches
  418. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  419. - new upstream release
  420. - SECURITY fix.
  421. - http://www.openssl.org/news/secadv_20040317.txt
  422. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  423. - new upstream release
  424. - [Security fix]
  425. - Vulnerabilities in ASN.1 parsing
  426. http://www.openssl.org/news/secadv_20030930.txt
  427. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  428. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  429. - add openssl.pc for pkgconfig
  430. * Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  431. - New upstream version
  432. - dropped patch10, 11
  433. -- merged upstream version
  434. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  435. - rebuild for VineSeed
  436. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  437. - [Security Fix]
  438. - Timing-based attacks on RSA keys
  439. http://www.openssl.org/news/secadv_20030317.txt
  440. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  441. http://www.openssl.org/news/secadv_20030317.txt
  442. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  443. - new upstream release 0.9.6i
  444. - [Security Fix]
  445. - build for Vine Linux 2.6 errata
  446. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  447. - new upstream release 0.9.6h
  448. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  449. - new upstream release 0.9.6g
  450. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  451. - SECURITY: CAN-2002-0659 fixed
  452. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  453. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  454. - update asn patch to fix accidental reversal of a logic check
  455. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  456. - update asn patch to reduce chance that compiler optimization will remove
  457. one of the added tests
  458. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  459. - rebuild
  460. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  461. - add patch to fix ASN.1 vulnerabilities
  462. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  463. - rename spec file name
  464. - SECURITY: CA-2002-23 fixed
  465. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  466. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  467. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  468. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  469. - added ${PATH} in LD_LIBRARY_PATH
  470. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  471. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  472. - remove --no-<cipher>
  473. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  474. - add Patch10 for mipsel shared ( Configure )
  475. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  476. - build for Vine Linux
  477. - use openssl-engine-0.9.6b.tar.gz
  478. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  479. - update to 0.9.6b
  480. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  481. - move .so symlinks back to %%{_libdir}
  482. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  483. - move shared libraries to /lib (#38410)
  484. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  485. - switch to engine code base
  486. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  487. - add a script for creating dummy certificates
  488. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  489. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  490. - add s390x support
  491. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  492. - change two memcpy() calls to memmove()
  493. - don't define L_ENDIAN on alpha
  494. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  495. - make subpackages depend on the main package
  496. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  497. - adjust the hobble script to not disturb symlinks in include/ (fix from
  498. Joe Orton)
  499. * Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  500. - drop the m2crypo patch we weren't using
  501. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  502. - configure using "shared" as well
  503. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  504. - update to 0.9.6a
  505. - use the build-shared target to build shared libraries
  506. - bump the soversion to 2 because we're no longer compatible with
  507. our 0.9.5a packages or our 0.9.6 packages
  508. - drop the patch for making rsatest a no-op when rsa null support is used
  509. - put all man pages into <section>ssl instead of <section>
  510. - break the m2crypto modules into a separate package
  511. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  512. - use BN_LLONG on s390
  513. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  514. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  515. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  516. - move c_rehash to the perl subpackage, because it's a perl script now
  517. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  518. - update to 0.9.6
  519. - enable MD2
  520. - use the libcrypto.so and libssl.so targets to build shared libs with
  521. - bump the soversion to 1 because we're no longer compatible with any of
  522. the various 0.9.5a packages circulating around, which provide lib*.so.0
  523. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  524. - change hobble-openssl for disabling MD2 again
  525. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  526. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  527. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  528. apps built against a version of the library without it
  529. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  530. - disable some inline assembly, which on x86 is Pentium-specific
  531. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  532. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  533. - fix s390 patch
  534. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  535. - added support s390
  536. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  537. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  538. - add the CA.pl man page to the perl subpackage
  539. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  540. - always build with -mcpu=ev5 on alpha
  541. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  542. - add a symlink from cert.pem to ca-bundle.crt
  543. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  544. - add a ca-bundle file for packages like Samba to reference for CA certificates
  545. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  546. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  547. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  548. - add unzip as a buildprereq (#17662)
  549. - update m2crypto to 0.05-snap4
  550. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  551. - fix some issues in building when it's not installed
  552. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  553. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  554. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  555. - add Richard Henderson's patch for BN on ia64
  556. - clean up the changelog
  557. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  558. - fix the building of python modules without openssl-devel already installed
  559. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  560. - byte-compile python extensions without the build-root
  561. - adjust the makefile to not remove temporary files (like .key files when
  562. building .csr files) by marking them as .PRECIOUS
  563. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  564. - break out python extensions into a subpackage
  565. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  566. - tweak the makefile some more
  567. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  568. - disable MD2 support
  569. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  570. - disable MDC2 support
  571. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  572. - tweak the disabling of RC5, IDEA support
  573. - tweak the makefile
  574. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  575. - strip binaries and libraries
  576. - rework certificate makefile to have the right parts for Apache
  577. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  578. - use %%{_perl} instead of /usr/bin/perl
  579. - disable alpha until it passes its own test suite
  580. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  581. - move the passwd.1 man page out of the passwd package's way
  582. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  583. - update to 0.9.5a, modified for U.S.
  584. - add perl as a build-time requirement
  585. - move certificate makefile to another package
  586. - disable RC5, IDEA, RSA support
  587. - remove optimizations for now
  588. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  589. - Bero told me to move the Makefile into this package
  590. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  591. - add lib*.so symlinks to link dynamically against shared libs
  592. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  593. - update to 0.9.5
  594. - run ldconfig directly in post/postun
  595. - add FAQ
  596. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  597. - Fix build on non-x86 platforms
  598. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  599. - move /usr/share/ssl/* from -devel to main package
  600. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  601. - inital packaging
  602. - changes from base:
  603. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  604. - handle RPM_OPT_FLAGS