xorg-x11-drv-intel-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate1 20130611
  4. %define gputoolsdate2 20110817
  5. %if "%{?_dist_release}" >= "vl7"
  6. %define accel sna
  7. #%define gputoolsdate 20130611
  8. %define gputoolsdate 1.8
  9. %else
  10. %define accel sna
  11. %define gputoolsdate 20110817
  12. %endif
  13. Summary: Xorg X11 Intel video driver
  14. Summary(ja): Xorg X11 Intel ビデオドライバ
  15. Name: xorg-x11-drv-intel
  16. Epoch: 1
  17. Version: 2.99.916
  18. Release: 2%{?_dist_release}
  19. URL: http://intellinuxgraphics.org/
  20. License: MIT
  21. Group: User Interface/X Hardware Support
  22. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  23. Source2: intel.xinf
  24. #Source3: intel-gpu-tools-%{gputoolsdate1}.tar.bz2
  25. Source3: intel-gpu-tools-1.8.tar.bz2
  26. Source4: intel-gpu-tools-%{gputoolsdate2}.tar.bz2
  27. # vine patch
  28. Patch0: xf86-video-intel-2.99.916-git20141120.patch
  29. ExclusiveArch: %{ix86} x86_64 ia64
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  31. BuildRequires: autoconf, automake, libtool
  32. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  33. BuildRequires: libXvMC-devel
  34. BuildRequires: libGL-devel >= 7.10
  35. BuildRequires: libdrm-devel >= 2.4.25
  36. BuildRequires: kernel-headers >= 2.6.33
  37. BuildRequires: eudev-libudev-devel
  38. BuildRequires: libxcb-devel >= 1.5
  39. BuildRequires: xcb-util-devel
  40. BuildRequires: cairo-devel
  41. Requires: hwdata
  42. Requires: xorg-x11-server-Xorg
  43. Requires: xcb-util
  44. Obsoletes: xorg-x11-drv-i810
  45. Provides: xorg-x11-drv-i810
  46. #Conflicts: kudzu < 1.2.42-1
  47. Vendor: Project Vine
  48. Distribution: Vine Linux
  49. Packager: daisuke
  50. %description
  51. X.Org X11 Intel video driver.
  52. %package devel
  53. Summary: Xorg X11 Intel video driver XvMC development package
  54. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  55. Group: Development/System
  56. Requires: %{name} = %{epoch}:%{version}-%{release}
  57. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  58. %description devel
  59. X.Org X11 Intel video driver XvMC development package.
  60. %package -n intel-gpu-tools
  61. Summary: Debugging tools for Intel graphics chips
  62. Group: Development/Tools
  63. %description -n intel-gpu-tools
  64. Debugging tools for Intel graphics chips
  65. %prep
  66. %setup -q -n xf86-video-intel-%{version} -b3 -b4
  67. %patch0 -p1
  68. %build
  69. autoreconf -vi
  70. %if "%{?_dist_release}" < "vl7"
  71. export CFLAGS="-I/usr/include/X11/dri"
  72. %endif
  73. %configure \
  74. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  75. --enable-dri --enable-xvmc \
  76. --enable-sna --enable-uxa \
  77. --with-default-accel=%{accel} \
  78. --enable-xaa=no
  79. make
  80. pushd ../intel-gpu-tools-%{gputoolsdate}
  81. autoreconf -v --install
  82. %configure --disable-nouveau --disable-dumper
  83. make
  84. popd
  85. %install
  86. rm -rf $RPM_BUILD_ROOT
  87. make install DESTDIR=$RPM_BUILD_ROOT
  88. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  89. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  90. pushd ../intel-gpu-tools-%{gputoolsdate}
  91. make install DESTDIR=$RPM_BUILD_ROOT
  92. popd
  93. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %triggerpostun -- XOrg < 7.0
  97. if (grep -q i810 /etc/X11/xorg.conf)
  98. then
  99. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  100. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  101. fi ||:
  102. %files
  103. %defattr(-,root,root,-)
  104. %{driverdir}/intel_drv.so
  105. %{_datadir}/hwdata/videoaliases/intel.xinf
  106. %{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
  107. %{_libdir}/libI810XvMC.so.*
  108. %{_libdir}/libIntelXvMC.so.*
  109. %{_libexecdir}/xf86-video-intel-backlight-helper
  110. %{_mandir}/man4/i*
  111. %files devel
  112. %defattr(-,root,root,-)
  113. %{_libdir}/libI810XvMC.so
  114. %{_libdir}/libIntelXvMC.so
  115. %files -n intel-gpu-tools
  116. %defattr(-,root,root,-)
  117. %{_bindir}/*
  118. %{_mandir}/man1/intel_*.1*
  119. %changelog
  120. * Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-2
  121. - add Patch0 (xf86-video-intel-2.99.916-git20141120.patch)
  122. - update Source3 (intel-gpu-tools-1.8.tar.bz2)
  123. * Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
  124. - update to 2.99.916
  125. * Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
  126. - update to 2.99.912
  127. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
  128. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  129. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
  130. - rebuild with VineSeed environment
  131. * Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
  132. - new upstream release
  133. * Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
  134. - new upstream release
  135. - change default accel method to sna.
  136. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
  137. - new upstream release
  138. * Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
  139. - new upstream release
  140. * Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
  141. - new upstream release
  142. * Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
  143. - new upstream release
  144. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
  145. - new upstream release
  146. * Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
  147. - new upstream release
  148. * Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
  149. - new upstream release
  150. * Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
  151. - new upstream release
  152. * Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  153. - new upstream release
  154. * Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
  155. - new upstream release
  156. * Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
  157. - rebuild with xcb-util-0.3.9
  158. * Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
  159. - disable sna, enable uxa
  160. * Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
  161. - new upstream release
  162. * Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
  163. - rebuild with xserver-1.12.0
  164. * Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  165. - new upstream release
  166. - enable sna
  167. * Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
  168. - disable sna/vmap
  169. * Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  170. - new upstram release
  171. - disable copy-fb patch
  172. * Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
  173. - rebuild with xserver-1.11.1.902
  174. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  175. - add --enable-sna --enable-vmap
  176. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  177. - new upstream release
  178. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  179. - rebuild with xcb-util-0.3.8
  180. - drop Patch200
  181. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  182. - update to disable copy_fb on sandybridge/ivybridge
  183. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  184. - update intel.xinf
  185. - add patch10 from fedora
  186. - Clamp VGA pixel clock to 250MHz,
  187. anything higher's going to look awful anyway. (#559426)
  188. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  189. - drop patch1-3 and replaced with new patch1 from git master
  190. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  191. - update intel-gpu-tools
  192. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  193. - add Patch1-3 from upstream
  194. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  195. - new upstream release
  196. - drop upstream patches: 107-115
  197. - temporary disabled patch101
  198. - BR: libdrm >= 2.4.25
  199. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  200. - add Patch101-115 from ubuntu/debian package
  201. - Patch101: Plymouth integration patch
  202. - Patch107: Check null return from uxa_acquire_solid()
  203. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  204. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  205. - Patch110,114: Cherry picks to fix a large number of build warnings.
  206. - Patch111: Fix clipped window plane offset
  207. - Patch112: Fix issue where vertical green line and strange colors
  208. shows up when playing gstreamer with certain videos,
  209. when dragged. (LP 460677)
  210. - Patch113: Fixes GPU lockup during login with
  211. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  212. error messages listed in the gpu dump text. (LP 710321)
  213. - Patch115: Don't fill up Xorg.0.log with
  214. "get vblank counter failed: Invalid argument" warnings.
  215. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  216. - rebuild with xserver-1.10.0
  217. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  218. - new upstream release
  219. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  220. - new upstream release
  221. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  222. - rebuild with xserver-1.9.2
  223. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  224. - new upstream release
  225. - add Patch40: fix uxa planemask (backported)
  226. - add Patch61: add support for backlight on macbooks
  227. - add Patch62: disable page flipping for stability
  228. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  229. - new upstream release
  230. - drop patch70
  231. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  232. - rebuild again with xserver-1.8rc
  233. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  234. - add intel-gpu-tools as sub-package
  235. - rebuild with libdrm-2.4.18
  236. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  237. - new upstream release
  238. - import Patch1,2,60,70 from fedora
  239. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  240. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  241. - add BR; libudev-devel and autoreconf for Patch60
  242. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  243. - rebuild with libdrm-2.4.17
  244. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  245. - new upstream release
  246. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  247. - new upstream release (hopefully fixes severe issues w/ efifb)
  248. - drop all patches already upstreamed; import Patch20/21 from Fedora
  249. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  250. - import Patch121,122 from ubuntu
  251. - build with libdrm-2.4.12 which fixes vt switch crash
  252. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  253. - apply patch114 to fix Xv with non-GEM kernel
  254. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  255. - update to 2.6.3
  256. - add patch106,107,115,118,119,120 from ubuntu
  257. - add Patch106: remove triple buffering
  258. - add Patch107: remove page flipping
  259. - add Patch115: fix crash Xv overlay
  260. - add Patch118: drop legacy3d
  261. - add Patch119: fix crashes in drm bo
  262. - add Patch120: fix vt switch
  263. - add patch130-134 from upstream git
  264. - add Patch130: fix another vt switch leak
  265. - add Patch131: Create known output configuration at EnterVT time
  266. - add Patch132: fix leak of some 965 render state on VT switch
  267. - add Patch133: fix crash with fake bufmgr and UXA
  268. - add Patch134: fix EnterVT/LeaveVT
  269. - add Patch135: add new chip supoprt
  270. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  271. - revert to 2.6.1, add Epoch
  272. - add Patch103-121 from ubuntu
  273. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  274. - new upstream release
  275. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  276. - new upstream release
  277. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  278. - new upstream release
  279. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  280. - add Patch5 - Dont die on irq handler failure
  281. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  282. - new upstream release
  283. - add BR: libdrm-devel >= 2.4.0-3
  284. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  285. - import Patch10,11,12 from ubuntu
  286. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  287. - new upstream release
  288. - add triggerpostun script to replace i810 driver to intel driver
  289. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  290. - new upstream release
  291. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  292. - new upstream release
  293. - rename i810.xinf to intel.xinf
  294. - update intel.xinf (add Intel 4 series)
  295. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  296. - rebuild with new xserver
  297. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  298. - new upstream release
  299. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  300. - new upstream release
  301. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  302. - new upstream release
  303. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  304. - initial build for Vine Linux
  305. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  306. - Rebuild for new server ABI.
  307. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  308. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  309. - hook up ch7017 (bz#408471)
  310. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  311. - xf86-video-intel 2.2.0
  312. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  313. - xf86-video-intel 2.1.99.
  314. - Drop the i810 driver. Time to move on.
  315. - Require xserver 1.4.99.1
  316. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  317. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  318. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  319. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  320. for textured Xv to use as an offscreen pixmap so xv actually works under
  321. compiz - granted it may be unusably slow but at least stuff shows up.
  322. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  323. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  324. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  325. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  326. - intel-2.1.1-quirk-update.patch - update quirks from master
  327. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  328. - i810.xinf: Flip everything over to -intel by default now. Still install
  329. i810 driver just in case.
  330. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  331. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  332. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  333. - xf86-video-intel 2.1.1.
  334. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  335. - xf86-video-intel 2.1.0.
  336. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  337. - Update Requires and BuildRequires.
  338. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  339. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  340. 965GME, G33, Q33, and Q35 chips.
  341. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  342. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  343. DRI clients are active, for better battery life.
  344. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  345. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  346. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  347. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  348. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  349. rename this at some point.
  350. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  351. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  352. 915GM.
  353. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  354. - i810.xinf: More intel whitelisting (#214011, #234877)
  355. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  356. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  357. - i810.xinf: Point 965GM support at the intel driver since it's not present
  358. in old i810.
  359. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  360. - xf86-video-intel-1.9.93 (RC3).
  361. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  362. - fix typo with 945GM pci id from my laptop
  363. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  364. - xf86-video-intel 1.9.92 (RC2).
  365. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  366. - Updated modesetting driver to one that will actually work with a 1.3 server.
  367. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  368. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  369. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  370. code anywhere
  371. - Disown the module
  372. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  373. - update modesetting driver to git snapshot from today
  374. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  375. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  376. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  377. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  378. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  379. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  380. actually require kudzu to run.
  381. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  382. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  383. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  384. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  385. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  386. driver match the corresponding terrible heuristic in the server.
  387. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  388. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  389. correctly distinguish between Mac Mini and Macbook Pro.
  390. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  391. - i810.xinf: PCI IDs for i965.
  392. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  393. - i810.xinf: Uppercase PCI IDs.
  394. * Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  395. - Update i810 to 1.6.5, should fix DRI.
  396. - Add kuzdu requires.
  397. - i810.xinf: Start whitelisting devices over to intel.
  398. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  399. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  400. you know, load.
  401. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  402. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  403. LFP special casing in favor of the blacklist.
  404. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  405. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  406. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  407. and is selected with Driver "intel" in xorg.conf. Individual devices will
  408. whitelist over to "intel" until that branch gets merged into head.
  409. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  410. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  411. the BIOS is known to lie.
  412. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  413. - Today's snapshot: I2C bus creation fix.
  414. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  415. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  416. clock when computing the modes list.
  417. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  418. in centimeters as the size of the display in pixels.
  419. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  420. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  421. probing.
  422. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  423. - Update again for a mode comparison bugfix.
  424. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  425. - Update to today's git; crash fixes, better pre-915 support, slightly better
  426. autoconfigurability.
  427. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  428. - rebuild
  429. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  430. - Fix Revision number to match naming policy.
  431. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  432. - Add back modesetting changes.
  433. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  434. - Roll back modesetting changes and build for fc5 aiglx repo.
  435. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  436. - Snapshot of the git modesetting branch.
  437. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  438. - Update i810.xinf to include entries for E7221 and 945GM.
  439. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  440. - Add with_dri macro to spec file, and conditionalize build time DRI support
  441. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  442. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  443. to pick up proto-devel as well.
  444. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  445. - Rebuild for 7.1 ABI fix.
  446. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  447. - Bump for fc5-bling build.
  448. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  449. - Update to 1.6.0 from 7.1RC1.
  450. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  451. - Add patch to add missing #include's, specifically assert.h.
  452. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  453. - Update to CVS snapshot of 20060322.
  454. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  455. - rebuilt for new gcc4.1 snapshot and glibc changes
  456. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  457. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  458. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  459. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  460. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  461. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  462. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  463. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  464. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  465. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  466. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  467. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  468. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  469. - Fix *.la file removal.
  470. - Added 'devel' subpackage for XvMC .so
  471. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  472. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  473. - Update BuildRoot to use Fedora Packaging Guidelines.
  474. - Deglob file manifest.
  475. - Limit "ExclusiveArch" to x86, x86_64, ia64
  476. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  477. - Initial spec file for i810 video driver generated automatically
  478. by my xorg-driverspecgen script.