netatalk-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360
  1. %define _sysconfdir /etc
  2. ################################################# BASIC PACKAGE INFORMATION
  3. Summary: AFP fileserver for Macintosh clients
  4. Summary(ja): Macintoshクライアント向けのAFPファイルサーバー
  5. Name: netatalk
  6. Version: 3.1.11
  7. Release: 1%{_dist_release}
  8. License: GPLv2+
  9. Group: System Environment/Daemons
  10. URL: http://netatalk.sourceforge.net/
  11. Source0: %{name}-%{version}.tar.bz2
  12. Source1: netatalk.pam-system-auth
  13. Patch0: netatalk-3.0.1-basedir.patch
  14. ############################################################## REQUIREMENTS
  15. Requires(post): /sbin/chkconfig /sbin/ldconfig
  16. Requires(preun): /sbin/chkconfig
  17. Requires(preun): /sbin/service
  18. Requires(postun): /sbin/service /sbin/ldconfig
  19. BuildRequires: cracklib openssl-devel pam quota libtool automake
  20. BuildRequires: autoconf libdb-devel pam-devel tcp_wrappers libgcrypt-devel
  21. BuildRequires: avahi-devel libacl-devel openldap-devel
  22. BuildRequires: dbus-devel dbus-glib-devel glib2-devel systemtap-sdt-devel
  23. BuildRequires: libevent-devel libtdb-devel libmysqlclient-devel
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: shaolin, tomop
  28. %description
  29. Netatalk is a freely-available Open Source AFP fileserver. A *NIX/*BSD
  30. system running Netatalk is capable of serving many Macintosh clients
  31. simultaneously as an AppleShare file server (AFP).
  32. %description -l ja
  33.  Netatalkは自由に利用可能なオープンソースAFPファイルサーバーです。
  34. Netatalkを実行している*NIX/*BSDシステムでは、多くのMacintoshクライ
  35. アントに対してAppleShareファイルサーバー(AFP)としてサービスを提供
  36. 可能です。
  37. %package devel
  38. Group: Development/Libraries
  39. Summary: Headers for Netatalk development
  40. Summary(ja): Netatalk開発用ヘッダファイル
  41. %description devel
  42. This package contains the header files for Netatalk.
  43. %prep
  44. %setup -q
  45. %patch0 -p1 -b .basedir
  46. ln -s ./NEWS ChangeLog
  47. %build
  48. export CFLAGS="$RPM_OPT_FLAGS"
  49. %ifnarch x86_64
  50. # XXX : enable for x86_64 when glibc bug 149284 is fixed!
  51. export CFLAGS="$CFLAGS -fPIE"
  52. export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack"
  53. #"export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack,-z,nodlopen"
  54. #Also in case of i686, nodlopen causes the problem.
  55. %endif
  56. %configure \
  57. --with-pkgconfdir=%{_sysconfdir}/netatalk \
  58. --with-cracklib \
  59. --with-pam \
  60. --with-shadow \
  61. --with-uams-path=%{_libdir}/netatalk \
  62. --enable-shared \
  63. --enable-krbV-uam \
  64. --enable-overwrite \
  65. --with-gnu-ld \
  66. --with-init-style=redhat-sysv \
  67. --with-libgcrypt \
  68. --without-libevent \
  69. --without-tdb \
  70. --with-pam-confdir=%{_sysconfdir}/pam.d \
  71. --with-dbus-sysconf-dir=%{_sysconfdir}/dbus-1/system.d
  72. make %{?_smp_mflags} all
  73. %install
  74. ### INSTALL (USING "make install") ###
  75. rm -rf ${RPM_BUILD_ROOT}
  76. make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
  77. # install example config files in doc
  78. mkdir config.example
  79. cp -fp config/afp.conf config.example
  80. cp -fp config/extmap.conf config.example
  81. mkdir -p $RPM_BUILD_ROOT/usr/share/netatalk
  82. cp -fp %{SOURCE1} config.example
  83. # XXX bad hack until this file is updated in glibc-headers:
  84. rm -f $RPM_BUILD_ROOT/usr/include/netatalk/at.h
  85. # Clean up .a and .la files
  86. find $RPM_BUILD_ROOT -name \*.a -exec rm {} \;
  87. find $RPM_BUILD_ROOT -name \*.la -exec rm {} \;
  88. %post
  89. if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
  90. mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
  91. fi
  92. if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
  93. mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
  94. fi
  95. /sbin/chkconfig --add netatalk
  96. /sbin/ldconfig
  97. %preun
  98. if [ "$1" = "0" ] ; then
  99. # check for existence due to renaming initscript
  100. if [ -x %{_initrddir}/netatalk ] ; then
  101. /sbin/service netatalk stop > /dev/null 2>&1
  102. /sbin/chkconfig --del netatalk
  103. fi
  104. fi
  105. %postun
  106. if [ "$1" -ge "1" ]; then
  107. # Package upgrade, not uninstall
  108. if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
  109. mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
  110. fi
  111. if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
  112. mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
  113. fi
  114. /sbin/service netatalk condrestart > /dev/null 2>&1 || :
  115. fi
  116. /sbin/ldconfig
  117. %clean
  118. rm -rf ${RPM_BUILD_ROOT}
  119. %files
  120. %defattr(-,root,root)
  121. %doc COPYRIGHT COPYING ChangeLog VERSION NEWS
  122. %doc config.example
  123. %attr(755,root,root) %{_initrddir}/netatalk
  124. %dir %{_sysconfdir}/netatalk
  125. %config(noreplace) %{_sysconfdir}/netatalk/afp.conf
  126. %config(noreplace) %{_sysconfdir}/netatalk/extmap.conf
  127. %config(noreplace) %{_sysconfdir}/netatalk/dbus-session.conf
  128. %config(noreplace) %{_sysconfdir}/pam.d/netatalk
  129. %config(noreplace) %{_sysconfdir}/dbus-1/system.d/netatalk-dbus.conf
  130. %{_sbindir}/*
  131. %{_bindir}/*
  132. %exclude %{_bindir}/netatalk-config
  133. %{_mandir}/man*/*
  134. %exclude %{_mandir}/man*/netatalk-config*
  135. %{_datadir}/netatalk
  136. %{_libdir}/*.so
  137. %{_libdir}/*.so.*
  138. %dir %{_libdir}/netatalk
  139. %{_libdir}/netatalk/*.so
  140. %{_localstatedir}/netatalk
  141. %files devel
  142. %defattr(-,root,root)
  143. %doc COPYRIGHT COPYING
  144. %dir %{_includedir}/atalk
  145. %attr(0644,root,root) %{_includedir}/atalk/*
  146. %{_datadir}/aclocal/netatalk.m4
  147. %{_bindir}/netatalk-config
  148. %{_mandir}/man*/netatalk-config.1*
  149. %changelog
  150. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-1
  151. - new upstream release.
  152. * Wed Jul 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.9-1
  153. - new upstream release.
  154. - dropped Patch1: fixed in upstream.
  155. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-2
  156. - added Patch1.
  157. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-1
  158. - new upstream release.
  159. * Tue Jun 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
  160. - new upstream release.
  161. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
  162. - rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
  163. * Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
  164. - new upstream release.
  165. - added build option 'force_uidgid'.
  166. * Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
  167. - new upstream release
  168. - fix configure options; add missing BRs
  169. * Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
  170. - now back from the upstream confusion (and one more or two...)
  171. new upstream release 2.2.0 at the official site
  172. * Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
  173. - fix Patch10 to follow HAT-san's strong and confident objection
  174. (no need to set ATALK_NAME explicitly in netatalk.conf)
  175. * Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
  176. - new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
  177. - add Source100 to add one missing header file in the tarball
  178. - revise Patch10
  179. - explicitly specify --disable-ddp for the first time
  180. * Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
  181. - new upstream release
  182. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
  183. - rebuild with openssl-1.0.0c
  184. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
  185. - fix Patch10 & update description - upon HAT-san's suggestions
  186. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
  187. - new upstream release
  188. - update Vine patch
  189. * Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
  190. - new upstream release
  191. * Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
  192. - new upstream release
  193. * Sun Mar 8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
  194. - rebuilt both for VineSeed / VinePlus-4.0
  195. * Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
  196. - updated to the cjk-6 patch
  197. - Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
  198. - Patch14 updated for db46
  199. * Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
  200. - remove openslp dependency
  201. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
  202. - add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
  203. - TODO: remember to revise this fix after VineSeed changes default locale
  204. from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
  205. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
  206. - revise description (thanks HAT-san for pointing this out)
  207. - run libtoolize/aclocal/auto{make,conf,header} before doing configure
  208. (without this, uams_* modules won't get .so suffix)
  209. * Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
  210. - Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
  211. (Patch10 now includes all the modifications and more fixes)
  212. * Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
  213. - add patch13 and patch14 for db-4.3.
  214. - move files in %%_libexecdir to %%libdir.
  215. * Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
  216. - updated to 2.0.3 release w/ cjk patches (see the above Patch section)
  217. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  218. - security fix: added Patch10 (CAN-2004-0974)
  219. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  220. - configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
  221. * Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
  222. - updated to 2.0 with cjk patch
  223. (see the above Patch section for details)
  224. * Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
  225. - merge the patch repairing bug for System 7.5.5
  226. - (patch6 netatalk-1.5.3.oldsys.patch)
  227. - made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
  228. - patch6 addupted no matter noeuc is, license GPL, URL in comment
  229. * Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
  230. - euc and kana patch originally by
  231. - Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
  232. - applied to netatalk-1.5.2 by me
  233. - README.vine
  234. - omit VERSION from doc, omit perl from require
  235. * Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
  236. - this package is removed because the release number duplicated
  237. * Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
  238. - move acleandir.rc to the doc directory, remove executable flag.
  239. * Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
  240. - updated to new upstream release
  241. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
  242. - added Japanese Summary for devel and corrected Group
  243. * Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
  244. - Oops, check /var/lock/atalkd instead of /var/run/atd.pid
  245. (say atd.pid doesn't have anything to do with netatalk!!)
  246. * Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
  247. - updated to new upstream release
  248. * Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
  249. - install man pages into %%{_mandir}
  250. - PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
  251. - let pre script exit 0
  252. * Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
  253. - spec cleanup
  254. - backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
  255. - restart atalk daemons in the %%post section
  256. * Sun Feb 3 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  257. - v1.5.1.1-0vl1
  258. * Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  259. - v1.5.0-0vl1
  260. - release 1.5.0 for sourceforge
  261. * Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  262. - v1.5pre6-1rh7
  263. - pre-release 6 for sourceforge
  264. * Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  265. - v1.5pre5-1
  266. - pre-release 5 for sourceforge
  267. * Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  268. - v1.5pre5-0
  269. - pre-release 5 for sourceforge (prebuild)
  270. * Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  271. - v1.5pre4-1
  272. - pre-release 4 for sourceforge
  273. - modified/split mandrake spec for redhat 7 build
  274. * Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  275. - v1.5pre3-1mdk
  276. - pre-release 3 for sourceforge
  277. - moved away from 1.4.99 ...
  278. * Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  279. - v1.4.99-0.20001108mdk
  280. - pre-release 2 for sourceforge
  281. * Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  282. - v1.4.99-0.20000927mdk
  283. - pre-release 1 for sourceforge