autoconf-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. Summary: A GNU tool for automatically configuring source code.
  4. Summary(ja): ソースコードを自動的に設定するための GNU ツール
  5. Name: autoconf
  6. Version: 2.65
  7. Release: 2%{?_dist_release}
  8. License: GPL
  9. Group: Development/Tools
  10. URL: http://www.gnu.org/software/autoconf/
  11. Source: ftp://ftp.gnu.org/pub/gnu/autoconf/autoconf-%{version}.tar.xz
  12. # Vine Source(s)
  13. Source10: autoconf-mode-install.sh
  14. Source11: autoconf-mode-remove.sh
  15. Prereq(post,preun): /sbin/install-info
  16. Requires: gawk, m4, mktemp, perl, textutils
  17. Obsoletes: autoconf253
  18. BuildArch: noarch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. %description
  21. GNU's Autoconf is a tool for configuring source code and Makefiles.
  22. Using Autoconf, programmers can create portable and configurable
  23. packages, since the person building the package is allowed to
  24. specify various configuration options.
  25. You should install Autoconf if you are developing software and
  26. would like to create shell scripts that configure your source code
  27. packages. If you are installing Autoconf, you will also need to
  28. install the GNU m4 package.
  29. Note that the Autoconf package is not required for the end-user who
  30. may be configuring software with an Autoconf-generated script;
  31. Autoconf is only required for the generation of the scripts, not
  32. their use.
  33. %description -l ja
  34. GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
  35. です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
  36. 作ることができます.そのため,パッケージ作成者はさまざまな設定
  37. オプションを指定できます。
  38. ソフトウェアを開発していてソースコードパッケージを設定するシェル
  39. スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
  40. Autoconf をインストールするためには GNU m4 パッケージもインストールする
  41. 必要があります.
  42. Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
  43. エンドユーザには Autoconf パッケージが必要ないことに注目してください.
  44. Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
  45. 必要ありません.
  46. %package mode
  47. Summary: Emacs-lisp autoconf-mode for autoconf/autotest
  48. Group: Applications/Editors/Emacs
  49. %prereq_ge emacsen-common
  50. PreReq: emacsen
  51. %description mode
  52. Emacs-lisp autoconf-mode for autoconf/autotest
  53. %prep
  54. %setup -q -n autoconf-%{version}
  55. #patch0 -p1
  56. %build
  57. %configure
  58. make
  59. #make check
  60. %install
  61. rm -rf ${RPM_BUILD_ROOT}
  62. %makeinstall
  63. gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info*
  64. # We don't want to include the standards.info stuff in the package,
  65. # because it comes from binutils...
  66. rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
  67. # cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
  68. # remove info dir file since it isn't packaged
  69. rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  70. # move elisp files
  71. pushd ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp
  72. mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/autoconf-mode
  73. mv *.el autoconf-mode/
  74. popd
  75. # emacsen-common-ize
  76. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/autoconf-mode
  77. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  78. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  79. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
  80. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
  81. %_installemacsenscript autoconf-mode %{SOURCE10}
  82. %_removeemacsenscript autoconf-mode %{SOURCE11}
  83. %clean
  84. rm -rf ${RPM_BUILD_ROOT}
  85. %post
  86. /sbin/install-info %{_infodir}/autoconf.info.gz %{_infodir}/dir
  87. %post mode
  88. if [ "$1" = 2 ]; then
  89. %_emacsenPackageRemove autoconf-mode
  90. fi
  91. %_addemacsenlist autoconf-mode
  92. %_emacsenPackageInstall autoconf-mode
  93. %preun
  94. if [ "$1" = 0 ]; then
  95. /sbin/install-info --del %{_infodir}/autoconf.info.gz %{_infodir}/dir
  96. fi
  97. %preun mode
  98. if [ "$1" = 0 ]; then
  99. %_emacsenPackageRemove autoconf-mode
  100. %_removeemacsenlist autoconf-mode
  101. fi
  102. %files
  103. %defattr(-,root,root)
  104. %doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
  105. %{_bindir}/*
  106. %{_infodir}/*.info*
  107. %{_datadir}/autoconf
  108. %{_mandir}/man1/*
  109. %files mode
  110. %defattr(-,root,root)
  111. %{_datadir}/emacs/site-lisp/autoconf-mode/
  112. #/usr/lib/emacsen-common/packages/install/autoconf-mode
  113. #/usr/lib/emacsen-common/packages/remove/autoconf-mode
  114. %{emacsen_pkgdir}/install/autoconf-mode
  115. %{emacsen_pkgdir}/remove/autoconf-mode
  116. %changelog
  117. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.65-2
  118. - rebuilt with rpm-4.8.1-3
  119. * Sun Apr 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.65-1
  120. - new upstream release
  121. * Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.63-1
  122. - new upstream release
  123. - dropped Patch0 (merged into upstream)
  124. * Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.62-3
  125. - added %%emacsen_pkgdir macro
  126. - spec in utf-8
  127. * Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.62-2
  128. - import Patch0 from Fedora 2.62-2
  129. * Fri Jun 06 2008 Karsten Hopp <karsten@redhat.com> 2.62-2
  130. - add upstream fix from Eric Blake for #449973,
  131. m4_if releated error message from autotest
  132. * Sun May 4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.62-1
  133. - new upstream release
  134. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.61-0vl1
  135. - new upstream release
  136. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.59-2vl4
  137. - changed autoconf-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  138. - added Japanese summary and description from vinedocs.sourceforge.jp
  139. - s/Copyright/License/
  140. * Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 2.59-2vl3
  141. - rebuild
  142. * Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl2
  143. - rebuild
  144. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl1
  145. - update to 2.59 bugfix release
  146. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.58-0vl1
  147. - new upstream release
  148. * Tue Apr 08 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.57-3vl1
  149. - source update
  150. * Mon Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl2
  151. - don't show annoying messages during elisp compilation
  152. * Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl1
  153. - based on 2.56-1 from Rawhide and built for Vine Linux
  154. - emacsen-common-ize
  155. * Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 2.56-1
  156. - update to 2.56
  157. - obsolete autoheader-warn patch
  158. - no longer provide autoconf253
  159. - include site-lisp and man files
  160. - remove info dir which is not in the manifest
  161. - do not version suffix bin files for now
  162. * Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 2.53-8
  163. - make check
  164. * Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.53-7
  165. - update url (#66840)
  166. - added doc files
  167. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.53-6
  168. - automated rebuild
  169. * Sun May 26 2002 Tim Powers <timp@redhat.com> 2.53-5
  170. - automated rebuild
  171. * Mon May 20 2002 Bill Nottingham <notting@redhat.com> 2.53-4
  172. - provide autoconf253
  173. * Thu May 16 2002 Bill Nottingham <notting@redhat.com> 2.53-3
  174. - obsolete autoconf253
  175. * Wed May 8 2002 Jens Petersen <petersen@redhat.com> 2.53-2
  176. - patch autoheader so that --warnings=CATEGORY works (#64566)
  177. [reported with fix by hjl@gnu.org]
  178. * Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 2.53-1
  179. - update to autoconf-2.53
  180. - drop mawk patch again
  181. - version suffix bindir files and add symlinks to unversioned names
  182. * Fri Feb 1 2002 Jens Petersen <petersen@redhat.com> 2.52-7
  183. - revert to 2.52 (also fixes #58210!)
  184. - remove relversion variable
  185. - bring back mawk -> gawk patch
  186. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.52-6
  187. - automated rebuild
  188. * Thu Dec 20 2001 Jens Petersen <petersen@redhat.com> 2.52-5
  189. - update to 2.52f
  190. - add URL
  191. - minor description improvements
  192. - define relversion to carry version number
  193. - mawk.patch no longer needed
  194. * Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-4
  195. - rebuild
  196. * Wed Sep 19 2001 Jens Petersen <petersen@redhat.com> 2.52-3
  197. - restore patch to prefer gawk to mawk
  198. * Tue Sep 18 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-2
  199. - update to 2.52d
  200. * Mon Sep 17 2001 Jens Petersen <petersen@redhat.com> 2.52-1
  201. - update to 2.52
  202. - remove obsolete patches, since already new version
  203. - dont install install-sh
  204. * Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
  205. - add patch to include various standard C headers as needed
  206. by various autoconf tests (#19114)
  207. - add patch to autoscan.pl to get a better choice of init
  208. file (#42071), to test for CPP after CC (#42072) and to
  209. detect C++ source and g++ (#42073).
  210. * Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
  211. - Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
  212. from version 2.50 to make detection of C++ exit()
  213. declaration prototype platform independent. The check is
  214. done in AC_PROG_CXX with the result stored in "confdefs.h".
  215. The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
  216. (fixes #18829)
  217. * Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  218. - Fix up interoperability with glibc 2.2 and gcc 2.96:
  219. AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
  220. the test code without throwing an exception, causing a conflict
  221. with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
  222. always failed, returning wrong results
  223. * Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  224. - add textutils as a dependency (#14439)
  225. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  226. - automatic rebuild
  227. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  228. - FHS packaging.
  229. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  230. - fix preun
  231. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  232. - add patch to help autoconf clean after itself and not leave /tmp clobbered
  233. with acin.* and acout.* files (can you say annoying?)
  234. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  235. - auto rebuild in the new build environment (release 4)
  236. - use gawk, not mawk
  237. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  238. - moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
  239. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  240. - Injected new description and group.
  241. * Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
  242. - update to 2.13.
  243. * Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
  244. - build against glibc 2.1
  245. * Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
  246. - requires perl
  247. * Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
  248. - patch for fixing /tmp race conditions
  249. * Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
  250. - spec file cleanups
  251. - made a noarch package
  252. - uses autoconf
  253. - uses install-info
  254. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  255. - built with glibc