notification-daemon-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. %define gtk2_version 2.10.0
  2. %define glib2_version 2.8.0
  3. %define dbus_version 0.60
  4. %define libnotify_version 0.4.0
  5. Summary: Notification Daemon
  6. Name: notification-daemon
  7. Version: 0.4.0
  8. Release: 7%{?_dist_release}
  9. URL: http://www.galago-project.org/specs/notification/
  10. License: GPL
  11. Group: System Environment/Libraries
  12. Source0: %{name}-%{version}.tar.bz2
  13. Source1: notification-daemon-0.4.0-ja.po
  14. Patch1: notification-daemon-0.4.0-ja.patch
  15. # patches from ubuntu
  16. Patch103: notification-daemon-0.4.0-fix-xinerama-stack.patch
  17. Patch104: notification-daemon-0.4.0-dont-crash-on-critical-warnings.patch
  18. Patch105: notification-daemon-0.4.0-spacing.patch
  19. Patch107: notification-daemon-0.4.0-memleak-daemon.patch
  20. Patch109: notification-daemon-0.4.0-change-themes-crash-rev1.patch
  21. # vine theme (based on coco) and vine5 theme (old theme)
  22. # http://github.com/tatofoo/notification-daemon-engine-coco
  23. Source200: notification-daemon-engine-vine.tar.bz2
  24. # Vine patch
  25. # use gvfs-open instead of gnome-open
  26. Patch300: notification-daemon-0.4.0-browser.patch
  27. # dirty hack to change notification bubble position.
  28. Patch310: notification-daemon-0.4.0-position.patch
  29. # add vine and vine5 theme
  30. Patch320: notification-daemon-0.4.0-vine-theme.patch
  31. # change default to slider
  32. Patch330: notification-daemon-0.4.0-default-theme.patch
  33. # change default notify location to TOP_RIGHT
  34. Patch340: notification-daemon-0.4.0-location.patch
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  36. Requires: dbus >= %{dbus_version}
  37. Requires: dbus-glib >= %{dbus_version}
  38. Requires(post): GConf2
  39. BuildRequires: glib2-devel >= %{glib2_version}
  40. BuildRequires: dbus-devel >= %{dbus_version}
  41. BuildRequires: dbus-glib-devel >= %{dbus_version}
  42. BuildRequires: libnotify-devel >= %{libnotify_version}
  43. BuildRequires: libsexy-devel
  44. BuildRequires: libwnck-devel
  45. %description
  46. notification-daemon is the server implementation of the freedesktop.org
  47. desktop notification specification.
  48. Vendor: Project Vine
  49. Distribution: Vine Linux
  50. Packager: daisuke
  51. %prep
  52. %setup -q -a 200
  53. %patch1 -p1 -b .ja
  54. %patch103 -p1
  55. %patch104 -p1
  56. %patch105 -p0
  57. %patch107 -p1
  58. %patch109 -p1
  59. %patch300 -p1
  60. %patch310 -p1
  61. %patch320 -p1
  62. %patch330 -p1
  63. %patch340 -p1
  64. # install japanese message catalog
  65. %{__cp} %{SOURCE1} po/ja.po
  66. %build
  67. autoreconf -f -i
  68. %configure --disable-schemas-install
  69. make %{?_smp_mflags}
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  73. %find_lang %name
  74. # remove unpackaged files
  75. rm -f $RPM_BUILD_ROOT%{_libdir}/notification-daemon-1.0/engines/*.{a,la}
  76. # install desktop file
  77. desktop-file-install --delete-original \
  78. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  79. --add-category DesktopSettings \
  80. ${RPM_BUILD_ROOT}%{_datadir}/applications/notification-properties.desktop
  81. %pre
  82. if [ "$1" -gt 1 ]; then
  83. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  84. gconftool-2 --makefile-uninstall-rule \
  85. %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
  86. fi
  87. %post
  88. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  89. gconftool-2 --makefile-install-rule \
  90. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  91. touch --no-create %{_datadir}/icons/hicolor
  92. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  93. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  94. fi
  95. %preun
  96. if [ "$1" -eq 0 ]; then
  97. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  98. gconftool-2 --makefile-uninstall-rule \
  99. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  100. fi
  101. %postun
  102. touch --no-create %{_datadir}/icons/hicolor
  103. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  104. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  105. fi
  106. %clean
  107. rm -rf %{buildroot}
  108. %files -f %{name}.lang
  109. %defattr(-,root,root)
  110. %doc COPYING ChangeLog NEWS
  111. %{_bindir}/notification-properties
  112. %{_sysconfdir}/gconf/schemas/%{name}.schemas
  113. %dir %{_libdir}/notification-daemon-1.0
  114. %dir %{_libdir}/notification-daemon-1.0/engines
  115. %{_libdir}/notification-daemon-1.0/engines/*.so
  116. %{_libexecdir}/notification-daemon
  117. %{_datadir}/dbus-1/services/org.freedesktop.Notifications.service
  118. %{_datadir}/applications/notification-properties.desktop
  119. %{_datadir}/icons/hicolor/16x16/apps/notification-properties.png
  120. %{_datadir}/icons/hicolor/22x22/apps/notification-properties.png
  121. %{_datadir}/icons/hicolor/24x24/apps/notification-properties.png
  122. %{_datadir}/icons/hicolor/32x32/apps/notification-properties.png
  123. %{_datadir}/icons/hicolor/48x48/apps/notification-properties.png
  124. %{_datadir}/icons/hicolor/scalable/apps/notification-properties.svg
  125. %{_datadir}/notification-daemon/notification-properties.glade
  126. %changelog
  127. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.4.0-7
  128. - rebuilt with rpm-4.8.1-3
  129. * Sun May 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-6
  130. - update Source201
  131. * Sat May 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-5
  132. - rebuild with new toolchain
  133. - update Source201 (add modified coco theme as new default)
  134. - add patch300 to use gvfs-open instead of gnome-open
  135. - add patch310 to change notification bubble position
  136. - add patch320 to add new vine theme
  137. - add patch340 to change default notification localtion to top_right.
  138. - add BR: libwnck-devel
  139. * Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-4
  140. - add Categories=DesktopSettings for notification-properties.desktop
  141. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-3
  142. - add Source200, Patch200,201
  143. - add vine theme engine based on ubuntu engine.
  144. - add patch101-109 from ubuntu
  145. - Patch103: fix xinerama stack
  146. - Patch104: dont crash on critical warnings
  147. - Patch105: fix notification spacing
  148. - Patch107: fix memleak
  149. - Patch109: fix crash on theme changing
  150. * Sat Mar 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-2
  151. - add japanese translation (Source1 and Patch1)
  152. - prperly install/uninstall gconf schemas
  153. - update gtk icon cache with %%post, %%postun
  154. * Fri Mar 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1
  155. - new upstream release
  156. - change required gtk2 version to 2.10.0
  157. * Sun Oct 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-1
  158. - applied new versioning policy
  159. * Tue Dec 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl2
  160. - rebuilt with libwnck 2.20.2
  161. * Tue May 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl1
  162. - new upstream release
  163. - rebuilt with libsexy 0.1.10
  164. - added BuildRequores: libsexy-devel
  165. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.5-0vl1
  166. - new upstream release
  167. * Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4-0vl1
  168. - initial build for Vine Linux partialy based on FC package.
  169. * Wed Mar 08 2006 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-9
  170. - Add patch to fix struct handling in the dbus glib binding for dbus 0.61
  171. so image data works again
  172. * Tue Feb 14 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-8
  173. - BuildRequires love, for all you lovers out there.
  174. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-7.1
  175. - bump again for double-long bug on ppc(64)
  176. * Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
  177. - remove empty scripts from .spec file
  178. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-6.1
  179. - rebuilt for new gcc4.1 snapshot and glibc changes
  180. * Fri Feb 3 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-6
  181. - Add patch to determine whether a compositing manager is running
  182. when drawing a new notification bubble, as long as the CM grabs
  183. the appropriate XSelection.
  184. * Fri Jan 20 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-5
  185. - Make it so that marked-up messages appear with markup
  186. * Thu Jan 12 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-4
  187. - Provide desktop-notification-daemon, since libnotify requires a
  188. notification deamon, but not this specific one. Other notification
  189. daemons can exist on the system so long as they meet the provides
  190. (and the API of course).
  191. * Mon Jan 9 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-3
  192. - Fix positioning of the notification bubble to not draw off-screen
  193. * Wed Dec 14 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  194. - Actuall release of 0.3.1
  195. * Thu Nov 17 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-1
  196. - Upgrade to upstream 0.3.1
  197. * Tue Nov 15 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.0-1
  198. - inital build