wordpress-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228
  1. Summary: WordPress blogging software
  2. Summary(ja): WordPress ブログソフトウエア
  3. URL: http://www.wordpress.org
  4. Name: wordpress
  5. Version: 2.9.2
  6. Group: Applications/Publishing
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. #Source0: http://wordpress.org/%{name}-%{version}.tar.gz
  10. Source0: http://ja.wordpress.org/wordpress-%{version}-ja.tar.gz
  11. Source1: wordpress-httpd-conf
  12. Source2: README.wordpress
  13. Source3: README.ja.wordpress
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. Requires: php5
  16. BuildArch: noarch
  17. %description
  18. Wordpress is an online publishing / weblog package that makes it very easy,
  19. almost trivial, to get information out to people on the web.
  20. %prep
  21. %setup -q -n wordpress
  22. # disable wp_version_check, updates are always installed via rpm
  23. sed -i -e "s,\(.*\)'wp_version_check'\(.*\),#\1'wp_version_check'\2,g" \
  24. wp-includes/update.php
  25. # disable update_nag() function
  26. sed -i -e "s,\(.*\)'update_nag'\(.*\),#\1'update_nag'\2,g; \
  27. s,\(.*\)\$msg .=\(.*\),\1\$msg .= '';,g;" \
  28. wp-admin/includes/update.php
  29. # fix file encoding
  30. sed -i -e 's/\r//' license.txt
  31. %install
  32. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/wordpress
  33. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress
  34. install -m 0644 -D -p %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/httpd/conf.d/wordpress.conf
  35. cp -pr * ${RPM_BUILD_ROOT}%{_datadir}/wordpress
  36. cat wp-config-sample.php | sed -e "s|dirname(__FILE__).'/'|'/usr/share/wordpress/'|g" > \
  37. ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress/wp-config.php
  38. /bin/ln -sf ../../../etc/wordpress/wp-config.php ${RPM_BUILD_ROOT}%{_datadir}/wordpress/wp-config.php
  39. /bin/cp %{SOURCE2} ./README.vine
  40. /bin/cp %{SOURCE3} ./README.ja.vine
  41. # Remove empty files to make rpmlint happy
  42. find ${RPM_BUILD_ROOT} -type f -empty -exec rm -f {} \;
  43. # These are docs, remove them from here, docify them later
  44. rm -f ${RPM_BUILD_ROOT}%{_datadir}/wordpress/{license.txt,readme.html}
  45. %clean
  46. rm -rf ${RPM_BUILD_ROOT}
  47. %post
  48. if [ "$1" -eq 1 ]; then
  49. if [ "$LANG"="ja_JP.UTF-8" ]; then
  50. echo "Wordpress: MySQL に Wordpress データベースを作成する必要があります。"
  51. echo "Wordpress: %{_docdir}/%{name}-%{version}/README.ja を参照して初期設定を行って下さい。"
  52. else
  53. echo "Wordpress: You may need to setup your MySQL database for Wordpress."
  54. echo "Wordpress: Please read "%{_docdir}/%{name}-%{version}/README.ja" to initial setup."
  55. fi
  56. fi
  57. %files
  58. %defattr(-,root,root,-)
  59. %config(noreplace) %{_sysconfdir}/httpd/conf.d/wordpress.conf
  60. %dir %{_datadir}/wordpress
  61. %{_datadir}/wordpress/wp-admin
  62. %{_datadir}/wordpress/wp-content
  63. %{_datadir}/wordpress/wp-includes
  64. %{_datadir}/wordpress/index.php
  65. %doc license.txt
  66. %doc readme.html
  67. %doc README.fedora
  68. %{_datadir}/wordpress/wp-atom.php
  69. %{_datadir}/wordpress/wp-app.php
  70. %{_datadir}/wordpress/wp-blog-header.php
  71. %{_datadir}/wordpress/wp-comments-post.php
  72. %{_datadir}/wordpress/wp-commentsrss2.php
  73. %{_datadir}/wordpress/wp-config-sample.php
  74. %{_datadir}/wordpress/wp-config.php
  75. %config(noreplace) %{_sysconfdir}/wordpress/wp-config.php
  76. %{_datadir}/wordpress/wp-cron.php
  77. %{_datadir}/wordpress/wp-feed.php
  78. %{_datadir}/wordpress/wp-links-opml.php
  79. %{_datadir}/wordpress/wp-load.php
  80. %{_datadir}/wordpress/wp-login.php
  81. %{_datadir}/wordpress/wp-mail.php
  82. %{_datadir}/wordpress/wp-pass.php
  83. %{_datadir}/wordpress/wp-rdf.php
  84. %{_datadir}/wordpress/wp-register.php
  85. %{_datadir}/wordpress/wp-rss.php
  86. %{_datadir}/wordpress/wp-rss2.php
  87. %{_datadir}/wordpress/wp-settings.php
  88. %{_datadir}/wordpress/wp-trackback.php
  89. %{_datadir}/wordpress/xmlrpc.php
  90. %dir %{_sysconfdir}/wordpress
  91. %changelog
  92. * Tue Apr 20 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.2-1
  93. - initial build for Vine Linux based on fedora package
  94. - update to 2.9.2 japanese version
  95. * Mon Nov 16 2009 Adrian Reber <adrian@lisas.de> - 2.8.6-2
  96. - updated to 2.8.6 (Security Release)
  97. * Wed Oct 21 2009 Adrian Reber <adrian@lisas.de> - 2.8.5-1
  98. - updated to 2.8.5 (Hardening Release)
  99. * Sun Aug 30 2009 Adrian Reber <adrian@lisas.de> - 2.8.4-1
  100. - updated to 2.8.4 (security fixes were already available with 2.8.3-2)
  101. * Tue Aug 11 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-2
  102. - another security update to fix "Remote admin reset password":
  103. http://lists.grok.org.uk/pipermail/full-disclosure/2009-August/070137.html
  104. * Mon Aug 03 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-1
  105. - updated to 2.8.3 for security fixes
  106. * Tue Jul 28 2009 Adrian Reber <adrian@lisas.de> - 2.8.2-1
  107. - updated to 2.8.2 for security fixes - BZ 512900
  108. - fixed "wrong-script-end-of-line-encoding" of license.txt
  109. - correctly disable auto update check
  110. - fixed an error message from 'find' during the build
  111. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-2
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  113. * Fri Jul 10 2009 Adrian Reber <adrian@lisas.de> - 2.8.1-1
  114. - updated to 2.8.1 for security fixes - BZ 510745
  115. * Mon Jun 22 2009 Adrian Reber <adrian@lisas.de> - 2.8-1
  116. - updated to 2.8
  117. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.1-2
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  119. * Wed Feb 11 2009 Adrian Reber <adrian@lisas.de> - 2.7.1-1
  120. - updated to 2.7.1
  121. * Wed Nov 26 2008 Adrian Reber <adrian@lisas.de> - 2.6.5-2
  122. - updated to 2.6.5
  123. * Fri Oct 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.3-1
  124. - updated to 2.6.3
  125. * Tue Sep 09 2008 Adrian Reber <adrian@lisas.de> - 2.6.2-1
  126. - updated to 2.6.2
  127. * Sun Aug 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.1-1
  128. - updated to 2.6.1
  129. * Mon Jul 21 2008 Adrian Reber <adrian@lisas.de> - 2.6-1
  130. - updated to 2.6
  131. * Sat Apr 26 2008 Adrian Reber <adrian@lisas.de> - 2.5.1-1
  132. - updated to 2.5.1 for security fixes - BZ 444396
  133. * Fri Feb 8 2008 John Berninger <john at ncphotography dot com> - 2.3.3-0
  134. - update to 2.3.3 for security fixes - BZ 431547
  135. * Sun Dec 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.2-1
  136. - updated to 2.3.2 (bz 426431, Draft Information Disclosure)
  137. * Tue Oct 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.1-1
  138. - updated to 2.3.1 (bz 357731, wordpress XSS issue)
  139. * Mon Oct 15 2007 Adrian Reber <adrian@lisas.de> - 2.3-1
  140. - updated to 2.3
  141. - disabled wordpress-core-update
  142. * Tue Sep 11 2007 Adrian Reber <adrian@lisas.de> - 2.2.3-0
  143. - updated to 2.2.3 (security release)
  144. * Wed Aug 29 2007 John Berninger <john at ncphotography dot com> - 2.2.2-0
  145. - update to upstream 2.2.2
  146. - license tag update
  147. * Mon Apr 16 2007 john Berninger <jwb at redhat dot com> - 2.1.3-1
  148. - update to 2.1.3 final - bz235912
  149. * Mon Mar 26 2007 John Berninger <jwb at redhat dot com> - 2.1.3-rc2
  150. - update to 2.1.3rc2 for bz 233703
  151. * Sat Mar 3 2007 John Berninger <jwb at redhat dot com> - 2.1.2-0
  152. - update to 2.1.2 - backdoor exploit introduced upstream in 2.1.1 - bz 230825
  153. * Tue Feb 27 2007 John Berninger <jwb at redhat dot com> - 2.1.1-0
  154. - update to 2.1.1 to fix vuln in bz 229991
  155. * Wed Jan 31 2007 John Berninger <jwb at redhat dot com> - 2.1-0
  156. - update to v2.1 to fix multiple bz/vuln's
  157. * Sun Dec 3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-2
  158. - Remove mysql-server dependency
  159. * Sun Dec 3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-1
  160. - Update to upstream 2.0.5 to fix vuln in bz 213985
  161. * Thu Oct 26 2006 John Berninger <jwb at redhat dot com> - 2.0.4-1
  162. - Doc fix for BZ 207822
  163. * Sat Aug 12 2006 John Berninger <jwb at redhat dot com> - 2.0.4-0
  164. - Upstream security vulns - bz 201989
  165. * Sun Jul 23 2006 John Berninger <jwb at redhat dot com> - 2.0.3-4
  166. - Fix broken upgrade path from FE4
  167. * Tue Jul 4 2006 John Berninger <jwb at redhat dot com> - 2.0.3-3
  168. - Add a README.fedora file
  169. - Add php-mysql requires
  170. * Tue Jun 20 2006 John Berninger <jwb at redhat dot com> - 2.0.3-2
  171. - Remove use of installprefix macro
  172. - %%{_datadir}/wordpress/wp-config.php is not a config file
  173. - Symlink is relative
  174. * Mon Jun 19 2006 John Berninger <jwb at redhat dot com> - 2.0.3-1
  175. - Changes from Jarod Wilson as below
  176. - Update to 2.0.3
  177. - Rearrange to use /usr/share/wordpress and /etc/wordpress
  178. - Remove patch (included upstream)
  179. - Remove empty files to make rpmlint happy
  180. * Tue May 30 2006 John Berninger <jwb at redhat dot com> - 2.0.2-1
  181. - Added patch for \n cache injection - upstream changeset #3797
  182. * Sat May 27 2006 John Berninger <jwb at redhat dot com> - 2.0.2-0
  183. - Initial build