libghc-aeson-vl.spec 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. %define pkg_name aeson
  2. %define pkg_version 1.4.2.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: Haskell libraries: %{pkg_name} and dependent libraries
  5. Name: libghc-%{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD3
  9. Group: Applications/Text
  10. URL: http://hackage.haskell.org
  11. Source0: packages
  12. Source11: base-compat-0.10.5.tar.gz
  13. Source12: base-compat.cabal
  14. Source13: tagged-0.8.6.tar.gz
  15. Source14: tagged.cabal
  16. Source15: th-abstraction-0.2.8.0.tar.gz
  17. Source16: th-abstraction.cabal
  18. Source17: time-locale-compat-0.1.1.5.tar.gz
  19. Source18: time-locale-compat.cabal
  20. Source19: uuid-types-1.0.3.tar.gz
  21. Source20: uuid-types.cabal
  22. Source21: aeson-1.4.2.0.tar.gz
  23. Source22: aeson.cabal
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: ghc haskell-platform
  26. BuildRequires: libffi-devel gmp-devel zlib-devel
  27. BuildRequires: libghc-dlist
  28. BuildRequires: libghc-old-locale
  29. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  30. Requires: ghc haskell-platform
  31. Requires: haskell-platform-dep
  32. Requires: libghc-dlist
  33. Requires: libghc-old-locale
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: ara_t
  37. %description
  38. Haskell libraries: %{pkg_name}
  39. %prep
  40. %{__rm} -rf ${RPM_BUILD_ROOT}
  41. %build
  42. %ghc_pkg_init
  43. cd %{_builddir}
  44. for pkg in `cat %{SOURCE0}`; do
  45. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  46. pushd ${pkg}
  47. %ghc_fix_dependencies ${pkg}
  48. %cabal_configure2 %{name} ${pkg}
  49. %cabal_build
  50. %cabal_haddock
  51. %cabal_copy_resister %{name}_${pkg}
  52. popd
  53. done
  54. %install
  55. # copy documents
  56. pushd %{_builddir}/%{pkg_name}-%{version}
  57. %{__cp} changelog.md README.markdown \
  58. ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
  59. popd
  60. %clean
  61. %{__rm} -rf ${RPM_BUILD_ROOT}
  62. %post
  63. %ghc_pkg_recache
  64. %postun
  65. %ghc_pkg_recache
  66. %files
  67. %defattr(-, root, root)
  68. %{_libdir}/ghc-%{ghc_version}/
  69. %{_libdir}/ghc-lib/
  70. %{_datadir}/
  71. %changelog
  72. * Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 1.4.2.0-1
  73. - update to 1.4.2.0
  74. - build using ghc-8.6.3
  75. * Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 1.3.1.1-3
  76. - build with ghc-8.4.3-2
  77. * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 1.3.1.1-2
  78. - build using ghc-8.4.3
  79. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 1.3.1.1-1
  80. - update to 1.3.1.1
  81. - rebuild using ghc-8.4.2
  82. - rewrite using macro
  83. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 1.2.3.0-1
  84. - update to 1.2.3.0
  85. - build using ghc-8.2.2
  86. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.11.3.0-1
  87. - update to 0.11.3.0
  88. - build using ghc-8.0.1
  89. * Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.9.0.1-3
  90. - rebuilt
  91. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.9.0.1-2
  92. - correct SPEC file
  93. * Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.9.0.1-1
  94. - new package