autoconf-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  2. Summary: A GNU tool for automatically configuring source code.
  3. Summary(ja): ソースコードを自動的に設定するための GNU ツール
  4. Name: autoconf
  5. Version: 2.68
  6. Release: 1%{?_dist_release}
  7. License: GPL
  8. Group: Development/Tools
  9. URL: http://www.gnu.org/software/autoconf/
  10. Source: ftp://ftp.gnu.org/pub/gnu/autoconf/autoconf-%{version}.tar.xz
  11. # Vine Source(s)
  12. Source10: autoconf-mode-install.sh
  13. Source11: autoconf-mode-remove.sh
  14. Requires(post,preun): /sbin/install-info
  15. Requires: gawk, m4, mktemp, perl, textutils
  16. Obsoletes: autoconf253
  17. BuildArch: noarch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. %description
  20. GNU's Autoconf is a tool for configuring source code and Makefiles.
  21. Using Autoconf, programmers can create portable and configurable
  22. packages, since the person building the package is allowed to
  23. specify various configuration options.
  24. You should install Autoconf if you are developing software and
  25. would like to create shell scripts that configure your source code
  26. packages. If you are installing Autoconf, you will also need to
  27. install the GNU m4 package.
  28. Note that the Autoconf package is not required for the end-user who
  29. may be configuring software with an Autoconf-generated script;
  30. Autoconf is only required for the generation of the scripts, not
  31. their use.
  32. %description -l ja
  33. GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
  34. です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
  35. 作ることができます.そのため,パッケージ作成者はさまざまな設定
  36. オプションを指定できます。
  37. ソフトウェアを開発していてソースコードパッケージを設定するシェル
  38. スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
  39. Autoconf をインストールするためには GNU m4 パッケージもインストールする
  40. 必要があります.
  41. Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
  42. エンドユーザには Autoconf パッケージが必要ないことに注目してください.
  43. Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
  44. 必要ありません.
  45. %package mode
  46. Summary: Emacs-lisp autoconf-mode for autoconf/autotest
  47. Group: Applications/Editors/Emacs
  48. BuildRequires: emacsen
  49. %prereq_ge emacsen-common
  50. Requires: emacsen
  51. %description mode
  52. Emacs-lisp autoconf-mode for autoconf/autotest
  53. %prep
  54. %setup -q -n autoconf-%{version}
  55. #patch0 -p1
  56. %build
  57. %configure
  58. make
  59. #make check
  60. %install
  61. rm -rf ${RPM_BUILD_ROOT}
  62. %makeinstall
  63. gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info*
  64. # We don't want to include the standards.info stuff in the package,
  65. # because it comes from binutils...
  66. rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
  67. # cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
  68. # remove info dir file since it isn't packaged
  69. rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  70. # move elisp files
  71. pushd ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp
  72. mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/autoconf-mode
  73. mv *.el autoconf-mode/
  74. popd
  75. # emacsen-common-ize
  76. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/autoconf-mode
  77. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  78. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  79. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
  80. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
  81. %_installemacsenscript autoconf-mode %{SOURCE10}
  82. %_removeemacsenscript autoconf-mode %{SOURCE11}
  83. %clean
  84. rm -rf ${RPM_BUILD_ROOT}
  85. %post
  86. /sbin/install-info %{_infodir}/autoconf.info.gz %{_infodir}/dir
  87. %post mode
  88. if [ "$1" = 2 ]; then
  89. %_emacsenPackageRemove autoconf-mode
  90. fi
  91. %_addemacsenlist autoconf-mode
  92. %_emacsenPackageInstall autoconf-mode
  93. %preun
  94. if [ "$1" = 0 ]; then
  95. /sbin/install-info --del %{_infodir}/autoconf.info.gz %{_infodir}/dir
  96. fi
  97. %preun mode
  98. if [ "$1" = 0 ]; then
  99. %_emacsenPackageRemove autoconf-mode
  100. %_removeemacsenlist autoconf-mode
  101. fi
  102. %files
  103. %defattr(-,root,root)
  104. %doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
  105. %{_bindir}/*
  106. %{_infodir}/*.info*
  107. %{_datadir}/autoconf
  108. %{_mandir}/man1/*
  109. %files mode
  110. %defattr(-,root,root)
  111. %{_datadir}/emacs/site-lisp/autoconf-mode/
  112. #/usr/lib/emacsen-common/packages/install/autoconf-mode
  113. #/usr/lib/emacsen-common/packages/remove/autoconf-mode
  114. %{emacsen_pkgdir}/install/autoconf-mode
  115. %{emacsen_pkgdir}/remove/autoconf-mode
  116. %changelog
  117. * Sun Nov 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.68-1
  118. - new upstream release
  119. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.65-2
  120. - rebuilt with rpm-4.8.1-3
  121. * Sun Apr 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.65-1
  122. - new upstream release
  123. * Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.63-1
  124. - new upstream release
  125. - dropped Patch0 (merged into upstream)
  126. * Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.62-3
  127. - added %%emacsen_pkgdir macro
  128. - spec in utf-8
  129. * Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.62-2
  130. - import Patch0 from Fedora 2.62-2
  131. * Fri Jun 06 2008 Karsten Hopp <karsten@redhat.com> 2.62-2
  132. - add upstream fix from Eric Blake for #449973,
  133. m4_if releated error message from autotest
  134. * Sun May 4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.62-1
  135. - new upstream release
  136. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.61-0vl1
  137. - new upstream release
  138. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.59-2vl4
  139. - changed autoconf-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  140. - added Japanese summary and description from vinedocs.sourceforge.jp
  141. - s/Copyright/License/
  142. * Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 2.59-2vl3
  143. - rebuild
  144. * Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl2
  145. - rebuild
  146. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl1
  147. - update to 2.59 bugfix release
  148. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.58-0vl1
  149. - new upstream release
  150. * Tue Apr 08 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.57-3vl1
  151. - source update
  152. * Mon Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl2
  153. - don't show annoying messages during elisp compilation
  154. * Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl1
  155. - based on 2.56-1 from Rawhide and built for Vine Linux
  156. - emacsen-common-ize
  157. * Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 2.56-1
  158. - update to 2.56
  159. - obsolete autoheader-warn patch
  160. - no longer provide autoconf253
  161. - include site-lisp and man files
  162. - remove info dir which is not in the manifest
  163. - do not version suffix bin files for now
  164. * Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 2.53-8
  165. - make check
  166. * Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.53-7
  167. - update url (#66840)
  168. - added doc files
  169. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.53-6
  170. - automated rebuild
  171. * Sun May 26 2002 Tim Powers <timp@redhat.com> 2.53-5
  172. - automated rebuild
  173. * Mon May 20 2002 Bill Nottingham <notting@redhat.com> 2.53-4
  174. - provide autoconf253
  175. * Thu May 16 2002 Bill Nottingham <notting@redhat.com> 2.53-3
  176. - obsolete autoconf253
  177. * Wed May 8 2002 Jens Petersen <petersen@redhat.com> 2.53-2
  178. - patch autoheader so that --warnings=CATEGORY works (#64566)
  179. [reported with fix by hjl@gnu.org]
  180. * Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 2.53-1
  181. - update to autoconf-2.53
  182. - drop mawk patch again
  183. - version suffix bindir files and add symlinks to unversioned names
  184. * Fri Feb 1 2002 Jens Petersen <petersen@redhat.com> 2.52-7
  185. - revert to 2.52 (also fixes #58210!)
  186. - remove relversion variable
  187. - bring back mawk -> gawk patch
  188. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.52-6
  189. - automated rebuild
  190. * Thu Dec 20 2001 Jens Petersen <petersen@redhat.com> 2.52-5
  191. - update to 2.52f
  192. - add URL
  193. - minor description improvements
  194. - define relversion to carry version number
  195. - mawk.patch no longer needed
  196. * Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-4
  197. - rebuild
  198. * Wed Sep 19 2001 Jens Petersen <petersen@redhat.com> 2.52-3
  199. - restore patch to prefer gawk to mawk
  200. * Tue Sep 18 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-2
  201. - update to 2.52d
  202. * Mon Sep 17 2001 Jens Petersen <petersen@redhat.com> 2.52-1
  203. - update to 2.52
  204. - remove obsolete patches, since already new version
  205. - dont install install-sh
  206. * Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
  207. - add patch to include various standard C headers as needed
  208. by various autoconf tests (#19114)
  209. - add patch to autoscan.pl to get a better choice of init
  210. file (#42071), to test for CPP after CC (#42072) and to
  211. detect C++ source and g++ (#42073).
  212. * Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
  213. - Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
  214. from version 2.50 to make detection of C++ exit()
  215. declaration prototype platform independent. The check is
  216. done in AC_PROG_CXX with the result stored in "confdefs.h".
  217. The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
  218. (fixes #18829)
  219. * Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  220. - Fix up interoperability with glibc 2.2 and gcc 2.96:
  221. AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
  222. the test code without throwing an exception, causing a conflict
  223. with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
  224. always failed, returning wrong results
  225. * Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  226. - add textutils as a dependency (#14439)
  227. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  228. - automatic rebuild
  229. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  230. - FHS packaging.
  231. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  232. - fix preun
  233. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  234. - add patch to help autoconf clean after itself and not leave /tmp clobbered
  235. with acin.* and acout.* files (can you say annoying?)
  236. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  237. - auto rebuild in the new build environment (release 4)
  238. - use gawk, not mawk
  239. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  240. - moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
  241. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  242. - Injected new description and group.
  243. * Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
  244. - update to 2.13.
  245. * Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
  246. - build against glibc 2.1
  247. * Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
  248. - requires perl
  249. * Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
  250. - patch for fixing /tmp race conditions
  251. * Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
  252. - spec file cleanups
  253. - made a noarch package
  254. - uses autoconf
  255. - uses install-info
  256. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  257. - built with glibc